Jump to content
Local
Kiano

2WAN и mikrotik

Recommended Posts

1 час назад, vlin сказал:

 Це все робиться на мт один в один, бо мт і є лінукс. Меню ip->rules. Працює чудово. 

Какое меню?

Edited by Kiano

Share this post


Link to post
Share on other sites

Уточнення, меню ip -> routes, закладка rules

Share this post


Link to post
Share on other sites
12 минут назад, vlin сказал:

Уточнення, меню ip -> routes, закладка rules

 

Это и есть pbr

Изложите, пжл, своё видение, какое решение?

Edited by Kiano

Share this post


Link to post
Share on other sites

Для реалок

/ip route rule add src-address=126.126.126.0/24 action=lookup table=isp2
/ip route add dst-address=0.0.0.0/0 gateway=125.125.125.1 routing-mark=isp2

Для сірих адрес за натом треба ще одне правило в rules

/ip route rule add src-address=10.1.1.0/24 action=lookup table=isp2

Edited by vlin

Share this post


Link to post
Share on other sites
8 часов назад, vlin сказал:

Для реалок

/ip route rule add src-address=126.126.126.0/24 action=lookup table=isp2
/ip route add dst-address=0.0.0.0/0 gateway=125.125.125.1 routing-mark=isp2

Для сірих адрес за натом треба ще одне правило в rules

/ip route rule add src-address=10.1.1.0/24 action=lookup table=isp2

Интересная идея, попробую

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Kiano
      Прошу помощи, камрады
       
      Ситуация такова:
      Есть много NAS-ов на базе зоопарка, от routeros до линуха и разных извращений.
      Но сейчас о первых, на базе RouterOS. В свою очередь NAT - это сервачок, на том же нелюбимом RouterOS, который тупо натит и роутит.
       
      На NAS-ах: авторизация по PPPoE, обычный роутинг, без NATа, NAS не имеет дефолт роута, абоны маркируются mangle-ом и роутятся на NAT, а дальше в интернеты.
      Абонент с деньгами получает всегда один и тот же серый/белый IP, на NATе статик роуты на подсеть (для каждого NASа своя подсеть), всё в порядке.
      Абонент без денег получает КАЖДЫЙ РАЗ новый серый адрес из подсети с маской /21, а NAT уже в душе не е*ёт, какой IP на какой NAS роутить, вот здесь пи*дец и наступает.
      Т.е. сейчас абон получил IP 172.30.1.1 на одном NASе, через час ребутнул свою железку, получил тут же IP 172.30.123.123, а 172.30.1.1 например, получил уже совсем другой абон, на совсем другом NASе. Итого, эдакая динамика.
       
      Сейчас решил через задницу (как по мне), но оно работает.
      Каждый NAS все ноумани IP роутит по отдельному маршруту на NAT, у каждого NASа свой влан, своя подсеточка для обмена с NATом, в свою очередь NAT добавляет в отдельный address list все src которые пришли с каждого влана, а обратный трафик исходя dst засылает на нужный NAS. Сами address list-ы динамические, т.е. новая запись появляется там только тогда, когда абон без денег пытается куда-то ломиться. Таймаут 30сек (или около того) и всё.
      Повторюсь, в принципе, всё работает, но через ж#пу. Если запросов от абона не было - то NAT снова же в душе не е*ёт, где тот абон и с каким он ипом сейчас.
       
      ЗАЧЕМ ЭТО НУЖНО:
      Чтобы дать возможность абонам без денег зайти в личный кабинет, пополнить счёт через приватики и прочую фигню, чтобы сайтик компании был доступен и прочие whitelist.
       
      Что хочется:
      Чтобы NASы волшебным образом обменивались с NATом маршрутами, чтобы NAT знал от NASa какие на нём сейчас абоны с ипами из диапазона /21.
       
      Что подскажете?
    • By Kiano
      Продам RouterOS level 6 x86_64
      С коробки видит всю оперативку (не 2гб)
      Официальная, никаких нюансов и приколов, снял у себя с продакшна, перешли на другое железо.
       
      В наличии 2 шт.
      Цена 2000 грн. за одну.

    • By tarantul13
      Продам вінчестер SSD з RouterOS Level5  х86. Підходить для запуску маршрутизатора на компютері. Ціна 2200.
    • By WideAreaNetwork
      пожалуйста посоветуйте нормальную флешку юсб для ROS, а то если глюкнет флешка не приятно будет
    • By maliner
      Продайте ключ L5 x86 routeros
×