Jump to content
Local
VitalyMoiseev

Pon Monitor - система мониторинга PON

Recommended Posts

On 9/19/2019 at 7:32 PM, camchatix said:

Firefox пише - 

 

Кодування - UTF-8
 

 

И как тогда Firefox писал про UTF-8?

Share this post


Link to post
Share on other sites
14 часов назад, Darth Vader2 сказал:

В силу того, что скучно, я нашел файл onu_detail.php, результат в браузере у меня:

 

Ethernet РїРѕСЂС‚ ID

 

Сейчас ради интереса буду искать у себя причину такого отображения.

 

p.s. дело в кодировке, по умолчанию на сервере windows-1251, а должно быть utf-8. Файл настроек апача или добавить в conf.d нужный конфигурационный файл. К примеру такой:

 


Alias /test /usr/share/test

<Directory /usr/share/test/>
AddDefaultCharset UTF-8
   AllowOverride All
   Order deny,allow
   Deny from All
   Allow from "ваш ip без кавычек"
</Directory>

После изменений:

 

Ethernet порт ID

 

 

 

<Directory "/usr/local/www/apache24/iteco">
AddDefaultCharset UTF-8
 

 

запустив phpinfo()

результат - 

default_charset UTF-8UTF-8

default_mime type text/html text/html

 

всерівно крякозябрі....

 

щось на сервері не хватає ? якогось модуля ?

Share this post


Link to post
Share on other sites

Создайте файл .htaccess, укажите в нём содержимое

AddDefaultCharset UTF-8

 

смотрите вывод в браузере, кодировка должна соответствовать UTF-8

 

меняйте на

AddDefaultCharset WINDOWS-1251

смотрите вывод в браузере, кодировка должна соответствовать WINDOWS-1251

 

Закиньте в директорию обрезанный файл onu_detail.php, в котором оставьте только это (не копируйте отсюда, отредактируйте свой файл):

 

<?php

    echo '<table class="features-table" width="100%"><thead><tr>';
    echo '<td class="grey">Ethernet порт ID</td>';
    echo '<td class="grey">State</td>';
    echo '<td class="grey">PVID</td>';
    echo '<td class="grey">Manage</td>';
    echo '</tr></thead>';
    echo '<tbody>';

Открывайте его в браузере, меняйте кодировку и ищите причину, почему у Вас слово "ПОРТ" отображается кракозяблами.

Edited by Darth Vader2

Share this post


Link to post
Share on other sites
В 10.09.2019 в 16:22, VitalyMoiseev сказал:

по уведомлению в телеграм: планирую на этой неделе.

работать будет так:

настройка:

1. Регистрируем телеграм-бота, получаем его токен, при желании - настраиваем ему аватарку и прочее

Дальше есть два варианта - автоматическое добавление получателей или вручную. Лучше, конечно, автоматически, но для этого ПонМонитор должен работать по https. Еще плюс автоматического варианта - можно коммандой боту выключить-включить уведомления. Плюс можно еще какие-угодно комманды реализовать через телеграм.

Автоматический вариант:

2. В настройках ПонМонитора указываем полученный токен, получаем адрес веб-хука, даем комманду телеграм-боту установить этот веб-хук. После этого ПонМонитор может принимать комманды через телеграм-бота.

3. В телеграме находим нашего бота, даем ему комманду /start - и мы автоматически подписываемся на сообщения.

Ручной вариант:

2. Находим в телеграме нашего бота, пишем ему что угодно

3. через браузер получаем апдейт от бота, смотрим в полученном тексте чат-ид и вписываем его в настройках ПонМонитора. И так каждый раз для каждого получателся уведомлений

4. В настройках ПонМонитора ставим галочки - уведомление о изменении статуса чего присылать: ОЛТ, линки на портах ОЛТ (епон, езернет и т.д.), ОНУ

 

Получаем уведомления. При этом проверка ОЛТ и портов можно в кроне сделать отдельно от опроса ОНУ

 

Может у кого еще какие идеи по уведомлениям через телеграм? Чтоб потом не переделывать :)

 

В 11.09.2019 в 23:37, VitalyMoiseev сказал:

можно, сделаю.

Поиск по маку можно в двух вариантах - по текущим макам на ОЛТ, или по крону собирать ФДБ таблицу и хранить ее в базе, и потом в базе искать. В таком варианте есть плюс, что можно найти того клиента, ОНУ которого отключена

С интересом ждем новую версию.

Share this post


Link to post
Share on other sites

Превращаете постепенно в кашу. Нет четкого разграничение зон ответственности клиента и провайдера. Зачем мониторить клиентское оборудование? Что будете делать, если клиент свою ОНУ отключит? Зачем вам вообще знать об этом, работает конкретна ОНУ клиента или он её отключил? Может он автомат подачи электричества отключил в доме?

 

Есть техподдержка, есть телефон, если у клиента возникнет проблема на его стороне, то он обязательно позвонит. А дальше дело диагностики, соответственно в дело вступают другие механизмы, инструменты и они в руках техподдержки. Именно техподдержка выполняет диагностику, принимает заявку и регулирует процессы ремонта, восстановления. Техподдержка сидит перед компьютером, ей телеграм точно не нужен, но нужны другие инструменты тестирования сети.

 

Реализация централизованного управления через телеграмм это неправильно для развитой структуры предприятия. Разве что удобно для мелкого провайдера, у кого сеть две хаты в разных сёлах и это один человек-оркестр, у которого нет работников на постоянной основе, только подрядчики и временно нанятые. Кроме того, что будете делать, когда сломается доступ в интернет у сервера пон-монитора? Поддержка домена, выделенный ip, https сертификат. Не слишком ли много зависимостей возникает? Да, всё решаемо, но есть и другой путь - оптимизация производства. Вы сейчас загоните пон-монитор в угол и он превратится в монструозное недоразумение, коим стали многие его собраться и интерес к нему возникнет у ограниченной аудитории. Мой совет, пока не поздно, либо разделите проекты, либо стройте адекватную систему, а не многорукую шиву с перманентными зависимостями, не превращайтесь в блевотный юэергейт.

 

Впрочем, я не настаиваю и обсуждать своё сообщение точно не буду. :)

Edited by Darth Vader2
  • Like 1

Share this post


Link to post
Share on other sites
В 22.09.2019 в 22:47, Darth Vader2 сказал:

Создайте файл .htaccess, укажите в нём содержимое

AddDefaultCharset UTF-8

 

смотрите вывод в браузере, кодировка должна соответствовать UTF-8

 

меняйте на

AddDefaultCharset WINDOWS-1251

смотрите вывод в браузере, кодировка должна соответствовать WINDOWS-1251

 

Закиньте в директорию обрезанный файл onu_detail.php, в котором оставьте только это (не копируйте отсюда, отредактируйте свой файл):

 


<?php

    echo '<table class="features-table" width="100%"><thead><tr>';
    echo '<td class="grey">Ethernet порт ID</td>';
    echo '<td class="grey">State</td>';
    echo '<td class="grey">PVID</td>';
    echo '<td class="grey">Manage</td>';
    echo '</tr></thead>';
    echo '<tbody>';

Открывайте его в браузере, меняйте кодировку и ищите причину, почему у Вас слово "ПОРТ" отображается кракозяблами.

 

Я скопировал файл в другой (123.php)

 

открываю в браузере - меняю в .htaccess и в httpd.conf charset default - windows-1251, utf-8

а в браузере всегда отображается правильно слово ПОРТ...

а на самой странице - кряки %(((

я уже не знаю где копать....

 

http://iteco.com.ua/123.php - обрезаный onu_detail - текст ОК

http://iteco.com.ua/ - index.php - текст кряки

 

Share this post


Link to post
Share on other sites
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 
<html lang="ru">

 

Ошибка в DOCTYPE, исправьте, думаю, что должно будет взлететь.

 

файл /include/header.php

 

вместо
 

<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\"
<html lang=\"$lang\"><head><title>$title</title>
<META HTTP-EQUIV=\"Content-Type\" CONTENT=\"text/html;charset=UTF-8\" />
<meta name=\"viewport\" content=\"width=device-width\" />
<style type=\"text/css\">

 

укажите

 

<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\"
\"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\">
<html lang=\"$lang\"><head><title>$title</title>
<META HTTP-EQUIV=\"Content-Type\" CONTENT=\"text/html;charset=UTF-8\" />
<meta name=\"viewport\" content=\"width=device-width\" />
<style type=\"text/css\">

 

Когда будете сохранять, обязательно сохраните в UTF-8

Edited by Darth Vader2

Share this post


Link to post
Share on other sites

И еще, файл /include/enterform.php строка 13 вместо

 

            <td class="green" width="60%"><input id="f1_name" name="username" required value="<?php echo $username; ?>" /</td>

поменять на

 

            <td class="green" width="60%"><input id="f1_name" name="username" required value="<?php echo $username; ?>" /></td>

 

Edited by Darth Vader2

Share this post


Link to post
Share on other sites
16 часов назад, Darth Vader2 сказал:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 
<html lang="ru">

 

Ошибка в DOCTYPE, исправьте, думаю, что должно будет взлететь.

 

файл /include/header.php

 

вместо
 


<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\"
<html lang=\"$lang\"><head><title>$title</title>
<META HTTP-EQUIV=\"Content-Type\" CONTENT=\"text/html;charset=UTF-8\" />
<meta name=\"viewport\" content=\"width=device-width\" />
<style type=\"text/css\">

 

укажите

 


<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Strict//EN\"
\"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd\">
<html lang=\"$lang\"><head><title>$title</title>
<META HTTP-EQUIV=\"Content-Type\" CONTENT=\"text/html;charset=UTF-8\" />
<meta name=\"viewport\" content=\"width=device-width\" />
<style type=\"text/css\">

 

Когда будете сохранять, обязательно сохраните в UTF-8

 

поменял. Никаких изменений :(

удалил полностью строчку - тоже без результата

 

Share this post


Link to post
Share on other sites
8 минут назад, camchatix сказал:

без результата

у вас что-то криво в настройках апапача

в современных веб-серверах и браузерах уже давным давно забыли про всякие кодировки и т.п.

создайте в веб директории файлик с содержимым:

<?php
phpinfo();
?>

откройте его в браузере и покажите, что вывело

Share this post


Link to post
Share on other sites
7 минут назад, VitalyMoiseev сказал:

у вас что-то криво в настройках апапача

в современных веб-серверах и браузерах уже давным давно забыли про всякие кодировки и т.п.

создайте в веб директории файлик с содержимым:


<?php
phpinfo();
?>

откройте его в браузере и покажите, что вывело

http://iteco.com.ua/t.php

Share this post


Link to post
Share on other sites

с апачем все ок, и с файлами все ок.

Криво с кодировкой в базе. Либо не та кодировка в самой базе, либо криво залили дамп таблицы texts

Share this post


Link to post
Share on other sites

покажите из мискля:

SHOW CREATE DATABASE ponmon;

SHOW CREATE TABLE pm_texts;

Share this post


Link to post
Share on other sites

У вас текст формируется, скорее всего, не на странице, а всасывается из базы (не?). Так-как кодировка стоит UTF-8, а "кракозябры" в cp-1251 (win). Надо либо у источника текста менять charset, либо у страниц его менять.

 

Share this post


Link to post
Share on other sites
3 часа назад, VitalyMoiseev сказал:

покажите из мискля:

SHOW CREATE DATABASE ponmon;

SHOW CREATE TABLE pm_texts;

 

| pon      | CREATE DATABASE `pon` /*!40100 DEFAULT CHARACTER SET utf8 */ |

 

pm_texts | CREATE TABLE `pm_texts` (
  `Id` int(11) NOT NULL AUTO_INCREMENT,
  `label` varchar(255) DEFAULT NULL,
  `label_uk` text,
  `label_ru` text,
  PRIMARY KEY (`Id`),
  UNIQUE KEY `label` (`label`)
) ENGINE=InnoDB AUTO_INCREMENT=80 DEFAULT CHARSET=utf8 |

 


 

1 час назад, vop сказал:

У вас текст формируется, скорее всего, не на странице, а всасывается из базы (не?). Так-как кодировка стоит UTF-8, а "кракозябры" в cp-1251 (win). Надо либо у источника текста менять charset, либо у страниц его менять.

 

 

тот крякозаберный текст из PHP файлов отдается клиенту а не с базы...

 

Share this post


Link to post
Share on other sites
39 минут назад, camchatix сказал:

тот крякозаберный текст из PHP файлов отдается клиенту а не с базы...

это вы мне рассказываете, что там откуда отдается? :)

с базой все ОК, значит дамп залили криво

Скрытый текст

image.thumb.png.5b747fd941e1349e8c6a31a4fa579246.png

Скрытый текст

image.png.185d786064a283f00554d6ba4c0daec0.png

        <td class="grey" width="60%"><?php echo $labels['bilenter']; ?></td>
        
    </tr>

<?php
switch ($lang) {
        case 'ru':
            echo "<a href=\"\" onclick=\"set_lang('uk'); return false;\">Українська</a> - Русский";
            break;
        case 'uk':
            echo "Українська - <a href=\"\" onclick=\"set_lang('ru'); return false;\">Русский</a>";
            break;
    }
    ?>

Вот код: Надпись "Вхід у Pon Monitor" - она из базы, надписи "Українська - Русский" - они из файла.

Как и чем зщаливаете дамп таблицы в базу?

Edited by VitalyMoiseev

Share this post


Link to post
Share on other sites

PhpMyAdmin откройте, посмотрите в таблице pm_texts текст как отображется?

 

Первый пример ничего общего с базой не имел. А теперь действительно на базу указывает всё. Комплексная какая-то проблема?

Edited by Darth Vader2

Share this post


Link to post
Share on other sites

насколько помню, через PhpMyAdmin лучше дамп заливать заархивированным, чтоб избежать перекодировки файлов

Share this post


Link to post
Share on other sites

Большое спасибо что помогли и за ваше терпение ВСЕМ!

 

база создавалась с кодировкой УТФ8. Таблицы тоже проверил - все УТФ8

скачал файл с сайта, на сервере unzip ponmon.zip. Потом mysql -uroot -p -D pon <pon.sql

файл дампа заливался в базу с кряками.

поставил phpmyadmin -  в таблице кряки. удалил таблицы, импорт файла в браузере через phpmyadmin - и все ок. таблица pm_texts в порядке

 

Спасибо что помогли!

 

пс. Готовы донатить если будет версия для ZTE C300

 

Share this post


Link to post
Share on other sites

Видимо в консоли стоит другая кодировка. Там есть такая фишка:

mysql --default-character-set=utf8

 

PS Может я и не прав.

Share this post


Link to post
Share on other sites

Міг би протестити роботу із BDCOM GP3600-08, GP3600-16, є в наявності різних версій прошивок.

Share this post


Link to post
Share on other sites
В 26.09.2019 в 19:27, camchatix сказал:

Большое спасибо что помогли и за ваше терпение ВСЕМ!

 

база создавалась с кодировкой УТФ8. Таблицы тоже проверил - все УТФ8

скачал файл с сайта, на сервере unzip ponmon.zip. Потом mysql -uroot -p -D pon <pon.sql

файл дампа заливался в базу с кряками.

поставил phpmyadmin -  в таблице кряки. удалил таблицы, импорт файла в браузере через phpmyadmin - и все ок. таблица pm_texts в порядке

 

Спасибо что помогли! 

 

пс. Готовы донатить если будет версия для ZTE C300

 

а по вашей голове оригинальная дорументация присутствует?

Share this post


Link to post
Share on other sites

Добрый день форумчане!

Появилась проблема, такого плана:

установил Ubuntu Bionic LTS, php sql, apache настроил их по мануалам, и возникла проблема неработающей страницы сразу после Аутентификации.

Захожу на http://127.0.0.1/superdomain/ ввожу логин и пароль, перекидывает на страницу http://127.0.0.1/superdomain/auth и

Not Found

The requested URL was not found on this server.

Apache/2.4.29 (Ubuntu) Server at 127.0.0.1 Port 80

Я побегал по форумам и сделал:

a2enmod rewrite
service apache2 restart

и файл .htaccess

 

#Options +FollowSymLinks
DirectoryIndex index.php

IndexIgnore */*

AddDefaultCharset UTF-8;
RewriteEngine on


# if a directory or a file exists, use it directly
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

# otherwise forward it to index.php
RewriteRule . index.php

 

Логи апача

[Fri Nov 08 13:00:46.456748 2019] [mpm_prefork:notice] [pid 2283] AH00169: caught SIGTERM, shutting down
[Fri Nov 08 13:00:46.534561 2019] [mpm_prefork:notice] [pid 3595] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Fri Nov 08 13:00:46.534624 2019] [core:notice] [pid 3595] AH00094: Command line: '/usr/sbin/apache2'
[Fri Nov 08 13:07:59.156519 2019] [mpm_prefork:notice] [pid 3595] AH00169: caught SIGTERM, shutting down
[Fri Nov 08 13:07:59.234940 2019] [mpm_prefork:notice] [pid 3865] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Fri Nov 08 13:07:59.235005 2019] [core:notice] [pid 3865] AH00094: Command line: '/usr/sbin/apache2'
[Fri Nov 08 13:09:49.081991 2019] [mpm_prefork:notice] [pid 3865] AH00169: caught SIGTERM, shutting down
[Fri Nov 08 13:10:39.454611 2019] [mpm_prefork:notice] [pid 958] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[Fri Nov 08 13:10:39.519527 2019] [core:notice] [pid 958] AH00094: Command line: '/usr/sbin/apache2'

 

Не пойму куда копать (

Edited by trsnah

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Andrey1980
      КУПЛЮ БУ BDCOM 3310c
    • By dnserg
      Б.У. В работе было 2 года. Цена - 32400 грн. В цену модуля не входят. минимальный торг.
       

    • By Romari0
      Продам
       
      Quanta LB6M 10GbE 24-Port SFP 4x 1GbE, прошита под брокейд, жрет как 10ж так и 1ж модули - 400 баксов
       
      MikroTik CCR1036-12G-4S - 500 баксов
       
      OLT BDCOM P3310B есть три штуки, по 300 баксов за штуку или 850 за три сразу
       
      Все добро находится в г. Бровары, могу подвезти в Киев, или отправлю новой почтой
    • By XNeo
      Всем привет
       
      Такая вот конфигурация клиента:
      interface EPON0/6:1 epon onu port 1 ctc vlan mode tag 222 priority 0 epon onu port 1 loopback detect epon onu port 1 storm-control mode 4 threshold 256 epon onu port 1 ip access-group access_list_6:23 От клиента валит флуд следующего типа:
      74:ea:3a:ad:xx:xx (oui Unknown) > Broadcast, ethertype ARP (0x0806), length 60: Request who-has 192.168.1.1 tell 192.168.1.1, length 46 Около 2500 пакетов в секунду. ONU никак не реагирует. Что я упустил/сделал не так?
       
      BDCOM(tm) P3608-2TE Software, Version 10.1.0E Build 60793
      ONU Model 151C, 10.0.17A 1007.
    • By imbiter
      Замінили 3310С на 3608В,
      ОНУ NGpon E105 - не реєструються, йде циклічна перереєстрація
      Інші ОНУ працюють без проблем
       
      прошивка version 10.1.0F build 58197
       
      з конфігу вже викинули все, оставили самий мінімум.
      в чому може бути проблема?
       
      !version 10.1.0F build 58197 service timestamps log date service timestamps debug date logging buffered 4096 ! hostname test port-protected 1 ! ! ! ! ! ! spanning-tree mode rstp ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! ! aaa authentication login default local aaa authentication enable default none aaa authorization exec default local ! username .......... ! ! ! ! epon oam-version 1 0x30 epon oam-version 2 0x21 epon oam-version 3 0x20 ! epon onu-config-template 1 cmd-sequence 001 epon onu all-port ctc vlan mode tag 25 ! ! interface Null0 ! interface FastEthernet0/0 no ip address no ip directed-broadcast ! !!slot 0 1 unknow CARD interface GigaEthernet0/1 switchport mode trunk ! interface GigaEthernet0/2 switchport mode trunk ! interface GigaEthernet0/3 switchport mode trunk ! interface GigaEthernet0/4 switchport mode trunk ! interface GigaEthernet0/5 switchport mode trunk ! interface GigaEthernet0/6 switchport mode trunk ! interface GigaEthernet0/7 switchport mode trunk ! interface GigaEthernet0/8 switchport pvid 9 ! interface TGigaEthernet0/1 switchport mode trunk ! interface TGigaEthernet0/2 shutdown ! interface EPON0/1 epon pre-config-template 1 binded-onu-llid 1-64 epon bind-onu mac .... epon bind-onu mac switchport mode trunk switchport protected 1  
×