Jump to content

Pon Monitor - система мониторинга PON


Recommended Posts

  • Replies 331
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Вот решил выдать, кому интересно, собстветнную систему мониторинга PON сети - Pon Monitor. Сделана по аналогии с Poncontrol, но делалась по потребностям инженеров и монтажников.   Возмо

проект живой. Продвигается медленно, так как нет на него пока времени

Вот Pon Monitor под BDCOM GP3600-16 Берите кому нужно. Переделка не профессиональная, поэтому берите как есть Pon Monitor.rar

Posted Images

  • 1 month later...
42 минуты назад, Kto To сказав:

У кого есть контакт с автором? Пару месяцев пишу на почту, все безуспешно :(

Мені відписував 2.11

 

Edited by Інет.укр
Link to post
Share on other sites
27 минут назад, Kto To сказав:

У кого есть контакт с автором?

у меня есть :)
Но времени адаптировать под ГКОМ или что-то другое, к сожалению, нет. Тут бы версию 2 хотя-бы допилить.

Link to post
Share on other sites
  • 3 weeks later...

Поставил систему добавил OLT, но ничего не происходит,тест SNMP и telnet проходит а результата ноль в базу ону не записываются при открытии файла check_onu.php в браузере выдает следующее, "-6703 sec from last start, exit"  OLT V-SOL V1600D

Link to post
Share on other sites
15 часов назад, vitalijkee сказал:

Поставил систему добавил OLT, но ничего не происходит,тест SNMP и telnet проходит а результата ноль в базу ону не записываются при открытии файла check_onu.php в браузере выдает следующее, "-6703 sec from last start, exit"  OLT V-SOL V1600D

Эта система под BDCOM запилена, вроде как

Link to post
Share on other sites
45 минут назад, vitalijkee сказал:

OID  были заменены BDCOM на  VSOL. 

так этого мало.

Эта система под EPON BDCOM

Я пытался под себя подредактировать, под GPON BDCOM, и это было не так быстро. И без помощи автора было бы тяжко.

И то, работает процентов 60 всего функционала

Edited by trsnah
Link to post
Share on other sites

Да это понятно что тяжко,вот и пришел сюда,за помошью может кто подскажет куда копнуть чтобы хоть что-то заработало.просто смотрю у многих завелось и работает.Думаю дай попробую,чтобы с нуля не заморачиватся и не писать под v-sol 

 

 

Link to post
Share on other sites
1 час назад, vitalijkee сказал:

Да это понятно что тяжко,вот и пришел сюда,за помошью может кто подскажет куда копнуть чтобы хоть что-то заработало.просто смотрю у многих завелось и работает.Думаю дай попробую,чтобы с нуля не заморачиватся и не писать под v-sol 

 

 

Я не спец по php, поэтому не помогу. Но там в общем нужно исходник колупать, а не snmp, а саму структуру массивов, переменных, которые в итоге дадут правильный вывод snmp на веб страницу.

Edited by trsnah
Link to post
Share on other sites
1 час назад, vitalijkee сказал:

интересно,автор еще тут,подскажет может что или проще забить и писать потихоньку своё?

Он очень редко комментит. Можете посмотреть разницу между его сообщениями

Link to post
Share on other sites
13 часов назад, trsnah сказал:

так этого мало.

Эта система под EPON BDCOM

Я пытался под себя подредактировать, под GPON BDCOM, и это было не так быстро. И без помощи автора было бы тяжко.

И то, работает процентов 60 всего функционала

поделись или продай. а что работает? фдб? сигналы?

Link to post
Share on other sites

Кто подскажет каков должен быть правильный вывод команды snmpwalk -v 2c -c tramatanga 192.168.128.162     1.3.6.1.4.1.37950.1.1.5.12.1.12.1 ?

Сначало сыпет кучу вот такого:  

Cannot find module (HOST-RESOURCES-MIB): At line 0 in (none)
Cannot find module (HOST-RESOURCES-TYPES): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (SNMPv2-SMI): At line 6 in /usr/share/snmp/mibs/IF-MIB.mib
Cannot find module (SNMPv2-TC): At line 9 in /usr/share/snmp/mibs/IF-MIB.mib
Cannot find module (SNMPv2-MIB): At line 11 in /usr/share/snmp/mibs/IF-MIB.mib
Did not find 'mib-2' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'DisplayString' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'PhysAddress' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'TruthValue' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'RowStatus' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'TimeStamp' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'AutonomousType' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'TestAndIncr' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)
Did not find 'snmpTraps' in module #-1 (/usr/share/snmp/mibs/IF-MIB.mib)

 

Потом выплевывает нормальные значения 

so.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.0 = STRING: "podst_ekat2"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.1 = STRING: "podst_ekat4"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.2 = STRING: "smidta_street"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.3 = STRING: "boiko"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.4 = STRING: "pekarnya"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.5 = STRING: "shmidt22"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.6 = STRING: "melnica"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.7 = STRING: "br_sovet"
iso.3.6.1.4.1.37950.1.1.5.12.1.12.1.10.8 = STRING: "parhomenko_1"

Link to post
Share on other sites

FDB не работает, не было времени. Но там не сложно переделать.

Не работает онлайн/офлайн

Расстояние

Всё остальное работает

Безымянный1.jpg

Безымянный 12.jpg

Link to post
Share on other sites
1 час назад, ~Tornado~ сказал:

Таки да, на 3608B таблицу FDB не отображает :(

Тоже не отображается и бывает очень долго думает прежде чем отобразить инфу 

Link to post
Share on other sites
  • 2 weeks later...

Вот Pon Monitor под BDCOM GP3600-16

Берите кому нужно. Переделка не профессиональная, поэтому берите как есть

Pon Monitor.rar

Edited by trsnah
  • Like 5
Link to post
Share on other sites
  • 1 month later...

Уже весна нового года... Возможно, автор найдет время на допиливание ПОН-монитора?

А ми скинемся автору на хорошее пиво с рыбкой, или с чем автор сам пожелает?

 

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Pasivka
      Продам залишки :
      - пігтейли :
      LC/UPS 1.5 м 72шт  - 4 грн/шт
      SC/UPC 1.5м 72шт  - 4грн/шт
      - адаптер SC/UPC 150шт/100грн
      - FOB-04-16    2шт   - 100грн/шт
      - Crosver Fosc-MB-338/24-1-12-9SC 6шт                               - 85грн/шт
      - дільник 1/8  30шт  - 85грн/шт








    • By Pasivka
      Продам залишки :
      - пігтейли :
      LC/UPS 1.5 м 72шт  - 4 грн/шт
      SC/UPC 1.5м 72шт  - 4грн/шт
      - адаптер SC/UPC 150шт/100грн
      - FOB-04-16    2шт   - 100грн/шт
      - Crosver Fosc-MB-338/24-1-12-9SC 6шт                               - 85грн/шт
      - дільник 1/8  30шт  - 85грн/шт








    • By Ilya016
      Проблема в следующем. Была задача от начальства перенести конфиг (Не важно как. Я перебил команды вручную) с p3310c на p3608.
      Уже раньше так делал, ничего вроде сложного (это не писать конфиг с нуля), но произошел конфуз... При замене с 33-ей на 36-ую устройство не поднялось. А именно какой-то косяк с приходом. Не регистрируется, удаленного доступа нет, трафик вроде даже не бегает. В чем может быть косяк? Настройки почти идентичные, лишь некоторые расхождений в синтаксисе (на мой оч. непрофессиональный взгляд). Кто сможет, помогите плз.
       
      конфиг 3310:
      !version 10.1.0E build 46085
      service timestamps log date
      service timestamps debug date
      service password-encryption
      logging buffered 4096
      !
      hostname **************
      port-protected 1
      !
      !
      !
      !
      ip default-gateway ***.***.171.1
      !
      !
      spanning-tree mode rstp
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      aaa authentication login default local
      aaa authentication enable default none
      aaa authorization exec default local
      !
      username admin password 7 ******************
      username user password 7 *****************
      !
      !
      epon oam-version 1 0x30
      epon oam-version 2 0x21
      epon oam-version 3 0x20
      !
      !!slot 0 89
      interface GigaEthernet0/1
       description Uplink_mikrotik
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/2
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/3
       shutdown
       description _
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/4
       description _
       switchport trunk vlan-allowed 176
       switchport mode trunk
      !
      interface GigaEthernet0/5
       description Storojka
       switchport trunk vlan-allowed 176,240
       switchport trunk vlan-untagged 240
       switchport pvid 240
      !
      interface GigaEthernet0/6
       description mikrotik_AC_monitoring
       switchport trunk vlan-allowed 171
       switchport mode trunk
        dhcp snooping trust
      !         
      !!slot end
      !         
      interface VLAN171
       description management
       ip address ***.***.171.10 255.255.255.0
      !         
      interface VLAN236
       no ip address
      !         
      interface VLAN239
       no ip address
      !         
      interface VLAN240
       no ip address
      !         
      !         
      !         
      vlan 1,70,171,173,175-176,232-240
      !         
       loopback-detection
      !         
      !         
      !         
      ip dhcp-relay snooping
      ip dhcp-relay snooping vlan  240
      !         
      !         
      ip http server
      !         
      !         
      !         
      snmp-server community 0 ******* ** 
      snmp-server community 0 ******* **** ******
      snmp-server contact ************
      snmp-server location *************
      !         
      line console 0
       length 256
       width 256
      !         
      line vty 0 1
       exec-timeout 0
       length 256
       width 256
      !         
      line vty 2 31
       exec-timeout 0
      !         
      !
      !
      ip sshd enabled
      !
      time-zone Moscow 3 0
      ntp query-interval 720
      ntp server ***.***.***.***
      !         
      !Pending configurations for absent linecards:
      !         
      !No configurations pending global
       
      Конфиг p3608:
      !version 10.1.0F build 72136
      service timestamps log date
      service timestamps debug date
      service password-encryption
      logging buffered 4096
      !
      hostname ***********
      port-protected 1
      !
      !
      !
      !
      !
      !
      spanning-tree mode rstp
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      aaa authentication login default local
      aaa authentication enable default none
      aaa authorization exec default local
      !
      username admin password 7 ****************************
      username user password 7 *************************
      !
      !
      !
      !
      epon oam-version 1 0x30
      epon oam-version 2 0x21
      epon oam-version 3 0x20
      !
      interface Null0
      !
      interface FastEthernet0/0
       shutdown
       ip address 192.168.0.1 255.255.255.0
       no ip directed-broadcast
      !
      !!slot 0 1 unknow CARD
      interface GigaEthernet0/1
       description Uplink_mikrotik_sfp
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/2
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/3
       shutdown
       description _
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/4
       description _
       switchport trunk vlan-allowed 176
       switchport mode trunk
      !
      interface GigaEthernet0/5
       description Storojka
       switchport trunk vlan-allowed 176,240
       switchport trunk vlan-untagged 240
       switchport mode dot1q-tunnel-uplink
       switchport pvid 240
      !
      interface GigaEthernet0/6
       description mikrotik_AC_monitoring
       switchport trunk vlan-allowed 171
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/7
       description Uplink_mikrotik
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/8
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      interface TGigaEthernet0/1
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      interface TGigaEthernet0/2
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      !
      !!slot end
      !
      interface VLAN171
       description management
       ip address ***.***.171.10 255.255.255.0
       no ip directed-broadcast
      !
      interface VLAN236
       no ip address
       no ip directed-broadcast
      !
      interface VLAN239
       no ip address
       no ip directed-broadcast
      !
      interface VLAN240
       no ip address
       no ip directed-broadcast
      !
      !
      !
      vlan 1,70,171,173,175-176,232-240
      !
       loopback-detection
      !
      !
      !
      !
      ip dhcp-relay snooping
      ip dhcp-relay snooping vlan  240
      !
      !
      !
      !
      !
      !
      ip route default ***.***.171.1
      ip exf
      !
      ipv6 exf
      !
      !
      ip http server
      !
      !
      !
      snmp-server community 0 ******* **
      snmp-server community 0 ***** *** *****
      snmp-server contact ***************
      snmp-server location *************
      !
      line console 0
       length 256
       width 256
      !
      line vty 0 1
       exec-timeout 0
       length 256
       width 256
      !
      line vty 2 31
       exec-timeout 0
      !
      !
      !
      ip sshd enable
      !
      time-zone Moscow 3 0
      ntp query-interval 720
      ntp server ***.***.***.***
      !
      !Pending configurations for absent linecards:
      !
      !No configurations pending global
       
       
      На 33-ей приход в 1 gigaethernet, на 36-ой в 7-ой gigaethernet, т.к. на ней нет медных портов до 5-го
    • By ssergiy
      Надаю послуги по розварюванню (сварці), зварюванню оптоволоконна, магістральних ВОЛЗ. Пошук пошкодження, втрати сигналу, вхідний контроль, контроль після прокладки та монтажу. При потребі виконаю виміри рефлектометром, оптичними тестерами.
      При потребі надам виконавчу документацію згідно КНД41-141-99.
      Досвід роботи по будівництву та монтажу ВОЛЗ, PON мережі.
      Ціна залежить від об'єму робіт.
      Можливий виїзд.
      т. 0959310003
    • By os8143385.com
      Продам OLT-и BDCOM у відмінному стані, у зв'язку з переходом на XPON.
      В наявності:
      BDCOM 3616-2TE - 1шт ( 1350 $ )
      BDCOM 3608-2TE - 1шт ( 650 $ )
      BDCOM 3608        - 1шт ( 500 $ )
      BDCOM 3310        - 3шт ( 300 $ )
      Курс 33 грн.
       



×
×
  • Create New...