Jump to content

Pon Monitor - система мониторинга PON


Recommended Posts

On 16.12.2019 at 19:01, CoCOsmall said:

Немного оффтоп, есть может у кого oid под zte c300/c320 для трафика на ону?

Аналог вывода комманды show interface gpon-onu_1/2/1:1 либо какой-то способ того же, но для конкретного VLAN.
1424585573_.png.304f01a6ae142c3d77186a1d1b508693.png

onu in/out oid  у кого?

Link to post
Share on other sites
  • 1 month later...
  • Replies 331
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Вот решил выдать, кому интересно, собстветнную систему мониторинга PON сети - Pon Monitor. Сделана по аналогии с Poncontrol, но делалась по потребностям инженеров и монтажников.   Возмо

проект живой. Продвигается медленно, так как нет на него пока времени

Вот Pon Monitor под BDCOM GP3600-16 Берите кому нужно. Переделка не профессиональная, поэтому берите как есть Pon Monitor.rar

Posted Images

  • 4 weeks later...

SNMP не отвечает (см. скрин). OLT  BDCOM P3310B. Софт Version 10.1.0B Build 22960.  Из консоли Ubuntu server 16 x32 (на этой же системе PON monitor)  все замечательно отзывается.

Bdcom.jpg

Link to post
Share on other sites

Добавил графики сигнала и трафика на порту onu c zabbix. Темплейты для бдкомов сюда скидывал.https://local.com.ua/forum/topic/88117-zabbix-tempate-на-dlink-и-bdcom/?tab=comments#comment-1258027 Если кому интересно, выложу файлы.

image.thumb.png.46e87db9d94b1942de3f7d4e911a95b5.png

image.thumb.png.fd8046fa9093172a2a673bbcbc323ceb.png

 VitalyMoiseev , а возможно сделать поиск по MAC такого вида http://ponmonitor/search.php?mac=22:22:22:22:22:22

Что бы можно было с внешних программ попадать сразу на страницу искомой onu http://ponmonitor/PM/PON/1/1/1/22:22:22:22:22:22 ?

Edited by vovchokig
  • Thanks 1
Link to post
Share on other sites
В 13.03.2020 в 07:29, vovchokig сказал:

Добавил графики сигнала и трафика на порту onu c zabbix. Темплейты для бдкомов сюда скидывал.https://local.com.ua/forum/topic/88117-zabbix-tempate-на-dlink-и-bdcom/?tab=comments#comment-1258027 Если кому интересно, выложу файлы.

image.thumb.png.46e87db9d94b1942de3f7d4e911a95b5.png

image.thumb.png.fd8046fa9093172a2a673bbcbc323ceb.png

 VitalyMoiseev , а возможно сделать поиск по MAC такого вида http://ponmonitor/search.php?mac=22:22:22:22:22:22

Что бы можно было с внешних программ попадать сразу на страницу искомой onu http://ponmonitor/PM/PON/1/1/1/22:22:22:22:22:22 ?

Коментарий и ID подтягивается с ОЛТа? И кто какое время поставил в кроне, для обновления?

Link to post
Share on other sites
48 минут назад, Небесный сказав:

Коментарий и ID подтягивается с ОЛТа? И кто какое время поставил в кроне, для обновления?

Нет, не подтягиваются. Это или вручную, или привязать к биллингу.

Link to post
Share on other sites

Коментарий и ID подтягивается скорее всего с Биллинга, на данном скрине.

У меня не привязано к Биллингу, я сам всё пишу руками

У меня стоит 30 минут, пока что этого достаточно с головой.

Link to post
Share on other sites

Не все ОНУ обновляются по сигналу, зашел вручную проверить на ОЛТ, сигнал получаю.

Вот например вручную на проблемной ОНУшке делаю на сервере.

root@site:~# snmpwalk -v 2c -c ********* 10.10.100.3 .1.3.6.1.2.1.2.2.1.2.12
iso.3.6.1.2.1.2.2.1.2.12 = STRING: "EPON0/4:2"
root@site:~# snmpwalk -v2c -c ********* 10.10.100.3 .1.3.6.1.4.1.3320.101.10.5.1.5.12
iso.3.6.1.4.1.3320.101.10.5.1.5.12 = INTEGER: -315
 

 

Link to post
Share on other sites
В 19.03.2020 в 9:37 AM, Oktirus сказав:

Доброго дня, може хтось знає, чи можна підтягнути description з bdcom в pm?, тому що завжди підписували на самому bdcom.

Да було б непогано зробити можливість брати підписи з ОЛТ. Ми теж підписуємо на ОЛТ. Тако ж я б додав сигнали ОНУ Tx/Rx  бо зараз лише Tx, а бувають іноді перекоси...

Edited by CoUL
Link to post
Share on other sites

Доброго времени суток!

 

Господа, подскажите, что я делаю неправильно?

 

1. Распаковал архив в подпапку pm веб-сервера.

2. Создал базу и пользователя.

3. Залил шаблон базы.

4. Отредактировал /include/vars.php под свои параметры.

5. Назначил владельцем папки пользователя вебсервера.

 

После ввода учетных данных на странице http://address/pm, получаю перенаправление на http://address/pm/auth  с результатом not found...

 

P.S. Испытывалось на связке: apache+php7.3-fpm Модуль rewrite присутствует и активирован.

Link to post
Share on other sites
4 минуты назад, blood сказав:

После ввода учетных данных на странице http://address/pm, получаю перенаправление на http://address/pm/auth  с результатом not found...

скриншот покажите

Link to post
Share on other sites

362635490_.png.50dd18860fd9431bc0af3354bfc0829d.png

 

В логе апач-а:

[core:info] [pid 1794] [client 10.250.250.2:26046] AH00128: File does not exist: /var/www/pm/auth, referer: http://10.250.250.110/pm/index.php

 

Возможно, у меня не установлены необходимые модули php?

 

Также прошу помощи для конвертации .htaccess под nginx...

 

ЗЫ. Прошу сильно ногами не пинать...

Edited by blood
Link to post
Share on other sites
годину тому, blood сказав:

[core:info] [pid 1794] [client 10.250.250.2:26046] AH00128: File does not exist: /var/www/pm/auth, referer: http://10.250.250.110/pm/index.php

rewrite не работает

Link to post
Share on other sites
55 минут назад, VitalyMoiseev сказал:

rewrite не работает 

Благодарю за подсказку...

Действительно, отсутствовала деректива в конфигурации /Directory для rewrite.

 

 

Link to post
Share on other sites

Было бы неплохо сделать кнопку удаление(дерегистрация) onu c bdcom и сответственно с пон монитора.

  • Like 2
Link to post
Share on other sites

Всем не хворать 😃

У кого-то получилось $onu_macs  получить в нормальном виде на GP3600?

Link to post
Share on other sites

Добавил себе в корень файл поиска ону по маку, для редиректа с билинга. В данном случаэ из nodeny+ http://forum.nodeny.com.ua/index.php?topic=2786.90

Может кому понадобиться.

 

<?php

$mac_pm = $_GET['mac'];
require 'include/vars.php';
require 'include/database.php';
$mac_pm = str_replace(":", "", $mac_pm);
$mac_pm = str_replace("-", "", $mac_pm);
$mac_pm = str_replace(".", "", $mac_pm);
$mac_pm = str_replace("a", "A", $mac_pm);
$mac_pm = str_replace("b", "B", $mac_pm);
$mac_pm = str_replace("c", "C", $mac_pm);
$mac_pm = str_replace("d", "D", $mac_pm);
$mac_pm = str_replace("e", "E", $mac_pm);
$mac_pm = str_replace("f", "F", $mac_pm);
$any_mac_1 = substr($mac_pm, 0, 2);
$any_mac_2 = substr($mac_pm, 2, 2);
$any_mac_3 = substr($mac_pm, 4, 2);
$any_mac_4 = substr($mac_pm, 6, 2);
$any_mac_5 = substr($mac_pm, 8, 2);
$any_mac_6 = substr($mac_pm, 10, 2);

$any_mac = $any_mac_1.":".$any_mac_2.":".$any_mac_3.":".$any_mac_4.":".$any_mac_5.":".$any_mac_6;
$mac_pm = $any_mac;

$table = 'pm_onu';
$query = "SELECT * FROM `$table` WHERE `mac` = '$mac_pm'";
$result = $mysqli_wb->query($query);
$row = $result->fetch_array(MYSQLI_ASSOC);
$result->close();
    $onu_t = $row;
    $sfp_n = ltrim($onu_t['onu_name'], 'EPON0/');
    $sfp_n = explode(':',$sfp_n);
    $sfp_n = $sfp_n[0];
    $spl1 = explode("/", $onu_t['onu_name']);
    $spl2 = explode(":", $spl1[1]);
    $onu_n = $spl2[1];

$onu_T = $onu_t['olt'];
$onu_M = $onu_t['mac'];

$url = "$protocol$sitename/$base_url1/PON/$onu_T/$sfp_n/$onu_n/$onu_M";


 header ("Location:  $url");  
  exit();    


?>

 

Edited by vovchokig
  • Like 1
Link to post
Share on other sites
  • 4 weeks later...

При проверка telnet выкидает ошибку:

>su 
password: 
Access denied!

 

В конфиге админ прописан так:
 

aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
username admin password 0 ********
!
enable password 0 ****** level 15

Че не так? 

Link to post
Share on other sites
7 минут назад, VitalyMoiseev сказал:

пока нет поддержки enable пароля. Сегодня-завтра постараюсь добавить

Ясно, просто удобно было бы поменять конфигурацию ОНУшки прямо из сайта, чтобы не лезть на ОЛТ.

Link to post
Share on other sites

Небольшое расширение функционала - в списке ОНУ разным цветом выделены разные причины дерегистрации ОНУ:

Скрытый текст

image.thumb.png.27de90cfbddfd7012681c11b8d7eb9f2.png

На следующей неделе планирую выпустить новую версию с обновлениями.

  • Like 1
Link to post
Share on other sites
В 13.03.2020 в 7:29 AM, vovchokig сказав:

 VitalyMoiseev , а возможно сделать поиск по MAC такого вида http://ponmonitor/search.php?mac=22:22:22:22:22:22

Что бы можно было с внешних программ попадать сразу на страницу искомой onu http://ponmonitor/PM/PON/1/1/1/22:22:22:22:22:22 ?

пробуйте.

Файлик в корень. Использовать:

/redirect.php?mac=00:11:22:33:44:55

понимает и 0011.2233.4455 и просто 001122334455

redirect.php

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Pasivka
      Продам залишки :
      - пігтейли :
      LC/UPS 1.5 м 72шт  - 4 грн/шт
      SC/UPC 1.5м 72шт  - 4грн/шт
      - адаптер SC/UPC 150шт/100грн
      - FOB-04-16    2шт   - 100грн/шт
      - Crosver Fosc-MB-338/24-1-12-9SC 6шт                               - 85грн/шт
      - дільник 1/8  30шт  - 85грн/шт








    • By Pasivka
      Продам залишки :
      - пігтейли :
      LC/UPS 1.5 м 72шт  - 4 грн/шт
      SC/UPC 1.5м 72шт  - 4грн/шт
      - адаптер SC/UPC 150шт/100грн
      - FOB-04-16    2шт   - 100грн/шт
      - Crosver Fosc-MB-338/24-1-12-9SC 6шт                               - 85грн/шт
      - дільник 1/8  30шт  - 85грн/шт








    • By Ilya016
      Проблема в следующем. Была задача от начальства перенести конфиг (Не важно как. Я перебил команды вручную) с p3310c на p3608.
      Уже раньше так делал, ничего вроде сложного (это не писать конфиг с нуля), но произошел конфуз... При замене с 33-ей на 36-ую устройство не поднялось. А именно какой-то косяк с приходом. Не регистрируется, удаленного доступа нет, трафик вроде даже не бегает. В чем может быть косяк? Настройки почти идентичные, лишь некоторые расхождений в синтаксисе (на мой оч. непрофессиональный взгляд). Кто сможет, помогите плз.
       
      конфиг 3310:
      !version 10.1.0E build 46085
      service timestamps log date
      service timestamps debug date
      service password-encryption
      logging buffered 4096
      !
      hostname **************
      port-protected 1
      !
      !
      !
      !
      ip default-gateway ***.***.171.1
      !
      !
      spanning-tree mode rstp
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      aaa authentication login default local
      aaa authentication enable default none
      aaa authorization exec default local
      !
      username admin password 7 ******************
      username user password 7 *****************
      !
      !
      epon oam-version 1 0x30
      epon oam-version 2 0x21
      epon oam-version 3 0x20
      !
      !!slot 0 89
      interface GigaEthernet0/1
       description Uplink_mikrotik
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/2
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/3
       shutdown
       description _
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/4
       description _
       switchport trunk vlan-allowed 176
       switchport mode trunk
      !
      interface GigaEthernet0/5
       description Storojka
       switchport trunk vlan-allowed 176,240
       switchport trunk vlan-untagged 240
       switchport pvid 240
      !
      interface GigaEthernet0/6
       description mikrotik_AC_monitoring
       switchport trunk vlan-allowed 171
       switchport mode trunk
        dhcp snooping trust
      !         
      !!slot end
      !         
      interface VLAN171
       description management
       ip address ***.***.171.10 255.255.255.0
      !         
      interface VLAN236
       no ip address
      !         
      interface VLAN239
       no ip address
      !         
      interface VLAN240
       no ip address
      !         
      !         
      !         
      vlan 1,70,171,173,175-176,232-240
      !         
       loopback-detection
      !         
      !         
      !         
      ip dhcp-relay snooping
      ip dhcp-relay snooping vlan  240
      !         
      !         
      ip http server
      !         
      !         
      !         
      snmp-server community 0 ******* ** 
      snmp-server community 0 ******* **** ******
      snmp-server contact ************
      snmp-server location *************
      !         
      line console 0
       length 256
       width 256
      !         
      line vty 0 1
       exec-timeout 0
       length 256
       width 256
      !         
      line vty 2 31
       exec-timeout 0
      !         
      !
      !
      ip sshd enabled
      !
      time-zone Moscow 3 0
      ntp query-interval 720
      ntp server ***.***.***.***
      !         
      !Pending configurations for absent linecards:
      !         
      !No configurations pending global
       
      Конфиг p3608:
      !version 10.1.0F build 72136
      service timestamps log date
      service timestamps debug date
      service password-encryption
      logging buffered 4096
      !
      hostname ***********
      port-protected 1
      !
      !
      !
      !
      !
      !
      spanning-tree mode rstp
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      aaa authentication login default local
      aaa authentication enable default none
      aaa authorization exec default local
      !
      username admin password 7 ****************************
      username user password 7 *************************
      !
      !
      !
      !
      epon oam-version 1 0x30
      epon oam-version 2 0x21
      epon oam-version 3 0x20
      !
      interface Null0
      !
      interface FastEthernet0/0
       shutdown
       ip address 192.168.0.1 255.255.255.0
       no ip directed-broadcast
      !
      !!slot 0 1 unknow CARD
      interface GigaEthernet0/1
       description Uplink_mikrotik_sfp
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/2
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/3
       shutdown
       description _
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/4
       description _
       switchport trunk vlan-allowed 176
       switchport mode trunk
      !
      interface GigaEthernet0/5
       description Storojka
       switchport trunk vlan-allowed 176,240
       switchport trunk vlan-untagged 240
       switchport mode dot1q-tunnel-uplink
       switchport pvid 240
      !
      interface GigaEthernet0/6
       description mikrotik_AC_monitoring
       switchport trunk vlan-allowed 171
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/7
       description Uplink_mikrotik
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/8
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      interface TGigaEthernet0/1
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      interface TGigaEthernet0/2
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      !
      !!slot end
      !
      interface VLAN171
       description management
       ip address ***.***.171.10 255.255.255.0
       no ip directed-broadcast
      !
      interface VLAN236
       no ip address
       no ip directed-broadcast
      !
      interface VLAN239
       no ip address
       no ip directed-broadcast
      !
      interface VLAN240
       no ip address
       no ip directed-broadcast
      !
      !
      !
      vlan 1,70,171,173,175-176,232-240
      !
       loopback-detection
      !
      !
      !
      !
      ip dhcp-relay snooping
      ip dhcp-relay snooping vlan  240
      !
      !
      !
      !
      !
      !
      ip route default ***.***.171.1
      ip exf
      !
      ipv6 exf
      !
      !
      ip http server
      !
      !
      !
      snmp-server community 0 ******* **
      snmp-server community 0 ***** *** *****
      snmp-server contact ***************
      snmp-server location *************
      !
      line console 0
       length 256
       width 256
      !
      line vty 0 1
       exec-timeout 0
       length 256
       width 256
      !
      line vty 2 31
       exec-timeout 0
      !
      !
      !
      ip sshd enable
      !
      time-zone Moscow 3 0
      ntp query-interval 720
      ntp server ***.***.***.***
      !
      !Pending configurations for absent linecards:
      !
      !No configurations pending global
       
       
      На 33-ей приход в 1 gigaethernet, на 36-ой в 7-ой gigaethernet, т.к. на ней нет медных портов до 5-го
    • By ssergiy
      Надаю послуги по розварюванню (сварці), зварюванню оптоволоконна, магістральних ВОЛЗ. Пошук пошкодження, втрати сигналу, вхідний контроль, контроль після прокладки та монтажу. При потребі виконаю виміри рефлектометром, оптичними тестерами.
      При потребі надам виконавчу документацію згідно КНД41-141-99.
      Досвід роботи по будівництву та монтажу ВОЛЗ, PON мережі.
      Ціна залежить від об'єму робіт.
      Можливий виїзд.
      т. 0959310003
    • By os8143385.com
      Продам OLT-и BDCOM у відмінному стані, у зв'язку з переходом на XPON.
      В наявності:
      BDCOM 3616-2TE - 1шт ( 1350 $ )
      BDCOM 3608-2TE - 1шт ( 650 $ )
      BDCOM 3608        - 1шт ( 500 $ )
      BDCOM 3310        - 3шт ( 300 $ )
      Курс 33 грн.
       



×
×
  • Create New...