Jump to content

Рабочий конфиг BDcom QinQ


Tormato

Recommended Posts

Всем привет,

 

Поделитесь рабочим конфигом стандартного QinQ.

Задача распаковать влан в первый порт онушки. Так и не понял как это сделать т.к. примеры не помогли☹️

Собсвенно есть 25 влан (тестирую на BDCOM P3616-2TE), который я хочу распаковать в порт клиенту, где клиент включается в порт онушки на interface EPON0/1:1.

Клиент хочет сам добавлять убавлять вланы.

Такое впечатление что оно такого не умеет но вдруг повезет...

Пытался так:

interface GigaEthernet0/5
 switchport trunk vlan-allowed 8,25,237
 switchport trunk vlan-untagged none
 switchport mode dot1q-tunnel-uplink

interface EPON0/1
 description Client-PON
 switchport trunk vlan-allowed 25
 switchport trunk vlan-untagged none
 switchport mode dot1q-translating-tunnel
 switchport pvid 25

interface EPON0/1:1
  epon onu port 1 ctc vlan mode tag 250 priority 0
  epon onu port 1 loopback detect

Но оно не работает плюс, здесь подразумевается что я должен знать о вланах клиента.

Edited by Tormato
Link to post
Share on other sites

Не знаю как BDCOM P3616-2TE, но что бы оно работало на на 3310B/C я настраивал следующим образом.

 

Что бы все пролезло.

system mtu 1976

Аплинк:

interface GigaEthernet0/5
 switchport trunk vlan-allowed 8,25,237
 switchport trunk vlan-untagged none
 switchport mode dot1q-tunnel-uplink

epon порт:

interface EPON0/1
 switchport mode dot1q-translating-tunnel
 switchport pvid 25
 switchport trunk vlan-allowed add 25

Далее глобально на самом олт(тут точно не помню, но если предварительно не настроить аплинк - есть вероятность, что потеряете управление к олту):

dot1q-tunnel

Далее настройка ону. То, что вы привели в примере - это когда от абонента прилетает нетегированный трафик и на ону навешивается тег 250. Тегированного трафика от абонента там быть не может. Что бы от абонента получать тегированный трафик и потом добавлять на него второй тег с влан 25 - нужно настраивать так:

interface EPON0/1:1
  epon onu port 1 ctc vlan mode trunk 100 200,300,500

В данном примере если от абонента прилетит нетегированный трафик - то ону добавит тег 100, а потом олт добавит второй тег 25. Так же на порту разрешены тегированные вланы 200,300 и 500. Олт на них тоже добавит второй тег с vlan-id 25. Но эти вланы(200,300 и 500) как бы нужно согласовывать с клиентом.

Что бы вланы с клиентом не согласовывать - ону можно настраивать так:

interface EPON0/1:1
  epon onu port 1 ctc vlan mode transparent

В конфиге оно отображаться не будет(т.к. это дефолтные настройки). При этом через езернет порт ону будет разрешен теггированный трафик с любым vlan-id. Второй вариант чреват последствиями - вы же не будите использовать целый epon порт olt, для включения одного клиента? Там будут другие ону с другими вланами. И как бы возможен такой исход, что клиент из epon0/1:1 захочет использовать такой же vlan-id, как вы назначили на epon0/1:2 или epon0/1:3. И если так случится - ничего хорошего из этого не выйдет. Ну и к этому клиенту будет лететь броадкаст из ваших вланов не зависимо от того использует он их или нет.

 

Ну и опять же - если для других ону под этим epon портом вы хотите использовать другие вланы, то при конфиге выше - олт и на другие вланы добавит второй тег с vlan-id 25. Что бы на другие вланы второй тег не добавлять можно настроить:

interface EPON0/1
switchport trunk vlan-allowed add 237
switchport dot1q-translating-tunnel mode flat translate 237 237 0 (или switchport dot1q-translating-tunnel mode flat translate 1to1 237 237 0)

Но тут есть ограничение. Таких вланов, на которые  олт не будет добавляться второй тег - можно настроить ограниченное количество.

 

И еще один важный момент. Если  вы используете ip dhcp-relay snooping + ip verify source например для vlan-id 237 - не уверен, что оно будет работать при использовании QinQ

 

Edited by khatgit
  • Like 4
  • Thanks 2
Link to post
Share on other sites

Спасибо, то что нужно и отдельное спасибо за подробности, их то в основном и не хватает из-за достаточно мутного процесса настройки.

Link to post
Share on other sites

system mtu 1600

 

interface g 0/x

switchport mode dot1q-tunnel-uplink

 

interface e 0/x

switchport trunk vlan-allowed 100-200

switchport pvid 25

 

dot1q-tunnel

 

interface epon 0/x:x

epon onu port 1 ctc vlan mode tag 100

Edited by gooddeath
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ikoko
      Вітаю !
      Куплю абонентське обладнання PON P2000-08B, P2000-16B, P2000-24B або щось аналогічне запропонуйте. 
    • By Axel K
      Вітаю!
       
      налаштування capsman
      /caps-man channel add band=2ghz-b/g/n extension-channel=disabled frequency=2412,2437,2462 name=channel1 add band=5ghz-a/n/ac extension-channel=disabled frequency=5180 name=channel5 skip-dfs-channels=yes tx-power=40 /caps-man datapath add bridge=Main client-to-client-forwarding=yes local-forwarding=no name=datapath1 /caps-man configuration add channel=channel1 datapath=datapath1 max-sta-count=20 mode=ap name=cfg1 rx-chains=0,1,2,3 ssid=25 tx-chains=0,1,2,3 add channel=channel5 datapath=datapath1 hide-ssid=no mode=ap name=cfg5 rx-chains=0,1,2,3 ssid=25 tx-chains=0,1,2,3 /caps-man access-list add action=reject allow-signal-out-of-range=10s disabled=no signal-range=-120..-85 ssid-regexp="" /caps-man manager set enabled=yes /caps-man provisioning add action=create-dynamic-enabled hw-supported-modes=ac master-configuration=cfg5 name-format=prefix-identity add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=cfg1 name-format=prefix-identity проблема у низькій швидкості у клієнта
      якщо включити local-forwarding=yes, клієнт підключається, але не отримує ір.
       
      розумію, що на bdcom не вистачає налаштувань, прошу допомоги.
    • By Futura
      Подскажите пожалуйста.
      Подключаюсь консольным кабелем через Putty, (Speed 9600) к данной голове, сыпет мусор, фото добавляю.
      При этом же конфиге подключаю 3310С, консоль работает.
      Что может быть? Какие параметры для подключения к 3310D?
       
       

    • By Axel K
      Вітаю спільноту!
      Є пон мережа на BDCOM p3310d. Задача розмістити точки доступу UNIFI.
      При налаштуванні самих точок підключених до роутера проблем не виникло.
      При підключенні напряму до ону точка іп отримує, на пінг відповідає, але в додатку не з'являється і при підключенні до вайфай іп клієнту не видає.
      Прошу підказки.
    • By Futura
      Подскажите пожалуйста, кто сталкивался, будут ли проблемы?
      Построили небольшой н/п, абоненты получились на удалении 19000-21000 м. с уровнями -17...-25 все на ONU BDCOM. 
      OLT BDCOM P3616-2TE (10.1.0F Build 74816), SFP модули С++.
×
×
  • Create New...