Jump to content
Local
Stiff

Inetaccess на Qt 4

Recommended Posts

Кто то обещал и .rpm выложить... Сделайте большой подарок :)

Share this post


Link to post
Share on other sites

Держи: qia-1.3.1-i386.rpm

Но честно предупреждаю: не проверял. Нет под рукой системы с RPM...

Share this post


Link to post
Share on other sites

Спасибо за оперативность. От меня вам низкий уклон.

Установилось без проблем, запускается тоже.

Настройки, логин и пароль вбил. Нажимаю "Подключится" вроде как пробует, через секунд 10 кнопка отжимается и все. В консоль выкидывает IAMainWindow::onStatChanged - status = 0

На сервере в лог пишет - User's connect failed. IP 192.168.Х.Х

Может ли быть из-за того, что сервер версии 2.014.7.6 RC2

Share this post


Link to post
Share on other sites

Спасибо за оперативность. От меня вам низкий уклон.

Установилось без проблем, запускается тоже.

Настройки, логин и пароль вбил. Нажимаю "Подключится" вроде как пробует, через секунд 10 кнопка отжимается и все. В консоль выкидывает IAMainWindow::onStatChanged - status = 0

На сервере в лог пишет - User's connect failed. IP 192.168.Х.Х

Может ли быть из-за того, что сервер версии 2.014.7.6 RC2

Да, версия слишком старая. Последние версии сервера поддерживают старые авторизаторы, но новые авторизаторы не умеют работать со старыми версиями сервера.

Share this post


Link to post
Share on other sites

Значить так

Поставил новый сервак, завел там новую версию stargazer-2.405.9.8

Протестил обе версии

 

Вариант авторизатора от Stiff-а собранный из svn собрался и работает. Запускается, подключается, но названия направлений выводятся бякой, вообщем бока с кодировкой

 

madf, еще раз спасибо за .rpm. Твой вариант, тоже запускается, отлично подключается, все красиво показывает по направлениям. Но если поставить птичку "Привязать пароль на hdd" (правда не уверен что именно из-за нее) - такое начинается О_о. Хочет показать окно насчет ошибки, но так как кеды виснут нахрен, точно сказать не могу. Может вылазит дофига сообщений про ошибку и поэтому виснет, вообщем хз. Но версия сырая - поэтому претензий ноль. А может из-за того что у меня compiz...

 

Плохо, что при автоподключении не сворачивается само. И если нажимаешь свернуть, трындит про, что "Я не закрываюсь, а только пошла в трей. Захочешь выключить нажми в трее "Выход" через правую кнопку"

 

Пока все, дальше не пробовал - стабильность, переподключение и прочее

Share this post


Link to post
Share on other sites

Значить так

Поставил новый сервак, завел там новую версию stargazer-2.405.9.8

Лучше поставь 2.406. В ней кучи глюков нет, только парочка :)

 

Протестил обе версии

 

Вариант авторизатора от Stiff-а собранный из svn собрался и работает. Запускается, подключается, но названия направлений выводятся бякой, вообщем бока с кодировкой

 

madf, еще раз спасибо за .rpm. Твой вариант, тоже запускается, отлично подключается, все красиво показывает по направлениям. Но если поставить птичку "Привязать пароль на hdd" (правда не уверен что именно из-за нее) - такое начинается О_о. Хочет показать окно насчет ошибки, но так как кеды виснут нахрен, точно сказать не могу. Может вылазит дофига сообщений про ошибку и поэтому виснет, вообщем хз. Но версия сырая - поэтому претензий ноль. А может из-за того что у меня compiz...

Если изза привязки пароля - то это очень странно. Я этот функционал пока вобще не реализовал, он только в виде чекбокса существует :)

К стати, надо всеь нереализованный функционал поотключать. Чтобы не сбивать с толку...

 

Плохо, что при автоподключении не сворачивается само. И если нажимаешь свернуть, трындит про, что "Я не закрываюсь, а только пошла в трей. Захочешь выключить нажми в трее "Выход" через правую кнопку"

 

Пока все, дальше не пробовал - стабильность, переподключение и прочее

Спасибо, сегодня-завтра исправлю.

Share this post


Link to post
Share on other sites
Лучше поставь 2.406

Кто ж спорит :)

Но мы, админы, народ ленивый и мне лень было собирать из исходников. Нашел .rpm 2.405.9.8 для CentOS 5.2 попробовал поставить на fedora 11 - с полпинка установилось и запустилось.

Вот если вы сделаете красивый .rpm для версии 2.406 сразу же и обновлю. Начитался где то про правильность установки через rpm, а не через исходники - вот теперь не могу себя пересилить :)

Share this post


Link to post
Share on other sites
Лучше поставь 2.406

Кто ж спорит :)

Но мы, админы, народ ленивый и мне лень было собирать из исходников. Нашел .rpm 2.405.9.8 для CentOS 5.2 попробовал поставить на fedora 11 - с полпинка установилось и запустилось.

Вот если вы сделаете красивый .rpm для версии 2.406 сразу же и обновлю. Начитался где то про правильность установки через rpm, а не через исходники - вот теперь не могу себя пересилить :)

Привычка очень правильная. Проблема только в том что сам я собирать rpm-ки не умею. Предыдущую собрал только потому что используемяа в проекте система сборки позволяет такое делать.

Ну посмотрим что можно придумать...

Share this post


Link to post
Share on other sites

Выложил версию 1.3.2.

Исходники: qia-1.3.2.tar.gz

DEB: qia-1.3.2-i386.deb

RPM: qia-1.3.2-i386.rpm

 

Исправлено поведение при возникновении ошибки подключения и включенном переподключении (судя по всему это те феерические эффекты о которых писал rozloff выше).

Теперь сообщение при hide-on-close появляется только один раз (при первом таком действии).

Если включена опция "Автоподключение" окно авторизатора не появляется (стартует свернутым в трей).

Сделал неактивными все пункты настроек которые еще не реализованы.

 

PS: если кто знает как можно без прав root получить серийник жесткого диска - отпишитесь, пожалуйста. От этого зависит судьба пункта настроек "Привязать пароль к НЖМД". О ioctl HDIO_GET_IDENTITY я знаю, но он требует привилегий доступа к /dev/[h|s]da. Еще была идея использовать 32-битный вывод gethostid, но он, похоже, зависит только от IP хоста.

Share this post


Link to post
Share on other sites

PS: если кто знает как можно без прав root получить серийник жесткого диска - отпишитесь, пожалуйста.

 

ls -l /dev/disk/by-id/
итого 0
lrwxrwxrwx 1 root root  9 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA -> ../../sda
lrwxrwxrwx 1 root root 10 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA-part2 -> ../../sda2
lrwxrwxrwx 1 root root 10 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA-part4 -> ../../sda4
lrwxrwxrwx 1 root root 10 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA-part5 -> ../../sda5
lrwxrwxrwx 1 root root 10 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA-part6 -> ../../sda6
lrwxrwxrwx 1 root root 10 Дек  1 18:16 ata-Hitachi_HDP725050GLA360_GEA534RJ374MGA-part7 -> ../../sda7
lrwxrwxrwx 1 root root  9 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA -> ../../sda
lrwxrwxrwx 1 root root 10 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA-part2 -> ../../sda2
lrwxrwxrwx 1 root root 10 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA-part4 -> ../../sda4
lrwxrwxrwx 1 root root 10 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA-part5 -> ../../sda5
lrwxrwxrwx 1 root root 10 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA-part6 -> ../../sda6
lrwxrwxrwx 1 root root 10 Дек  1 18:16 scsi-SATA_Hitachi_HDP7250_GEA534RJ374MGA-part7 -> ../../sda7

 

Где GEA534RJ374MGA - серийный номер моего винта.

Share this post


Link to post
Share on other sites

PS: если кто знает как можно без прав root получить серийник жесткого диска - отпишитесь, пожалуйста.

 

ls -l /dev/disk/by-id/
...

 

Где GEA534RJ374MGA - серийный номер моего винта.

 

Про это я знаю, но у всех ли такое есть? Да и подменить его для "взлома" пароля в таком виде очень легко.

Share this post


Link to post
Share on other sites

madf - случайно нету сподвижек с файликом .rpm для версии 2.406

А то есть громадное желание обновиться с версии 2.405.9.8 до версии 2.406 и перевести со старого сервера всех пользователей. И так хотелось бы рпм-кой раз уже на то пошло дело.

Share this post


Link to post
Share on other sites

madf - случайно нету сподвижек с файликом .rpm для версии 2.406

А то есть громадное желание обновиться с версии 2.405.9.8 до версии 2.406 и перевести со старого сервера всех пользователей. И так хотелось бы рпм-кой раз уже на то пошло дело.

Попробуй этот в аттаче. Только сперва проверь его на тестовой машине. Все-таки я первый раз собирал RPM вручную, мог чего-то накосячить... Особенно проверь как оно себя поведет при обновлении со старой версии.

stargazer-2.406-1.i386.rpm.txt

Share this post


Link to post
Share on other sites

Не хочет ни устанавливаться, ни обновлятся

Сначала просил по зависимостям libexpat и libpq.so.5

ошибка: Неудовлетворенные зависимости:
libexpat нужен для stargazer-2.406-1.i386
libpq.so.5 нужен для stargazer-2.406-1.i386

Хотя expat установлен, нужные либы какбы лежать на месте. Тем более, что версия 2.405.9.8 спокойно установилась и работает.

Доинсталил libpqxx.i586 2.6.8-13 и заодно обновил expat до версии -2.0.1-8

libpq уже не просит, а в libexpat уперся вот давай и все

В lib лежат

/lib/libexpat.so.1 #simlink na libexpat.so.1.5.2
/lib/libexpat.so.1.5.2

сделал еще один симлинк libexpat.so и еще один libexpat - и все равно не хочет ни install, ни update

Share this post


Link to post
Share on other sites

Не хочет ни устанавливаться, ни обновлятся

Сначала просил по зависимостям libexpat и libpq.so.5

ошибка: Неудовлетворенные зависимости:
libexpat нужен для stargazer-2.406-1.i386
libpq.so.5 нужен для stargazer-2.406-1.i386

Хотя expat установлен, нужные либы какбы лежать на месте. Тем более, что версия 2.405.9.8 спокойно установилась и работает.

Доинсталил libpqxx.i586 2.6.8-13 и заодно обновил expat до версии -2.0.1-8

libpq уже не просит, а в libexpat уперся вот давай и все

В lib лежат

/lib/libexpat.so.1 #simlink na libexpat.so.1.5.2
/lib/libexpat.so.1.5.2

сделал еще один симлинк libexpat.so и еще один libexpat - и все равно не хочет ни install, ни update

libpqxx не нужен. Остальное посмотрю.

Симлинки тоже не нужны.

Share this post


Link to post
Share on other sites

libpqxx не нужен. Остальное посмотрю.

Симлинки тоже не нужны.

libpq.so нашелся в libpqxx, а раз по зависимостям попросил то пришлось ставить

 

А насчет симлинков я понимаю, что они не нужны - ну это как обычно крайняя мера, когда lib-ы есть, но их хотят под другим именем

Share this post


Link to post
Share on other sites

Очень рад, что моя разработка подтолкнула madfа на пиление собственной версии. Я уж и как-то забыл совсем про эту тему.

У меня в сети всё ещё крутится старгейзер версии stg-2.404.9.7, на момент написания последняя версия виндовой инетакцесс с доступными исходниками была 2.55.7, оттуда и выдрал весь код, отвечающий за авторизацию.

С более новыми версиями старгейзера не тестировал, всё никак руки не доходят пойти обновить стг.

Насчёт кракозябров в названиях направлений: исправить несложно, только я не знаю, в какой кодировке они приходят с сервера, так как у самого все направления написаны по-английски

Share this post


Link to post
Share on other sites

libpqxx не нужен. Остальное посмотрю.

Симлинки тоже не нужны.

И снова добрый день :)

madf ты не смотрел по зависимостям? есть как вылечить от такой требовательности?

Share this post


Link to post
Share on other sites

libpqxx не нужен. Остальное посмотрю.

Симлинки тоже не нужны.

И снова добрый день :)

madf ты не смотрел по зависимостям? есть как вылечить от такой требовательности?

Нет, не смотрел. Там обьявился мейнтейнер из ALT Linux, скоро сделает сборку для Альта. Думаю, тебе подойдет.

Share this post


Link to post
Share on other sites

alf.uzlovaya.ru/stg/stg-web/ уже не работает давно, скиньте мне я захостю у себя на постоянной основе,у меня stg-2.406 админка с этой версией работать будет? Проект жив или загнулся стоет на админку рассчитывать или нет?

Share this post


Link to post
Share on other sites

alf.uzlovaya.ru/stg/stg-web/  уже не работает  давно, скиньте мне я захостю у себя на постоянной основе,у меня stg-2.406 админка с этой версией работать будет? Проект жив или загнулся стоет  на  админку  рассчитывать или нет?

 

С удовольствием зазеркалю всё что нужно.

Share this post


Link to post
Share on other sites

qia-1.3.2-i386.deb на runtu-lxde-10.04, stargazer 2.406.

При попытке подключиться ничего не происходит. Вводили правильные и неправильные login/password. В логах старгейзера чисто, т.е. как бы даже не было попытки подключиться, можете что-то посоветовать?

Share this post


Link to post
Share on other sites

qia-1.3.2-i386.deb на runtu-lxde-10.04, stargazer 2.406.

При попытке подключиться ничего не происходит. Вводили правильные и неправильные login/password. В логах старгейзера чисто, т.е. как бы даже не было попытки подключиться, можете что-то посоветовать?

Проверить настройки: адрес и порт.

Share this post


Link to post
Share on other sites

Проверить настройки: адрес и порт.

Те же, что и в windows системах. Виндовый под wine с теми же настройками в линуксе работает.

Share this post


Link to post
Share on other sites

Проверить настройки: адрес и порт.

Те же, что и в windows системах. Виндовый под wine с теми же настройками в линуксе работает.

Тогда файрвол.

tcpdump показывает передачу данных?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×