Jump to content
Local
Sign in to follow this  
Колян

Медиаконвертеры не пропускают теггированный трафик

Recommended Posts

Собственно, сабж. Похоже, конвертера (или один из них, менять нечем, все такие) отбрасывают тагированные кадры любого размера.

Никто с таким не сталкивался? Если кто-то гоняет тегированный траф через конвики, скажите модели конвиков плиз, или продайте оные плиз:blink:

Share this post


Link to post
Share on other sites

врядле это конверторы. смотрите настройки портов на свичах.

Share this post


Link to post
Share on other sites

свитч там неуправляемый, пропускает другие теги нормально, а что через эти конвы - отбрасывает.

есть правда на пути еще один свитч неуправляемый, энкоре, вот уже начинаю думать на него, подозрительный он:blink:

спасибо за наводку)

Share this post


Link to post
Share on other sites

мы перепробовали уже наверное все конверторы которые есть на рынке Украины - нигде подобной проблемы не встречали. Проблемы были только со свичами и с неправильной настройкой портов.

Share this post


Link to post
Share on other sites

та у него там судя по разговору цепочка тупых свитчей, естессно можно еще и не такие грабли отхватить :blink:

Share this post


Link to post
Share on other sites

тут два свитча в цепочке, в другой цепочке 4, во второй работает, в этой нет, видать свитч какой-то гувно попался, буду искать, отпишусь если все заведется, спс:)

Share this post


Link to post
Share on other sites

Замена свитча на тот, который 100% пропускал тэгированный трафик ничего не дала, скорее всего таки конвы:)

Share this post


Link to post
Share on other sites

Не встречал такого ниразу, какие конверторы??? помоему конверторам похер что гонять

Share this post


Link to post
Share on other sites

А вот и нет! У нас были редкостные экземпляры конвертеров Опто-фокус кажется. Один не пропускает ничего кроме icmp. Второй пропускает gre и icmp без проблем, а вот простой http резал. Много они нам кровушки-то выпили, пока мы методом замены их не вычислили. Теперь храним как музейные экспонаты. Так что у китайского говна возможно что угодно :)

Share this post


Link to post
Share on other sites

ну так оптофокус с одной стороны и асотель с другой, стомегабитные вдм. Я ж в сабже писал:)

Share this post


Link to post
Share on other sites

ну дык поменяй по очереди конвертеры. У одного из них явно крышу снесло.

Share this post


Link to post
Share on other sites

Не встречал такого ниразу, какие конверторы??? помоему конверторам похер что гонять

 

 

А вот и нет! У нас были редкостные экземпляры конвертеров Опто-фокус кажется. Один не пропускает ничего кроме icmp. Второй пропускает gre и icmp без проблем, а вот простой http резал. Много они нам кровушки-то выпили, пока мы методом замены их не вычислили. Теперь храним как музейные экспонаты. Так что у китайского говна возможно что угодно :)

 

 

Да у нас тоже был случай. Конвик (тот который 1310) стоял на доме и пропускал все кроме фтп ))) тоже долго маялись что с ним. проблему решили методом перестановки 1310 в ядро, а 1550 на дом. Вот такая сказка

Share this post


Link to post
Share on other sites

У меня все конвертера задействованы, завтра два куплю, поменяю, отпишусь, всем спасибо за помощь:)

Share this post


Link to post
Share on other sites

Не все конвертеры одинаково полезны :)

Есть которые не поддерживают 802.1Q

 

Лучше уточнять сразу при покупке

Share this post


Link to post
Share on other sites

Не все конвертеры одинаково полезны :blink:

Есть которые не поддерживают 802.1Q

 

Лучше уточнять сразу при покупке

Бред, железо уровня L1 не может и не должно поддерживать протоколы L2. Ему все равно что через него гоняют..

Если что-то где-то не пропускается - подгоревший чип или битая флешка, бывают любые чудеса.

Share this post


Link to post
Share on other sites

а вроде конвики - это л2:) они как сетевые мосты, только с технологиям разными, медь/оптика, по-моему даже формат кадра разный, не утверждаю, могу ошибаться.

Share this post


Link to post
Share on other sites

а вроде конвики - это л2:) они как сетевые мосты, только с технологиям разными, медь/оптика, по-моему даже формат кадра разный, не утверждаю, могу ошибаться.

 

Помоему, наоборот, л1. Это не сетевой мост. Изменяется сигнал только на физическом уровне (тип модуляции, определение и коррекиця ошибок, и прочее). Ничего кроме преобразовывать электрический сигнал в световой и наоборот не умеют :blink: Это я о дешевых за 25-50 уе.

Share this post


Link to post
Share on other sites

Ребята, серьезно, они заглядывают во фреймы.

Функция называется Transparent Vlan.

 

Глянул в спецификацию конверторов:

Поддержка прозрачной передачи пакетов IEEE802.1q VLAN.

 

А в некоторых нету :blink:

Share this post


Link to post
Share on other sites

Не все конвертеры одинаково полезны :)

Есть которые не поддерживают 802.1Q

 

Лучше уточнять сразу при покупке

Бред, железо уровня L1 не может и не должно поддерживать протоколы L2. Ему все равно что через него гоняют..

Если что-то где-то не пропускается - подгоревший чип или битая флешка, бывают любые чудеса.

ооо, они и не такое умеют :blink:

SNMP, теги, и многое другое

Share this post


Link to post
Share on other sites

Ребята, серьезно, они заглядывают во фреймы.

Функция называется Transparent Vlan.

 

Глянул в спецификацию конверторов:

Поддержка прозрачной передачи пакетов IEEE802.1q VLAN.

 

А в некоторых нету :)

"Заглядывают" во фреймы только двуглазые конверторы, одноглазые не могут ибо только один глаз :blink:

Share this post


Link to post
Share on other sites

Извелся весь уже, не знаю, че и менять, свитчи поменял, конвертера поменял, а вилан все не видит и не видит, вот засада:(

Видно, что какие-то пакеты пролетают, индикатор моргает изредка, когда флудпингом валишь.

устройство с виланом - длинк дир-100, маршрутизатор - линукс дебиан 5 версии.

другие виланы работают, а тут нет, подозрение на оптический линк, хотя конвертера поменял. уже не знаю, что и думать.

Share this post


Link to post
Share on other sites

Остальное все пролетает нормально, конвертера на этот раз планеты.

Девайс с адресом 192.168.1.1 висит на 4 порту:( Магистралка в 5-м.

router:/proc/net/vlan# cat config
VLAN Dev name    | VLAN ID
Name-Type: VLAN_NAME_TYPE_PLUS_VID_NO_PAD
vlan4          | 4  | eth4
vlan3          | 3  | eth4
vlan5          | 5  | eth4
router:/proc/net/vlan# cat vlan3
vlan3  VID: 3    REORDER_HDR: 1  dev->priv_flags: 1
        total frames received            0
         total bytes received            0
     Broadcast/Multicast Rcvd            0

     total frames transmitted        58961
      total bytes transmitted      2710262
           total headroom inc            0
          total encap on xmit        58961
Device: eth4
INGRESS priority mappings: 0:0  1:0  2:0  3:0  4:0  5:0  6:0 7:0
EGRESSS priority Mappings:
router:/proc/net/vlan# ifconfig vlan3
vlan3     Link encap:Ethernet  HWaddr 00:19:5b:87:08:31
         inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
         inet6 addr: fe80::219:5bff:fe87:831/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0 frame:0
         TX packets:58967 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:0
         RX bytes:0 (0.0   TX bytes:2710538 (2.5 MiB)

router:/proc/net/vlan# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable
From 192.168.1.2 icmp_seq=3 Destination Host Unreachable
^C
--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 3016ms
, pipe 3

post-7663-1275309935,3056_thumb.png

post-7663-1275309944,5632_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×