Jump to content
Local
Sign in to follow this  
нечто

статистика stg

Recommended Posts

сарг генерит только то что ты перенаправляешЪ на сквид ... это по идее 80 порт .. а статистика стг учитывает запросы на все порты ... вот тебе и расхождения..

Share this post


Link to post
Share on other sites
сарг генерит только то что ты перенаправляешЪ на сквид ... это по идее 80 порт .. а статистика стг учитывает запросы на все порты

Да, в общем понятно. Просто немного не разберусь. Захожу на www.rejik.ru к примеру.

Имеем отчет саржа:

www.rejik.ru 78 201.84K 21.99% 22.76% 77.24% 00:00:08 8.95K 8.23%

 

www.rejik.ru 05/01/2006 14:23:26

www.rejik.ru 05/01/2006 14:23:45

www.rejik.ru 05/01/2006 14:23:48

www.rejik.ru 05/01/2006 14:23:56

www.rejik.ru 05/01/2006 14:23:57

www.rejik.ru 05/01/2006 14:24:00

И о том же периоде отчет Вашей статистики с параметром "gethost=1":

Lin_Serv (192.168.0.5) Локаль 45.66 kb 16.51 kb 0.000048 грн

192.168.0.255 Мир 938.98 kb 367.39 kb 0.043165 грн

Итого  984.64 kb 383.90 kb 0.043213 грн

Количество трафика больше потому, что там был не только режик,

Подскажите, пожалуйста, что я напутал, даже понять не могу в какую сторону рыть...

Удачи!

Share this post


Link to post
Share on other sites

2li$ergin: По-видимому, у тебя используется адресация 192.168.0.0/хх

Если я не ошибся в чтении показанного лога, то...

Комп 192.168.0.5 разослал бродкасты на адрес 192.168.0.255, а стг посчитал это как "мир".

Мораль: бродкасты надо в рулесах, как локальный трафик описывать.

И вообще, желательно резать маршрутизатором.

Share this post


Link to post
Share on other sites

В общем, где-то я, наверное, изрядно ламерю...

почитал вот, решил и себе сию статистику попробовать

качнул версию 1.064, распаковал в каталог данных апача, почитал config.php, поправил, выставил права 777

захожу браузером - говорит, нету зенд оптимайзера. Скачал. Поставил.

захожу еще раз - пусто. вообще.

попробовал набрать

http://localhost/stat/index.php - пусто

http://localhost/stat/config.php - выдает такое

 

Notice: Undefined index: PHP_AUTH_USER in /usr/local/www/data/stat/config.php on line 47

 

ткните меня носом, плз, где я торможу

Сенкс.

Share this post


Link to post
Share on other sites

если вспомню то напишу как я попборол ету проьлемку...

П.С. ты не один такой

 

 

подожди а логин с паролем спрашивает????

Share this post


Link to post
Share on other sites

Ничего не спрашивает.

Просто пустой экран, и все.

Логи PHP и апача в порядке, ничего криминального.

Куда копать - не знаю.

С одной стороны, вроде все нормально подсчитывается, с другой хотелось бы и глазами это видеть

Share this post


Link to post
Share on other sites

возможно реализовать бек резолф (ну что бы не ip писались а имена хостов ) зарание снкс

Share this post


Link to post
Share on other sites

2 Ом

смотри в конфиге на параметр $gethost

 

вообщем много народу жаловалось на белые странички.. поковырял немного вроде ща все ок.. немного изменился конфиг.. не забудьте поменять..

 

http://spn.dp.ua/files/stat_stg_1.065.tar.gz

Share this post


Link to post
Share on other sites
2 Ом

смотри в конфиге на параметр $gethost

 

вообщем много народу жаловалось на белые странички.. поковырял немного вроде ща все ок.. немного изменился конфиг.. не забудьте поменять..

 

http://spn.dp.ua/files/stat_stg_1.065.tar.gz

то ли я что-то не так делаю, то ли еще чего косо, но вот:

 

Fatal error: Call to undefined function: session_start() in /usr/local/www/data/stat/stargazer/index.php on line 3

 

FreeBSD 5.4 Release

PHP 5.0.3

Apache 1.3.33

Zend Optimizer 3.0.1

Share this post


Link to post
Share on other sites

у меня такая же херня, ставил не из портов.

FreeBSD 5.5

PHP 4.4.3

Apache 2.0.59

Zend Optimizer 3.0.1

Share this post


Link to post
Share on other sites
доставь php-extensions
да, действительно помогло, спасибо, тока ставил я не из портов.

Share this post


Link to post
Share on other sites

А что это за зверь -php-extentions, и где его взять? И какие именно нужно ставить?

Share this post


Link to post
Share on other sites
это не зверь это ./configure --enable-extensions

А как его теперь пересобрать правильно?

Я его тоже не из портов ставил, из пакетов еще при инсталляции системы включил.

Мало что понимаю, о порядке действий в таком случае

Share this post


Link to post
Share on other sites

хм... качаешь c php.net дистрибутив, распаковываешь, и говоришь ./configure --enable-extensions потом make&make install всё вроде.

Share this post


Link to post
Share on other sites
хм... качаешь c php.net дистрибутив, распаковываешь, и говоришь ./configure --enable-extensions потом make&make install всё вроде.

А этот PHP, что уже установлен и работает, надо как-то деинсталлировать?

Share this post


Link to post
Share on other sites
естественно.

а откуда ж ему сказать make deinstall, если я даже не знаю где исходники лежат егойные?

не пинайте сильно, не доводилось мне до сих пор столь плотно с этим ковыряться, а тут что-то захотелось-таки прикрутить эту статистику...

Share this post


Link to post
Share on other sites

а make deinstall вы сделать и не сможите, вам надо в ручную удалять все файлы которые были проинсталены.

вам поможет locate php

Share this post


Link to post
Share on other sites
а make deinstall вы сделать и не сможите, вам надо в ручную удалять все файлы которые были проинсталены.

вам поможет locate php

В общем, непонятки тут у меня с этим.

Существующий PHP я таки удалил. Сгрузил архив php-4.4.4, распаковал сконфигурил с --enable-extensions, собрал и проинсталлировал

Только вот незадача, апачу теперь надо libphp4.so где-то взять, а его нет. Вот просто нигде нет, где только не искал.

Может, в конфигуре еще какие-то опции должны быть заданы?

Share this post


Link to post
Share on other sites

./configure --with-apxs2=/path_to_apache/bin/apxs

 

ну или --with-apxs для апача 1.x

 

в общем виде должно быть так: ./configure --enable-extensions --with-apxs2=/path_to_apache/bin/apxs

ну или --with-apxs для апача 1.x

Share this post


Link to post
Share on other sites

Есть. Таки заработало.

Всем спасибо! :)

Share this post


Link to post
Share on other sites

Статистика выводится.

Но вот только перед нею выпадает целая куча:

 

Notice: Undefined variable: type in /usr/local/www/data/stat/stargazer/index.php on line 70

Notice: Undefined variable: type in /usr/local/www/data/stat/stargazer/index.php on line 158

Notice: Undefined variable: dir_tmp in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 2 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined variable: money in /usr/local/www/data/stat/stargazer/index.php on line 194

Notice: Undefined index: 0 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 1 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 2 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 1 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 0 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 2 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 1 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 0 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 2 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 0 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 1 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 2 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 0 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 1 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 1 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 2 in /usr/local/www/data/stat/stargazer/index.php on line 193

Notice: Undefined index: 0 in /usr/local/www/data/stat/stargazer/index.php on line 193

 

как лечить?

поставил PHP-4.4.4

надо было пятый ставить?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×