Перейти к содержимому

DeepNet

ASP24.com.ua - Всё разнообразие оборудования - от сплиттера до OLT. Звоните! 050-374-0066
Фото

BDCOM P3310C

bdcom pon

  • Чтобы отвечать, сперва войдите на форум
496 ответов в теме

#321 Check

Check

    Пролетал Мимо

  • Маглы
  • Фишка
  • 7 Сообщений:

Опубликовано 26 Март 2017 - 08:33

 

status: no carrier
^^^????

 

Потому что switchport trunk vlan-untagged none. Соответственно no carrier. Vlan не поднимается. У него интерфейс в vlan20 за ONU должен быть в итоге. Пока не будет - vlan не поднимется, не на что ему подниматься.

Пусть поднимет на OLT Интерфейс vlan20 и проверит оно вообще у него работает или нет.

interface VLAN20
 ip address 172.20.0.2 255.255.255.0

Добавил

interface VLAN20
ip address 172.20.0.3 255.255.255.0

 

В итоге:

в ifconfig

status: active

 

С ОЛТ пингуется 172.20.0.1. C сервера и тестовой машины пингуется 172.20.0.3, но с тестовой машины так шлюз и не пингуется.


  • 0

#322 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 26 Март 2017 - 09:14

Отлично, Вот теперь можно перекурить и подумать. В итоге, у нас работает связка ОЛТ и FreeBSD , но не работает связка клиент за ONU и FreeBSD, я правильно понимаю?


  • 0

#323 GrDEV

GrDEV

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 263 Сообщений:

Опубликовано 26 Март 2017 - 09:34

Может проблема в ОНУ?


Изменено: GrDEV, 26 Март 2017 - 09:34

  • 0

#324 l1ght

l1ght

    Вампир

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишка
  • 1 808 Сообщений:
  • Пол:Мужчина
  • Город:Запорожье

Опубликовано 26 Март 2017 - 10:04

А посмотреть таблицу мак адресов и конфигу ону?

Может банально ону не в том влане сидит.

Пробуйте вырубать 

ip arp inspection vlan  1,20
ip verify source vlan  1,20

На опцию 82 всё равно не влияет.


  • 0

#325 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 26 Март 2017 - 11:26

А посмотреть таблицу мак адресов и конфигу ону?

Может банально ону не в том влане сидит.

 

На предыдущей странице конфиг:

interface EPON0/1:1
  epon onu port 1 ctc vlan mode tag 20 priority 0
  epon onu port 1 loopback detect

в том vlan висит

 

пусть выполнит

sh ip dhcp-relay snooping binding all

  • 0

#326 l1ght

l1ght

    Вампир

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишка
  • 1 808 Сообщений:
  • Пол:Мужчина
  • Город:Запорожье

Опубликовано 26 Март 2017 - 12:31

На предыдущей странице конфиг:
 

Это ещё ничего не значит))))))

Поэтому и говорю смотреть таблицу мак адресов.


  • 0

#327 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 26 Март 2017 - 17:57

Уберите vlan1 отсюда:

interface GigaEthernet0/1
 switchport trunk vlan-allowed 1-2,20

и отсюда уберите vlan1

interface EPON0/1
 epon bind-onu mac 8014.a84a.e5d8 1
 filter dhcp
 switchport trunk vlan-allowed 1-2,20

и отсюда уберите vlan1

ip arp inspection vlan  1,20
ip verify source vlan  1,20

выполните и покажите вывод

sh vlan

Получите ip адрес от DHCP сервера и покажите вывод

show ip dhcp-relay agent bind
sh ip dhcp-relay snooping binding all
sh epon int e0/1:1 onu ctc opt

ну и ради интереса покажите вывод

sh onu-config-template
sh run db-llid

а так же для приличия покажите вывод

sh mac address-table
show mac address-table interface EPON0/1
show mac address-table interface EPON0/1:1

Изменено: Darth Vader2, 26 Март 2017 - 18:37

  • 1

#328 Check

Check

    Пролетал Мимо

  • Маглы
  • Фишка
  • 7 Сообщений:

Опубликовано 27 Март 2017 - 07:54

Уберите vlan1 отсюда: interface GigaEthernet0/1 switchport trunk vlan-allowed 1-2,20
 
Убрал.
 

выполните и покажите вывод sh vlan
 
 
#show vlan
VLAN Status  Name                             Ports
---- ------- -------------------------------- ---------------------------------
1    Static  Default                          g0/5, g0/6, g0/4, g0/3, g0/2
                                              epon0/1, epon0/2, epon0/3
                                              epon0/4
2    Static  VLAN0002                         g0/1, epon0/1
20   Static  VLAN0020                         g0/1, epon0/1
 

Получите ip адрес от DHCP сервера и покажите вывод show ip dhcp-relay agent bind sh ip dhcp-relay snooping binding all
 
#show ip dhcp-relay agent bind
 
Hardware Address    IP Address      remainder time Helper Address  VLAN    interface
 
#show ip dhcp-relay snooping binding all
 
Hardware Address  IP Address      Surplus Time Type    VLAN Intf
----------------- --------------- ------------ ------- ---- ----------
20:1a:06:46:b3:b9 172.20.0.2      3240         DHCP_SN 20   epon0/1
 
 

sh epon int e0/1:1 onu ctc opt
 
#show epon interface ePON 0/1:1 onu ctc opt
 operating temperature(degree): 31
 supply voltage(V): 3.3
 bias current(mA): 13.2
 transmitted power(DBm): 1.9
 received power(DBm): -3.1
 

ну и ради интереса покажите вывод sh onu-config-template sh run db-llid
#show onu-config-template
ONU config template T1 ,total cmd 2
-------------------------------------------
Index     command content
 1       epon onu all-port ctc vlan mode tag 20
 2       epon onu all-port ctc loopback detect
 
#show run db-llid
Building database configuration...
 
 
interface EPON0/1:1
  epon onu port 1 ctc vlan mode tag 20 priority 0
  epon onu port 1 loopback detect
!

а так же для приличия покажите вывод sh mac address-table show mac address-table interface EPON0/1 show mac address-table interface EPON0/1:1
#show mac address-table
        Mac Address Table (Total 3)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
All     8479.735b.6812    STATIC     CPU
2       9418.8238.2e6d    DYNAMIC    g0/1
20      9418.8238.2e6d    DYNAMIC    g0/1
20      201a.0646.b3b9    DYNAMIC    epon0/1:1
 
#show mac address-table interface EPON0/1
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
20      201a.0646.b3b9    DYNAMIC    epon0/1:1
 
#show mac address-table interface EPON0/1:1
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
20      201a.0646.b3b9    DYNAMIC    epon0/1:1
 
 
 
 
 

  • 0

#329 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 10:38

У Вас так:

ip dhcp-relay snooping
ip dhcp-relay snooping vlan  20
ip arp inspection vlan  20
ip verify source vlan  20
ip dhcp-relay snooping information option format hn-type
ip dhcp-relay snooping log

сделайте вот так

ip dhcp-relay snooping
ip dhcp-relay snooping vlan  20
ip arp inspection vlan  20
ip verify source vlan  20
ip dhcp-relay snooping information option format hn-type
ip dhcp-relay agent
ip dhcp-relay helper-address 172.16.0.1 vlan 20
ip dhcp-relay snooping log

получите ip от DHCP покажите вывод

show ip dhcp-relay agent bind
sh ip dhcp-relay snooping binding all

это очень много

sh epon int e0/1:1 onu ctc opt
....
received power(DBm): -3.1

попробуйте занизить через делитель до -20 к примеру

 

p.s. проверьте на всякий случай, не блокирует ли фаервол FreeBSD icmp пакеты от клиента, послушайте tcpdump на интерфейсе FreeBSD Приходят ли icmp пакеты от клиента за ONU.

 

Пропингуйте клиентом за ONU  интерфейс vlan20 находящийся на OLT


Изменено: Darth Vader2, 27 Март 2017 - 10:47

  • 0

#330 Check

Check

    Пролетал Мимо

  • Маглы
  • Фишка
  • 7 Сообщений:

Опубликовано 27 Март 2017 - 11:04

получите ip от DHCP покажите вывод show ip dhcp-relay agent bind sh ip dhcp-relay snooping binding all

 

#show ip dhcp-relay agent binding
 
Hardware Address    IP Address      remainder time Helper Address  VLAN    interface
 
#show ip dhcp-relay snooping binding all
 
Hardware Address  IP Address      Surplus Time Type    VLAN Intf
----------------- --------------- ------------ ------- ---- ----------
20:1a:06:46:b3:b9 172.20.0.2      3300         DHCP_SN 20   epon0/1
 
Прикол в том что с ОЛТ пингуется и комп и шлюз
Из компа пингуется интерфейс на ОЛТ, но шлюз нет.

  • 0

#331 Dimkers

Dimkers

    Вампир

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишка
  • 1 189 Сообщений:
  • Пол:Мужчина
  • Город:kr.ua
  • Интересы:IP

Опубликовано 27 Март 2017 - 11:09

С ОЛТ пинг может идти на шлюз через другой инт-влан. Закройте инт-влан2.


Изменено: Dimkers, 27 Март 2017 - 11:11

  • 0

#332 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 12:08

Хуже не будет, добавьте вот так:

ip dhcp-relay snooping
ip dhcp-relay snooping vlan  2,20
ip arp inspection vlan  2,20
ip verify source vlan  2,20
ip dhcp-relay snooping information option format hn-type
ip dhcp-relay agent
ip dhcp-relay helper-address 172.16.0.1 vlan 2,20
ip dhcp-relay snooping log

и вот так

conf
interface GigaEthernet0/1
switchport pvid 2

и так

conf
interface EPON0/1
no filter dhcp

получите ip через DHCP и покажите вывод

show ip dhcp-relay agent bind
sh ip dhcp-relay snooping binding all

  • 0

#333 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 12:11

По поводу tcpdump какой результат? Пакеты icmp есть, нет?


  • 0

#334 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 12:16

В логах DHCP с какого vlan приходит запрос на получение ip адреса?

 

p.s. Создайте условие выдать ip если vlan совпадает с 20.

Покажите итоговый dhcp.conf


Изменено: Darth Vader2, 27 Март 2017 - 12:19

  • 0

#335 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 12:21

С ОЛТ пинг может идти на шлюз через другой инт-влан. Закройте инт-влан2.

 

Не надо, он не мешает, потом уберет, если захочет, да и не надо его убирать вовсе.


Изменено: Darth Vader2, 27 Март 2017 - 12:21

  • 0

#336 GrDEV

GrDEV

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 263 Сообщений:

Опубликовано 27 Март 2017 - 14:06

Может все же дело в прошивке ОЛТ? 


Изменено: GrDEV, 27 Март 2017 - 14:07

  • 0

#337 Check

Check

    Пролетал Мимо

  • Маглы
  • Фишка
  • 7 Сообщений:

Опубликовано 27 Март 2017 - 15:33

Доходит до маразма....

Упростил конфиг до безобразия.

Аплинк в гиговый порт 1

тестовый комп в гиговый порт 2

На компе статически прописан адрес 172,20,0,2

У шлюза адрес 172,20,0,1

У ОЛТ адрес 172,20,0,10

На ОЛТ только один влан 20

Из ОЛТ пингуется и шлюз и тестовый комп

Из сервера пинугется только ОЛТ

Из компа только ОЛТ

Building configuration...


Current configuration:
!
!version 10.1.0E build 37276
service timestamps log date
service timestamps debug date
logging buffered 4096
!
port-protected 1
!
!
!
!
ip default-gateway 172.20.0.1
!
!
spanning-tree mode rstp
!
!
!
!
!
!
!
!
!
!
!
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
!
username admin password 0 admin
!
!

epon oam-version 1 0x21
epon oam-version 2 0x20
!
!!slot 0 89
interface GigaEthernet0/1
 switchport trunk vlan-allowed 20
 switchport mode trunk
!
interface GigaEthernet0/2
 switchport pvid 20
!
interface GigaEthernet0/3
!
interface GigaEthernet0/4
!
interface GigaEthernet0/5
!
interface GigaEthernet0/6
!
interface EPON0/1
 switchport protected 1
!
interface EPON0/2
 switchport protected 1
!
interface EPON0/3
 switchport protected 1
!
interface EPON0/4
 switchport protected 1
!
!!slot end
!
interface VLAN20
 ip address 172.20.0.10 255.255.255.0
!
!
!
vlan 1,20
!
!
!
!
!
!
ip http server
!
!
!
!
!
!
!Pending configurations for absent linecards:
!
!No configurations pending global

Уже хз что думать....


  • 0

#338 Dimkers

Dimkers

    Вампир

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишка
  • 1 189 Сообщений:
  • Пол:Мужчина
  • Город:kr.ua
  • Интересы:IP

Опубликовано 27 Март 2017 - 16:57

Вот куски:

show running-config
Building configuration...


Current configuration:
!
!version 10.1.0E build 36957
service timestamps log date
service timestamps debug date
!
hostname Le
port-protected 1
!
!
!
!
ip default-gateway 10.255.128.1
!
!
spanning-tree mode rstp
...........................................................

!
interface GigaEthernet0/6
 description Uplink
 switchport trunk vlan-allowed 1,2500
 switchport mode trunk
  dhcp snooping trust
!
interface EPON0/1
 description PON-3
 epon pre-config-template T1 binded-onu-llid 1-64
 epon bind-onu mac a0c6.ec07.c8e8 1
 switchport trunk vlan-allowed 2500
 switchport trunk vlan-untagged none
 switchport mode trunk
 switchport pvid 2500
 switchport protected 1
!
interface EPON0/1:1
  epon onu port 1 ctc vlan mode tag 2500 priority 0
  epon onu port 1 loopback detect
!
.............................................................

Все пашет без задоринки.


Изменено: Dimkers, 27 Март 2017 - 16:58

  • 0

#339 GrDEV

GrDEV

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 263 Сообщений:

Опубликовано 27 Март 2017 - 18:06

Дык у него прошивка version 10.1.0E build 37276

А у вас version 10.1.0E build 36957

 

ИМХО прошивка какашка.


Изменено: GrDEV, 27 Март 2017 - 18:07

  • 0

#340 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 19:18

BDCOM(tm) P3310C Software, Version 10.1.0E Build 37276

нет никаких проблем


  • 0





Также с меткой «bdcom, pon»

7 пользователей читают эту тему

0 members, 7 guests, 0 anonymous users

Local.blog МЕТА - Украина