Перейти к содержимому

DeepNet

ASP24.com.ua - Всё разнообразие оборудования - от сплиттера до OLT. Звоните! 050-374-0066
Tiger
Фото

BDCOM P3310C

bdcom pon

  • Чтобы отвечать, сперва войдите на форум
506 ответов в теме

#341 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 27 Март 2017 - 19:27

Аплинк в гиговый порт 1
тестовый комп в гиговый порт 2
На компе статически прописан адрес 172,20,0,2
У шлюза адрес 172,20,0,1
У ОЛТ адрес 172,20,0,10
На ОЛТ только один влан 20
Из ОЛТ пингуется и шлюз и тестовый комп
Из сервера пинугется только ОЛТ
Из компа только ОЛТ

Посмотрите мак адреса видно на конечных устройствах, в частности, на тестовом компьютере и сервере? Видят они по мак адресам друг друга или нет?

Где-то рядом ходим. Возможно не в OLT дело, а в сервере.


  • 0

#342 sanitariu

sanitariu

    Пролетал Мимо

  • Маглы
  • Фишка
  • 39 Сообщений:

Опубликовано 04 Апрель 2017 - 19:15

Hi to all.

 

For second time my OLT crashes and looses onu configuration.

Model is P3310C.

First time it was version 37276 something and it crashed on ssh. I saw that

after running show break command.

I've got fixed that in the latest version 40285.

BDCOM™ P3310C Software, Version 10.1.0E Build 40285

version 37276 still has SSH crash.

Today crash happened again. Now may be it is other not ssh.

The ugly thing is that when OLT crashes it makes autorestart.

After restart the files ifindex-config and config.db are 0 bytes.

So all onu configuration is lost. Somehow it is erased.

You need manually setup all onus or somehow to restore from tftp.

Anyone have some solution for these ?

It is very bad that it requires human to sort things out and make new configuration.

All clients are out of service during that time.

I understand and read russian perfect but just can not speak. So please 

excuse me and you can answer me on russian.

This crash is going to happen on you too ... I am sure just needs time.

Part of the crash:

--------------------

#show break

=========================================================
BreakNum: 1
Exception Type:2-TLB miss exception (load or instruction fetch)
TaskID=818df820, TaskName=Sty1
date: 2017-4-4  time: 15:4:45
zero                    at                      v0                      v1
00000000                817b0000                00000000                ffffffff
a0                      a1                      a2                      a3
00000000                818de590                00000010                ffffffff
t0                      t1                      t2                      t3
00000000                1000fc00                1000fc01                00000000
t4                      t5                      t6                      t7
83e3ee2c                00000000                00000000                00000000
s0                      s1                      s2                      s3
00000000                00000000                815f7d54                818de590
s4                      s5                      s6                      s7
815f9b10                ffffffff                00000010                00000000
t8                      t9                      k0                      k1
00000002                818df820                eeeeeeee                00000000
gp                      sp                      s8                      ra
816034f0                818de4f8                818de5a0                80468184
pc
80d89268
sr    = 1000fc01
cause = 00000008
call procedure--
0x80468184--
0x80cf8508--
0x80cf7dc8--
0x80344298--
0x803431b0--
0x80482280--
 
.......

Изменено: sanitariu, 04 Апрель 2017 - 19:25

  • 0

#343 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 05 Апрель 2017 - 00:37

Спасибо за сообщение. Надеюсь меня эта проблема не коснется. Вы единственный, у кого это случилось?

Thank you for your message. I hope, this problem will not happen to me. You're the only one with problems, or not?

 

p.s. Show your conf, please. Just in case.


Изменено: Darth Vader2, 05 Апрель 2017 - 01:07

  • 0

#344 sanitariu

sanitariu

    Пролетал Мимо

  • Маглы
  • Фишка
  • 39 Сообщений:

Опубликовано 05 Апрель 2017 - 09:05

show version all

 

check if you have:  

ssh           2.2.30          2015-05-26

 

that version. If so it just need time or something specific to crash on ssh.

I have acl filter for access ssh.

It may be connected.

 

!

ip access-list standard ssh-acl

 permit  192.168.10.0 255.255.255.0
!
!
ip sshd timeout 360
ip sshd access-class ssh-acl
ip sshd save
!
 
 
Crash may happen not problem. The real problem is that when it happens it makes the config files 0 bytes 
and this is disaster.
This happened on second 3310C OLT so i am excluding hardware point of failure.

  • 0

#345 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 05 Апрель 2017 - 17:58

Try moving from ssh to telnet, if it's possible for you.

Of course with

 

ip access-list standard telnet-acl


  • 0

#346 sanitariu

sanitariu

    Пролетал Мимо

  • Маглы
  • Фишка
  • 39 Сообщений:

Опубликовано 05 Апрель 2017 - 18:42

Yes thanks. Thats what i did. Also disabled ssh. It is old version and needs old protocols enabled

like:

 

KexAlgorithms +diffie-hellman-group1-sha1

 

I am more scared about future crash which will zero config.db and how to protect from this.


  • 0

#347 Darth Vader2

Darth Vader2

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 297 Сообщений:

Опубликовано 05 Апрель 2017 - 23:19

Please, try read this:

http://forum.nag.ru/...dpost&p=1278679

 

Maybe it's your accident. Many different manufacturer ONU, like source of the problem.


  • 0

#348 Fallen_Grayswandir

Fallen_Grayswandir

    Пролетал Мимо

  • Маглы
  • Фишка
  • 26 Сообщений:

Опубликовано 07 Апрель 2017 - 16:29

Добрый день. Столкнулись с такой проблемой.

Подключаем новую ONU к голове, она регистрируется, аутентифицируется, но не подхватывает конфиг с шаблона. В статусе у неё заместо auto_configured стоит authenticated.

Помогает перезагрузка головы. Но дёргать сотню абонентов при каждом подключении нового - совсем не вариант.

Думали, проблема с онушками - как раз привезли новую партию FORA EP-1001E1. Хотя 6 онушек с этой партии завелись нормально, потом началась такая канитель.

Затем попробовали BDCOM P1501C1 и V-Solution V2801HE - результат тот же.

Затем начали грешить на то, что мощность сигнала недостаточна, но проблема проявилась у последующих 4х абонентов на разных подветках одного EPON-порта. Да и после перезагрузки головы у этой онушки вполне себе нормальный уровень -22,1

Самое странное то, что проблема проявляется только на порту EPON0/2 (см. конфиг ниже) на котором на момент появления проблемы было 49 абонентов. 50й, 51й, 52й уже начали выделываться.

 

P.S. после ребута головы проблема теперь и у старых абонентов

В логах онушки, с которыми проблема, каждую минуту флапают.

 

Версия прошивки.

ponfive-01#sh ver
BDCOM(tm) P3310C Software, Version 10.1.0D Build 33463
Copyright by Shanghai Baud Data Communication CO. LTD.
Compiled: 2016-2-24 18:19:9 by SYS_33463, Image text-base: 0x80008000
ROM: System Bootstrap, Version 0.4.1, Serial num:00316001396
System image file is "Switch.bin"
hardware version:V1.0
(RISC) processor with 131072K bytes of memory, 16384K bytes of flash
Base ethernet MAC Address: 84:79:73:5b:26:d4
snmp info:
  product_ID:294   system_ID:1.3.6.1.4.1.3320.1.294.0

Конфиг:

ponfive-01#sh run

Current configuration:
!
!version 10.1.0D build 33463
service timestamps log date
service timestamps debug date
service password-encryption
logging 217.199.XXX.XXX
logging buffered 4096
logging trap debugging
!
hostname ponfive-01
port-protected 1
!
lldp run
!
ip default-gateway 172.20.111.158
!
spanning-tree mode rstp
!
aaa authentication login default local
aaa authentication enable default none
!
username admin password 7 13433A15721878541C51
username techs password 7 13254763344B42441F267C1D
!
epon oam-version 1 0x21
epon oam-version 2 0x20
!
epon onu-config-template EPON_1
 cmd-sequence 1 epon onu all-port ctc vlan mode tag 701
 cmd-sequence 2 epon onu all-port loopback detect
 cmd-sequence 3 epon sla downstream pir 100000 cir 20000
 cmd-sequence 4 epon sla upstream pir 100000 cir 20000
!
epon onu-config-template EPON_2
 cmd-sequence 1 epon onu all-port ctc vlan mode tag 702
 cmd-sequence 2 epon onu all-port loopback detect
 cmd-sequence 3 epon sla downstream pir 100000 cir 20000
 cmd-sequence 4 epon sla upstream pir 100000 cir 20000
!
epon onu-config-template EPON_3
 cmd-sequence 1 epon onu all-port ctc vlan mode tag 703
 cmd-sequence 2 epon onu all-port loopback detect
 cmd-sequence 3 epon sla downstream pir 100000 cir 20000
 cmd-sequence 4 epon sla upstream pir 100000 cir 20000
!
epon onu-config-template EPON_4
 cmd-sequence 1 epon onu all-port ctc vlan mode tag 704
 cmd-sequence 2 epon onu all-port loopback detect
 cmd-sequence 3 epon sla downstream pir 100000 cir 20000
 cmd-sequence 4 epon sla upstream pir 100000 cir 20000
!
!
!!slot 0 89
interface GigaEthernet0/1
 switchport trunk vlan-allowed 1,700-704
 switchport mode trunk
!
interface GigaEthernet0/2
 switchport trunk vlan-allowed 1,700-704
 switchport mode trunk
!
interface GigaEthernet0/3
 description uplink_gig5/8
 switchport trunk vlan-allowed 1,700-704
 switchport mode trunk
!
interface GigaEthernet0/4
 switchport trunk vlan-allowed 1,700-704
 switchport mode trunk
!
interface GigaEthernet0/5
 switchport trunk vlan-allowed 1,700-704
 switchport mode trunk
!
interface GigaEthernet0/6
 switchport trunk vlan-allowed 1,700-704
 switchport mode trunk
!
interface EPON0/1
 epon pre-config-template EPON_1 binded-onu-llid 1-64
 switchport trunk vlan-allowed 701
 switchport mode trunk
 switchport protected 1
!
interface EPON0/2
 epon pre-config-template EPON_2 binded-onu-llid 1-64
 epon bind-onu mac 8479.7323.e9fe 1
 [......]
 epon bind-onu mac 1c87.7912.abd0 49
 switchport trunk vlan-allowed 702
 switchport mode trunk
 switchport protected 1
!
interface EPON0/3
 epon pre-config-template EPON_3 binded-onu-llid 1-64
 epon bind-onu mac 8479.7323.e656 1
[.....]
 epon bind-onu mac 8479.7399.0d4c 19
 switchport trunk vlan-allowed 703
 switchport mode trunk
 switchport protected 1
!
interface EPON0/4
 epon pre-config-template EPON_4 binded-onu-llid 1-64
 epon bind-onu mac 8479.7323.eaaf 1
[......]
 epon bind-onu mac 8479.7399.0696 11
 switchport trunk vlan-allowed 704
 switchport mode trunk
 switchport protected 1
!
!!slot end
!
interface VLAN700
 description PON_mgmt
 ip address 172.20.111.129 255.255.255.224
!
interface VLAN701
 description PPPoE_ponfive-01_1
 no ip address
!
interface VLAN702
 description PPPoE_ponfive-01_2
 no ip address
!
interface VLAN703
 description PPPoE_ponfive-01_3
 no ip address
!
interface VLAN704
 description PPPoE_ponfive-01_4
 no ip address
!
vlan 1,700-704
!
ip http server
!
snmp-server community 0 XXX RO
snmp-server contact XXX
snmp-server location XXX
!
!
time-zone tz 3 0
ntp server 217.199.XXX.XXX

Логи:

#cat /var/log/remote/remote.log | grep abc8
Apr  7 15:45:15 172.20.111.129 172.20.111.129 %EPON-ONUREG: ONU 1c87.7912.abc8 is registered on EPON0/2:50.
Apr  7 15:45:15 172.20.111.129 172.20.111.129 %EPON-ONUAUTHEN: ONU 1c87.7912.abc8 is authenticated on EPON0/2:50.
Apr  7 15:46:15 172.20.111.129 172.20.111.129 %EPON-ONUDEREG: ONU 1c87.7912.abc8 is deregistered on EPON0/2:50.
Apr  7 15:46:16 172.20.111.129 172.20.111.129 %EPON-ONUREG: ONU 1c87.7912.abc8 is registered on EPON0/2:50.
Apr  7 15:46:16 172.20.111.129 172.20.111.129 %EPON-ONUAUTHEN: ONU 1c87.7912.abc8 is authenticated on EPON0/2:50.
Apr  7 15:47:16 172.20.111.129 172.20.111.129 %EPON-ONUDEREG: ONU 1c87.7912.abc8 is deregistered on EPON0/2:50.
Apr  7 15:47:16 172.20.111.129 172.20.111.129 %EPON-ONUREG: ONU 1c87.7912.abc8 is registered on EPON0/2:50.
Apr  7 15:47:16 172.20.111.129 172.20.111.129 %EPON-ONUAUTHEN: ONU 1c87.7912.abc8 is authenticated on EPON0/2:50.

Изменено: Fallen_Grayswandir, 07 Апрель 2017 - 16:49

  • 0

#349 Fallen_Grayswandir

Fallen_Grayswandir

    Пролетал Мимо

  • Маглы
  • Фишка
  • 26 Сообщений:

Опубликовано 10 Апрель 2017 - 10:40

Проблема получила продолжение.

На порту EPON0/2 на данный момент 51 ONU

Если погасить порт и поднять его, то стабильно 2 рандомные онушки либо аутентифицируются и вообще не получают конфиг с шаблона (стоит статус authenticated), либо получают не полностью, только description и vlan'ы (стоит статус config_failed).

Такое ощущение, что OLT на порту понимает только 49 ONU заместо заявленных 64.

Кто-нибудь сталкивался с таким?

 

UPD

Разобрался.

Проблема была в команде

cmd-sequence 3 epon sla downstream pir 100000 cir 20000
cmd-sequence 4 epon sla upstream pir 100000 cir 20000

Голова гарантированно выделяла 49 онушкам по 20 Мбит, а последующие просто не регистрировала.


Изменено: Fallen_Grayswandir, 10 Апрель 2017 - 12:09

  • 0

#350 dsredline

dsredline

    Пролетал Мимо

  • Маглы
  • Фишка
  • 14 Сообщений:
  • Пол:Мужчина
  • Город:Хмельницкий

Опубликовано 10 Апрель 2017 - 12:55

Проблема получила продолжение.

На порту EPON0/2 на данный момент 51 ONU

Если погасить порт и поднять его, то стабильно 2 рандомные онушки либо аутентифицируются и вообще не получают конфиг с шаблона (стоит статус authenticated), либо получают не полностью, только description и vlan'ы (стоит статус config_failed).

Такое ощущение, что OLT на порту понимает только 49 ONU заместо заявленных 64.

Кто-нибудь сталкивался с таким?

 

UPD

Разобрался.

Проблема была в команде

cmd-sequence 3 epon sla downstream pir 100000 cir 20000
cmd-sequence 4 epon sla upstream pir 100000 cir 20000

Голова гарантированно выделяла 49 онушкам по 20 Мбит, а последующие просто не регистрировала.

Добрый день.

Проблема может быть  в cir 20000, но я не уверен в этом.

У нас была похожая ситуация, на линии после появления 59 ону, перестали регестрироваться 2  онушки,  хотя сигналы были в норме. Cir был 15000, поменяли на 12000, пока все нормально.


  • 0

#351 Fallen_Grayswandir

Fallen_Grayswandir

    Пролетал Мимо

  • Маглы
  • Фишка
  • 26 Сообщений:

Опубликовано 10 Апрель 2017 - 13:43

Да, да проблема именно в cir 20000

1 000 000 (гиговый линк - максимальная полоса пропускания EPON-порта) делим на 20 000 (минимальная гарантированная скорость для каждой ONU), получаем 50. Т.е. голова зарегистрирует 49 онушек, а остальные просто посылает лесом.

Тоже поменял на 12000


  • 0

#352 a_n_h

a_n_h

    Вампир

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишка
  • 1 161 Сообщений:
  • Пол:Мужчина
  • Город:Одещина

Опубликовано 10 Апрель 2017 - 15:53

Да, да проблема именно в cir 20000

1 000 000 (гиговый линк - максимальная полоса пропускания EPON-порта) делим на 20 000 (минимальная гарантированная скорость для каждой ONU), получаем 50. Т.е. голова зарегистрирует 49 онушек, а остальные просто посылает лесом.

Тоже поменял на 12000

в "b" ревизии кто-то, что-то подобное замечал?


  • 0

#353 Den_LocalNet

Den_LocalNet

    Дьявол

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 4 726 Сообщений:
  • Пол:Мужчина

Опубликовано 11 Апрель 2017 - 14:18

3608
отвалился клиент
смотрю и вижу:
 
#sh mac address-table int e0/3:9
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
2110    4c5e.0c16.7d79    DYNAMIC    epon0/4:1
 
Делаю повторно, когда связь с клиентом появилась:
 
#sh mac address-table int e0/3:9
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
2110    0027.2249.b4e9    DYNAMIC    epon0/3:9
 
 
чудеса....

  • 0

#354 dsredline

dsredline

    Пролетал Мимо

  • Маглы
  • Фишка
  • 14 Сообщений:
  • Пол:Мужчина
  • Город:Хмельницкий

Опубликовано 11 Апрель 2017 - 14:20

 

3608
отвалился клиент
смотрю и вижу:
 
#sh mac address-table int e0/3:9
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
2110    4c5e.0c16.7d79    DYNAMIC    epon0/4:1
 
Делаю повторно, когда связь с клиентом появилась:
 
#sh mac address-table int e0/3:9
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
2110    0027.2249.b4e9    DYNAMIC    epon0/3:9
 
 
чудеса....

 

У нас на 3310с  точно также... 


  • 0

#355 Den_LocalNet

Den_LocalNet

    Дьявол

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 4 726 Сообщений:
  • Пол:Мужчина

Опубликовано 11 Апрель 2017 - 17:18

блин ну как оно так работает... это же даже другой ствол...

на 3310В вообще никогда никаких проблем у меня не было


  • 0

#356 sanyadnepr

sanyadnepr

    Дракон

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 2 716 Сообщений:

Опубликовано 11 Апрель 2017 - 17:44

блин ну как оно так работает... это же даже другой ствол...

на 3310В вообще никогда никаких проблем у меня не было

Покращення :)


  • 0

#357 exhalace

exhalace

    Пролетал Мимо

  • Маглы
  • Фишка
  • 1 Сообщений:

Опубликовано 28 Апрель 2017 - 05:22

В очередной раз не теряю надежды заюзать supervlan. На этот раз на BDCOM-е. Еще ни разу не встречал нормально запиленной данной технологии.

!
interface SuperVLAN1
 ip address 10.1.0.1 255.255.255.0
 ip address 10.1.1.1 255.255.255.0 secondary
 ip address 10.1.2.1 255.255.255.0 secondary
 ip address 10.1.3.1 255.255.255.0 secondary
 ip address 10.1.4.1 255.255.255.0 secondary
 ip address 10.1.5.1 255.255.255.0 secondary
 ip address 10.1.6.1 255.255.255.0 secondary
 ip address 10.1.7.1 255.255.255.0 secondary
 ip proxy-arp subvlan same-interface
 no ip directed-broadcast
 ip helper-address 10.10.10.2
 subvlan add 251-258
!
!         
filter dhcp
filter enable
!
vlan 2
 name multicast
!
vlan 203
 name manage
!
vlan 251
 name ipoe-pon-1
!
vlan 252
 name ipoe-pon-2
!
vlan 253
 name ipoe-pon-3
!
vlan 254
 name ipoe-pon-4
!
vlan 255
 name ipoe-pon-5
!
vlan 256
 name ipoe-pon-6
!
vlan 257
 name ipoe-pon-7
!
vlan 258
 name ipoe-pon-8
!

Кто уже юзал? Отзовитесь? Оно живое? Только поставили P3608-2TE в бой, еще не знаю, как данный конфиг себя поведет.


  • 0

#358 Den_LocalNet

Den_LocalNet

    Дьявол

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 4 726 Сообщений:
  • Пол:Мужчина

Опубликовано 28 Апрель 2017 - 07:57

L3 на бдкоме это для людей с сильным характером.

Пользуясь случаем спрошу про 3310b и qnq.
Нужно пробросить влан между двумя гиговыми портами без распаковки и вмешательства. Т.е. в g3 зашло, из g6 вышло дальше. Если какие-то нюансы с этим?
  • 1

#359 Dimkers

Dimkers

    Вампир

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишка
  • 1 191 Сообщений:
  • Пол:Мужчина
  • Город:kr.ua
  • Интересы:IP

Опубликовано 28 Апрель 2017 - 09:59

не скажу за ОЛТы, но стоял s2228f от БДКома - куинку не взлетело. Воткнули перед ним хуавей 2326(тот шо Киевстаровский).


  • 0

#360 Ivan1970

Ivan1970

    Первая Кровь

  • Маглы
  • ФишкаФишка
  • 66 Сообщений:

Опубликовано 01 Май 2017 - 07:52

 

#sh mac address-table int e0/3:9
        Mac Address Table (Total 1)
------------------------------------------
 
Vlan    Mac Address       Type       Ports
----    -----------       ----       -----
2110    4c5e.0c16.7d79    DYNAMIC    epon0/4:1

Насколько  я понял на ОЛТ 36 серии это фишка такая. Если ОНУ не залинкована, то на команду sh mac address-table отображаются маки какой-нибудь другой ОНУ.


  • 0





Также с меткой «bdcom, pon»

3 пользователей читают эту тему

0 members, 3 guests, 0 anonymous users

Local.blog МЕТА - Украина