Перейти к содержимому
Local
allo

Ошибка при подключении нового MikroTik`a в качестве NAS.

Рекомендованные сообщения

Добрый день.

Ubilling установлен по инструкции, работает не первый месяц, нареканий нет.
Возникла ошибка при подключении нового микротика в качестве НАСа

Notice: Undefined variable: _done in /usr/local/www/apache24/data/billing/api/libs/api.routeros.php on line 192

Общая инфорация о состоянии MikroTik`a
Аптайм     5 д. 20h41m33s
Версия RouterOS     6.20
Время сборки     Oct/01/2014 10:06:12
Свободно опер. памяти     1.54 Gb
Всего опер. памяти     1.91 Gb
Процессор     tilegx
Кол-во процессоров     9
Частота процессора     1200 MHz
Загрузка процессора     24 %
Свободно памяти HDD     61.61 Mb
Всего памяти HDD     128 Mb
Архитектура     tile
Название платы     CCR1009-8G-1S-1S+
Платформа     MikroTik



С другим роутером ошибок не возникало, работает отлично.

Общая инфорация о состоянии MikroTik`a
Аптайм     16m31s
Версия RouterOS     6.20
Время сборки     Oct/01/2014 10:06:12
Свободно опер. памяти     40.34 Mb
Всего опер. памяти     64 Mb
Процессор     MIPS 24Kc V8.5
Кол-во процессоров     1
Частота процессора     400 MHz
Загрузка процессора     4 %
Свободно памяти HDD     109.06 Mb
Всего памяти HDD     128 Mb
Записано секторов     750
Всего записано секторов     3562064
Плохих секторов     0 %
Архитектура     mipsbe
Название платы     CRS226-24G-2S+
Платформа     MikroTik


Может кто сталкивался с такой ошибкой и как-то её решил? Спасибо.

 

post-38961-0-79859500-1490786198_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Покажите что у вас в Серверах доступа

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Обратился к спецу по php, то с его слов ошибка в том, что не объявлена переменная $_done, и из елсе выход не корретный. Но исправить не взялся.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Костыль.

Нашёл схожий API, эксемплы котрого работают без ошибок,
нашёл кусок кода, в котором объявляется схожая переменная
https://github.com/BenMenking/routeros-api/blob/master/routeros_api.class.php#L270L274
которая аналогично работает в таком-же блоке,
https://github.com/BenMenking/routeros-api/blob/master/routeros_api.class.php#L324L335
объявил переменную в нашем API и ошибка исчезла.

post-38961-0-56234700-1490860527_thumb.jpg

Обращаюсь к разработчикам: если данный костыль не противоречит логике работы,
то добавить на гитхаб строку $_done = false; после строки
https://github.com/nightflyza/Ubilling/blob/master/api/libs/api.routeros.php#L149

 Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Костыль не помог. Ошибка ушла а вместе с ней и управление микротиком.

 

Может кто сталкивался с такой ошибкой и как-то всё-таки её решил?

 

Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Костыль не помог. Ошибка ушла а вместе с ней и управление микротиком.

 

Может кто сталкивался с такой ошибкой и как-то всё-таки её решил?

 

Спасибо.

Вот здесь была предпринята попытка перевести RouterOS API на версию 1.6, в которой уже исправлены такие глюки, а также добавлена поддержка API-SSL.

https://github.com/nightflyza/Ubilling/pull/9

 

Остальные патчи для MikroTik (определение активности пользователя по нахождению в dhcp leases, просмотр ARP через API, ping через API) планировалось писать поверх RouterOS API версии 1.6.

Но не взлетело :(

 

По решению проблемы - оказалось гораздо проще поддерживать набор локальных патчей.

 

P.S.

https://local.com.ua/forum/topic/92425-%D0%BE%D1%88%D0%B8%D0%B1%D0%BA%D0%B8-%D0%B2-079/

Изменено пользователем Dmitry2

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Нашёл причину, вызывающую ошибку
Notice: Undefined variable: _done in /usr/local/www/apache24/data/billing/api/libs/api.routeros.php on line 192

для её повторения

(проверено на двух разных девайсах, второй девайс такой:
Общая инфорация о состоянии MikroTik`a
Аптайм     17m18s
Версия RouterOS     6.38.5 (stable)
Время сборки     Mar/09/2017 11:32:49
Свободно опер. памяти     1.68 Gb
Всего опер. памяти     1.89 Gb
Процессор     tilegx
Кол-во процессоров     16
Частота процессора     1200 MHz
Загрузка процессора     0 %
Свободно памяти HDD     67.78 Mb
Всего памяти HDD     128 Mb
Архитектура     tile
Название платы     CCR1016-12S-1S+
Платформа     MikroTik)

необходимо добавить 344 влан следующей последовательностью команд:

[admin@MikroTik] > /interface vlan add interface=Ether2 name=VLAN344 vlan-id=344
[admin@MikroTik] > /interface vlan remove VLAN344                                 
[admin@MikroTik] > /interface vlan add interface=Ether2 name=VLAN344 vlan-id=344

Удаление влана устраняет ошибку. Переименование - иногда устраняет, иногда нет.

Костыль, кстати, таки работает, но в правильности его работы не уверен в свзи с отсутствием специфических знаний и умений.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

Удаление влана устраняет ошибку. Переименование - иногда устраняет, иногда нет.

А у тебя "общение" Микротика с биллингом через 344 vlan идет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

"Общение" Микротика с биллингом идет через другой vlan. Ещё возможной причиной могут быть ошибки в конфигурации бриджей и eoip туннелей, которых в этом влане 37 штук. Поиск продолжаю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может быть. Я, когда использовал модуль "Укправление Mikrotik", никаких проблем не было в плане связки billing-mikrotik. Правда со временем все равно перешел на radius, так как статические списки доступа и arp записи не совмем то, что хотелось

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

"Общение" Микротика с биллингом идет через другой vlan. Ещё возможной причиной могут быть ошибки в конфигурации бриджей и eoip туннелей, которых в этом влане 37 штук. Поиск продолжаю.

Щось знайшли? А то схожа проблема в мене, все перепробував неможу знайти чому

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

-del

Изменено пользователем Optimal

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

  • Похожие публикации

    • Автор: denborisjuk
      Продаётся в связи с переходом на пон, блоки питания в комплекте:
       
      Mikrotik rb-800               1шт - 2300грн
      Mikrotik rb-800               1шт - 2000грн (1 порт битый)
      Mikrotik SXT 5 lite          1шт - 700грн
      Mikrotik SXT 2nD           1шт - 700грн
      Mikrotik r11e-5hnd         2шт - 350грн\шт
    • Автор: Woods
      Здравствуйте, ситуация такова. Нужно замутить такую схему:
       
      При балансе равным нулю, чтобы доступ к учетке на ubilling блокировался и перенаправлял на внешний сайт с оплатой.
      Или же при ситуации, если аккаунта у пользователя нет, так же доступа к ubilling не предоставлялся, а происходило перенаправление на внешний сайт с оплатой. (регистрацией аккаунта в системе биллинг).
      Метод использования Хот-спот.
       
      P.S. тапками прошу не кидаться, новичок.
    • Автор: антоха
      Тестируем Asterisk, который стоит за NATом Микротика.
      Возникает проблема - не слышно звонящему с Водафона, кто ему отвечает с Asterisk-а.
       
       
      По факту в логах приходят пакеты с реального ip, а отправляются назад на серый ip
      Подскажите как правильно перенаправить ответный пакет на тот же адрес, с которого он пришел.
       

    • Автор: bot
      Латвийский производитель сетевого оборудования MikroTik выпустил обновления прошивки RouterOS, использующейся в ряде моделей маршрутизаторов компании, устраняющие опасную уязвимость , которая позволяет подключиться к MikroTik Winbox, запросить файл системной базы данных пользователей и авторизоваться на устройстве. Уязвимость уже активно эксплуатируется хакерами.

      Первые сообщения об атаках появились на одном из чешских технофорумов. Согласно словам пользователей, все попытки взлома имели схожий характер: злоумышленник трижды пытался авторизоваться на устройстве (две неудачные попытки и одна удачная), затем изменял несколько сервисов, выходил из системы и через несколько часов вновь возвращался. В атаках эксплуатировался инструмент Winbox для удаленной настройки маршрутизаторов. Порт Winbox 8291 открыт по умолчанию на всех маршрутизаторах MikroTik. Предположительно, все попытки взлома - дело рук одного атакующего, так как они осуществлялись с IP-адреса 103.1.221.39 в Тайване.

      Уязвимость затрагивает все версии RouterOS, начиная с v6.29. Проблема исправлена в версиях RouterOS v6.42.1 и v6.43rc4. В связи с тем, что база данных оказалась в руках злоумышленника, и отсутствием возможности идентифицировать скомпрометированные маршрутизаторы инженеры MikroTik рекомендуют всем пользователям как можно скорее установить обновления или изменить пароли на устройствах. Также рекомендуется изменить порт Winbox или ограничить доступ к устройству, за исключением доверенных IP-адресов и интернет-провайдеров.

      Данной уязвимости пока не присвоен идентификатор CVE. Как отмечается, вышеописанная проблема не связана с уязвимостью CVE-2018-7445, затрагивающей SMB сервис маршрутизаторов MikroTik или с недавно возросшей активностью ботнета Hajime.
       
       
      Источник: securitylab
       
×