Перейти к содержимому

DeepNet

ASP24.com.ua — MikroTik Router OS Level 4, 5, 6, Extra Channel по лучшим ценам. Звоните! 098-89-66-219
Синтегра
Фото

Утилиты для блокировки ВК, ОК и т.д.

python bash указ вк блокировка однокласники яндекс

  • Чтобы отвечать, сперва войдите на форум
120 ответов в теме

#81 KaYot

KaYot

    Злобный фей

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 6 796 Сообщений:
  • Пол:Мужчина

Опубликовано 21 Май 2017 - 08:31

Не понимаю, зачем обсуждать DPI? Блокировка ресурсов подразумевает блокировку по IP/DNS - всё, точка.

Глупости. В следующий раз вам дадут для блокировки ссылку на видео в youtube, будете весь гугль блокировать?
В российских списках таких ссылок полно, и живут люди. Даже заглушки для https отображают.
  • 1

LanTorg.com

#82 DmitryAVET

DmitryAVET

    Пролетал Мимо

  • Маглы
  • Фишка
  • 3 Сообщений:
  • Пол:Мужчина

Опубликовано 21 Май 2017 - 08:51

Глупости. В следующий раз вам дадут для блокировки ссылку на видео в youtube, будете весь гугль блокировать? В российских списках таких ссылок полно, и живут люди. Даже заглушки для https отображают.

Про это никто не подумал. На текущий момент нет никаких дополнительных разъяснительных юридических норм, которые бы описывали как это надо делать технически. К тому же есть Конституция и без внесения в неё правок, а также в ККУ, всё можно трактовать по-разному. Это очень скользкая дорожка. Впрочем, в Украине законы уже давно не имею никакой юридической силы (лишение гражданства вопреки Конституции? - легко; взять на службу иностранцев? - легко; и другие примеры).

 

Действительно, заблокировать URL по IP/DNS не получится. Если контент нарушает законодательство - "позивач" должен обратиться к поставщику услуги, если у него есть представительство в Украине, и проинформировать его о нарушении украинского законодательства / уведомить о постановлении суда. После предоставления решения суда, Поставщик услуги должен ограничить доступ к конкретным материалам для пользователей из Украины.

 

Как уже упоминалось ранее, основанием для ограничения доступа может быть только:

1) решение суда

2) ЗУ “Про телекомунікації”

3) "Правила надання та отримання телекомунікаційних послуг"

 

Конституція України: Стаття 60. Ніхто не зобов'язаний виконувати явно злочинні розпорядження чи накази. За віддання і виконання явно злочинного розпорядження чи наказу настає юридична відповідальність.

 

Как же плохо украинцы знают законодательство... для чего в пример Россия? Вы же вовсю кричите, что там жесткая цензура, нет свободы слова и так далее. Критикуете, но сами предлагаете делать то же самое.

 

P.S. Списки подсетей для некоторых ресурсов, в формате для Mikrotik. Даже не представляю себе, какой будет попадос у провайдеров, когда надо будет добавить несколько сотен ресурсов, и как все это будет проседать. Местные провайдеры пока не спешать ничего блокировать.

 

Вконтакте

/ip firewall address-list
add address=87.240.128.0/18 list=vkcom
add address=93.186.224.0/20 list=vkcom
add address=95.142.192.0/20 list=vkcom
add address=95.213.0.0/17 list=vkcom
add address=185.32.248.0/22 list=vkcom
add address=95.213.0.0/18 list=vkcom
add address=95.142.207.0/24 list=vkcom
add address=95.142.206.0/24 list=vkcom
add address=95.142.204.0/23 list=vkcom
add address=95.142.203.0/24 list=vkcom
add address=95.142.202.0/24 list=vkcom
add address=95.142.201.0/24 list=vkcom
add address=95.142.200.0/21 list=vkcom
add address=95.142.192.0/21 list=vkcom
add address=93.186.232.0/21 list=vkcom
add address=93.186.224.0/21 list=vkcom
add address=185.32.251.0/24 list=vkcom
add address=185.32.250.0/24 list=vkcom
add address=185.32.248.0/23 list=vkcom
add address=185.29.130.0/24 list=vkcom

Одноклассники

/ip firewall address-list
add address=5.61.16.0/21 list=okru
add address=5.61.232.0/21 list=okru
add address=79.137.157.0/24 list=okru
add address=79.137.183.0/24 list=okru
add address=94.100.176.0/20 list=okru
add address=95.163.32.0/19 list=okru
add address=128.140.168.0/21 list=okru
add address=178.22.88.0/21 list=okru
add address=178.237.16.0/20 list=okru
add address=185.5.136.0/22 list=okru
add address=185.6.247.0/24 list=okru
add address=185.16.244.0/22 list=okru
add address=188.93.56.0/21 list=okru
add address=194.186.63.0/24 list=okru
add address=195.211.20.0/22 list=okru
add address=195.218.168.0/24 list=okru
add address=195.218.190.0/23 list=okru
add address=217.20.144.0/20 list=okru
add address=217.69.128.0/20 list=okru
add address=185.16.247.0/24 list=okru
add address=185.16.246.0/24 list=okru

Изменено: DmitryAVET, 21 Май 2017 - 09:05

  • 0

#83 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 21 Май 2017 - 11:25

 

Глупости. В следующий раз вам дадут для блокировки ссылку на видео в youtube, будете весь гугль блокировать? В российских списках таких ссылок полно, и живут люди. Даже заглушки для https отображают.

Про это никто не подумал. На текущий момент нет никаких дополнительных разъяснительных юридических норм, которые бы описывали как это надо делать технически. К тому же есть Конституция и без внесения в неё правок, а также в ККУ, всё можно трактовать по-разному. Это очень скользкая дорожка. Впрочем, в Украине законы уже давно не имею никакой юридической силы (лишение гражданства вопреки Конституции? - легко; взять на службу иностранцев? - легко; и другие примеры).

 

Действительно, заблокировать URL по IP/DNS не получится. Если контент нарушает законодательство - "позивач" должен обратиться к поставщику услуги, если у него есть представительство в Украине, и проинформировать его о нарушении украинского законодательства / уведомить о постановлении суда. После предоставления решения суда, Поставщик услуги должен ограничить доступ к конкретным материалам для пользователей из Украины.

 

Как уже упоминалось ранее, основанием для ограничения доступа может быть только:

1) решение суда

2) ЗУ “Про телекомунікації”

3) "Правила надання та отримання телекомунікаційних послуг"

 

Конституція України: Стаття 60. Ніхто не зобов'язаний виконувати явно злочинні розпорядження чи накази. За віддання і виконання явно злочинного розпорядження чи наказу настає юридична відповідальність.

 

Как же плохо украинцы знают законодательство... для чего в пример Россия? Вы же вовсю кричите, что там жесткая цензура, нет свободы слова и так далее. Критикуете, но сами предлагаете делать то же самое.

 

P.S. Списки подсетей для некоторых ресурсов, в формате для Mikrotik. Даже не представляю себе, какой будет попадос у провайдеров, когда надо будет добавить несколько сотен ресурсов, и как все это будет проседать. Местные провайдеры пока не спешать ничего блокировать.

 

Вконтакте

/ip firewall address-list
add address=87.240.128.0/18 list=vkcom
add address=93.186.224.0/20 list=vkcom
add address=95.142.192.0/20 list=vkcom
add address=95.213.0.0/17 list=vkcom
add address=185.32.248.0/22 list=vkcom
add address=95.213.0.0/18 list=vkcom
add address=95.142.207.0/24 list=vkcom
add address=95.142.206.0/24 list=vkcom
add address=95.142.204.0/23 list=vkcom
add address=95.142.203.0/24 list=vkcom
add address=95.142.202.0/24 list=vkcom
add address=95.142.201.0/24 list=vkcom
add address=95.142.200.0/21 list=vkcom
add address=95.142.192.0/21 list=vkcom
add address=93.186.232.0/21 list=vkcom
add address=93.186.224.0/21 list=vkcom
add address=185.32.251.0/24 list=vkcom
add address=185.32.250.0/24 list=vkcom
add address=185.32.248.0/23 list=vkcom
add address=185.29.130.0/24 list=vkcom

Одноклассники

/ip firewall address-list
add address=5.61.16.0/21 list=okru
add address=5.61.232.0/21 list=okru
add address=79.137.157.0/24 list=okru
add address=79.137.183.0/24 list=okru
add address=94.100.176.0/20 list=okru
add address=95.163.32.0/19 list=okru
add address=128.140.168.0/21 list=okru
add address=178.22.88.0/21 list=okru
add address=178.237.16.0/20 list=okru
add address=185.5.136.0/22 list=okru
add address=185.6.247.0/24 list=okru
add address=185.16.244.0/22 list=okru
add address=188.93.56.0/21 list=okru
add address=194.186.63.0/24 list=okru
add address=195.211.20.0/22 list=okru
add address=195.218.168.0/24 list=okru
add address=195.218.190.0/23 list=okru
add address=217.20.144.0/20 list=okru
add address=217.69.128.0/20 list=okru
add address=185.16.247.0/24 list=okru
add address=185.16.246.0/24 list=okru

 

 

Зачем вы так заморчились с адрес листом надо было так 

 

add address=vk.com list=vkcom

add address=ok.ru list=okru

 

и все !!!

Раз в сутки обновление данного листа и все работает на ура и блочится конкретный ИП (группа) отвечающий за сайт, а не все подсети. Вот при такой блокировки как у Вас и получается что половина сервисов не работает даже те которые не относятся к блокировке. 


  • 0

NG Optics

#84 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 21 Май 2017 - 11:29

Еще нюанс в документе в котором перечислен список блокировки указаны конкретные ссылки (сервисы) что блокировать, а не все подряд.


  • 0

#85 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 21 Май 2017 - 11:51

Для МТ выглядит это так:

 

rus_drop.rsc файл в котором список что блокируем вида

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop timeout=23:59:00
add address=kaspersky.ru list=rus_drop timeout=23:59:00
 
Далее в /ip firewall filter
 0    ;;; RUS_DROP
      chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 
      log=no log-prefix=""

 

Далее в /system scheduler

add name=rus_drop start-date=may/21/2017 start
-time=00:10:00 interval=1d on-event="/import file-name=rus_drop.rsc"
 
 
и все пашет как нужно ...

  • 0

#86 UStas_rinet

UStas_rinet

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 227 Сообщений:

Опубликовано 21 Май 2017 - 12:21

Ребята, вы тему перепутали. Тут техническая информация и только. Юридические аспекты и срач в соседней теме.


  • 0

#87 isup

isup

    Пролетал Мимо

  • Маглы
  • Фишка
  • 1 Сообщений:

Опубликовано 21 Май 2017 - 19:46

8Спасибо UStas_rinet, за утилиту, то что не словом как другие , а делом

 

DNS redirect to spoof + IP block решит проблему на 99%

 

 

http://stackoverflow...-urls-encrypted

[TLS] does not provide a mechanism for a client to tell a server the name of the server it is contacting. It may be desirable for clients to provide this information to facilitate secure connections to servers that host multiple 'virtual' servers at a single underlying network address.

 

Кто понял, DPI по https способен закрыть?


  • 0

#88 _Maks_

_Maks_

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 829 Сообщений:
  • Пол:Мужчина
  • Город:Днепр

Опубликовано 21 Май 2017 - 20:42

 

Для МТ выглядит это так:

 

rus_drop.rsc файл в котором список что блокируем вида

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop timeout=23:59:00
add address=kaspersky.ru list=rus_drop timeout=23:59:00
 
Далее в /ip firewall filter
 0    ;;; RUS_DROP
      chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 
      log=no log-prefix=""

 

Далее в /system scheduler

add name=rus_drop start-date=may/21/2017 start
-time=00:10:00 interval=1d on-event="/import file-name=rus_drop.rsc"
 
 
и все пашет как нужно ...

 

А можно подробнее

1 правило мы добавили доменные имена 

2 блокируем

3 а тут я не понял откуда берется файл и что далее.


  • 0

#89 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 22 Май 2017 - 00:26

 

 

Для МТ выглядит это так:

 

rus_drop.rsc файл в котором список что блокируем вида

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop timeout=23:59:00
add address=kaspersky.ru list=rus_drop timeout=23:59:00
 
Далее в /ip firewall filter
 0    ;;; RUS_DROP
      chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 
      log=no log-prefix=""

 

Далее в /system scheduler

add name=rus_drop start-date=may/21/2017 start
-time=00:10:00 interval=1d on-event="/import file-name=rus_drop.rsc"
 
 
и все пашет как нужно ...

 

А можно подробнее

1 правило мы добавили доменные имена 

2 блокируем

3 а тут я не понял откуда берется файл и что далее.

 

Проще некуда на компе создаем файл

rus_drop.rsc

внутри файла необходимо первой строкой прописать 

/ip firewall address-list

а далее список что блокируем вида 

add address=www.kaspersky.ru list=rus_drop timeout=23:59:00

Эти правила формируют адрес лист с временем жизни 23часа 59 минут 

затем этот файл переносим на МТ, а далее в фаерволе создаем правило

0    ;;; RUS_DROP
      chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 
 

ну и в конце раз в 24 часа запускаеться правило которое заносит в адрес лист список из файла rus_drop.rsc  /system scheduler

add name=rus_drop start-date=may/21/2017 start
-time=00:10:00 interval=1d on-event="/import file-name=rus_drop.rsc"

  • 0

#90 pavlabor

pavlabor

    Дьявол

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 4 395 Сообщений:
  • Пол:Мужчина

Опубликовано 22 Май 2017 - 07:02

Думаю что это все пурга, нужны четкие алгоритмы и чтобы централизованное формирование блек листа, который и будет автоматически подчитыватся.

В противном случае, лично бы я завалил весь украинский сегмент интернет.

 

Механизм очень простой, по днс формируем комюнити "Украина" и наливаем что то типа

vk.com. 14400 IN CNAME president.gov.ua.

ok.ru. 14400 IN CNAME ssu.gov.ua.

... далее по вкусу.

Через сутки все домены Украины окажутся в блек листах провайдеров.

Все это подается как официальная ответка на притеснение русских в Украине.
 


  • 0

Промышленная гальваническая грозозащита LPGA-01M,
 для защиты узлов и магистральных решений локальных сетей. Пассивная защита устройств абонента.

Универсальная гальваническая грозозащита LPGA-01U,
для защиты роутеров, ноутбуков, персональных компьютеров, сетевых принтеров, IPTV приставок, Smart TV, сетевых систем хранения данных, проекторов, IP-камер, IP-телефонов, VoIP-шлюзов, коммутаторов и другой бытовой техники подключенной к локальным сетям.


#91 kosteek

kosteek

    Пролетал Мимо

  • Маглы
  • Фишка
  • 34 Сообщений:
  • Пол:Мужчина
  • Город:Славянск

Опубликовано 22 Май 2017 - 09:31

 

Для МТ выглядит это так:

 

rus_drop.rsc файл в котором список что блокируем вида

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop timeout=23:59:00
add address=kaspersky.ru list=rus_drop timeout=23:59:00
 
Далее в /ip firewall filter
 0    ;;; RUS_DROP
      chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 
      log=no log-prefix=""

 

Далее в /system scheduler

add name=rus_drop start-date=may/21/2017 start
-time=00:10:00 interval=1d on-event="/import file-name=rus_drop.rsc"
 
 
и все пашет как нужно ...

 

Можно еще проще

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop
add address=kaspersky.ru list=rus_drop

/ip firewall filter add chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 log=no log-prefix=""

/system scheduler add name=rus_drop start-date=may/21/2017 start-time=00:10:00 interval=1d on-event="/ip dns cache flush"

Изменено: kosteek, 22 Май 2017 - 12:14

  • 0

#92 Sandorik

Sandorik

    Точу Зубы

  • Сitizens
  • ФишкаФишкаФишка
  • 295 Сообщений:
  • Пол:Мужчина
  • Город:Харьков

Опубликовано 22 Май 2017 - 09:52

Ребята привет, а есть список подсетей майл.ру?


  • 0

#93 mixtery

mixtery

    Пролетал Мимо

  • Маглы
  • Фишка
  • 43 Сообщений:

Опубликовано 22 Май 2017 - 10:12

Ребята привет, а есть список подсетей майл.ру?


http://bgp.he.net/AS47764#_prefixes
http://bgp.he.net/AS47764#_prefixes6


ipv4

Spoiler


ipv6 
Spoiler


В пирах у них ещё две АСки свои

AS21051 и AS60863

Изменено: mixtery, 22 Май 2017 - 10:14

  • 0

#94 Dimkers

Dimkers

    Оборотень

  • Сitizens
  • ФишкаФишкаФишкаФишка
  • 371 Сообщений:
  • Пол:Мужчина
  • Город:kr.ua
  • Интересы:IP

Опубликовано 22 Май 2017 - 10:42

как минимум по АС-у блочить неправильно. Могут легко отпасть другие сервисы.  Тут вот у некоторых pctuner.ru и icq.com отпали после таких вот блоков и это то, что уже нашли.

Резолвьте список и блочьте.

 

кому интересно, список доменов из указа:

Spoiler

Изменено: Dimkers, 22 Май 2017 - 10:53

  • 0

#95 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 22 Май 2017 - 11:37

 

 

Для МТ выглядит это так:

 

rus_drop.rsc файл в котором список что блокируем вида

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop timeout=23:59:00
add address=kaspersky.ru list=rus_drop timeout=23:59:00
 
Далее в /ip firewall filter
 0    ;;; RUS_DROP
      chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 
      log=no log-prefix=""

 

Далее в /system scheduler

add name=rus_drop start-date=may/21/2017 start
-time=00:10:00 interval=1d on-event="/import file-name=rus_drop.rsc"
 
 
и все пашет как нужно ...

 

Можно еще проще

/ip firewall address-list
add address=www.kaspersky.ru list=rus_drop
add address=kaspersky.ru list=rus_drop

/ip firewall filter chain=forward action=drop dst-address-list=rus_drop out-interface=ether11 log=no log-prefix=""

/system scheduler add name=rus_drop start-date=may/21/2017 start-time=00:10:00 interval=1d on-event="/ip dns cache flush"

Вопрос, причем тут очистка днс кеша?

В МТ с версии 3,6 чевото там при добавлении в адрес лист НС имени к примеру vk.com создадуться динамические правила на все ИП к которым привязан данный домен и в блок попадут все ИП из этого списка. То о чем говорите вы это блокировка по ДНС в том случае если ваши клиенты используют ваш ДНС развернутый на МТ ... Разницу понимаете ...


Изменено: max_m, 22 Май 2017 - 11:39

  • 0

#96 kosteek

kosteek

    Пролетал Мимо

  • Маглы
  • Фишка
  • 34 Сообщений:
  • Пол:Мужчина
  • Город:Славянск

Опубликовано 22 Май 2017 - 12:44

Я прекрасно все понимаю о чем пишу, а вы понимаете о чем пишите?

 

Вы плохо поняли мысль скрипта.

У меня клиенты не используют ДНС МТ. От слова совсем. ДНС нужен самому МТ для резолва НС - для блокировки.


  • 0

#97 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 22 Май 2017 - 15:47

Я прекрасно все понимаю о чем пишу, а вы понимаете о чем пишите?

 

Вы плохо поняли мысль скрипта.

У меня клиенты не используют ДНС МТ. От слова совсем. ДНС нужен самому МТ для резолва НС - для блокировки.

Чет вы не поняли... 

И что это вам дало ? Ну ваш МТ не будет знать резольв к примеру vk.com  и что это дало ?

У клиента к примеру прописан ДНС гугла 8,8,8,8 и в каком месте вы заблочили абону доступ ?

Данный скрипт написан именно мною для моих целей и задач и я прекрасно знаю о чем я пишу.


  • 0

#98 max_m

max_m

    Вампиреныш

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишка
  • 507 Сообщений:
  • Пол:Мужчина

Опубликовано 22 Май 2017 - 15:49

Что бы не разводить холивар пропишите у себя на МТ то о чем Вы говорите, а на компе впишите к примеру днс гугла, а потом то о чем я описал выше. Сами поймете разницу.


Изменено: max_m, 22 Май 2017 - 15:52

  • 0

#99 andryas

andryas

    Дракон

  • Сitizens
  • ФишкаФишкаФишкаФишкаФишкаФишкаФишка
  • 2 806 Сообщений:
  • Пол:Мужчина

Опубликовано 22 Май 2017 - 15:52

Шимкив уже озвучил (читайте в соседней ветке): DNS блокирования достаточно, ACL юзать не обязательно.

Цель - уменьшить аудиторию соцсетей на столько, на сколько получится.


  • 0

#100 Dimkers

Dimkers

    Оборотень

  • Сitizens
  • ФишкаФишкаФишкаФишка
  • 371 Сообщений:
  • Пол:Мужчина
  • Город:kr.ua
  • Интересы:IP

Опубликовано 22 Май 2017 - 15:57

Я прекрасно все понимаю о чем пишу, а вы понимаете о чем пишите?

Вы не понимаете от слова совсем. Сделал проще - днс гугла выдает сам микрот абону. И с похожим скриптом как у макс_м - работает. Работает именно потому, что резолвится домен и добавляется ИПИШКА в блэклист.


  • 0





Также с меткой «python, bash, указ, вк, блокировка, однокласники, яндекс»

6 пользователей читают эту тему

0 members, 6 guests, 0 anonymous users

Local.blog МЕТА - Украина