Перейти до

Рекомендованные сообщения

Опубликовано: (відредаговано)

Всем уже известно, что будут кодироваться украинские каналы в небе.

Прикупили себе одесский стример DTN-1К для того, чтобы было куда тыкать КАМ-модули.

Стример выдает мультик, а интернет-пользователям даем юник. Встал вопрос как?

Пробую с помощью Астры и ни в какую, не принимает астра поток.

В тестовом режиме пробую всего только один канал.

На картинке обведенно красным, который канал пробую брать.

image_2020_01_09T14_46_03_915Z.thumb.png.0ead813c3f4dcaa9be364f9595791efe.png

 

Конфиг астры

make_channel({
    name = "2+2",
    input = {
        "udp://239.255.5.1:1235",
    },
    output = {
        "http://10.10.100.100:10999/2+2",
    },
})

 

Выхлоп в консоли при запуске астры и попытке подключения к поток через VLC

root@IPTV:~# astra /etc/astra/test.lua
Jan 10 11:17:49: INFO: Starting Astra 4.4.182
Jan 10 11:18:01: ERROR: [2+2 #1] Bitrate:0Kbit/s
Jan 10 11:18:02: ERROR: [2+2 #1] Bitrate:0Kbit/s
Jan 10 11:18:03: ERROR: [2+2 #1] Bitrate:0Kbit/s
Jan 10 11:18:04: ERROR: [2+2 #1] Bitrate:0Kbit/s
Jan 10 11:18:04: ERROR: [2+2] Failed to switch to reserve

Кончились уже идеи, почему не идет.

Відредаговано Небесный
Опубліковано:

Так першочергово треба провірити чи приходить мультикаст на порт найкраще самою ж астрою
astra --analyze udp://interface_Name@239.255.5.1:1235
ідеально би мультикаст подати на окремий інтерфейс сервера де астра, ну і дальше якшо приходить MPTS мій робочий конфіг:
make_channel({
    name = "10020",
    input = {"udp://vlan1023@227.0.0.9:100#pnr=10020"},
    output = {"http://0:20003/10020#keep_active"},
})
make_channel({
    name = "10030",
    input = {"udp://vlan1023@227.0.0.9:100#pnr=10030"},
    output = {"http://0:20003/10030#keep_active"},
})
make_channel({
    name = "10040",
    input = {"udp://vlan1023@227.0.0.9:100#pnr=10040"},
    output = {"http://0:20003/10040#keep_active"},
})
 

Опубліковано: (відредаговано)

Мультик доходил до сервера, но там умирал.

Причина была в том, что ядро убивало пакеты ибо сервер-астры и стример были в разных подсетях.

Настроил в одну подсеть и пошло, а думал, что мультику пофиг. Ну в общем то и пофиг мультику, но убунте было не пофиг - и убивала непонятные пакеты. )))Причина тому настройки ядра:

net.ipv4.conf.all.rp_filter = 1
net.ipv4.conf.default.rp_filter = 1

Если бы стояло "0" - тогда и работало бы.

 

Как-то так, я знал что какая-то мелочь ибо все перерыл с ног до головы, вот оно и оказалось тут.

Всем спасибо за советы!

passer отдельное СПС. )))

Відредаговано Небесный

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Вхід

Уже зарегистрированы? Войдите здесь.

Войти сейчас
×
×
  • Створити нове...