Jump to content
Local
sm_root

Отделение СУБД на другой сервер

Recommended Posts

Отделил СУБД MySQL на другой сервер Ubuntu Server 18.04.

На старом сервере версия MySQL Ver 14.14 Distrib 5.6.26, for FreeBSD10.2 (amd64) using  EditLine wrapper

На новом сервере версия MySQL Ver 14.14 Distrib 5.7.29, for Linux (x86_64) using  EditLine wrapper

 

В целом все прошло без ошибок, биллинг работает. Но иногда выскакивают ошибки, например при переназачении скорости

wrong data input: INSERT INTO userspeeds (id ,login ,speed) VALUES (NULL , '175001912', '');

Или при внесении данных в поля профиля

wrong data input: INSERT INTO `weblogs` (`id`,`date`,`admin`,`ip`,`event`) VALUES(NULL,'2020-05-05 13:40:06','slava','10.1.6.36','CF SET (175001204) TYPE [17] ON `Текущий ме�..`')

 

При этом сами значения устанавливаются.

 

Находил похожие проблемы на форуме у тех, кто обновлял биллинг, но я биллинг не обновлял. 

Share this post


Link to post
Share on other sites

STRICT_TRANS_TABLES отключите что-ли.

Share this post


Link to post
Share on other sites

Осталась ошибка при редактировании полей профиля

wrong data input: INSERT INTO `weblogs` (`id`,`date`,`admin`,`ip`,`event`) VALUES(NULL,'2020-05-07 09:08:29','slava','10.1.6.36','CF SET (175006426) TYPE [3] ON `Ибраим Жам�..`')

 

Share this post


Link to post
Share on other sites

при добавлении свитча

 

wrong data input: INSERT INTO switches (id ,modelid ,ip ,desc ,location ,snmp,geo,parentid) VALUES ('', '5', '10.9.90.81', 'MTSIGMON', 'Фуркат', 'dsfsd80sd','', NULL );

 

Share this post


Link to post
Share on other sites

Ну, вы проигнорировали мое предыдущее сообщение - это закономерный результат.

Я больше скажу - там где-то 40-45% всего биллинга не должно в таком виде работать от слова совсем.

 

Share this post


Link to post
Share on other sites

Я отключил STRICT_TRANS_TABLES, большая часть ошибок ушла, но некоторые остались.

 

mysql> SET GLOBAL sql_mode = 'NO_ENGINE_SUBSTITUTION';
Query OK, 0 rows affected, 1 warning (0.00 sec)
 

mysql> SELECT @@GLOBAL.sql_mode;
+------------------------+
| @@GLOBAL.sql_mode      |
+------------------------+
| NO_ENGINE_SUBSTITUTION |
+------------------------+
1 row in set (0.00 sec)
 

Edited by sm_root

Share this post


Link to post
Share on other sites
2 минуты назад, sm_root сказав:

Я отключил STRICT_TRANS_TABLES, большая часть ошибок ушла, но некоторые остались. 

 

http://demo.ubilling.net.ua:9999/billing/?module=eventview

 

Screenshot_20200508_Ubilling.png

 

делаем выводы.

11 минут назад, sm_root сказав:

при добавлении свитча

 


wrong data input: INSERT INTO switches (id ,modelid ,ip ,desc ,location ,snmp,geo,parentid) VALUES ('', '5', '10.9.90.81', 'MTSIGMON', 'Фуркат', 'dsfsd80sd','', NULL );

 

Здесь вообще части нужных полей нету.

 

Короче жестокая реальность, передает привет вашему, давно не существующему в природе 0.8.х или что это такое.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×