BaRYaN Posted October 9, 2008 at 01:08 PM Author Posted October 9, 2008 at 01:08 PM СТГ отключатся сам собой. В общем говоря вылетает, не зависимо ни от чего (добаляешь пользователей или оставляешь просто считать)
madf Posted October 9, 2008 at 01:17 PM Posted October 9, 2008 at 01:17 PM Ну, во-первых, можно посмотреть в лог (/var/log/stargazer.log) и консольный (если собран в debug-режиме). Может, он вылетает не без причины. Во-вторых, если логи молчат (хотя в консольном будет хоть что-то написано) - получить корку и сделать бектрейс. Как это делать - я уже писал 100 раз. Например, тут. Если повезет - бектрейс укажет причину падения. Если нет - попробовать запустить из-под valgrind (как это сделать - описано там-же). Возможно он покажет на проблемы с памятью.
BaRYaN Posted October 9, 2008 at 01:21 PM Author Posted October 9, 2008 at 01:21 PM Ты таки присел на антидепресанты пока ставил стг+мускуль, дальше только суицид...лучше остановись на достигнутом и сделай паузу))) О да признаюсь антидипрессанты я принимал (врач назначил), но до того как начал утанавливать СТГ, теперь чувствую надо вернуться к их приему иначе я действительно разочарюсь в себе и в том, какой путь я избрал для удовлетворения желаний своего руководства )) А так все хошо было со СКВИДом, хотя надо признаться что помучаться таки с ним пришлось, но гораздо меньше. Я даже думал заняться НЕТАМСом - хоть он и сложнее но зато очевиднее и яснее. Но все же мое сознание остановилось на СТГ+мускуль+веб), и теперь оно мучатся, осбенно от непонимания того почему такое простое, так сложно.... Вот %)
gall Posted October 9, 2008 at 01:28 PM Posted October 9, 2008 at 01:28 PM О да признаюсь антидипрессанты я принимал (врач назначил), но до того как начал утанавливать СТГ, теперь чувствую надо вернуться к их приему иначе я действительно разочарюсь в себе и в том, какой путь я избрал для удовлетворения желаний своего руководства )) Ну принимать-не принимать.. дело твое))) А вот к падениям стг 1-2 раза в сутки лучше просто привыкнуть. Я уже почти привык, искать надоело, потому как непонятно ЧТО искать. Осталось еще 120 юзеров приучить к падениям сервера и отвалу инета на 15-70сек. в зависимости от того в какой момент минуты он упадет
madf Posted October 9, 2008 at 01:29 PM Posted October 9, 2008 at 01:29 PM Потому что начинать нужно с малого. С установки stg в стандартной поставке. С работы на файлах. А потом уже делать навороты (и то - если они нужны).
BaRYaN Posted October 9, 2008 at 01:36 PM Author Posted October 9, 2008 at 01:36 PM Ну, во-первых, можно посмотреть в лог (/var/log/stargazer.log) и консольный (если собран в debug-режиме). Может, он вылетает не без причины.Во-вторых, если логи молчат (хотя в консольном будет хоть что-то написано) - получить корку и сделать бектрейс. Как это делать - я уже писал 100 раз. Например, тут. Если повезет - бектрейс укажет причину падения. Если нет - попробовать запустить из-под valgrind (как это сделать - описано там-же). Возможно он покажет на проблемы с памятью. К сожалению стг говорит что у него все хорошо 2008-10-08 21:40:50 -- Stg v. Stg 2.404 2008-10-08 21:40:50 -- Message queue created successfully. msgKey=5555 msgID=10518528 2008-10-08 21:40:50 -- Timer thread started successfully. 2008-10-08 21:40:50 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. 2008-10-08 21:40:50 -- Users started successfully. 2008-10-08 21:40:50 -- Traffcounter started successfully. 2008-10-08 21:40:50 -- Module: 'Ether_cap v.1.0'. Start successfull. 10 2008-10-08 21:40:50 -- Module: 'InetAccess authorizator v.1.2'. Start successfull. 50 2008-10-08 21:40:50 -- Module: 'Always Online authorizator v.1.0'. Start successfull. 70 2008-10-08 21:40:50 -- Module: 'Pinger v.1.01'. Start successfull. 100 2008-10-08 21:40:50 -- Module: 'Stg configurator v.0.07'. Start successfull. 220 2008-10-08 21:40:50 -- Stg started successfully. А по повуду консольного режима, что-то я читал но не помню где и как им пользоваться... а если нужен дебаг то сейчас в нем соберу Еще раз спасибо за помощь..
BaRYaN Posted October 9, 2008 at 02:17 PM Author Posted October 9, 2008 at 02:17 PM 9884 Ошибка сегментирования выдала косоль
BaRYaN Posted October 9, 2008 at 02:43 PM Author Posted October 9, 2008 at 02:43 PM Более подробно users.cpp > 18:30:00 > Sec = 1223562600 users.cpp > 18:30:00 > New Minute. old = 29 current = 30 users.cpp > 18:30:00 > RealDelUser() users to del: 0 ./startstg: line 3: 10140 Ошибка сегментирования
gall Posted October 9, 2008 at 05:17 PM Posted October 9, 2008 at 05:17 PM Все разобралси А более развернутый ответ можеш дать?
BaRYaN Posted October 10, 2008 at 08:35 AM Author Posted October 10, 2008 at 08:35 AM А более развернутый ответ можеш дать? Да, протестировав 12часов СТГ ниразу не вылетил... Проблема связанна с детальной статистикой.. собсно отключив ее у пользывателей СТГ перестал падать... почему СТГ падает из-за ДС пока не разобрался.. видимо что-то не нравится в базе
Колян Posted October 10, 2008 at 08:46 AM Posted October 10, 2008 at 08:46 AM может ресурсов не хватает, и он не успевает писать стату?
gall Posted October 10, 2008 at 08:56 AM Posted October 10, 2008 at 08:56 AM Да, протестировав 12часов СТГ ниразу не вылетил... Проблема связанна с детальной статистикой.. собсно отключив ее у пользывателей СТГ перестал падать... почему СТГ падает из-за ДС пока не разобрался.. видимо что-то не нравится в базе 12 часов маловато, отпишись как он проживет сутки-трое.
BaRYaN Posted October 10, 2008 at 08:59 AM Author Posted October 10, 2008 at 08:59 AM Врядли машина хоть и не самая новая и мощьная но все же ее более чем хdатать должно Athlon 64 4000+ /1Gb ddr/400Gb hdd В среднем 20% проца кушает
BaRYaN Posted October 10, 2008 at 09:00 AM Author Posted October 10, 2008 at 09:00 AM 12 часов маловато, отпишись как он проживет сутки-трое. Хорошо отпишусь
madf Posted October 10, 2008 at 09:21 AM Posted October 10, 2008 at 09:21 AM может ресурсов не хватает, и он не успевает писать стату? Не успевает... за кем? Есть два подозрения: concurrent access в счетчике и в модуле. В счетчике маловероятно. Под valgrind его бы...
BaRYaN Posted October 10, 2008 at 09:32 AM Author Posted October 10, 2008 at 09:32 AM Не успевает... за кем?Есть два подозрения: concurrent access в счетчике и в модуле. В счетчике маловероятно. Под valgrind его бы... Да я сейчас какрас этим занимаюсь
tseytnot Posted October 13, 2008 at 08:25 PM Posted October 13, 2008 at 08:25 PM Всем привет. У меня похожая ошибка. Решил перейти на MySQL и прикрутить веб-морду. В режиме хранения баз в mysql старгейзер не запускается, и пшет в логах следующее: cat messages: Oct 14 01:18:47 fregat kernel: stargazer[2146]: segfault at 0 rip 2b42a0ba6fa0 rsp 7fff0ad68a88 error 6 Oct 14 01:21:25 fregat kernel: stargazer[2211]: segfault at 100007f rip 2aaaaaab81a7 rsp 7fff7fcd5e20 error 4 Oct 14 01:21:53 fregat kernel: stargazer[2225]: segfault at 100007f rip 2aaaaaab81a7 rsp 7fff608469d0 error 4 Oct 14 01:49:16 fregat kernel: stargazer[2488]: segfault at 0 rip 2b3e2a815fa0 rsp 7fff810fadd8 error 6 Oct 14 01:49:50 fregat kernel: stargazer[2499]: segfault at 0 rip 2b4093850fa0 rsp 7fff180bdda8 error 6 Oct 14 01:50:29 fregat kernel: stargazer[2517]: segfault at 0 rip 2b175ef34fa0 rsp 7fff4c9da6b8 error 6 Oct 14 01:51:10 fregat kernel: stargazer[2537]: segfault at 0 rip 2b3189590fa0 rsp 7fff2237e068 error 6 Oct 14 02:18:15 fregat kernel: stargazer[3627]: segfault at 0 rip 2b17f715cfa0 rsp 7fffb47b24d8 error 6 cat stargazer.log: 2008-10-14 01:50:29 -- Stg v. Stg 2.404 2008-10-14 01:50:29 -- Message queue created successfully. msgKey=5555 msgID=458752 2008-10-14 01:50:29 -- Timer thread started successfully. 2008-10-14 01:50:29 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. 2008-10-14 01:51:10 -- Stg v. Stg 2.404 2008-10-14 01:51:10 -- Message queue created successfully. msgKey=5555 msgID=491520 2008-10-14 01:51:10 -- Timer thread started successfully. 2008-10-14 01:51:10 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. 2008-10-14 02:18:15 -- Stg v. Stg 2.404 2008-10-14 02:18:15 -- Message queue created successfully. msgKey=5555 msgID=524288 2008-10-14 02:18:15 -- Timer thread started successfully. 2008-10-14 02:18:15 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. Версия старгейзера 2.405.9.8, применен патч mysql_mutex-0.68. С оригинальным модулем mysql ситуация аналогичная. В файловом режиме запускается без проблем. Система Debian. Заранее благодарен.
gall Posted October 14, 2008 at 05:15 AM Posted October 14, 2008 at 05:15 AM Что то похожее было. Посмотри в сторону кодировки базы. И еще глянь в config.php тоже на предмет кодировки.
BaRYaN Posted October 14, 2008 at 11:19 AM Author Posted October 14, 2008 at 11:19 AM Всем привет.У меня похожая ошибка. Решил перейти на MySQL и прикрутить веб-морду. В режиме хранения баз в mysql старгейзер не запускается, и пшет в логах следующее: cat messages: Oct 14 01:18:47 fregat kernel: stargazer[2146]: segfault at 0 rip 2b42a0ba6fa0 rsp 7fff0ad68a88 error 6 Oct 14 01:21:25 fregat kernel: stargazer[2211]: segfault at 100007f rip 2aaaaaab81a7 rsp 7fff7fcd5e20 error 4 Oct 14 01:21:53 fregat kernel: stargazer[2225]: segfault at 100007f rip 2aaaaaab81a7 rsp 7fff608469d0 error 4 Oct 14 01:49:16 fregat kernel: stargazer[2488]: segfault at 0 rip 2b3e2a815fa0 rsp 7fff810fadd8 error 6 Oct 14 01:49:50 fregat kernel: stargazer[2499]: segfault at 0 rip 2b4093850fa0 rsp 7fff180bdda8 error 6 Oct 14 01:50:29 fregat kernel: stargazer[2517]: segfault at 0 rip 2b175ef34fa0 rsp 7fff4c9da6b8 error 6 Oct 14 01:51:10 fregat kernel: stargazer[2537]: segfault at 0 rip 2b3189590fa0 rsp 7fff2237e068 error 6 Oct 14 02:18:15 fregat kernel: stargazer[3627]: segfault at 0 rip 2b17f715cfa0 rsp 7fffb47b24d8 error 6 cat stargazer.log: 2008-10-14 01:50:29 -- Stg v. Stg 2.404 2008-10-14 01:50:29 -- Message queue created successfully. msgKey=5555 msgID=458752 2008-10-14 01:50:29 -- Timer thread started successfully. 2008-10-14 01:50:29 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. 2008-10-14 01:51:10 -- Stg v. Stg 2.404 2008-10-14 01:51:10 -- Message queue created successfully. msgKey=5555 msgID=491520 2008-10-14 01:51:10 -- Timer thread started successfully. 2008-10-14 01:51:10 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. 2008-10-14 02:18:15 -- Stg v. Stg 2.404 2008-10-14 02:18:15 -- Message queue created successfully. msgKey=5555 msgID=524288 2008-10-14 02:18:15 -- Timer thread started successfully. 2008-10-14 02:18:15 -- Storage plugin: mysql_store v.0.68-mutex (STG-Web). Loading successfull. Версия старгейзера 2.405.9.8, применен патч mysql_mutex-0.68. С оригинальным модулем mysql ситуация аналогичная. В файловом режиме запускается без проблем. Система Debian. Заранее благодарен. Проблему можно решить двумя способами 1) в /etc/stargazer/stargazer.conf добавить строчку dbtablecharset = koi8r 2) собрать STG езменив перед этим в makefile строчку dbtablecharset = koi8-r на dbtablecharset = koi8r Оба способа у меня работают
tseytnot Posted October 15, 2008 at 07:27 AM Posted October 15, 2008 at 07:27 AM Проблему можно решить двумя способами 1) в /etc/stargazer/stargazer.conf добавить строчку dbtablecharset = koi8r 2) собрать STG езменив перед этим в makefile строчку dbtablecharset = koi8-r на dbtablecharset = koi8r Оба способа у меня работают Спасибо за совет. Пересобрал с новой кодировкой и все запустилось, НО: при любой попытке сделать изменение через конфигуратор старгейзер вываливается в кору... где то на форуме такую проблему уже встречал, но конкретного решения не увидел...
tseytnot Posted October 15, 2008 at 07:49 AM Posted October 15, 2008 at 07:49 AM и ещё при попытке изменить через конфигуратор различные параметры, в логах пишет: Oct 15 12:54:42 fregat kernel: stargazer[13557]: segfault at 2b39d32c7918 rip 2b39d32c7918 rsp 45004ea8 error 15 Oct 15 13:10:04 fregat kernel: stargazer[13589] general protection rip:2aaaaac53171 rsp:45004f50 error:0 Oct 15 13:10:54 fregat kernel: stargazer[14586]: segfault at 0 rip 0 rsp 45004fe8 error 14 Oct 15 13:12:10 fregat kernel: stargazer[14613]: segfault at 2b4e973a0918 rip 2b4e973a0918 rsp 45004ea8 error 15 Oct 15 13:12:24 fregat kernel: stargazer[14629] general protection rip:2aaaaac53171 rsp:45004f50 error:0 Oct 15 13:30:29 fregat kernel: stargazer[14725] general protection rip:2aaaaac53171 rsp:45004f50 error:0
BaRYaN Posted October 15, 2008 at 10:16 AM Author Posted October 15, 2008 at 10:16 AM и ещёпри попытке изменить через конфигуратор различные параметры, в логах пишет: Oct 15 12:54:42 fregat kernel: stargazer[13557]: segfault at 2b39d32c7918 rip 2b39d32c7918 rsp 45004ea8 error 15 Oct 15 13:10:04 fregat kernel: stargazer[13589] general protection rip:2aaaaac53171 rsp:45004f50 error:0 Oct 15 13:10:54 fregat kernel: stargazer[14586]: segfault at 0 rip 0 rsp 45004fe8 error 14 Oct 15 13:12:10 fregat kernel: stargazer[14613]: segfault at 2b4e973a0918 rip 2b4e973a0918 rsp 45004ea8 error 15 Oct 15 13:12:24 fregat kernel: stargazer[14629] general protection rip:2aaaaac53171 rsp:45004f50 error:0 Oct 15 13:30:29 fregat kernel: stargazer[14725] general protection rip:2aaaaac53171 rsp:45004f50 error:0 Я довольно долго эсперементировал с базой скуля пержде чем доблися стабильной работы СТГ и выяснил что базу лучше содавать в кодировке сравнения utf8_unicode_ci (я говорю именно о сравнении базы, а те таблици, что создает СТГ должны быть koi8r_general_ci т.е. такими какими их создает СТГ) Не знаю почему но так у меня все нормально работает птфу птфу 3-е сутки Делаею я это чере phpMyAdmin. Вопрос... а ты используешь чистую базу? Если нет то попробуй завести СТГ с чистой базой
BaRYaN Posted October 15, 2008 at 10:19 AM Author Posted October 15, 2008 at 10:19 AM У меня собсна таже проблема была и я ее решил именно тем что создал чистую базу с кодировкой сравнения utf8_unicode_ci после чего сконвертировал пользывателей в СКУЛЬ из сторе
tseytnot Posted October 15, 2008 at 10:34 AM Posted October 15, 2008 at 10:34 AM База чистая (создает старгейзер при запуске)... Щас буду экспериментировать с кодировками...
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now