Jump to content
Local
Sign in to follow this  
dummy

dell linux агрегация каналов и vlan

Recommended Posts

Добрый день

есть такая схема:

903705955_.png.bcaa8a4f1685310d3f6e0d711fbb8fb2.png

 

dell:

interface ethernet 1/g1
description "uplink"
switchport mode trunk
switchport trunk allowed vlan add 2903
exit

interface ethernet 1/g19
description "serv"
channel-group 1 mode auto
exit

interface ethernet 1/g20
description "serv"
channel-group 1 mode auto
exit

interface ethernet 1/g21
description "mikrotik to internet"
switchport mode trunk
switchport trunk allowed vlan add 2903
exit

interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan add 2903
exit

linux:

auto bond0
iface bond0 inet manual
  bond-mode 802.3ad
  bond-miimon 100
  bond-downdelay 100
  bond-updelay 100
  bond-lacp-rate slow
  bond-slaves eno1 eno2
  bond-xmit-hash-policy layer2+3
  mtu 9000

auto bond0.2903
iface bond0.2903 inet static
   address x.x.x.x
   netmask x.x.x.x
   gateway x.x.x.x
   dns-nameservers 8.8.8.8

пока был подключен один сервер - проблем не было, подключил микротик и вылезла проблема:

трафик на сервер идет и на микротик. в пакетах стоят мак и ип сервера, а принимаются и сервером и микротиком. другими словами: на сервере приход и расход совпадают, а на микроте в приход попадает и микротовский и серверный трафик, а расход только микротовский

 

на делле выявил одну проблемку

console#show bridge address-table vlan 2903

Aging time is 300 Sec

  Vlan        Mac Address       Port          Type
-------- --------------------- ---------- --------------------
2903     D4CA.ХХХХ.ХХХХ        1/g21      Dynamic
2903     D867.ХХХХ.ХХХХ        1/g1       Dynamic

а мака от сервера нет

сделал

auto bond0
iface bond0 inet static
  hwaddress 78:2b:cb:64:11:11

мак не прилетел. может еще какието настройки надо на сервере или на делле ?

прошу помощи

Edited by dummy

Share this post


Link to post
Share on other sites

Смотрите на dell и linux состояние lacp.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By WhiteBoroda
      Продам салазки для винтов в сервера
      IBM x3850 X6 x3550 x3650 M5 00E7600 2.5" SAS SATA HDD Drive Tray Caddy L38552 - 10$
      Lenovo 31050784 ThinkServer RD330 RD430 RD530 RD630 RD830 RD340 RD440 RD540 RD640 2.5" HDD Tray caddy. - 10$
      Lenovo 03T8147   ThinkServer RD450 RD650 RD550 2.5" HDD Tray caddy - 10$
      DELL 2.5" Caddy Tray For R920 R720XD R620 R630 R715 R810 R610 R430 R930 0G176J - 10$
       

    • By dmitriy.server
      Сервер в хорошем состоянии, без рельс
      2 x Intel Xeon X5504 2.00
      4 х DELL Barracuda 500 gb
      4Gb DDR3
      RAID dell e2k-ucp-61-(b)

      300 у.е.
    • By Небесный
      Ребята, помогите с настройкой мультикаста на коммутаторе dell force10 s60-44t-ac-r.
      Есть два источника мультикаста которые приходят на 2 гигабит порта и 1 потребитель.
      Все три порта находятся в своем влане. Нужно настроить, чтобы мультикаст который приходит из двух разных источников, которые подключены к двум разным портам ишел на третий порт потребителя. И этот же мультикаст не ишел больше ни на какие другие порты.
      Не могу разобраться с настройкой в силу нубства в даной сфере.
      Огромное спасибо за помощь!!!
    • By denisluk
      Продам сервер. На борту 2 диска по 250 ГБ, 24ГБ ОЗУ, 2 процессора Xeon E5504. В комплекте с салазками, дисками, корзинами и блоками питания. Состояние видно на фото. Если остались вопросы - приглашаю в личные сообщения.
       
      Ценник: 7500 грн.
       
      Фото: 
       
    • By vovanchos
      контакти 0961110031 Володимир
       
      Продам ноутбук Thinkpad EDGE 550
      процесор core i3 4005u 2*1,7
      ram 1*4 gb
      hdd 320 gb
      батарея 15% зносу тримає близько 3х годин
      встановлено віндовс 10 про
      ціна 5300 грн

       
      hp stream 13 blue
      celeron N2840 2*2,16
      ram 2 gb
      ssd 32 gb
      батарея 90 циклів із 1000 тримає більше 5 годин залежно від навантаження
      ціна 3200 грн
       

       
      ноутбук трансформер Impression
      x5-z8300 4*1.44
      ram 2 gb
      ssd 32 gb
      11 дюймів full hd, touch, ips
      ціна 3200 грн
       

       

×