Jump to content

aggregator-group mode lacp BDCOM S5612 и bonding linux


Recommended Posts

Добрый день.
 

Имеем коммутатор BDCOM(tm) S5612 Software, Version 2.2.0B Build 37303

пытались подключить по лагу с линукс машиной, на которой настроен бондинг.
До этого машина работала на стенде по двум 10Г портам с коммутатором FORCE10 и дилинк. Было все ок.
Нужно было переключить машину в этот бдком.

Настройки на бдкоме:

enable
config
interface Port-aggregator6

description 20G_LACP

no spanning-tree

switchport trunk vlan-allowed 2,1000-1999

switchport mode trunk

exit

interface tgigaEthernet 1/11

no spanning-tree

aggregator-group 6 mode lacp

switchport trunk vlan-allowed 2,1000-1999

switchport mode trunk

exit
interface tgigaEthernet 1/10

no spanning-tree

aggregator-group 6 mode lacp

switchport trunk vlan-allowed 2,1000-1999

switchport mode trunk

exit


!
aggregator-group load-balance both-ip
!

 

Переключили физически в порты бдкома - порты поднимаются, а lacp down - не поднимается.

tg1/10  with_eth1           up        Trunk(1)    full     10000Mb  10Giga-FX        
tg1/11  with_eth2           up        Trunk(1)    full     10000Mb  10Giga-FX        
p6     20G_LACP        down        Trunk(1)    

 

Прошивка была 2.2.0B 37303
обновляли -> 2.2.0C 42666 -> 2.2.0C 50891 -> и на последнюю 2.2.0C 69953


 

Добавление вилана 1 помогло - заработало:
interface Port-aggregator6
switchport trunk vlan-allowed add 1


 

Хотя между коммутаторов работает без 1 (дефаулт) влана.

Может кому пригодиться, намучались немного :)
 

# cat interfaces
auto lo
iface lo inet loopback

auto eth1
iface eth1 inet manual
    bond-master bond0
    up ifconfig $IFACE mtu 9000
    post-down ifconfig $IFACE down

auto eth2
iface eth2 inet manual
    bond-master bond0
    up ifconfig $IFACE mtu 9000
    post-down ifconfig $IFACE down

auto bond0
iface bond0 inet manual
    bond-mode 802.3ad
    bond-miimon 100
    bond-downdelay 200
    bond-updelay 200
    bond-lacp-rate 1
    bond-xmit-hash-policy 1
    bond-slaves eth1 eth2
    up ifconfig $IFACE mtu 9000

auto bond0.2
iface bond0.2 inet static
    address 192.168.200.200
    netmask 255.255.0.0
    gateway 192.168.200.120
    dns-nameservers 8.8.8.8
    vlan_raw_device bond0




cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer3+4 (1)

Edited by fox_fan
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Jumpjet
      Посоветуйте РоЕ свич для домашнего использования, цена/качество, из требований - гигабитные порты (16-24, если не все, то большинство), РоЕ af/at и поддержка LACP
      Что можно посмотреть из такого?
    • By Tormato
      Приветствую,
       
      Ребята такое дело есть nat сервер на базе линукса и все вроде бы правильно с таким вот конфигом:
      flush ruleset table ip filter { chain input { type filter hook input priority 0; policy accept; ct state established accept iif "vlan4" counter drop iif "vlan5" counter drop } #flowtable fastnat { # hook ingress priority 0 # devices = { vlan4, vlan5 } #} #chain forward { # type filter hook forward priority 0; policy accept; # ip protocol { tcp , udp } flow offload @fastnat; #} } table ip nat { chain post { type nat hook postrouting priority 100; policy accept; ip saddr 10.0.0.0/8 oif "vlan5" snat to 105.46.1.1-105.46.1.125 persistent } chain pre { type nat hook prerouting priority -100; policy accept; } } Плюс подкручены стандартные опции для самого нат сервера через sysctl.
       
      Обратите внимание на закомменченную порцию с flow offload, с ней при 12G нат трафика неаблюдаются довольно сушественные потери на входе интерфейса:

       
      Если закомментить часть отвечающую за flow offload, то нагрузка на процессот немного вырастает но потери исчезают аж пока трафика не станет 19G при загрузке CPU 85%. Да и то при такой нагрузке потери менее значительные:

       
      Функция flow offload хороша и позволяет сэкономить на нагрузке CPU, но почему оно так сильно влияет на потери трафика или нужно настроить что либо еще?
       
    • By NETOS
      Доброго здоровья!
      Товарищи, подскажите может кто сталкивался с такой проблемой. Периодически происходит отвал LACP между сервером FreeBSD 12.1 и коммутатором D-Link DGS-3120-24TC
      Когда происходит отвал, пропадает трафик на интерфейсах и в meesages пишет:

       
       
      Настройки на коммутаторе:

       
       
      Настройки на FreeBSD:
       

       

       
       
    • By Darth Vader2
      Главные герои сюжета:
       
      1. WS-C3750G-24TS-1U  , SW Version 12.2(25)SED1
       
      2.
      VERSION : MA5600V800R013C00
      PATCH   : SPC101
      PRODUCT : MA5608T
       
      Задача в заголовке - LACP между CISCO и HUAWEI. Пока результат нулевой. Либо есть линк только со стороны  HUAWEI, либо есть линк с обеих сторон, на CISCO собирается etherchannel но обмена между устройствами нет. Ранее ни разу с подобной проблемой не сталкивался, взлетало сразу. А тут просидел несколько часов, перепробовал все возможные варианты - нет результата. Отдельно проверил каждый порт - всё исправно и работает, собрать LACP не получается.
       
      При этом LACP между CISCO и DLink, HUAWEI и DLINK взлетает без проблем. Хоть ставь между ними DLINK и запускай таким паровозиком. Требуется помощь сообщества, может кто сталкивался с подобной проблемой. Варианты настроек, наверное, предлагать не надо, всё пробовал - не работает. Нужна идейная мысль, к примеру замена прошивок на 100% рабочие и проверенные лично Вами в работе. Предположения и догадки тоже приветствуются.
       
      Спасибо.
    • By nedoinet
      Собственно сабж. Аплинк 10g, транзит во второй 10g и lacp из 4х портов в линуксовый такзик. Изначально lacp был на 3 порта. При трафике 1.6Г получаем возрастание latency, деградацию сервиса и упор в 1.8Г. После расширения лацпа до 4х портов ситуация не поменялась абсолютно. По 10г порту вопросов нет, льет трафик без проблем. Возможно у кого есть опыт с подобным мастодонтом. Или это пресловутая проблема маленького кеша? На сколько удалось выкурить - там 768кб на группу из 12 портов с непонятным разделением по портам.
       
×
×
  • Create New...