nightfly Posted April 23, 2013 at 11:57 AM Posted April 23, 2013 at 11:57 AM блаблаюла fatal error max execute time 30 sec Это последствия наличия .lock файла. Их быть не должно. Просто удалите их. По версии. Стоит последняя, то я указывал на какие грешил. Они грешны, за что давно отлучены от лона церкви не поддерживаются.
neironus Posted April 24, 2013 at 07:28 AM Posted April 24, 2013 at 07:28 AM блаблаюла fatal error max execute time 30 sec Это последствия наличия .lock файла. Их быть не должно. Просто удалите их. >По версии. Стоит последняя, то я указывал на какие грешил. Они грешны, за что давно отлучены от лона церкви не поддерживаются. решил начать с нуля. снес все нафик и поставил по новой - результат порадовал. теперь осталось рахобратся с отработкой шейпера. сообственно вопрос: скрипт shaper.sh запускается только при запуске стг или при обнаружении что от юзера пошел траффик? п.с. использую маскарад на eth0, при это в скрипте указан ifup=eth0 ifdown=eth1 табли маркеруют пакеты: 88225 119M MARK all -- * * 0.0.0.0/0 172.16.11.32 MARK set 0x79 78159 22M MARK all -- * * 172.16.11.32 0.0.0.0/0 MARK set 0x1019 но увы оверлимитов не наблюдаю [root@nas stargazer]# tc -s qdisc show qdisc pfifo_fast 0: dev eth0 root refcnt 2 bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1 Sent 98773885 bytes 193518 pkt (dropped 0, overlimits 0 requeues 0) rate 0bit 0pps backlog 0b 0p requeues 0 qdisc pfifo_fast 0: dev eth1 root refcnt 2 bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1 Sent 213953914 bytes 693650 pkt (dropped 0, overlimits 0 requeues 0) rate 0bit 0pps backlog 0b 0p requeues 0 куда подскажите копать?
DemonidZe Posted April 25, 2013 at 08:27 PM Posted April 25, 2013 at 08:27 PM (edited) блаблаюла fatal error max execute time 30 sec Это последствия наличия .lock файла. Их быть не должно. Просто удалите их. >>По версии. Стоит последняя, то я указывал на какие гре/p>ил. lockquote> Они грешны, за что давно отлучены от лона церкви не поддерживаются. решил начать с нуля. снес все нафик и поставил по новой - результат порадовал. теперь осталось рахобратся с отработкой шейпера. сообственно вопрос: скрипт shaper.sh запускается только при запуске стг или при обнаружении что от юзера пошел траффик? п.с. использую маскарад на eth0, при это в скрипте указан ifup=eth0 ifdown=eth1 табли маркеруют пакеты: 88225 119M MARK all -- * * 0.0.0.0/0 172.16.11.32 MARK set 0x79 78159 22M MARK all -- * * 172.16.11.32 0.0.0.0/0 MARK set 0x1019 но увы оверлимитов не наблюдаю [root@nas stargazer]# tc -s qdisc show qdisc pfifo_fast 0: dev eth0 root refcnt 2 bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1 Sent 98773885 bytes 193518 pkt (dropped 0, overlimits 0 requeues 0) rate 0bit 0pps backlog 0b 0p requeues 0 qdisc pfifo_fast 0: dev eth1 root refcnt 2 bands 3 priomap 1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1 Sent 213953914 bytes 693650 pkt (dropped 0, overlimits 0 requeues 0) rate 0bit 0pps backlog 0b 0p requeues 0 куда подскажите копать? скрипт сш запускается когда вы его запустите а вообще до запуска правил шейпера а начальный скрипт у вас как выглядит примерно так? $IPT -t mangle --flush $tc qdisc add dev $IFDOWN root handle 1: htb r2q 300 $tc class add dev $IFDOWN parent 1: classid 1:1 htb rate $SPEEDDOWN ceil $SPEEDDOWN и также на up интерфейс. и вы всем даете одну скорость? судя по тому что у вас весь трафик маркеруется под одни марки Edited April 25, 2013 at 08:28 PM by DemonidZe
sirko.n Posted May 13, 2013 at 05:35 PM Author Posted May 13, 2013 at 05:35 PM Под шестую centos наковырял утилитку SC. Она же шейпит она же в случае "минусов" не пускает в инет. Поправил онконект и ондисконект вроде все трудится. ИП и скорость для правил беру со стандартного GetSpeed. В iptables только два правила на форвард и собсно НАТ.
sirko.n Posted May 13, 2013 at 05:46 PM Author Posted May 13, 2013 at 05:46 PM (edited) Вот подметил еще какую штуку. Существует порядка 7ми разных пакетов. Самый популярный допустим 100грн. Следующий за ним допустим 150грн. Так вот в разделе деньги у соток ожидаемый платеж 100грн и у полторасоток тоже 100грн. Снимает со счета у полторасоток тоже 100грн. остальное остается на балансе. При этом все остальные пакеты все как должно быть. Подразумеваю что можно решить созданием "похожего пакета" и перебросом всех абонов на него, но хотелось бы понять в чем бок? Edited May 13, 2013 at 05:50 PM by sirko.n
sirko.n Posted May 13, 2013 at 05:52 PM Author Posted May 13, 2013 at 05:52 PM Вот подметил еще какую штуку. Существует порядка 7ми разных пакетов. Самый популярный допустим 100грн. Следующий за ним допустим 150грн. Так вот в разделе деньги у соток ожидаемый платеж 100грн и у полторасоток тоже 100грн. Снимает со счета у полторасоток тоже 100грн. остальное остается на балансе. При этом все остальные пакеты все как должно быть. Подразумеваю что можно решить созданием "похожего пакета" и перебросом всех абонов на него, но хотелось бы понять в чем бок? Капец! Вопрос снимается, ссори за внимание. Некто, кто имеет право на редактирование пакетов, сменило цену. Наказан.
DemonidZe Posted May 15, 2013 at 10:15 AM Posted May 15, 2013 at 10:15 AM Под шестую centos наковырял утилитку SC. Она же шейпит она же в случае "минусов" не пускает в инет. Поправил онконект и ондисконект вроде все трудится. ИП и скорость для правил беру со стандартного GetSpeed. В iptables только два правила на форвард и собсно НАТ. а можно по подробней про SC ?
DarkSpider Posted May 15, 2013 at 10:38 AM Posted May 15, 2013 at 10:38 AM а можно по подробней про SC ? Можно. Это утилита, написанная на perl, создающая готовые классы и фильтры с использованием iptables/ipset или U32 на основе хешей.
indorr Posted August 9, 2021 at 01:17 PM Posted August 9, 2021 at 01:17 PM В 12.11.2012 в 01:53, sirko.n сказал: Криво регается юзер. После "давайте зарегаем" бросает на стандартную страничку но там кроме адреса ничего нет. Делаю перенос на новую систему. Стоит: debian9, Stargazer 2.408, php5.6. Такая же проблема, и тариф не меняется и денег добавить не получается. stargazer стартует без ошибок: 2021-08-09 15:26:37 -- Stg v. 2.409 2021-08-09 15:26:37 -- Message queue created successfully. msgKey=5555 msgID=163840 2021-08-09 15:26:37 -- Timer thread started successfully. 2021-08-09 15:26:37 -- [store_mysql] MYSQL_STORE: Current DB schema version: 2 2021-08-09 15:26:37 -- Storage plugin: mysql_store v.0.67. Loading successfull. 2021-08-09 15:26:38 -- Users started successfully. 2021-08-09 15:26:38 -- Traffcounter started successfully. 2021-08-09 15:26:38 -- Module 'Remote script v 0.3' started successfully. 2021-08-09 15:26:38 -- Module 'Stargazer RPC v. 0.2' started successfully. 2021-08-09 15:26:38 -- Module 'Stg Configurator v. 2.0' started successfully. 2021-08-09 15:26:38 -- Module 'Always Online authorizator v.1.0' started successfully. 2021-08-09 15:26:38 -- Module 'InetAccess authorization plugin v.1.4' started successfully. 2021-08-09 15:26:38 -- Module 'cap_nf v. 0.4' started successfully. 2021-08-09 15:26:38 -- Stg started successfully. 2021-08-09 15:26:38 -- +++++++++++++++++++++++++++++++++++++++++++++ В 22.11.2012 в 20:10, nightfly сказал: Для начала давайте попробуем отдебужить по наивному. Тыкаете "SQL консоль" -> "PHP консоль" и исполняете там следующее: $login_q="SELECT `login` from `users` WHERE `Cash`>0"; $randomlogin=simple_query($login_q); if (!empty($randomlogin)) { $billing->resetuser($randomlogin['login']); } else { deb('nousers'); } После чего внимательно смотрим в /var/log/stargazer.log при выполнении запрос висит, в логах пусто. Подскажите в чем моет быть проблема? Заметил если втрой раз запустить stargazer, то начинает работать: 2021-08-09 16:15:07 -- Stg v. 2.409 2021-08-09 16:15:07 -- Message queue created successfully. msgKey=5555 msgID=196608 2021-08-09 16:15:07 -- Admin 'admin', 127.0.0.1: User 'anul_Lesnaya17ap0_ezz3': 'disabled' parameter changed from '0' to '1'. 2021-08-09 16:15:07 -- Timer thread started successfully. 2021-08-09 16:15:07 -- [store_mysql] MYSQL_STORE: Current DB schema version: 2 2021-08-09 16:15:07 -- Storage plugin: mysql_store v.0.67. Loading successfull. 2021-08-09 16:15:07 -- [conf_sg] Failed to read data from 127.0.0.1:59146. Unexpected EOF. 2021-08-09 16:15:07 -- Admin 'admin', 127.0.0.1: User 'anul_Lesnaya17ap0_ezz3': 'disabled' parameter changed from '1' to '1'. 2021-08-09 16:15:07 -- Admin 'admin', 127.0.0.1: User 'an17ap1_q52k': 'disabled' parameter changed from '0' to '1'. 2021-08-09 16:15:07 -- Admin 'admin', 127.0.0.1: User 'anul_Lesnaya17ap0_ezz3': 'disabled' parameter changed from '1' to '0'. 2021-08-09 16:15:07 -- Admin 'admin', 127.0.0.1: User 'anul_Lesnaya17ap0_ezz3': 'disabled' parameter changed from '0' to '0'. 2021-08-09 16:15:07 -- Admin 'admin', 127.0.0.1: User 'an17ap1_q52k': 'disabled' parameter changed from '1' to '0'. 2021-08-09 16:15:09 -- Users started successfully. 2021-08-09 16:15:09 -- Traffcounter started successfully. 2021-08-09 16:15:09 -- Module 'Remote script v 0.3' started successfully. 2021-08-09 16:15:09 -- [conf_rpc] Cannot bind the socket: Address already in use 2021-08-09 16:15:09 -- Failed to start module 'Stargazer RPC v. 0.2': 'Failed to bind socket' 2021-08-09 16:15:09 -- [conf_sg] Cannot bind listen socket: 'Address already in use'. 2021-08-09 16:15:09 -- Failed to start module 'Stg Configurator v. 2.0': 'Cannot bind listen socket: 'Address already in use'.' 2021-08-09 16:15:09 -- Module 'Always Online authorizator v.1.0' started successfully. 2021-08-09 16:15:09 -- [auth_ia] Cannot bind the socket: Address already in use 2021-08-09 16:15:09 -- Failed to start module 'InetAccess authorization plugin v.1.4': 'AUTH_IA: Bind failed.' 2021-08-09 16:15:09 -- [cap_nf] Cannot bind UDP socket: Address already in use 2021-08-09 16:15:09 -- Failed to start module 'cap_nf v. 0.4': 'Error binding UDP socket' 2021-08-09 16:15:09 -- Stg started successfully. 2021-08-09 16:15:09 -- +++++++++++++++++++++++++++++++++++++++++++++ после этого тарифы меняються, пользователя можно отключить и т.д.
Recommended Posts
Create an account or sign in to comment
You need to be a member in order to leave a comment
Create an account
Sign up for a new account in our community. It's easy!
Register a new accountSign in
Already have an account? Sign in here.
Sign In Now