Jump to content
Local
Myr4ik

Проброс unicast IPTV из сети одного оператора в сеть другого поверх интернета

Recommended Posts

Здравствуйте, ребята!

Есть желание пробросить unicast IPTV из сети одного оператора в сеть другого поверх интернета без туннелей.

Обычно делаю следующую настройку в NAT устройства (mikrotik), которое подключено к оператору, что вещает IPTV:

 

chain=dstnat action=dst-nat to-addresses="IP UDP-to-HTTP сервера провайдера" to-ports=4022 protocol=tcp in-interface=ether1 dst-port=4321

ether1 - линк с оператором, в который приходит IPTV и интернет, и откуда, разумеется, IPTV уходит во вне с порта 4321.

UDP-to-HTTP сервер оператора вещает с "IP UDP-to-HTTP сервера провайдера" и порта 4022.

 

 

После вышеописанного, модифицирую соответствующий плэйлист с каналами на принимающей стороне и вуяля - все работает.

Но недавно столкнулся с оператором, с которым этот финт не прокатил...

 

Суть проблемы, как мне кажется, в следующем:
Оператор, с которым, как я поначалу подумал не заработало правило NAT (а оно заработало вполне корректно), использует для вещания IPTV ПО Astra, которому не нравится в запросе от, например VLC, в поле Host, указание IP-адреса, а не FQDN.
Изображение недуачной попытки посмотреть ТВ:

 

unsuccess.png.8930afcc40c59861bdfc65846eafcdca.png

 

 

А вот успешный запрос с FQDN, после которого сразу начинается передача-прием потока:

 

successpng.png.6546649c5e91fa5ea38aa375167bde31.png

 

Вопрос - есть ли способ модифицировать правило(а) на mikrotik (без создания DNS-записей на принимающей стороне), чтобы стало возможным просматривать IPTV вне сети оператора с Astr`ой? Правильно ли я локализовал "проблему"?

 

Спасибо.

Share this post


Link to post
Share on other sites

Все сводится к вопросу: " Как обмануть Астру с помощью только микротика и без манипуляций с DNS?".

Share this post


Link to post
Share on other sites
3 часа назад, mr.Scamp сказал:

Haproxy?

Не ясна схема с использованием прокси. Могли бы Вы вкратце расписать логику?

Share this post


Link to post
Share on other sites
6 часов назад, mr.Scamp сказал:

Haproxy?

3 часа назад, Myr4ik сказал:

Не ясна схема с использованием прокси. Могли бы Вы вкратце расписать логику?

 

Ага, вероятно имелся ввиду обратный прокси. Гуглю, спасибо!

Share this post


Link to post
Share on other sites

Что-то я запутался. Не в службу, а в дружбу, прошу в двух словах описать схему, как должен работать обратный прокси при моей схеме и применим ли он вообще?

"сервер IPTV <> интернет <> роутер 1 <> интернет <> роутер 2 <> клиент"

Повторюсь, проблема в том, что обычного правила с dstnat на роутере 1 недостаточно, так как сервер IPTV ожидает в HTTP-запросе, в поле host, исключительно свое доменное имя, а не свой ip-адрес, который получается в результате отработки правила NAT.

 

Edited by Myr4ik

Share this post


Link to post
Share on other sites

Это херня затея. Если вкратце. 

Share this post


Link to post
Share on other sites
В 02.06.2018 в 04:56, loki сказал:

Это херня затея. Если вкратце. 

Таки да. В итоге поднял eoip, загнал туда мультикаст и горя не знаю.

  • Like 1

Share this post


Link to post
Share on other sites

 

В 05.06.2018 в 21:17, Myr4ik сказал:

Таки да. В итоге поднял eoip, загнал туда мультикаст и горя не знаю.

А можно по подробнее ? А то имею желание ретранслировать IPTV от провайдера во внешку.

 

Share this post


Link to post
Share on other sites
1 час назад, Ruskat сказал:

 

А можно по подробнее ? А то имею желание ретранслировать IPTV от провайдера во внешку.

 

IPTV_EOIP.png.f0acc17fbdefb3f90f049aee94b58fab.png

Share this post


Link to post
Share on other sites

Спасибо, но думаю микротик такую графику не поймет. Мне бы в примерах.

Вот я зашел по пути /webfig/#Interfaces.EoIP_Tunnel...

Что дальше?

У меня - интернет от провайдера - микротик (один) - домашняя сеть.

Share this post


Link to post
Share on other sites
3 часа назад, Ruskat сказал:

Спасибо, но думаю микротик такую графику не поймет. Мне бы в примерах.

Вот я зашел по пути /webfig/#Interfaces.EoIP_Tunnel...

Что дальше?

У меня - интернет от провайдера - микротик (один) - домашняя сеть.

Может быть Вам не нужен EoIP? Возможно, у Вашего провайдера есть UDP-to-HTTP proxy, чуть более дружелюбный чем в моем примере? Если есть, то схема несколько упростится (очень).

Если не знаете наверняка, есть UDP-to-HTTP proxy или нет, то уточните в поддержке провайдера.

 

P. S. Настройка EoIP с картинками - http://mikrotik.vetriks.ru/wiki/VPN:EoIP

 

Edited by Myr4ik

Share this post


Link to post
Share on other sites
В 13.11.2018 в 14:04, Myr4ik сказал:

... Возможно, у Вашего провайдера есть UDP-to-HTTP proxy, чуть более дружелюбный чем в моем примере? Если есть, то схема несколько упростится (очень).

Есть... Пример: 

//Провайдер давал:
http://78.46.93.39:4022/udp/239.50.11.26:5004
//TvBuzzer даёт:
udp://@239.50.11.26:5004

Но вот с TvBuzzer я не могу смотреть. То хотел бы такой проксяк или наподобии сделать, на Astra, или на чем там лучше. Если на махтотике проще, то на нем, но у Астры на каждый канал вроде сводка есть.

Еще WinServer есть. Может на нем лучше ?

Edited by Ruskat

Share this post


Link to post
Share on other sites

Mikrotik не умеет быть udp-to-http proxy. Я для этих целей использовал что-нибудь на openwrt, но так как у Вас есть WinServer, то подымите udp-to-http proxy на нем, а потом пробросьте его порт во внешку и измените плейлист соответсвующим образом. IPшка у Вас постоянная? Если нет, то воспользуйтесь каким-нибудь ddns сервисом (noip, he и т. п.), чтобы плейлист постоянно не менять. Если IPшка серая, то без тоннеля уже не обойтись ("голый" EoIP уже не сможет работать).

 

P. S. udp-to-http proxy для win - http://borpas.info/download/UdpProxy.exe

Share this post


Link to post
Share on other sites
В 17.11.2018 в 16:41, Myr4ik сказал:

Mikrotik не умеет быть udp-to-http proxy. Я для этих целей использовал что-нибудь на openwrt, но так как у Вас есть WinServer, то подымите udp-to-http proxy на нем, а потом пробросьте его порт во внешку и измените плейлист соответсвующим образом. IPшка у Вас постоянная? Если нет, то воспользуйтесь каким-нибудь ddns сервисом (noip, he и т. п.), чтобы плейлист постоянно не менять. Если IPшка серая, то без тоннеля уже не обойтись ("голый" EoIP уже не сможет работать).

 

P. S. udp-to-http proxy для win - http://borpas.info/download/UdpProxy.exe

ІР Постоянный, вроде белый (31......) Попробую. спасибо....

Увы... Я уточню, что я не могу получить канал, от ТВ-Баззера, к примеру

 udp://@239.50.11.26:5004

Смотреть я его могу только через существующий прокси: 

http://78.46.93.39:4022/udp/239.50.11.26:5004

Пока единственным рабочим решением является IceCast.

 

Edited by Ruskat

Share this post


Link to post
Share on other sites

Есть софт для гарантированной доставки потоков, есть CDN-ы специальные. А через ж#пу с костылями оно, наверное, легче.

Share this post


Link to post
Share on other sites
В 22.11.2018 в 08:25, loki сказал:

Есть софт для гарантированной доставки потоков, есть CDN-ы специальные. А через ж#пу с костылями оно, наверное, легче.

Пожалуйста, назовите "софт для гарантированной доставки потоков". Назовите "CDN-ы специальные". Если вы их знаете, конечно.

Share this post


Link to post
Share on other sites
В 03.12.2018 в 03:17, Ruskat сказал:

Пожалуйста, назовите "софт для гарантированной доставки потоков". Назовите "CDN-ы специальные". Если вы их знаете, конечно.

Ой, я забыл. В гугле поищите. Если, конечно,вы можете им пользоваться. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vegas.firestorm
      Добрый день!
      решил поднять на своем Микротике PPTP Всё делал по этой инструкции - https://howitmake.ru/blog/waildhand/176.html
       
      Разве что в правиле на файрволе для порта 1723 указал In. Interface List - WAN
       
      К ВПН-у конектится, но не видит никаких ресурсов внутри сети. Можете подсказать, что нужно ещё сделать, чтобы пользователь, который конектится по ВПН, видел всё внутри сети?
       
       
      Конфиг роутера:
       
      /interface bridge
      add arp=proxy-arp name=bridge1
      /interface pptp-server
      add name=pptp-in1 user=""
      /interface list
      add name=WAN
      add name=LAN
      /interface wireless security-profiles
      set [ find default=yes ] supplicant-identity=MikroTik
      /ip pool
      add name=dhcp ranges=192.168.77.10-192.168.77.154
      add name=vpn ranges=192.168.77.200-192.168.77.250
      /ip dhcp-server
      add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
      /interface bridge port
      add bridge=bridge1 interface=ether2
      add bridge=bridge1 interface=ether3
      add bridge=bridge1 interface=ether4
      add bridge=bridge1 interface=ether5
      add bridge=bridge1 interface=ether6
      add bridge=bridge1 interface=ether7
      add bridge=bridge1 interface=ether8
      add bridge=bridge1 interface=ether9
      add bridge=bridge1 interface=ether10
      add bridge=bridge1 interface=ether11
      add bridge=bridge1 interface=ether12
      /interface l2tp-server server
      set enabled=yes ipsec-secret=(IPSECSecret) use-ipsec=yes
      /interface list member
      add interface=ether1 list=WAN
      add interface=bridge1 list=LAN
      /interface pptp-server server
      set enabled=yes
      /interface sstp-server server
      set default-profile=default-encryption enabled=yes
      /ip address
      add address=111.111.55.102/24 comment=defconf interface=ether1 network=\
          111.111.55.0
      add address=192.168.77.1/24 interface=ether2 network=192.168.77.0
      /ip cloud
      set ddns-enabled=yes ddns-update-interval=1h
      /ip dhcp-client
      add dhcp-options=hostname,clientid interface=ether1
      add dhcp-options=hostname,clientid interface=ether1
      /ip dhcp-server network
      add address=192.168.77.0/24 gateway=192.168.77.1 netmask=24
      /ip dns
      set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4,9.9.9.9,1.1.1.1
      /ip firewall filter
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      /ip firewall nat
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      /ip route
      add distance=1 gateway=111.111.55.254
      add distance=1 gateway=111.111.55.254
      /lcd
      set backlight-timeout=2m
      /lcd pin
      set pin-number=1111
      /ppp secret
      add local-address=192.168.77.1 name=vpn password=vpnvpn profile=\
          default-encryption remote-address=192.168.77.200 service=pptp
      /system clock
      set time-zone-name=Europe/Kiev
    • By andrey-r
      Доброго времени суток, камрады
       
      Нужна помощь админа с опытом настройки роутеров микротик routeros
      Разовые заказы. Появилась потребность - поставил задачи, сделали, заплатил. Раз в 2-3 месяца.
       
      В частности сейчас нужно на один порт (или на сеть) дать гарантированный канал не менее 20мбит
      И на остальные порты (сети) дать не более 80мбит.
      Чтобы вип абонент имел гарантированный канал при 100% нагрузке канала.
       
      Кто поможет?
      Связь тут или Вайбер/телеграм по номеру 0937672229
       
    • By Omega TV
      Добрый день, уважаемые участники Локала и интернет-провайдеры
      Проект интернет ТВ "Омега ТВ" практически готов к запуску
      Осталось нам немного его потестировать
      Для полного технологического счастья не хватает совсем чуть-чуть.... отключить аналог, например )))

      Приглашаем провайдеров принять участие в тестировании нашей услуги
      Омега ТВ - 3 пакета, 160 телеканалов, 42 в HD ( включая телеканалы 4х медиагрупп )
      Территория распространения - Украина, со всеми правообладателями заключены договора. Работать сервис будет как в сети провайдера, так и за е е пределами.
      В данный момент доступны - Android Mobile, Android stb / Android Mobile, Web
      На этапе добавления в стор или финального тестирования - Smart TV Samsung, Smart TV LG, IOS, Stalker Portal

      Для получения полного доступа к услуге, необходимо заполнить форму - https://tinyurl.com/yc9afv9t и зарегистрироваться в системе "Омега ТВ"

      Самостоятельное тестирование ограниченного списка каналов :
      Omega TV для мобильных телефонов - https://tinyurl.com/y9e6ak26
      Omega TV для приставок на Android - https://tinyurl.com/y9wv8asd

      По коммерческим вопросам - писать на форуме.
      omega_tv_channels_4pack.xlsx
    • By Spiritok42
      Компанія Gazik запрошує до співпраці !
      великий асортимент товару  доступні ціни гарантія 1 рік !!! швидка доставка придбати обладнання з ПДВ! привезти обладнання під замовлення!  
                  ТОП продаж!!!
      MikroTik RB941-2nD                                19,99$
      MikroTik RBD52G-5HacD2HnD-TC         63$  
      MikroTik RB2011UiAS-2HnD-IN              113,85$ 
      MikroTik RBcapGI-5ACD2nD                   61$ 
      Точка доступу UBNT UAP-AC-LITE        85,56$
      Точка доступу UBNT UAP-AC-LR          105,22$   
      Контроллер UBNT UC-CK                      81,85$  
      Точка доступу UBNT LBE-M5-23           47$  
      Точка доступу UBNT PBE-M5-400         86,65$ 
       
      Наш прайс: GAZIK PRICE local.xlsx
       
      За детальною інформаціє звертайтеся:
      - tel. viber: +38 098 886 63 06
      - skype: live:spiritok42

    • By golohvostiy
      RB433GL - 800 грн
      RB800 - 2000 грн
      R52Hn - 500 грн (2 шт)
      R52n-M - 600 грн
      NetMetal 5 (RB922UAGS-5HPacD-NM) - 2300 грн
      Под роутерборды есть герметичные корпуса - 400 грн (2 шт)
      SXT Lite5 (RBSXT5nDr2) - отдам даром (питание подаётся, он включается, но сеть не видит)
       
×