Jump to content
Local
tiratore

huawei s2300 multicast igmp snooping хелп плз

Recommended Posts

Имеется huawei s2326, в него постоянно наливается n групп мультикаста в влане 100. Нужно чтобы одна из групп подмешивалась в абонентский влан 20 по запросу.

Делаю как написано тут http://support.huawei.com/hedex/pages/EDOC1000023737DEC02204/07/EDOC1000023737DEC02204/07/resources/dc/dc_cfg_mvlan_0005.html

Не работает. В ваершарке вижу пакеты membership query general от источника и membership report group 239.100.10.1 от компа на котором запущен влц и больше ничего полезного.

Share this post


Link to post
Share on other sites
 vlan batch 195 555
#
igmp-snooping enable
#
dhcp enable
dhcp snooping enable
dhcp option82 circuit-id format extend
#
 undo http server enable
 http server load s2300ei-v100r006c05.001.web.zip
#
 drop illegal-mac alarm
#
observe-port 1 interface GigabitEthernet0/0/2
#
acl number 3000
 rule 5 permit igmp
#
traffic classifier mvlan operator and
 if-match vlan-id 555
 if-match acl 3000
traffic classifier uvlan operator and
 if-match vlan-id 195
 if-match acl 3000
#
traffic behavior mvlan
 permit
traffic behavior uvlan
 deny
#
traffic policy igmp
 classifier mvlan behavior mvlan
 classifier uvlan behavior uvlan
#
vlan 195
 igmp-snooping enable
vlan 555
 igmp-snooping enable
 igmp-snooping querier enable
 multicast-vlan enable
 multicast-vlan user-vlan 195
 multicast-vlan send-query prune-source-port
#
interface Ethernet0/0/1
 description TEST
 port link-type access
 port default vlan 195
 loopback-detect enable
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 195 555
 loopback-detect enable
 traffic-policy igmp inbound
 dhcp snooping trusted
 port media type fiber
     undo negotiation auto
 combo-port auto
 port-mirroring to observe-port 1 inbound
 port-mirroring to observe-port 1 outbound

 

Share this post


Link to post
Share on other sites
5 часов назад, tiratore сказал:

У кого-нибудь вообще работает igmp-snooping?

Работает.

 

Share this post


Link to post
Share on other sites
15 часов назад, loki сказал:

Работает.

 

У меня теперь тоже работает, спс

Edited by tiratore

Share this post


Link to post
Share on other sites
9 минут назад, tiratore сказал:

У меня теперь тоже работает, спс

Так а что сделал?

Share this post


Link to post
Share on other sites
34 минуты назад, tiratore сказал:

У меня теперь тоже работает, спс

Пожалуйста))

Share this post


Link to post
Share on other sites
В 03.08.2018 в 15:56, Kiano сказал:

Так а что сделал?

Имеем следующее, мультки сыпятся постоянно в влане 555, 78 групп от 239.200.0.1 до 239.200.0.78. В качестве абон влана, выступает влан по умолчанию с ид 1. Все порты в этом влане без тега. Включаем igmp-snooping глобально и в 1 и 555 вланах, в 555 накидываем

multicast-vlan enable
multicast-vlan user-vlan 1

Можно еще igmp-snooping querier enable чтоб свитч опрашивал кто и какие группы еще смотрит и  igmp-snooping prompt-leave для быстрого покидания групп.

После переводим абон порты в hybrid и вносим влан 555 без тега, влан 1 который я использую как абонентский все еще висит там по умолчанию.

На аплинк накидываем 555 в теге.
В итоге конфиг выглядит так

 vlan batch 555
#
igmp-snooping enable
#
 undo http server enable
 undo http secure-server enable
#
vlan 1
 igmp-snooping enable
vlan 555
 igmp-snooping enable
 igmp-snooping query-interval 5
 igmp-snooping max-response-time 25
 igmp-snooping prompt-leave
 igmp-snooping querier enable
 multicast-vlan enable
 multicast-vlan user-vlan 1
#
interface Vlanif1
 ip address 10.10.13.5 255.255.255.128
#
interface Ethernet0/0/1
 port hybrid untagged vlan 555
#
interface Ethernet0/0/2
 port hybrid untagged vlan 555
#
interface Ethernet0/0/3
 port hybrid untagged vlan 555
#
interface Ethernet0/0/4
 port hybrid untagged vlan 555
#
interface GigabitEthernet0/0/2
 port hybrid tagged vlan 555
 l2-multicast static-group group-address 239.200.0.1 to 239.200.0.255 vlan 555

dis igmp-snooping port-info
 -----------------------------------------------------------------------
                     (Source, Group)  Port                          Flag
  Flag: S:Static     D:Dynamic     M: Ssm-mapping
 -----------------------------------------------------------------------
 VLAN 1, 25 Entry(s)
                   (*, 239.200.0.16)  Eth0/0/9                      -D-
                                                1 port(s)
                   (*, 239.200.0.17)  Eth0/0/10                     -D-
                                                1 port(s)
                   (*, 239.200.0.18)  Eth0/0/11                     -D-
                                                1 port(s)
                   (*, 239.200.0.19)  Eth0/0/12                     -D-
                                                1 port(s)
                   (*, 239.200.0.20)  Eth0/0/13                     -D-
                                                1 port(s)
                   (*, 239.200.0.21)  Eth0/0/14                     -D-
                                                1 port(s)
                   (*, 239.200.0.22)  Eth0/0/16                     -D-
                                                1 port(s)
                   (*, 239.200.0.23)  Eth0/0/15                     -D-
                                                1 port(s)
                   (*, 239.200.0.24)  Eth0/0/19                     -D-
                                                1 port(s)
/////

 VLAN 555, 255 Entry(s)
                    (*, 239.200.0.1)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.2)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.3)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.4)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.5)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.6)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.7)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.8)  GE0/0/2                       SD-
                                                1 port(s)
                    (*, 239.200.0.9)  GE0/0/2                       SD-
                                                1 port(s)
                   (*, 239.200.0.10)  GE0/0/2                       SD-
                                                1 port(s)
                   (*, 239.200.0.11)  GE0/0/2                       SD-
                                                1 port(s)
                   (*, 239.200.0.12)  GE0/0/2                       SD-
 

 

 

Вывод команды port info написал в укороченном виде

Edited by tiratore

Share this post


Link to post
Share on other sites
В 06.08.2018 в 17:44, tiratore сказал:

После переводим абон порты в hybrid и вносим влан 555 без тега, влан 1 который я использую как абонентский все еще висит там по умолчанию.

И в итоге на порте висят два untagged влана - 1 и 555. Т.е. мультикасты при такой настройке ходят и без настроек multicast-vlan, проверено. Что-то там ещё китайцы забыли написать в своих инструкциях, или эта настройка тупо разгружает CPU? Хотя эта надпись в примере 1-to-N Replication видимо тоже самое рекомендует делать, до нахождения этой темы я долго думал, что же они имеют ввиду:

image.png.ebae1357d66fa56a2970bdd5ad1dbe23.png

 

В общем если со стороны пользовательского интерфейса и влана ещё сверху прикрутить BTV и тоже статичные группы, то можно фильтровать мультикасты как угодно.

Edited by zedalert

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Michael111666
      Продам 10шт Huawei nova lite 2017 новые 2200грн/шт
      Год гарантии от производителя
       
      ДисплейДиагональ экрана: 5
      Разрешение дисплея: 1280×720 (HD)
      Тип матрицы: IPS
      ПроизводительHuawei
      МодельNova lite 2017
      Дата анонса2017 год
      Размеры143,5х71х8,05 мм
      Вес: 145 г
      SIM-картаNano-SIM
      Количество SIM-карт2
      Операционная системаAndroid 7.0 Nougat с интерфейсом EMUI 5.1.
      Стандарт связиGSM
      WCDMA (UMTS)
      ПамятьОП: 2ГБ;
      ВП: 16Гб;
      Поддержка карты памяти: microSD до 128 Гб
      КамераОсновная: 13 Мп
      Вспышка/ Автофокус: Есть/Есть
      Фронтальная: 5 Мп
      Вспышка/Автофокус: Нет/Есть
      ПроцессорНазвание: Qualcomm MediaTek Snapdragon 425 MSM8917
      Видеоядро: Adreno 308
      Количество ядер: 4
      Частота: 1.6 ГГц
      Беспроводные технологииWi-Fi 802.11 a/b/g/n
      Bluetooth 4.0
      БатареяЕмкость аккумулятора: 3020 мА*ч
      Быстрая зарядка: Нет
      Съемный АКБ: Нет
      РазъемыРазъем зарядного устройства: micro-USB
      Разъем для наушников: 3.5 мм
      НавигацияGPS: Есть
      A-GPS: Есть
      Beidou: Нет
      ГЛОНАСС: Есть
      ДатчикиДатчик приближения
      Датчик освещенности
      Датчик отпечатка пальца
      Акселерометр


    • By Kto To
      Куплю 20-30 штук Huawei S2326TP-EI по вменяемой цене. С предложениями в личку.
    • By integrae
      Всем доброго! К продаже большой ассортимент профессиональной линейки РРЛ оборудования и отдельно лицензий
       
      NEC, серия Pasolink NEO 300 до 360 мб/с, частоты 7/13/18/23/38
       
      Комплект (внешний и внутренний блоки) 270 мб/с фулл дуплекс, с антеннами 0.3 м (1 модем) - 1500$ 
      Комплект (внешний и внутренний блоки) 270 мб/с фулл дуплекс, с антеннами 0.6 м (1 модем) - 2500$ 
       
      Комплект (внешний и внутренний блоки) 360 мб/с фулл дуплекс, с антеннами 0.3 м (1 модем) - 2000$ 
      Комплект (внешний и внутренний блоки) 360 мб/с фулл дуплекс, с антеннами 0.6 м (1 модем) - 3000$ 
       
      NEC, серия ipasolink 200/400 до 1.9 Гб/с, частоты 7/13/18/23/38
       
      ipasolink 200 + модем NEO
      Комплект (внешний и внутренний блоки) 360 мб/с фулл дуплекс, с антеннами 0.3 м (2 модем) - 2500$ 
      Комплект (внешний и внутренний блоки) 360 мб/с фулл дуплекс, с антеннами 0.6 м (2 модем) - 3500$ 
       
      ipasolink 200* + модем NEO
      Комплект (внешний и внутренний блоки) 720 мб/с фулл дуплекс, с антеннами 0.3 м (2 модем) - 4500$ 
      Комплект (внешний и внутренний блоки) 720 мб/с фулл дуплекс, с антеннами 0.6 м (2 модем) - 5500$ 
      *софтовая агрегация с двух модемов 360*2 мб/с
       
      ipasolink 400 + модем NEO
      Комплект (внешний и внутренний блоки) 410 мб/с фулл дуплекс, с антеннами 0.3 м (1 модем) - 6000$ 
      Комплект (внешний и внутренний блоки) 410 мб/с фулл дуплекс, с антеннами 0.6 м (1 модем) - 7000$ 
       
      ipasolink 400* + модем NEO
      Комплект (внешний и внутренний блоки) 820 мб/с фулл дуплекс, с антеннами 0.3 м (2 модем) - 7500$ 
      Комплект (внешний и внутренний блоки) 820 мб/с фулл дуплекс, с антеннами 0.6 м (2 модем) - 8500$ 
      *физическая агрегация c двух модемов 410*2 мб/с
       
      ipasolink 400* + модем NEO
      Комплект (внешний и внутренний блоки) 1.6 гб/с фулл дуплекс, с антеннами 0.3 м (4 модем) - 9500$ 
      Комплект (внешний и внутренний блоки) 1.6 гб/с фулл дуплекс, с антеннами 0.6 м (4 модем) - 10500$ 
      *физическая агрегация c четырех модемов 410*4 мб/с
       
      ipasolink 400 + модем iPasolink
      Комплект (внешний и внутренний блоки) 485 мб/с фулл дуплекс, с антеннами 0.3 м (1 модем) - 7500$ 
      Комплект (внешний и внутренний блоки) 485 мб/с фулл дуплекс, с антеннами 0.6 м (1 модем) - 8500$ 
       
      ipasolink 400 + модем iPasolink*
      Комплект (внешний и внутренний блоки) 970 мб/с фулл дуплекс, с антеннами 0.3 м (2 модем) - 9500$ 
      Комплект (внешний и внутренний блоки) 970 мб/с фулл дуплекс, с антеннами 0.6 м (2 модем) - 10500$ 
      *физическая агрегация с двух модемов 485*2 мб/с
       
      ipasolink 400 + модем iPasolink*
      Комплект (внешний и внутренний блоки) 1.9 гб/с фулл дуплекс, с антеннами 0.3 м (4 модем) - 11500$ 
      Комплект (внешний и внутренний блоки) 1.9 гб/с фулл дуплекс, с антеннами 0.6 м (4 модем) - 12500$ 
      *физическая агрегация с четырех модемов 485*2 мб/с
       
      Возможность поставки РРЛ 1.2 м и более для больших расстояний
       
      NEC, серия EX 80 ГГц 1/1.6/3/10 Гб/с, outdoor исполнение
       
      1 Гб/с/0.3 м - 10 000$
      1.6 Гб/с/0.3 м - 11 000$
      3 Гб/с/0.3 м - 12500$
      10 Гб/с/0.6 м - 15000$
       
      Для версии 1/1.6/3 Гб/с доплата за антенны 0.6 м на пролет - 2000$ 
       
      Возможность продажи некомплектных РРЛ на ЗИП
       
      Лицензии для ваших существующих пролетов NEC, Ceragon, Huawei
       
      NEC
      Расширение Pasolink NEO с 270 до 360 мб/с - 500$
      Открыть все лицензии серии ipasolink - 1000$
      Открыть все лицензии серии EX ipasolink - 2000$ 
       
      Ceragon
      Открыть все лицензии серии iP 10/20 - 1000$
       
      Huawei
      Открыть все лицензии серии RTN - 1000$
       
      Отдельно оплачивается доставка оборудования с Европы/СНГ от 2$ за кг
       
      Связь через ЛС
       
       
    • By Nicki67
      Продам ONU HUAWEI ECHOLIFE HG-8310M новые . Есть 5 шт . за все 50 у.е.


    • By Sarik_1525
      Народ настраиваю в OLTC320 а он а он не принимает... как можно это сделать? или HUAWEI сам не подходит под ZTE?
×