Jump to content
Local
virtus

Mikrotik VS Youtube

Recommended Posts

Приветствую !

Есть проблема в доступе к youtube у пользователей работающих с android и смарт телевизоров. Рулит доступом пользователей mikrtoik через IPOE (NAT, Hotspot). DHCP раздаёт DNS пользователям по умолчанию 1.1.1.1 и 8.8.8.8 (меняли и на другие - не помогает). 

 

Проявляется так:

1. На смарт телевизорах в youtube не загружается превью картинка видео, само видео можно посмотреть через раз. Приложения на смарт телевизоре обновить также не получается.

2. На android (телефон, планшет) youtube открывается через раз.

 

На PC всё работает и открывается нормально.

Выход пока найден только один роутеры Tenda F3 (через них всё работает нормально), на остальных роутерах (tplink, totolink, netis, asus) проблема присутствует. 

 

У кого наблюдалось подобное ? Как можно решить проблему ?

 

P.S.

Только не предлагайте продавать пользователям роутеры tenda :)

Share this post


Link to post
Share on other sites

Где-то тут что-то уже подобное проскальзывало.

Кстати, покажите настройки IP - DNS на микротике (который раздаёт интернет).

 

Share this post


Link to post
Share on other sites

Також замітили на нашій мережі схожу з описаною автором топіка проблему. У нас рішалось зміною ДНС на роутері TP-Link  (наприклад на 8.8.8.8 або інший, але це не вихід).  В даний момент проблема як сама появилась так і сама зникла. 

Цікаво що це було?

Share this post


Link to post
Share on other sites
49 минут назад, Туйон сказал:

Где-то тут что-то уже подобное проскальзывало.

Кстати, покажите настройки IP - DNS на микротике (который раздаёт интернет).

 

DNS самого mikrotik не используется

________________________________________________________________________________________

ip dns> pr
                      servers: 8.8.4.4,208.67.220.222,1.1.1.1,8.8.8.8
              dynamic-servers: 
        allow-remote-requests: yes
          max-udp-packet-size: 512
         query-server-timeout: 2s
          query-total-timeout: 10s
       max-concurrent-queries: 100
  max-concurrent-tcp-sessions: 20
                   cache-size: 2048KiB
                cache-max-ttl: 1w
                   cache-used: 1967KiB
________________________________________________________________________________________

ip dhcp-server network
add address=10.5.50.0/24 comment="hotspot network" dns-server=8.8.4.4,1.1.1.1 \
    gateway=10.5.50.1

________________________________________________________________________________________

Share this post


Link to post
Share on other sites

Попробуй поднять свой DNS, только без форвард на паблик днсы а напрямую чтоб обращался к корневым серверам. Нам помогло, до этого в бинде был настроен форвард на 8.8.8.8, 8.8.4.4, 1.1.1.1 и проблема была аналогичной. Я так подозреваю что при больших запросах на ГуглДНС он начинает не коректно отдавать согласно гео-данным. Вот тут они об этом пишут https://support.google.com/interconnect/answer/7658602?hl=en&ref_topic=7659366

 

Share this post


Link to post
Share on other sites
7 минут назад, s.t.a.l.k.e.r сказал:

Попробуй поднять свой DNS, только без форвард на паблик днсы а напрямую чтоб обращался к корневым серверам. Нам помогло, до этого в бинде был настроен форвард на 8.8.8.8, 8.8.4.4, 1.1.1.1 и проблема была аналогичной. Я так подозреваю что при больших запросах на ГуглДНС он начинает не коректно отдавать согласно гео-данным. Вот тут они об этом пишут https://support.google.com/interconnect/answer/7658602?hl=en&ref_topic=7659366

 

Как тогда tenda обходит эти ограничения ?

Share this post


Link to post
Share on other sites

Еще иногда помогает в настройках DHCP сервера роутера клиента указать основной и альтернативный ДНС (основной обычно указываю адрес роутера, альтернативный - 8.8.8.8). По-умолчанию tp-link выдает по DHCP только один адрес DNS сервера - свой. Роутер при подключении к сети получает адреса моих DNS-серверов.

 

второй вариант - прошиваю старые  tp-link прошивкой от gargoyle, и роутер работает стабильней, и проблем как правило с youtube и прочими после такого не наблюдается....

Edited by lemosh

Share this post


Link to post
Share on other sites
Цитата

 max-udp-packet-size: 512

Меняем на 4096 и пробуем. Раньше по-умолчанию в микротиках было 512, щас 4096.

Был случай, когда плохо работал ютуб а так же вайбер. Причем выборочно у некоторых клиентов.

Помогло именно то, что я написал.

У Вас, видимо, осталось ещё со времен обновления с 5-й версии.

Так же рекомендую увеличить размер кеша, он у Вас вообще маленький.

У меня вот так:

/ip dns
set allow-remote-requests=yes 
cache-size=65535KiB 
max-concurrent-queries=65535 
max-concurrent-tcp-sessions=65535 
query-server-timeout=1s
query-total-timeout=5s 
servers=1.1.1.1,8.8.4.4

 

Edited by Туйон

Share this post


Link to post
Share on other sites

Пару месяцев назад в нашей сети была аналогичная ситуация. Помогало прописать гугловские DNSы на роутерах абонентов. Трабла была исключительно на роутерах TP-Link

Share this post


Link to post
Share on other sites
2 часа назад, Туйон сказал:

Меняем на 4096 и пробуем. Раньше по-умолчанию в микротиках было 512, щас 4096.

Был случай, когда плохо работал ютуб а так же вайбер. Причем выборочно у некоторых клиентов.

Помогло именно то, что я написал.

У Вас, видимо, осталось ещё со времен обновления с 5-й версии.

Так же рекомендую увеличить размер кеша, он у Вас вообще маленький.

У меня вот так:


/ip dns
set allow-remote-requests=yes 
cache-size=65535KiB 
max-concurrent-queries=65535 
max-concurrent-tcp-sessions=65535 
query-server-timeout=1s
query-total-timeout=5s 
servers=1.1.1.1,8.8.4.4

 

Спасибо, поменял !

Но вопрос как это обходят tenda ?

И как на это влияет настройка dns mikrotik, если он абонентам не выдаётся ??

Share this post


Link to post
Share on other sites
3 минуты назад, virtus сказал:

Спасибо, поменял !

 

Эффект есть или нет ?

Share this post


Link to post
Share on other sites
3 минуты назад, Туйон сказал:

Эффект есть или нет ?

Завтра у абонов узнаю, напишу.

Share this post


Link to post
Share on other sites
7 минут назад, virtus сказал:

Завтра у абонов узнаю, напишу.

Ок. Мне интересно.

14 минут назад, virtus сказал:

 И как на это влияет настройка dns mikrotik, если он абонентам не выдаётся ??

В моём случае абонентам ничего не выдается, никаких рррое или дхцп нету.

Статические записи локальной сети, микротик в роли шлюза и днс в настройках сети, НАТ.

Т.е. на компьютерах или роутерах как ДНС указывается только тот же ай-пи, что и шлюз (микротик).

Share this post


Link to post
Share on other sites
8 минут назад, Туйон сказал:

Ок. Мне интересно.

В моём случае абонентам ничего не выдается, никаких рррое или дхцп нету.

Статические записи локальной сети, микротик в роли шлюза и днс в настройках сети, НАТ.

Т.е. на компьютерах или роутерах как ДНС указывается только тот же ай-пи, что и шлюз (микротик).

 

У меня напрямую 1.1.1.1 и 8.8.4.4  (но теперь первым кинул DNS самого mikrotik для теста)

10 минут назад, sanyadnepr сказал:

покажи выхлоп ip dns pr

ip dns pr
                      servers: 1.1.1.1,8.8.4.4
              dynamic-servers: 
        allow-remote-requests: yes
          max-udp-packet-size: 4096
         query-server-timeout: 2s
          query-total-timeout: 10s
       max-concurrent-queries: 65535
  max-concurrent-tcp-sessions: 65535
                   cache-size: 4096KiB
                cache-max-ttl: 1w
                   cache-used: 1792KiB

Edited by virtus

Share this post


Link to post
Share on other sites

Cделай:

4 минуты назад, virtus сказал:

allow-remote-requests: no

И кеш очисть.

У пользователей днсы статикой же вписаны ?

 

Share this post


Link to post
Share on other sites
22 минуты назад, sanyadnepr сказал:

Cделай:

И кеш очисть.

У пользователей днсы статикой же вписаны ?

 

 

Нет отдаются по DHCP (но кеш чистил без allow-remote-requests: no)

 

/ip dhcp-server network> pr
 # ADDRESS            GATEWAY         DNS-SERVER      WINS-SERVER     DOMAIN     
 0 ;;; hotspot network
   10.5.50.0/24       10.5.50.1                 10.5.50.1      
                                                              1.1.1.1        
                                                              8.8.4.4

Share this post


Link to post
Share on other sites
1 час назад, virtus сказал:

Но вопрос как это обходят tenda ?

Вероятней всего, корректно отрабатывает.

Выключи микротиковский днс вообще, а первым выдаваемым днс укажи 1.1.1.1 вторым 8-ки. локальные 10.5.50.1 днс вообще удали.

 

 

 

Share this post


Link to post
Share on other sites
1 минуту назад, sanyadnepr сказал:

Вероятней всего, корректно отрабатывает.

Выключи микротиковский днс вообще, а первым выдаваемым днс укажи 1.1.1.1 вторым 8-ки. локальные 10.5.50.1 днс вообще удали.

 

 

 

Его только поставил для теста , по началу так и было единицы и восьмёрки

Share this post


Link to post
Share on other sites

Давайте по очереди будем делать, пока сделал как описывал Туйон, завтра проверю, отпишусь. Если не сработает то попробую сделать как описал sanyadnepr, а то щас накуеверчу.

Share this post


Link to post
Share on other sites
41 минуту назад, sanyadnepr сказал:

allow-remote-requests: no

у меня стоит YES, когда выставлял NO то не работало, почему не разбирался - выставил YES и забыл, может подскажете почему не работало?

Share this post


Link to post
Share on other sites
11 минут назад, WideAreaNetwork сказал:

у меня стоит YES, когда выставлял NO то не работало, почему не разбирался - выставил YES и забыл, может подскажете почему не работало?

Это типа разрешает резолв DNS если клиент сделает на него запрос.

Но не должно влиять если у клиента стоит DNS не самого mikrotik

Edited by virtus

Share this post


Link to post
Share on other sites
32 минуты назад, virtus сказал:

Но не должно влиять если у клиента стоит DNS не самого mikrotik

у клиента стоит адрес влана на мтике

Share this post


Link to post
Share on other sites

allow-remote-requests: yes

Позволяет обращаться к днс микротика всем удаленным хостам

no - только сам микротик и все

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×