Jump to content
Local
init

Обновление Ubilling c 0.7.2

Recommended Posts

Добрый день! Появилась необходимость обновить Ubilling с версии 0.7.2 до текущей, как бы это сделать быстро и безболезненно?

Я так понимаю надо с версии на версию прыгать? или есть какой-то инструмент который инкрементно обновит до текущей версии?

Благодарю

Share this post


Link to post
Share on other sites

Берете и обновляетесь автообновлятором в последнюю стабильную 0.9.5 либо в 0.9.6 current. До 0.8.2 проходите все рекомендации к обновлению ручками, снизу вверх, после - можно просто кликать по менеджеру обновлений. Бэкап БД/директории billing, перед этим - залог здоровья.

Edited by nightfly
-

Share this post


Link to post
Share on other sites

за стопку перцовки намек принят xD,

за совет обновления после 0.8.2 отдельное спасибо, а то бы красноглазили до посинения

Share this post


Link to post
Share on other sites
1 час назад, init сказал:

за стопку перцовки намек принят xD,

за совет обновления после 0.8.2 отдельное спасибо, а то бы красноглазили до посинения

c 0.6 че то там до карента за 20 минут добирается

хз что там делать до красноглазия

или у вас так быстро глаза краснеют?

Edited by l1ght
  • Like 1

Share this post


Link to post
Share on other sites
В 27.02.2019 в 13:05, nightfly сказал:

Берете и обновляетесь автообновлятором в последнюю стабильную 0.9.5 либо в 0.9.6 current. До 0.8.2 проходите все рекомендации к обновлению ручками, снизу вверх, после - можно просто кликать по менеджеру обновлений. Бэкап БД/директории billing, перед этим - залог здоровья.

 

 

кстати я забыл спросить, а обновляясь до 0.8.2 судя по рекомендациям к обновлению - я обновляю базу и конфиги, а ревизия файлов до 0.8.2 остается прежней? если нет, то как понять какие файлы мне нужно заменить?

Допустим мне нужно обновиться с 0.7.2 до 0.7.3 - какие файлы заменить? я в github как то должен между тегами 0.7.2 и 0.7.3 сравнить версии? Я просто не до конца этот момент понимаю )

Edited by init

Share this post


Link to post
Share on other sites
15 минут назад, init сказал:

кстати я забыл спросить, а обновляясь до 0.8.2 судя по рекомендациям к обновлению - я обновляю базу и конфиги, а ревизия файлов до 0.8.2 остается прежней? если нет, то как понять какие файлы мне нужно заменить?

Допустим мне нужно обновиться с 0.7.2 до 0.7.3 - какие файлы заменить? я в github как то должен между тегами 0.7.2 и 0.7.3 сравнить версии? Я просто не до конца этот момент понимаю ) 

Если хотите придумать сами себе какие-то несуществующие проблемы и героически с ними бороться - пожалуйста.

А можно просто открыть рекомендации к обновлению и немножечко подумать. Недолго. Минуты три от силы.

Share this post


Link to post
Share on other sites
1 минуту назад, nightfly сказал:

Если хотите придумать сами себе какие-то несуществующие проблемы и героически с ними бороться - пожалуйста.

А можно просто открыть рекомендации к обновлению и немножечко подумать. Недолго. Минуты три от силы.

 

да это я понял что в рекомендациях по обновлению я изменяю конфигурационные файлы и базу, а сами файлы биллинга (нужно же понимать какие файлы заменять, удалять, добавлять)?

Share this post


Link to post
Share on other sites
2 минуты назад, init сказал:

да это я понял что в рекомендациях по обновлению я изменяю конфигурационные файлы и базу, а сами файлы биллинга (нужно же понимать какие файлы заменять, удалять, добавлять)?

Вам не нужно много думать. За вас уже подумано. И делать не нужно ничего. За вас уже все сделано.

Если не доходит, ну видео о обновлении посмотрите, что-ли..

Share this post


Link to post
Share on other sites
51 минуту назад, nightfly сказал:

Вам не нужно много думать. За вас уже подумано. И делать не нужно ничего. За вас уже все сделано.

Если не доходит, ну видео о обновлении посмотрите, что-ли..

 

Простите, но Блин, сегодня и правда чет мозг не работает, посмотрел видео для тупых даже ))) там используется autoubupdate.sh, но он обновляет сразу на последнюю версию...

Не понимаю как обновляется файловая структура между 0.7.2 и 0.7.3

В свое время 0.7.2 ставили вручную без инсталлера

Edited by init

Share this post


Link to post
Share on other sites
7 минут назад, init сказал:

Простите, но Блин, сегодня и правда чет мозг не работает, посмотрел видео для тупых даже ))) там используется autoubupdate.sh, но он обновляет сразу на последнюю версию... 

Ну... и зачем еще какое-то дрочево самому себе придумывать, если видео четко иллюстрирует что и как должно работать?

 

7 минут назад, init сказал:

Не понимаю как обновляется файловая структура между 0.7.2 и 0.7.3

Вам и не нужно этого понимать, так как ничего раньше 0.9.6 и 0.9.7 в природе уже не существует. Годами. Забыли. Все.

 

7 минут назад, init сказал:

В свое время 0.7.2 ставили вручную без инсталлера

Ну и? Это что-то радикально меняет? Какие-то религиозные предрассудки?

 

Возможно у вас нету обновлятора? Ну так кто-же вам виноват. Возьмите и разверните себе. Вообще не вижу проблемы.

Share this post


Link to post
Share on other sites
3 минуты назад, nightfly сказал:

Ну... и зачем еще какое-то дрочево самому себе придумывать, если видео четко иллюстрирует что и как должно работать?

 

Вам и не нужно этого понимать, так как ничего раньше 0.9.6 и 0.9.7 в природе уже не существует. Годами. Забыли. Все.

 

Ну и? Это что-то радикально меняет? Какие-то религиозные предрассудки?

 

Возможно у вас нету обновлятора? Ну так кто-же вам виноват. Возьмите и разверните себе. Вообще не вижу проблемы.

 

я немного запутался, вы изначально написали что обновиться нужно вручную до версии 0.8.2, выполняя рекомендации по обновлению, а затем уже через менеджер обновлений до текущей. Я поэтому то и поинтересовался как мне обновиться до 0.8.2, то есть мне же нужно будет изменять до 0.8.2 как то файловую структуру биллинга?

Share this post


Link to post
Share on other sites

Нет, не писал. Это ваша фантазия. Перечитайте еще раз второй пост в этом топике. Это не сложно. Да, ничего не изменилось, кроме того, что сейчас каррэнт это 0.9.7. 

Share this post


Link to post
Share on other sites

я кажется родил, до 082 делаю магию с изменением конфигов и обновлением базы, а затем через автоапдэйтер, но у меня тут 2 вопроса...

Ubilling работает на линухе, лежит он в /var/www/billing

задал переменные в скрипте

#apache version macro
APVER_VAR=""

# path to your apache data
APACHE_DATA_PATH="/var/www"

# ubilling path
UBILLING_PATH="./billing/"

сам скрипт положил в /var/www/ как и было сказано уровнем выше установки ubilling, и в итоге получаю Wrong current directory

 

сохранит ли autoupdater все настройки которые были в настройках личного кабинета и самой админки?

Edited by init

Share this post


Link to post
Share on other sites

 Спасибо за поддержку, биллинг обновил кажись...

Кстати я собрал из гита последнюю сборку старгейзера 409, не rc5, а видимо релиз уже 18 года, база обновлена на версию 2. Как работает 409 релиз? Не тестировали?

Share this post


Link to post
Share on other sites
3 часа назад, init сказал:

сам скрипт положил в /var/www/ как и было сказано уровнем выше установки ubilling, и в итоге получаю Wrong current directory

Это защита от дурака не дающая потереть окружение. Очевидно она сработала.

 

3 часа назад, init сказал:

сохранит ли autoupdater все настройки которые были в настройках личного кабинета и самой админки? 

Это от вас зависит и от вашей способности читать.

 

2 часа назад, init сказал:

Кстати я собрал из гита последнюю сборку старгейзера 409, не rc5, а видимо релиз уже 18 года, база обновлена на версию 2. Как работает 409 релиз? Не тестировали? 

Понятия не имею чего, на чем и как вы там насобирали и чего я должен был тестировать. Битва экстрасенсов и провидцев это где-то на телеке. Я не там.

Stargazer 2.409rc5 работает вполне стабильно, поэтому и предлагается как опция в инсталляторе.

 

123.png

Share this post


Link to post
Share on other sites
6 часов назад, nightfly сказал:

Это защита от дурака не дающая потереть окружение. Очевидно она сработала.

 

Это от вас зависит и от вашей способности читать.

 

Понятия не имею чего, на чем и как вы там насобирали и чего я должен был тестировать. Битва экстрасенсов и провидцев это где-то на телеке. Я не там.

Stargazer 2.409rc5 работает вполне стабильно, поэтому и предлагается как опция в инсталляторе.

 

123.png

 

 

 

Собрал последний снапшот отсюда http://git.stg.codes/stg.git/shortlog/refs/heads/stg-2.409

Share this post


Link to post
Share on other sites

Еще вопрос, у меня в менеджере обновлений высвечивается будто ни база ни файлы конфигураций не обновлены, хотя там все строки и база обновлена исходя из рекомендаций.

Как то можно заставить ubiiling перечитать базу и файлы?BophGOR.thumb.png.7a9d695a79861f85a42e8dbf4ee61a2f.png

Edited by init

Share this post


Link to post
Share on other sites
13 минут назад, init сказал:

Еще вопрос, у меня в менеджере обновлений высвечивается будто ни база ни файлы конфигураций не обновлены

Я понятия не имею, почему вы так решили.

Может таки посмотрите аж минутное видео о обновлении и больше не будете выдумывать себе какие-то проблемы, чтобы с ними героически бороться?

Цитата

Как то можно заставить ubiiling перечитать базу и файлы?

Пожалуйста, не втягивайте меня в мир своих больных фантазий.

Edited by nightfly
  • Like 1

Share this post


Link to post
Share on other sites
2 минуты назад, nightfly сказал:

Я понятия не имею, почему вы так решили.

Может таки посмотрите аж минутное видео о обновлении и больше не будете выдумывать себе какие-то проблемы, чтобы с ними героически бороться?

Пожалуйста, не втягивайте меня в мир своих больных фантазий.

 

вообще-то я умею грепать файлы на предмет параметров, сам эти параметры вручную прописывал и применял патчи на sql исходя из рекомендаций к обновлению

Share this post


Link to post
Share on other sites
15 minutes ago, init said:

вообще-то я умею грепать файлы на предмет параметров

медаль тебе выдать? ну на

medal-za-userdie-24-r.jpg.64fe7b578212ba7a4c7434c8b5d0dbe9.jpg

  • Haha 1

Share this post


Link to post
Share on other sites

У вас все документировано как вы пишете 

3 минуты назад, JohnC сказал:

медаль тебе выдать? ну на

medal-za-userdie-24-r.jpg.64fe7b578212ba7a4c7434c8b5d0dbe9.jpg

 

 

Модераторам и админам лучше бы блокировать всякого рода спамеров и болтунов, если уж по делу отвечать не можете. Зачем форум, когда толку нет никакого

Share this post


Link to post
Share on other sites

Правду говорят, что хуже дураков только усердные дураки с амбициями.

  • Haha 2

Share this post


Link to post
Share on other sites
3 минуты назад, JohnC сказал:

Правду говорят, что хуже дураков только усердные дураки с амбициями.

 

Уважаемый, вы вообще зачем сюда что-то написали? Это не флудилка вообще-то

Share this post


Link to post
Share on other sites

по теме - я пробежался по каждому обновлению снизу вверх, менеджер обновлений успешно сообщал мне что все новые параметры в конфигах уже существуют и будут проигнорированы, однако из менеджера обновлений предыдущие релизы так и не пропали. В плане базы данных тоже самое, пробежался снизу вверх, менеджер обновлений мне сообщал, что по некоторым таблицам поля уже созданы (ну это естественно, потому что я применял sql запросы вручную), и также из менеджера обновлений ничего не ушло. Это же конкретный баг менеджера обновлений. Какая логика у менеджера обновлений? Он перечитывает файлы конфигураций на предмет новых параметров? Или он где-то у себя в базе помечает что релиз на такую-то версию прошел удачно/неудачно?

Share this post


Link to post
Share on other sites
6 минут назад, init сказал:

по теме - я пробежался по каждому обновлению снизу вверх, менеджер обновлений успешно сообщал мне что все новые параметры в конфигах уже существуют и будут проигнорированы, однако из менеджера обновлений предыдущие релизы так и не пропали. В плане базы данных тоже самое, пробежался снизу вверх, менеджер обновлений мне сообщал, что по некоторым таблицам поля уже созданы (ну это естественно, потому что я применял sql запросы вручную), и также из менеджера обновлений ничего не ушло. Это же конкретный баг менеджера обновлений. Какая логика у менеджера обновлений? Он перечитывает файлы конфигураций на предмет новых параметров? Или он где-то у себя в базе помечает что релиз на такую-то версию прошел удачно/неудачно?

обожаю самоцитирование

1 час назад, nightfly сказал:

Пожалуйста, не втягивайте меня в мир своих больных фантазий.

 

P.S. А вы действительно упорный.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dimonian
      Не получается настроить SMSPILOT, все сделал по инструкции: включил собаку-посылаку, включил SMSZILLA, установил длину номера и код (раскоментировал строки и установил значение), вставил API-ключ, создал список номеров и у клиентов указал номера телефонов. При попытке отправить сообщение клиентам, номера не извлекаются (фильтр настроен, как "отправить всем"). При попытке отправить на номера из списка возникает ошибка Warning: strpos(): Empty needle in /usr/local/www/apache24/data/billing/api/libs/api.workaround.php on line 2813.
      Пробовал на чистом Биллинге, сообщения ставятся в очередь, но не отсылаются. На сервис смс не приходит запрос от Биллинга. Номера извлекаются из списка номеров но Notice: Undefined index: mobile in /usr/local/www/apache24/data/billing/api/libs/api.smszilla.php on line 3093
    • By vovvw
      Здравствуйте, господа форумчане. Помогите пожалуйста решить проблемку с убилингом:
      У абонов нет интернета на новой подсети. Айпи выдаются, шлюз пингуется, интернета нет.
      Система ubuntu 18.04
    • By dimonian
      при настройке smspilot возникла проблема, smszilla и собакапосылака включены, api указан- (баланс счета в биллинге виден)-однако сообщения ставятся в очередь но не отсылаются, на стороне smspilot запросов api нет. При некоторых манипуляциях с телефонами возникает ошибка: 
      Warning: strpos(): Empty needle in /usr/local/www/apache24/data/billing/api/libs/api.workaround.php on line 2813
      Прошу прощения за возможно глупый вопрос.
    • By DAnEq
      root@nas-bras:~/ubinstaller/nas_preconf # ./autosetup.sh ./autosetup.sh: Permission denied.
      ладно, мы не гордые
      root@nas-bras:~/ubinstaller/nas_preconf # sh autosetup.sh The package management tool is not yet installed on your system. Do you want to fetch and install it now? [y/N]: y Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/FreeBSD:11:amd64/quarterly, please wait... Verifying signature with trusted certificate pkg.freebsd.org.2013102301... done Installing pkg-1.11.1... Extracting pkg-1.11.1: 100% pkg-1.11.1 Package manager pkgng.installer: pkg2ng: not found NAS_120_64.tar.gz 100% of 99 MB 8287 kBps 00m12s x NAS_120_64/trafshow-5.2.3_2,1.txz далее куча сообщений подобного рода
      и потом
      Installing bandwidthd-2.0.1_11...
      pkg: wrong architecture: FreeBSD:12:amd64 instead of FreeBSD:11:amd64
      и так еще 62 пакета
       
      потом соответственно куча FAIL! not found No such file or directory
       
      но
       
      uname -a
      FreeBSD nas-bras 11.2-RELEASE FreeBSD 11.2-RELEASE #0 r335510: Fri Jun 22 04:32:14 UTC 2018     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

      такая же самая на которую на соседней виртуалке без проблем накатил убиллинг

      вопрос.
      что взять для наса ?
      11.0 или 11.1 ?
    • By reductor
      Помогите правильно настроить модуль "По ком звонит колокол" 
      Как правильно сделать запись в Кронтаб asterisk - возможен следующий запрос: /?module=remoteapi&key=[ubserial]&action=asterisk&number=[mobile_number]&param=[login|realname|swstatus]
×