Jump to content

HELP!не работают вызовы Remote API


Recommended Posts

Господа камрады выручайте ,ситуация така жил был сервер с биллингом и все было нормально пока в какой-то момент не перестали выполнятся задачи Remote API по крону (при этом осталные задачи работают)перерыл логи крона апача нигде ничего.Версия юбиллинга 1.1.4 rev 7876

Link to post
Share on other sites
2 минуты назад, skybetik сказал:

Теперь останется почистить ваш скрин и х*****  вам всякую дичь ) 

как вы могли заметить х...ть дичь и не выходит

Link to post
Share on other sites
3 минуты назад, skybetik сказал:

Давайте с начала какая ОС ? 

Где вводите задания в крон?

Покажите задания в кроне.

FreeBSD 12.0

через стандартный редактор юбила

 

40 1 1 * *      /bin/ubapi "vserviceschargefee"
*/20 * * * *    /bin/ubapi "swping"
0 */1 * * *     /bin/ubapi "swpoll"
*/10 * * * *    /bin/ubapi "watchdog"
*/5 * * * *     /bin/ubapi "senddog"
1 1 * * *       /bin/ubapi "backupdb"
3 * * * *       /bin/ubapi "rebuildglscache"
10 2 * * *      /bin/ubapi "dealwithit"
50 23 * * *     /bin/ubapi "exhorse"
*/10 * * * *    /bin/ubapi "nasmon"
*/30 * * * *    /bin/ubapi "mtsigmonpoll"
10 10 1 * *     /bin/ubapi "autocleandb"
10 */1 * * *    /bin/ubapi "fdbarchive"
*/10 * * * *    /bin/ubapi "oltpoll"
*/3 * * * *     /bin/ubapi "multigen"
*/10 * * * *     /bin/ubapi "multigentraff"
#*/5 * * * *     /bin/ubapi "senddog"
20 1 1 * *        /bin/ubapi "trinitytvcontrol&param=chargefee"
*/10 * * * *      /bin/ubapi "trinitytvcontrol&param=resurrect"
59 19 * * *       /bin/ubapi "onepunch&param=bigbro"
*/2 * * * * /usr/local/bin/php /usr/local/www/apache24/data/openpayz/libs/op_WorkerPaymentsProceed.php

 

 

из этого всего отрабатывает только последнее
 

Link to post
Share on other sites
1 минуту назад, skybetik сказал:

Серийник в /bin/ubapi  проверили ?  и да я так понимаю там у вас Виртуал хосты есть да ? 

на оба вопроса ответ да

Link to post
Share on other sites

/usr/local/bin/curl -o /dev/null "http://127.0.0.1/billing/?module=remoteapi&key=${UBSERIAL}&action=${ACTION}"      

 

если через консоль запустить какой віхлоп ? 

Link to post
Share on other sites

Ну проверьте на любом візове  /usr/local/bin/curl -o /dev/null "http://127.0.0.1/billing/?module=remoteapi&key=ваш_серийник&action=swping"

 

Ну и как вариант вместо 127.0.0.1   ip сервера впишите.

Edited by skybetik
Link to post
Share on other sites
3 часа назад, SerSkiner сказал:

UPD в процесе ковыряния но ключ точно верный

api2.jpg

api1.jpg

Ты неправильный ссыль в бравзере вводиш, тебе же вон Mixtery намекнул.

1 час назад, mixtery сказал:


Серийник не похож на "UB***1465=oltpoll"

 

Link to post
Share on other sites
3 часа назад, SerSkiner сказал:

UPD в процесе ковыряния но ключ точно верный

api2.jpg

api1.jpg

 

Ты неправильный ссыль в бравзере вводиш, тебе же вон Mixtery намекнул.

1 час назад, mixtery сказал:


Серийник не похож на "UB***1465=oltpoll"

 

Link to post
Share on other sites
4 минуты назад, Ромка сказал:

Ты неправильный ссыль в бравзере вводиш, тебе же вон Mixtery намекнул.

 

да увидел что action не хватало ,но ситуация не изменилась

Link to post
Share on other sites
3 часа назад, SerSkiner сказал:

Господа камрады выручайте ,ситуация така жил был сервер с биллингом и все было нормально пока в какой-то момент не перестали выполнятся задачи Remote API по крону (при этом осталные задачи работают)перерыл логи крона апача нигде ничего.Версия юбиллинга 1.1.4 rev 7876

/ib/mikrotik_2021.03.04.gif

Дай угадаю, "какой-то момент" наступил ровно тогда, когда прикрутил домен или ssl к биллингу?

Link to post
Share on other sites
1 минуту назад, Ромка сказал:

Дай угадаю, "какой-то момент" наступил ровно тогда, когда прикрутил домен или ssl к биллингу?

возможно,Но я пробовал с консоли и с доменом вместо айпи

Link to post
Share on other sites
2 минуты назад, SerSkiner сказал:

возможно,Но я пробовал с консоли и с доменом вместо айпи

Ремонтируй виртуалхосты в апаче. По дефолту оно работает типа так:

http://1.2.3.4/billing/....

А у тебя похже что так:

http://provider.net/...

Edited by Ромка
Link to post
Share on other sites
21 минуту назад, Ромка сказал:

Ремонтируй виртуалхосты в апаче. По дефолту оно работает типа так:

http://1.2.3.4/billing/....

А у тебя похже что так:

http://provider.net/...

отключил виртуалхосты вернул к прежнему виду все....отпишусь

Link to post
Share on other sites
51 минуту назад, SerSkiner сказал:

отключил виртуалхосты вернул к прежнему виду все....отпишусь

спасибо колеги за помощь отключение виртуалхостов помогло((((а теперь вопрос как правильно их настроить?)

Link to post
Share on other sites
4 минуты назад, SerSkiner сказав:

спасибо колеги за помощь отключение виртуалхостов помогло((((а теперь вопрос как правильно их настроить?)

Читати уважно вікі і не розорити Срібну землю)) за 20$ можуть тицьнути де саме то треба читати, так @nightfly? Мені там поблажка по вилам зарахується?)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ppv
      Проглянув FAQ і Ubilling Wiki. Зацікавило питання чи є в Ubilling якась реалізація reCAPTCHA, чи потрібно додавати руцями, (для прикладу для форми подачі заявок чи для кабінету користувача)?
       
    • By a_n_h
      Всем доброго дня!
        После "переезда" на новый сервер не работает подсчет трафика у абонов, графики рисует исправно.
       
        softflowd запущен:
        nobody  26980    0.0  0.0   13488   3148  -  Is   05:40       0:00.00 /usr/local/bin/softflowd -i bridge0 -n 127.0.0.1:42111 -m 16000 -p /var/run/softflowd.br
       
        при проверке  tcpdump -i lo0 port 42111 - тишина...
       
        Подскажите, куда копать?
    • By subhan
      У нас есть сервер Ubilling. к которому соединены 5 брасов. Каждый Nas работает по отдельному влану. В вланах браса в определенное время мы видим пустой трафик который поднимается. Например в норме если 200мб то 500мб. В влане котором видится пустое поднятие трафика, также и поднимается трафик во всех портах свитча. Это исправляется на время только при ребуте определенного Nas. Проблема раньше была только в одном Nas-э, щас и на других Nas-ах тоже данная проблема. Это проблема только наблюдается во вланах которые подключены в Ubilling.

      Можете пожалуйста, помочь в данной проблеме.
    • By a_n_h
      Доброго дня и с праздником!
         Как "формируется" ID пользователя для OnConnect OnDisconnect и проч. скриптов?
    • By a_n_h
      Всем доброго дня!
        Как перенести созданные в мастере отчетов отчеты на новый сервер?
       
      Нашел сам:
      /usr/local/www/apache24/data/billing/content/reports
×
×
  • Create New...