Колян Опубліковано: January 5, 2010 at 11:43 Опубліковано: January 5, 2010 at 11:43 Может быть. Раньше юзал стг от silitra, но после установки на восьмую фрю он начал периодически вылетать, не мог записать детальную статистику, де-то писал уже тут. Там с сообщениями было все норм. Выпадает через 10 минут после отправки сообщений. Че делать посоветуете?
trinux Опубліковано: January 5, 2010 at 11:47 Опубліковано: January 5, 2010 at 11:47 После 3-х месяцев стабильной работы произошло следующее stargazer[20162]: segfault at 00000008 eip b7407035 esp b7013100 error 4 Сделал запуск, все закрутилось снова. что бы это значило?
madf Опубліковано: January 5, 2010 at 11:55 Автор Опубліковано: January 5, 2010 at 11:55 Может быть. Раньше юзал стг от silitra, но после установки на восьмую фрю он начал периодически вылетать, не мог записать детальную статистику, де-то писал уже тут. Там с сообщениями было все норм. Выпадает через 10 минут после отправки сообщений. Че делать посоветуете? Отказаться от мускула в пользу других СУБД
madf Опубліковано: January 5, 2010 at 11:59 Автор Опубліковано: January 5, 2010 at 11:59 После 3-х месяцев стабильной работы произошло следующее stargazer[20162]: segfault at 00000008 eip b7407035 esp b7013100 error 4 Сделал запуск, все закрутилось снова. что бы это значило? Сегфолт. Ну я такое наблюдаю 1-2 раза в месяц на 3 боевых серверах (~2500/6000 в пике). Поймать пока не могу. Можно попробовать сделать отладочную сборку, ulimit -c unlimited, запустить с перенаправлением stdout в файл с ротацией раз в сутки и подождать следующего падения. Должна сформироваться корка, которую упаковать вместе с куском лога и выложить где-нибуть для меня (думаю, в почту такое не пролезет).
Колян Опубліковано: January 5, 2010 at 13:53 Опубліковано: January 5, 2010 at 13:53 Может быть. Раньше юзал стг от silitra, но после установки на восьмую фрю он начал периодически вылетать, не мог записать детальную статистику, де-то писал уже тут. Там с сообщениями было все норм. Выпадает через 10 минут после отправки сообщений. Че делать посоветуете? Отказаться от мускула в пользу других СУБД ну это как бы не реально, веб админка, и все такое... от Силитры сборка ж работала, такого бага небыло. Других путей решения проблемы нету?
madf Опубліковано: January 5, 2010 at 13:55 Автор Опубліковано: January 5, 2010 at 13:55 Может быть. Раньше юзал стг от silitra, но после установки на восьмую фрю он начал периодически вылетать, не мог записать детальную статистику, де-то писал уже тут. Там с сообщениями было все норм. Выпадает через 10 минут после отправки сообщений. Че делать посоветуете? Отказаться от мускула в пользу других СУБД ну это как бы не реально, веб админка, и все такое... от Силитры сборка ж работала, такого бага небыло. Других путей решения проблемы нету? Есть, конечно. Найти и исправить ошибку
Колян Опубліковано: January 5, 2010 at 14:14 Опубліковано: January 5, 2010 at 14:14 разработчики СТГ занимаются исправлением багов в модуле mysql_storage, или это вообще что-то отдельное? Я, и как наверное многие дургие, не могу отказаться от использования этой СУБД, да и сообщения отправлять юзерам периодически надо.
madf Опубліковано: January 5, 2010 at 15:17 Автор Опубліковано: January 5, 2010 at 15:17 разработчики СТГ занимаются исправлением багов в модуле mysql_storage, или это вообще что-то отдельное? Я, и как наверное многие дургие, не могу отказаться от использования этой СУБД, да и сообщения отправлять юзерам периодически надо. Нет, эта не наша разработка. Автор пропал, одно время этим модулем занимался den68 (его тоже давно не слышно). Плагин написан так плохо что его проще переписать с нуля чем править баги. Попробуй подложить исходники плагина из сборки от Silitra.
Kucher2 Опубліковано: January 5, 2010 at 15:46 Опубліковано: January 5, 2010 at 15:46 Я вообще отказался от посыла сообщений юзерам через консольный конфигуратор, если Вы об этом. Ну не любит СТГ посылать сразу пачку сообщений, похоже. Особено это заметно, если в Онлайне больше 20-ти человек - сунуть посыл сообщения в OnConnect и рестартануть СТГ. У меня биллинг отваливается сразу, тогда. Написал маленькую вэб-морду для юзеров - там, тариф могут сменить, инфу глянуть. Все знают, что оплата снимается 1-го числа. И не заморачиваюь никакими сообщениями.
Колян Опубліковано: January 6, 2010 at 09:15 Опубліковано: January 6, 2010 at 09:15 Я через виндовый отправляю. Насчет исходников - попробую подсунуть и собрать, но вроде как они модифицировали сам стг. В общем, отпишусь
Queeq Опубліковано: January 6, 2010 at 12:32 Опубліковано: January 6, 2010 at 12:32 Так что, на 8-й фре вообще без шансов запустить с мускулем?
madf Опубліковано: January 6, 2010 at 12:42 Автор Опубліковано: January 6, 2010 at 12:42 Так что, на 8-й фре вообще без шансов запустить с мускулем? Для сборки на 8-й фре нужно в билд-файле добавить строчку 8) OS=bsd7;; после строки 7) OS=bsd7;; (ориентировочно 87-я строка). По поводу мускула ничего не знаю.
Silitra Опубліковано: January 12, 2010 at 05:42 Опубліковано: January 12, 2010 at 05:42 На 8-й фре все должно работать, принципиальной разницы между 7-й и 8-й не вижу.
Колян Опубліковано: January 13, 2010 at 13:17 Опубліковано: January 13, 2010 at 13:17 Скомпилить модуль от Силитры не удалось Чего я собсно и ожидал...
Колян Опубліковано: January 14, 2010 at 08:11 Опубліковано: January 14, 2010 at 08:11 Еще вот что понял, не сборка от Силитры глючила, а скорее mysql server. Я про то, что в какой-то момент стг сервер не может записать детальную статистику. Или другие какие-то данные. Кто с таким стыкался? Server version: 5.1.39 Source distribution FreeBSD billing.kanivnet 8.0-PRERELEASE FreeBSD 8.0-PRERELEASE Раньше была другая версия мускул сервера, 5.0.24 по-моему, может это зависить от версии сервера бд?
madf Опубліковано: January 14, 2010 at 08:22 Автор Опубліковано: January 14, 2010 at 08:22 Может там переподключения в плагине нет?
Smeet Опубліковано: January 16, 2010 at 09:17 Опубліковано: January 16, 2010 at 09:17 Хотел перейти с freebsd 6.3 на 7.2. На чистую систему скомпилировалось без проблем, запустилось тоже, но при подключении конфигуратором после считывания порядка 70+-3 абонента выдает ошибку: parse error at line 1: not well formed (invalid token) Конфигуратор последний, 1.91.9 Им же подключается к рабочему серверу без проблем. Базу пробовал и в файлах и в мускуле, все едино. В логах сервера: Broken pipe ------------------------ чуть позже: сообщение удалить не смог, поэтому опишу причину: виноваты дрова на сетевуху Ateros (ale) bad chsum
egor2fsys Опубліковано: January 16, 2010 at 11:38 Опубліковано: January 16, 2010 at 11:38 Хотел перейти с freebsd 6.3 на 7.2. На чистую систему скомпилировалось без проблем, запустилось тоже, но при подключении конфигуратором после считывания порядка 70+-3 абонента выдает ошибку: parse error at line 1: not well formed (invalid token) Конфигуратор последний, 1.91.9 Им же подключается к рабочему серверу без проблем. Базу пробовал и в файлах и в мускуле, все едино. В логах сервера: Broken pipe Возможно, причиной этого является наличия в параметрах у кого-то из пользователей спец. символов типа <> Проверьте по файловой базе и отредактируйте параметры пользователя перед запуском сервера.
madf Опубліковано: January 16, 2010 at 12:01 Автор Опубліковано: January 16, 2010 at 12:01 Или кирилица в пароле. Паролям следует уделить особое внимание т.к. они передаются без кодирования в отличие от остальных полей.
Колян Опубліковано: January 19, 2010 at 07:53 Опубліковано: January 19, 2010 at 07:53 Ну база та же, что и была раньше, а вот мускуль вечно матюкается, что что-то не может записать. Щас попробую поставить ветку 5.0хх, отпишусь, помогло или нет...
morfey Опубліковано: February 9, 2010 at 20:29 Опубліковано: February 9, 2010 at 20:29 Стоїть mysql-server-5.0.89, СТГ 2.406 в stargazer.log жодного error
madf Опубліковано: February 10, 2010 at 08:57 Автор Опубліковано: February 10, 2010 at 08:57 Стоїть mysql-server-5.0.89, СТГ 2.406 в stargazer.log жодного error Мабуть залежить від карми
nightfly Опубліковано: February 10, 2010 at 09:20 Опубліковано: February 10, 2010 at 09:20 поточної фази місяця, популяції лемурів та нечіпання sgconf заєвий раз
morfey Опубліковано: February 10, 2010 at 13:33 Опубліковано: February 10, 2010 at 13:33 Мабуть залежить від карми поточної фази місяця, популяції лемурів та нечіпання sgconf заєвий раз 100%
yKpon Опубліковано: February 10, 2010 at 18:00 Опубліковано: February 10, 2010 at 18:00 в будущих релизах хотелось бы видеть опцию "Не снимать абонплату" в свойствах клиента
Рекомендованные сообщения