Перейти к содержимому
Local

Рекомендованные сообщения

Добрый день

 

Имеется работающий ubilling 0.8.8 rev 6006

ponizator + бдком + opt82 - все работает

Подключил zte c300, добавил в разделе свич оборудование с описание ОЛТ (снмп шаблон выбрал zte 320 ГПОН)

айпишка пингуется с биллинга

 

на ЗТЕ есть работающие 3 онушки но при опросе олт - в понизаторе, в списке неизвестных ону нету ону с ЗТЕ.. только с бдком

с билинга запустил snmpwalk на zte - посыпались данные

 

дальше поковырялся и в папке billing/exports вижу файлы с опросами ОЛТ

так вот файлы от бдкома вижу 5 штук (distance, fdb, signals, onuindex, onuinterface) 

а вот от zte c300 только один IDOLT_OLTSIGNALS (посмотрел что внутри а там все верно - 3 онушки и ихние сигналы)

 

но в понизаторе в таблице zte c300 пусто

такое ощущение что в файле snmp не правильные MIBs указаны

 

поделитесь инфо, или шаблоном snmp

версия firmware zte c300 1.2.5

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

там не реализовано всё что есть для бдкома.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Но саму онушку, уровень сигнала, MAC адрес в понизаторе должно быть видно ?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ZTE C320 - шаблон для епон

ZTE C320 GPON - шаблон для гпон

 

сами выберайте что вам нужно.

 

4 часа назад, camchatix сказал:

Но саму онушку, уровень сигнала, MAC адрес в понизаторе должно быть видно ?

 

Ну если онушку создать - то да, будет видно. Для гпона там ещё обязательно нужно ввести серийник.

Изменено пользователем l1ght

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Выбрал ZTE C320 GPON 

MIBs которые в шаблоне - не подходят k C300

только один из них верный - в billing/exports только один файлик генерируется

а их дожно быть судя по другим ОЛТ файликам 5 штук

 

я взял из snmptemplates/ZTE C320_GPON  mibs вручную snmpwalk прошелся

и почти на все mibs которые в шаблоне получаю ошибку

.1.3.6.1.4.1.3902.1015.1010.11.2.1.2.: Unknown Object Identifier (Sub-id not found: enterprises -> )

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
14 минут назад, camchatix сказал:

Выбрал ZTE C320 GPON 

MIBs которые в шаблоне - не подходят k C300

А так сразу и не скажешь.

 

ztec300.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
19 минут назад, camchatix сказал:

MIBs которые в шаблоне - не подходят k C300

Подходят. И к 220 и к 320 и к 300.

Во первых: у вас таки EPON или GPON?

Во вторых: в доке написано как настраивать снмп для зте.

В третьих: куча оидов не доступны напрямую и через snmpwalk нихера не увидите.

В четвертых: не будет оно показывать неизвестные ONU для зте. Ровно как и дистанцию.

Изменено пользователем l1ght

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

у нас GPON

snmp по документации настраивал - 3 команды ввел - на все 3 ответ - successful

только один из MIBs подошел

тот который уровни сигналов показывает (есть файл billing/exports/OLTSIGNALS)

снмп работает, один из показателей дошли до билинга а остальные нет 

подскажите пожалуйста где копать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
7 минут назад, camchatix сказал:

у нас GPON

snmp по документации настраивал - 3 команды ввел - на все 3 ответ - successful

только один из MIBs подошел

тот который уровни сигналов показывает (есть файл billing/exports/OLTSIGNALS)

снмп работает, один из показателей дошли до билинга а остальные нет 

подскажите пожалуйста где копать ?

Рассказываю.

Опрос происходит по серийнику. Но механика такова, что мак адрес онушки или чего угодно (хоть абонентский) нужно вбивать.

 

image.png.41fa074f6c6910021ecbb84922a538bb.png

 

Вот на картинке видно какие данные добавлены для гпон.

Ну и всё что в доке указано, remoteapi и прочее.

По серийнику: в конце доки расписаны режимы работы для гпон.

Правится непосредственно файл снмп шаблона (billing/config/snmptemplates).

Строка: SNMODE. 

 

image.png.0367d972bdeae35b4f74bd0e74bc6d1b.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Понял. Только теперь догнал что нужно самому вводить серийник и МАК

Иду пробовать

 

А так как с БДКОМ - чтобы при опросе  было видно онушки и маки (show gpon onu uncfg) - есть шанс в нашем уютном убилинге увидеть %) ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 минут назад, camchatix сказал:

А так как с БДКОМ - чтобы при опросе  было видно онушки и маки (show gpon onu uncfg) - есть шанс в нашем уютном убилинге увидеть %) ?

смотри здесь:

http://wiki.ubilling.net.ua/doku.php?id=zteonureg

Изменено пользователем a_n_h
  • Like 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Незареганные онушки по зте только в моем коммерческом модуле, да.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тоесть даже если на ЗТЕ я ОНУ добавлю - в билинге надо вручную серийники и маки писать?

А если с коммерческим модулем - тогда на полу-автомате ону на зте добавит и в биллинге видно будет ОНУ ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
9 минут назад, camchatix сказал:

Тоесть даже если на ЗТЕ я ОНУ добавлю - в билинге надо вручную серийники и маки писать?

А если с коммерческим модулем - тогда на полу-автомате ону на зте добавит и в биллинге видно будет ОНУ ?

Потрудитесь доку почитать и понять как оно работает.

Цитата

Так же стоит отметить, что если указать логин существующего пользователя - то для данной ONU создастся запись в ПОНизаторе. Можно оставить пустым, тогда в ПОНизатор ничего не внесется.

Сейчас при регистрации ОНУ из биллинга на ОЛТ можно её так же добавить и в понизатор и связать с конкретным пользователем (модуль для регистрации ону). Вообще я думал добавить галку "добавить в понизатор" или что-то в таком духе, но пока тоже заявок на это дело нет.

Онушки в понизатор добавляются ручками в большинстве своем. Вы можете написать скрипт который будет импортить то что вам нужно. Но это не предусмотрено в базовом функционале. Как именно вы будете забирать данные с ОЛТов и как будете импортить в БД - уже ваши проблемы.

Ибо онушки всё равно мигрируют между олтами и прочий АДъ. Следить за актуальностью данных всё равно нужно.

 

Нет мы не заббикс и не любая другая система мониторинга и даже не пытаемся ими прикидываться. У нас нет автодискавери всего чего угодно и прочих плюшек.

Паутине надо было для бдкома какие-то штуки - он их написал и они пошли в апстрим.

Лично ко мне заказов и вообще такого рода просьб не поступало, я не делал. И что-то смотрю никто больше не горит желанием реализовать.

А когда поковыряете ЗТЕ - то пойемете какой там "классный" SNMP.

Изменено пользователем l1ght

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поделитесь MIB-ами для ZTE 320?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

  • Похожие публикации

    • Автор: ronin_zp
      Доброй ночи.

      Пытаюсь настроит динамический шейпер, но он не отрабатывает. С помощью tcpdump выловил такое
      /queue/simple/set id=*1E2.=  max-limit=11000k/11000k.=burst-limit=k/11000k.=  burst-threshold=8800k/8800k.=burst-time=0/0
      trap(=message=failure: no download-burst-time  done.

      Чего ему не хватает?
       
    • Автор: sape4000
      Здравствуйте! Подскажите как сделать чтобы при выгрузке  файлов добавлять время выгрузки пример ABONENTS_yyyyMMdd_HHmm.csv
    • Автор: sape4000
      Здравствуйте!, Поставили мы биллинг без настройки nas, как теперь включить поддержку и доустановить nas на этом же сервере где и ubilling
    • Автор: mohax_kh_ua
      Добрый день.
      Пробую в тестовом режиме связку Ubilling + Mikrotik DHCP + multigen. Добавлен один НАС, заведено 3 абонента. Настроены следующие атрибуты:

      Столкнулся с такой проблемой, после запуска команды '/bin/ubapi "multigen"' в табличке mlg_reply чередуется количество атрибутов.
      Первый запуск:
      mysql> select * from mlg_reply; +----+-------------------+-----------------------+----+-----------------+ | id | username | attribute | op | value | +----+-------------------+-----------------------+----+-----------------+ | 1 | 20:47:da:8f:eb:96 | Session-Timeout | = | 7200 | | 2 | 20:47:da:8f:eb:96 | Framed-IP-Address | = | 10.10.10.2 | | 3 | 20:47:da:8f:eb:96 | Mikrotik-Rate-Limit | = | 100000k/100000k | | 4 | 20:47:da:8f:eb:96 | Mikrotik-Address-List | = | ALLOW | | 5 | 14:88:40:82:80:77 | Mikrotik-Rate-Limit | = | 100000k/100000k | | 6 | 14:88:40:82:80:77 | Framed-Pool | = | pool1 | | 7 | 14:88:40:82:80:77 | Mikrotik-Address-List | = | DOWN | | 8 | 14:88:40:82:80:77 | Session-Timeout | = | 120 | | 9 | 14:88:14:89:88:30 | Session-Timeout | = | 7200 | | 10 | 14:88:14:89:88:30 | Framed-IP-Address | = | 10.10.10.4 | | 11 | 14:88:14:89:88:30 | Mikrotik-Rate-Limit | = | 100k/100k | | 12 | 14:88:14:89:88:30 | Mikrotik-Address-List | = | ALLOW | +----+-------------------+-----------------------+----+-----------------+ Второй запуск:
      mysql> select * from mlg_reply; +----+-------------------+---------------------+----+-----------------+ | id | username | attribute | op | value | +----+-------------------+---------------------+----+-----------------+ | 2 | 20:47:da:8f:eb:96 | Framed-IP-Address | = | 10.10.10.2 | | 3 | 20:47:da:8f:eb:96 | Mikrotik-Rate-Limit | = | 100000k/100000k | | 5 | 14:88:40:82:80:77 | Mikrotik-Rate-Limit | = | 100000k/100000k | | 6 | 14:88:40:82:80:77 | Framed-Pool | = | pool1 | | 10 | 14:88:14:89:88:30 | Framed-IP-Address | = | 10.10.10.4 | | 11 | 14:88:14:89:88:30 | Mikrotik-Rate-Limit | = | 100k/100k | +----+-------------------+---------------------+----+-----------------+ Третий запуск вернет первую табличку, но будут изменены часть id-шников.
      При этом в биллинге никаких изменений не делаю.
      Что я делаю не так, и как побороть это?
       
    • Автор: revomix
      Привет, используем модуль CORPS, проблема с добавление денег через платежные системы, добавляються деньги только основному пользователю, хотя если из билинга добавлять деньги то добавляються всем связаным пользователям, подскажите как исправить?
×