Jump to content
Local
Sign in to follow this  
VadimS7

MikroTik Hotspot

Recommended Posts

Есть задача настроить hotspot средствами routeros, что б был показ сайта 5-10 секунд, после - доступ в сеть. Есть идеи как реализовать?

Share this post


Link to post
Share on other sites

прочитать вики микротика, где все описано

Share this post


Link to post
Share on other sites
8 часов назад, dmkhn сказал:

прочитать вики микротика, где все описано

Тс_ ахуел, да же вики от разработчика не почитал. Сразу же полез на форум, создавать тему. Да и Гугл никто не запрещал 

Share this post


Link to post
Share on other sites
9 часов назад, VadimS7 сказал:

Есть задача настроить hotspot средствами routeros, что б был показ сайта 5-10 секунд, после - доступ в сеть. Есть идеи как реализовать?

 

Если найдёшь как, напиши.

Я так и не нашёл ответа. Не работает на новых мобильных устройствах

@joker85 охуел тут ты наверное

Edited by EvilGenius

Share this post


Link to post
Share on other sites
1 час назад, EvilGenius сказал:

Если найдёшь как

hotspot / trial / advertise

1 час назад, EvilGenius сказал:

Не работает на новых мобильных устройствах

что именно не работает? сферический конь в вакууме?

Share this post


Link to post
Share on other sites
В 14.05.2019 в 09:13, dmkhn сказал:

hotspot / trial / advertise

что именно не работает? сферический конь в вакууме?

Нет, всего лишь сразу закрывает редирект на сайт. Самсунги, яблоки.

Share this post


Link to post
Share on other sites
56 минут назад, EvilGenius сказал:

...всего лишь сразу закрывает редирект на сайт.

после авторизации? CNA? не удивительно, этот алгоритм в них изначально заложен. именно поэтому рекламу нужно показывать ДО ввода логина/пароля...

Share this post


Link to post
Share on other sites
1 час назад, dmkhn сказал:

после авторизации? CNA? не удивительно, этот алгоритм в них изначально заложен. именно поэтому рекламу нужно показывать ДО ввода логина/пароля...

Речь о описанном Вами выше hotspot / trial / advertise .

Опишу для Вас подробнее: При подключении к вафле, нужно показать страничку заведения (кафе,рестораны, пабы и тд.) Так вот, на современных девайсах идёт редирект и сразу (еще даже до загрузки страницы) закрывается и даёт доступ. Причем на старых девайсах всё отрабатывает как положенно

Edited by EvilGenius

Share this post


Link to post
Share on other sites

я использую собственное решение, одна из функций которого, как раз возможность дать клиенту полюбоваться рекламной страницей до того, как попасть в тырнет. правда, это биллинг, своя (а не встроенная) страница авторизации и т.д. и т.п. 

вот уж не знаю, старый ли девайс - дочкин айфон хэ, но все он показывает и рассказывает. и на старых девайсах типа моего китайского ведроида все тоже срабатывает аналогично...

Видео на ютубе , показывает (в том числе) страницу с "рекламой", выводимую до возможности авторизации (которая ОТОБРАЖАЕТСЯ на мобильных девайсах), гостевую бесплатную авторизацию (которую можно настроить на автоматическое выполнение) и второй показ "рекламы", уже после авторизации (в качестве рекламы указан новостной сайт, КОТОРЫЙ ДА, НЕ ПОКАЗЫВАЕТСЯ НА МОБИЛЬНЫХ ДЕВАЙСАХ, т.к. они закрывают свое приложение, например, тот же CNA, как только унюхивают, что уже подключились к интернету)...

Share this post


Link to post
Share on other sites

Так я о том же,  просто отправлять в вики микрота в данном случае не совсем корректно.

Edited by EvilGenius

Share this post


Link to post
Share on other sites

вики микротика - это базис, который нужно прочесть, понять, и на основе этой информации слепить то, что хочется.

100500 раз мне по самым разным поводам говорили - "мы пробовали, ничего не получится". и я согласно кивал головой ровно до того момента, когда у меня не появлялся стимул сделать то, про что мне говорили "не получится". да, не всегда "с пол-пинка", но получалось... 

 

в озвученном вами случае, повторюсь, нужно НЕ АВТОРИЗОВАТЬ юзера до того, как он отсмотрит вашу инфо- (или ркламо-) страницу, иначе, да, авторизатор захлопывается, но реализация всего этого "блекджека с ...." все-равно базируется ИМЕННО на функциях, описанных в вики микротика

Share this post


Link to post
Share on other sites

Ничего в вики микротика реально нужного по построению правильного Hot Spot  и тем более с рекламой нет, как и в самом микротике  как в точке доступа. 

Вы вообще не понимаете, что такое хотспот, как он работает, и что для этого нужно от точки доступа. У микротика для реализации хотспота мало что есть. Как SOHO   для дома для семьи - может быть и приемлем - для сисадминов дома:),  а так слишком  он сложен для простого юзера, а работает хуже голимого тплинка. Сам по себе Микротик  ни архитектурно, ни функционально,  ни по радиодоступу,   как точка вайфай доступа HotSpot (публичный доступ в общественных местах, и тем более на улице) -непригоден.   

ЗЫ

А типа собственное решение на базе конструктора Микротик - это все строится  на костылях , работает через пень- колоду и  тупиковый путь 

 

Edited by Alver
  • Thanks 1

Share this post


Link to post
Share on other sites

ежели руки из жопы, то оправдание завсегда найдётся

Share this post


Link to post
Share on other sites
37 минут назад, Triam сказал:

ежели руки из жопы, то оправдание завсегда найдётся

Микротик по современным требованиям  ( как вайфай и ШБД) и есть полная жопа. 10 лет назад- не вопрос. Сейчас - полный отстой и шлак.

Edited by Alver

Share this post


Link to post
Share on other sites
В 16.05.2019 в 09:08, dmkhn сказал:

после авторизации? CNA? не удивительно, этот алгоритм в них изначально заложен. именно поэтому рекламу нужно показывать ДО ввода логина/пароля...

Подскажите, мне просто показать страницу с рекламой + ввод номера или Email человека который подключается к сети. 

Ввода пароля логина от человека не нужно. 

После этого предоставить доступ. 

Как реализовать что бы на яблоках и самсунгах работало? На huawei \ honor так же не работает. 

Share this post


Link to post
Share on other sites
1 час назад, Alver сказал:

Микротик по современным требованиям  ( как вайфай и ШБД) и есть полная жопа. 10 лет назад- не вопрос. Сейчас - полный отстой и шлак.

Ваши варианты? Что есть лучше микротика за такую же цену и функционал?

Share this post


Link to post
Share on other sites
6 часов назад, Володя сказал:

Ваши варианты? Что есть лучше микротика за такую же цену и функционал?

Смотрите на функционал, а потом на цену из тех что подходят. Будете делать наоборот - потратитесь дважды и все равно не будет работать как надо.

Сразу нужно вычеркнуть из рассмотрения  домашние вайфай роутеры ( AP SOHO).  Вам нужен AP Enterprise.

7 часов назад, olnet сказал:

 страницу с рекламой + ввод номера или Email человека который подключается к сети. 

 

Чья эта реклама ? Ваша на вашем сервере?

Вы разделите вопросы редиректа на Captive portal и возврата к запросу  http ( не говоря даже про проблему https)  и  то , что точка доступа глючит с аппл.

Edited by Alver

Share this post


Link to post
Share on other sites
48 минут назад, Alver сказал:

Смотрите на функционал, а потом на цену из тех что подходят. Будете делать наоборот - потратитесь дважды и все равно не будет работать как надо.

Сразу нужно вычеркнуть из рассмотрения  домашние вайфай роутеры ( AP SOHO).  Вам нужен AP Enterprise.

То-есть Микротик фигня, но производителя посоветовать не можете?

 

В моем случае всё проще, я такое могу сделать на кинетике при авторизации пользователей, но для Украины не подойдёт 

Edited by Володя

Share this post


Link to post
Share on other sites

От точки доступа нужно только делать редирект клиента на Captive Portal после  подключения к ТД и набора клиентом http запроса. Это умеют делать многие точки доступа , в том числе Микротик. Все остальное должен делать сервер, на который делается редирект.

У Микротика проблема не в редиректе, это может делать ТД или то, что микротик называет контролером доступа - Капсман ( если ТД не одна). Но проблемы Микротика даже не только в том что он плохо работает с Apple, что он не тянет больше 10 клиентов на ТД ( ТС может это и не нужно) , слабая антенна и др. ,а в том что в он на самом то деле реально не имеет функциональности для  построения сети HotSpot, он не вписывается в архитектуру правильно построенной сети HotSpot. Да, он типа гибкий, но  там  все делается на костылях и плохо ( глючит)  работает в сети в целом.

Share this post


Link to post
Share on other sites
1 час назад, Alver сказал:

От точки доступа нужно только делать редирект клиента на Captive Portal после  подключения к ТД и набора клиентом http запроса. Это умеют делать многие точки доступа , в том числе Микротик. Все остальное должен делать сервер, на который делается редирект.

У Микротика проблема не в редиректе, это может делать ТД или то, что микротик называет контролером доступа - Капсман ( если ТД не одна). Но проблемы Микротика даже не только в том что он плохо работает с Apple, что он не тянет больше 10 клиентов на ТД ( ТС может это и не нужно) , слабая антенна и др. ,а в том что в он на самом то деле реально не имеет функциональности для  построения сети HotSpot, он не вписывается в архитектуру правильно построенной сети HotSpot. Да, он типа гибкий, но  там  все делается на костылях и плохо ( глючит)  работает в сети в целом.

Спрошу третий раз: Что можете посоветовать взамен Микротика?

Share this post


Link to post
Share on other sites
9 минут назад, Володя сказал:

Спрошу третий раз: Что можете посоветовать взамен Микротика?

Сейчас будут спойлеры!

У этого товарища все сводится к одному. Все бренды говно! Но вот священная "Камбала" - панацея,решение всех проблем. Одна беда, хочет он за свои "решения" очень не мало денег.[/spioler]

Share this post


Link to post
Share on other sites
13 минут назад, pashid сказал:

Сейчас будут спойлеры!

  Показать содержимое

У этого товарища все сводится к одному. Все бренды говно! Но вот священная "Камбала" - панацея,решение всех проблем. Одна беда, хочет он за свои "решения" очень не мало денег.[/spioler]

Судя по тому, что ее не советуют - она не имеет нужного функционала

Share this post


Link to post
Share on other sites

Камбала в отличии от тыка хоть тянет больше юзверей. проверено!

Share this post


Link to post
Share on other sites

Cambium E410/600 indoor, E500/501S/502S outdoor имеет  весь необходимый  функционал для работы HotSpot. Это уровень Enterprise и стоит  по деньгам   как Enterprise и дешевле других ТД тоже Enterprise типа Cisco, Ruckus, Aruba.

Кто хочет посмотреть как Cambium работает в качестве HotSpot - бесплатный доступ с просмотром клиентом рекламы ( 10 сек перед входом в Интернет) - приходите, например,  на Крещатик, Майдан Незалежности в Киеве.  Бесплатный вайфай  со  скоростью  до 130Мbps (OOKLA speedtest) - на  планшет, 70Mbps -на смартфон  на удалении до 100- 150метров. Но такая дальность не востребована ,  на улице и  на площади стоят несколько точек доступа с роумингом, происходит переключение клиента handover  на дальности  до 70-100 метров (так выбран порог переключения по уровню сигнала).  

Есть  Cambium ePMP 1000 Integrated HotSpot 2.4 Ггц с близким к E серии функционалом за $100. Все что надо, включая редирект на Captive Portal c просмотром  рекламы и роуминг есть.

Edited by Alver

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NaviNavi
      Добрый вечер всем. Подскажите как на микротике ограничить например скачивание в день больше чем 1 Гб трафика для вифи клиентов, после скачивания чтоб скорость понижалась например до 1 мегабита. С микротиками не очень дружу так что попрошу не пинать сильно
    • By Polzovatel_009
      АБСОЛЮТНО НОВЫЙ!!!
      MikroTik CCR1036-8G-2S+EM является маршрутизатором операторского класса с мощным 36-ти ядерным процессором Tilera CPU!

      Беспрецедентная мощность и непревзойденная производительность — его главные характеристики, это устройство новый флагман. Более чем в 20 раз мощнее предыдущей топ-модели, CCR1036-8G-2S+EM поддерживает пропускную способность до 24 млн. пакетов в секунду, или до 16 Гигабит — полной скорости.

      Устройство поставляется в корпусе 1U в 19" стойку, имеет два порта SFP+, восемь портов Gigabit Ethernet, консольный порт и порт USB. Цветной сенсорный экран отображает состояние устройства, графики трафика, и обеспечивает доступ к простым параметрам конфигурации.

      Маршрутизатор имеет два слота SODIMM, поставляется с 16 ГБ оперативной памяти.

      CCR1036-8G-2S+EM работает на RouterOS, полнофункциональной операционной системе маршрутизатора, которая постоянно совершенствовалась в течение пятнадцати лет. Динамическая маршрутизация, точки доступа, брандмауэр, MPLS, VPN, передовые качества обслуживания, балансировки нагрузки и связи в реальном времени, настройки и мониторинга — это только некоторые из огромного количества функций, поддерживаемых RouterOS.
      _
      Абсолютно новый, с коробки не доставался, нигде не стоял. Покупался в зип, не понадобился.
       
      ЦЕНА 21000 грн.
    • By vovam
      Продам залишки wifi обладнання. Не використовується кілька років. Стан не відомий. Перевірити не маю на чому.
      Ціна 50грн за штуку.
       
       

    • By vegas.firestorm
      Добрый день!
      решил поднять на своем Микротике PPTP Всё делал по этой инструкции - https://howitmake.ru/blog/waildhand/176.html
       
      Разве что в правиле на файрволе для порта 1723 указал In. Interface List - WAN
       
      К ВПН-у конектится, но не видит никаких ресурсов внутри сети. Можете подсказать, что нужно ещё сделать, чтобы пользователь, который конектится по ВПН, видел всё внутри сети?
       
       
      Конфиг роутера:
       
      /interface bridge
      add arp=proxy-arp name=bridge1
      /interface pptp-server
      add name=pptp-in1 user=""
      /interface list
      add name=WAN
      add name=LAN
      /interface wireless security-profiles
      set [ find default=yes ] supplicant-identity=MikroTik
      /ip pool
      add name=dhcp ranges=192.168.77.10-192.168.77.154
      add name=vpn ranges=192.168.77.200-192.168.77.250
      /ip dhcp-server
      add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
      /interface bridge port
      add bridge=bridge1 interface=ether2
      add bridge=bridge1 interface=ether3
      add bridge=bridge1 interface=ether4
      add bridge=bridge1 interface=ether5
      add bridge=bridge1 interface=ether6
      add bridge=bridge1 interface=ether7
      add bridge=bridge1 interface=ether8
      add bridge=bridge1 interface=ether9
      add bridge=bridge1 interface=ether10
      add bridge=bridge1 interface=ether11
      add bridge=bridge1 interface=ether12
      /interface l2tp-server server
      set enabled=yes ipsec-secret=(IPSECSecret) use-ipsec=yes
      /interface list member
      add interface=ether1 list=WAN
      add interface=bridge1 list=LAN
      /interface pptp-server server
      set enabled=yes
      /interface sstp-server server
      set default-profile=default-encryption enabled=yes
      /ip address
      add address=111.111.55.102/24 comment=defconf interface=ether1 network=\
          111.111.55.0
      add address=192.168.77.1/24 interface=ether2 network=192.168.77.0
      /ip cloud
      set ddns-enabled=yes ddns-update-interval=1h
      /ip dhcp-client
      add dhcp-options=hostname,clientid interface=ether1
      add dhcp-options=hostname,clientid interface=ether1
      /ip dhcp-server network
      add address=192.168.77.0/24 gateway=192.168.77.1 netmask=24
      /ip dns
      set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4,9.9.9.9,1.1.1.1
      /ip firewall filter
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      /ip firewall nat
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      /ip route
      add distance=1 gateway=111.111.55.254
      add distance=1 gateway=111.111.55.254
      /lcd
      set backlight-timeout=2m
      /lcd pin
      set pin-number=1111
      /ppp secret
      add local-address=192.168.77.1 name=vpn password=vpnvpn profile=\
          default-encryption remote-address=192.168.77.200 service=pptp
      /system clock
      set time-zone-name=Europe/Kiev
    • By andrey-r
      Доброго времени суток, камрады
       
      Нужна помощь админа с опытом настройки роутеров микротик routeros
      Разовые заказы. Появилась потребность - поставил задачи, сделали, заплатил. Раз в 2-3 месяца.
       
      В частности сейчас нужно на один порт (или на сеть) дать гарантированный канал не менее 20мбит
      И на остальные порты (сети) дать не более 80мбит.
      Чтобы вип абонент имел гарантированный канал при 100% нагрузке канала.
       
      Кто поможет?
      Связь тут или Вайбер/телеграм по номеру 0937672229
       
×