Jump to content

Ubilling- Nas Mikrotik Radius (IP MAC)


Recommended Posts

Доброго вечора. Система Ubilling 1.0.4 rev 7269 Freebsd,  Nas Mikrotik 6.44.6 Radius DHCP. Налаштував все по мануалу. Проблема така після зміни mac клієнта,на старому mac видається іп та швидкість, після видалення користувача з білінгу теж саме! Що не так ????

1.jpg.0c8f1475cdb0dd9704e2f8a0de462ee0.jpg2.jpg.5c858070cd96e3fb4026d9ed5751476b.jpg3.thumb.jpg.2ea8879d71696a3993d2c171ccb5c22d.jpg

Link to post
Share on other sites

присутнє в кроні.

*/2 * * * *    root /bin/ubapi "multigen"

Після дабавлення в крон

*/5 * * * *    root /bin/ubapi "multigentotal"

  - все запрацювало!

Але я так зрозумів, так немає бути!?

Edited by wowanv
Link to post
Share on other sites
13 часов назад, wowanv сказал:

Після дабавлення в крон


*/5 * * * *    root /bin/ubapi "multigentotal"

Настільки дурна ідея, наскільки це можливо.

Такі штуки викликати можна якось хіба що так: 30 2 * * * і не частіше.

 

 

Link to post
Share on other sites
13 часов назад, wowanv сказал:

Але я так зрозумів, так немає бути!?

При видаленні користувача - спочатку його деактивація виставленням флагів down/alwaysonline у відповідний стан та примусова регенерація атрибутів.

Що далі з цими відомостями, буде робити конкретно ваш НАС - вже нікого не хвилює.

Link to post
Share on other sites
7 часов назад, nightfly сказал:

При видаленні користувача - спочатку його деактивація виставленням флагів down/alwaysonline у відповідний стан та примусова регенерація атрибутів.

Що далі з цими відомостями, буде робити конкретно ваш НАС - вже нікого не хвилює.

Як бути із зміною мак???

Edited by wowanv
Link to post
Share on other sites
1 час назад, nightfly сказал:

Слати POD при зміні, нє?

не, это ж дхцп который игнорит PoD/CoA

ему смотреть в сторону POD_ON_MAC_CHANGE который заодно и базу апдейтит

Edited by l1ght
Link to post
Share on other sites
2 минуты назад, l1ght сказав:

ему смотреть в сторону POD_ON_MAC_CHANGE который заодно и базу апдейтит

А я о чем? Или там при вызове он экстернал эвентс полного регена не происходит?

Edited by nightfly
причина-хуичина
Link to post
Share on other sites
14 минут назад, nightfly сказал:

Или там при вызове он экстернал эвентс полного регена не происходит?

полного нет, замена только конкретных аттрибов для конкретного юзера

Edited by l1ght
Link to post
Share on other sites
29 минут назад, l1ght сказав:

полного нет, замена только конкретных аттрибов для конкретного юзера

Если хорошо подумать, то де факто после смены мака, новый - становится новым юзернеймом, а старый себе валяется мертвеньким грузом до следующей multigentotal. В нормальных условиях, это не должно приводить ни к каким последствиям, так как новый юзер уже должен быть авторизован со всеми своими актуальными атрибутами относительно своего нового юзернейма. Если же старый мак уехал к какому-то другому юзеру (ну не знаю, роутер допустим, потащили в соседнюю квартиру) и он будет навешан на соответствующего пользователя из соседней квартиры - тоже ничего страшного не произойдет, все потроха будут регенерированы с этим же юзернеймом по новому через две минуты и все должно быть чики. Когда там вызовется следующая авторизация (по дискавер/ренью же, да? или только по таймауту на микротах?) уже тоже не наша проблема и в целом не важна. Если же старый МАК никуда не утащили... ну повисит он до тотального регена и все, либо просто повисит. Кому какое дело?

 

Итого я окончательно потерялся в попытках найти какую-то драматическую драму в этой всей механике и с чем так героически борется ТС. Мож ему просто лишних 3 рекорда в базе жмут - я хз.

Link to post
Share on other sites
  • 1 year later...

добрый день возникла необходимость настроить RADIUS NAS MikroTik DHCP (IP + MAC) все делаю как в монуале https://wiki.ubilling.net.ua/doku.php?id=mgmikrotikdhcp

но пользователи не получают IP адресса с ubilling в чем может быть причина где  и что надо подправить

 

image.thumb.png.d6b33ced33cfbd70966803595450f092.png

 

 

 

image.thumb.png.415ef8c50e6a1ec98e98f613c2098a46.png

 

image.thumb.png.9e60c7339a6bfe3a472be2abaa6b4e0e.png

image.thumb.png.9c414e74005e85674b4dd4e1ca87ad8c.png

 

 

image.thumb.png.a3b14f318ac0377d416fcd5f3e461426.png

 

image.thumb.png.e475dec870370b29e8052cdd0f62c09c.png

image.thumb.png.da1d0a77c25f09a73226f3df704b61d7.png

 

image.thumb.png.d2deb57b33cd369618a460dc38e177eb.png

  

image.png

Link to post
Share on other sites
  • 1 month later...

доброй ночи кто не будь настраивал  Ubilling- RADIUS NAS MikroTik DHCP (IP + MAC)  как настроить у кого есть опыт в настройке подскажите как и что делать уже несколько месяцев бьюсь о стену не могу настроить   

Link to post
Share on other sites
9 часов назад, Vitaliy1984 сказал:

доброй ночи кто не будь настраивал  Ubilling- RADIUS NAS MikroTik DHCP (IP + MAC)  как настроить у кого есть опыт в настройке подскажите как и что делать уже несколько месяцев бьюсь о стену не могу настроить   

Ответил в личку

Link to post
Share on other sites
  • 4 months later...
В 05.10.2021 в 10:30, datakrava сказал:

Ответил в личку

Можно и мне в личку ответить. 
Не получается сделать связку Ubilling - MikroTik IPoE
Месяц мучаюсь, не как не настрою

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By metiz4
      Куплю  MIKROTIK 2011UiAS-2HnD-IN или подобный. Б/у либо новый не очень дорого.
      050пят66ноль1пять6. Либо в личку.
    • By B0BER
      Продам за ненадібністю дві штуки LHG XL 5 AC бу. Ціна за штуку 2000 грн. При купівлі пари скидка. Є стандартна проблема з защолкою(5фото), вирішується не складно саморізом як на 3 фото. Свою ціну можете писати лічку.





    • By Pasha_admin
      Доброго дня, колеги.
      Очі з орбіт повипадають, вже третій день не можу запустити VRRP. Хоча здається та що ж там запускать?
       
      Два мікротика (CHR, v7.2.3, на віртуалках vmware). На ether1 інет. Адреси на інтерфейсах ether2 - 10.20.4.5/24 і 10.20.4.7/24.
      Створив інтерфейс vrrp1 на інтерфейсі ether2 на обох роутерах.
      Призначив і там і там на інтерфейсі vrrp1 10.20.4.1/32. Виставив priority на першому 255, на другому 100.
      Запустив.
       
      R1 - master, R2 - backup. Вимикаю ether2 на R1 протягом секунди R2 стає master, і навпаки. Ніби все красиво.
       
      З машини 10.20.4.10 не пінгується а ні 10.20.4.1, а ні інет. Якщо на машині 10.20.4.10 виставляю вручну шлюз за замовчуванням 10.20.4.5 або 7, тоді пінг на 10.20.4.5 або 7 є, інет є.
       
      Що може бути? Чи це такий v7-stable?
       
      Update: в ESXi у віртуальному свитчі дозволив "Promiscuous mode" і "MAC address changes" (знайшов на форумах що без цього не запустится), поки що без змін
    • By ProstoName
      На віртуалці протестуав перехід ubilling на mysql57. Здається, все нормально. Можливо, потрібні ще якісь специфічні настройки mysql?
    • By DAnEq
      купил точки доступа mikrotik cap ac и mikrotik hex poe lite
      конечная цель сделать бесшовный роуминг

      в мануалах везде указано что делается либо с помощью caspman либо с помощью mesh
      когда купил, прочитал, что в помощью capsman бесшовный роуминг сделать нельзя (в моем видении это когда точки сами смотрят на какой из них сигнал от клиента сильнее и переключают клиента сами без потери пакетов), можно лишь выставить чтобы точка принудительно отключала клиента с сигналом меньше заданого уровня, чтобы он переключился на более сильную точку (и думаю это будет с потерей пакетов)
      вопрос 1 - правда ли это ?

      вопрос 2
      включил на роутере cap, точку доступа поставил в такой же режим
      в итоге точка доступа айпи адрес получает, а клиент не получает, хоть на роутере попытки подключения видны
      на точке доступа поставил все интерфейсы в бридж
      конфиги сейчас приложу

      конфиг роутера
       
      /interface bridge add admin-mac=2C:C8:1B:C4:5D:AF auto-mac=no comment=defconf name=bridge /interface pppoe-client add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 password=0294 service-name=pppoe1 \ use-peer-dns=yes user=05710831 /caps-man interface add configuration.mode=ap configuration.ssid=RiOni disabled=no l2mtu=1600 mac-address=DC:2C:6E:B8:44:4E \ master-interface=none name=cap1 radio-mac=DC:2C:6E:B8:44:4E radio-name=DC2C6EB8444E \ security.authentication-types=wpa2-psk security.encryption=aes-ccm security.passphrase=88888888 add configuration.load-balancing-group="" configuration.mode=ap configuration.ssid=RiOni disabled=no l2mtu=1600 \ mac-address=DC:2C:6E:B8:44:4F master-interface=none name=cap2 radio-mac=DC:2C:6E:B8:44:4F radio-name=DC2C6EB8444F \ security.authentication-types=wpa2-psk security.encryption=aes-ccm security.passphrase=88888888 /interface list add comment=defconf name=WAN add comment=defconf name=LAN /interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik /ip pool add name=dhcp ranges=192.168.88.10-192.168.88.254 add name=cap1 ranges=192.168.1.0/24 /ip dhcp-server add address-pool=dhcp disabled=no interface=bridge name=defconf add address-pool=dhcp disabled=no interface=cap1 name=cap1 add address-pool=dhcp disabled=no interface=cap2 name=cap2 /caps-man manager set enabled=yes /interface bridge port add bridge=bridge comment=defconf interface=ether2 add bridge=bridge comment=defconf interface=ether3 add bridge=bridge comment=defconf interface=ether4 add bridge=bridge comment=defconf interface=ether5 add bridge=bridge disabled=yes interface=all /ip neighbor discovery-settings set discover-interface-list=LAN /interface list member add comment=defconf interface=bridge list=LAN add comment=defconf interface=ether1 list=WAN add interface=pppoe-out1 list=WAN /ip address add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0 /ip dhcp-client add comment=defconf interface=ether1 /ip dhcp-server network add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1 /ip dns set allow-remote-requests=yes /ip dns static add address=192.168.88.1 comment=defconf name=router.lan /ip firewall filter add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=\ established,related,untracked add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1 add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=\ established,related,untracked add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \ connection-state=new in-interface-list=WAN /ip firewall nat add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN /system clock set time-zone-name=Europe/Kiev /system package update set channel=long-term /tool mac-server set allowed-interface-list=LAN /tool mac-server mac-winbox set allowed-interface-list=LAN
      конфиг точки доступа
      /interface bridge add admin-mac=DC:2C:6E:B8:44:4C auto-mac=no comment=defconf name=bridgeLocal /interface wireless # managed by CAPsMAN # channel: 2447/20-eC/gn(28dBm), SSID: RiOni, CAPsMAN forwarding set [ find default-name=wlan1 ] ssid=MikroTik # managed by CAPsMAN # channel: 5200/20-eCee/ac(14dBm), SSID: RiOni, CAPsMAN forwarding set [ find default-name=wlan2 ] ssid=MikroTik /interface list add name=WAN add name=LAN /interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik /ip hotspot profile set [ find default=yes ] html-directory=hotspot /interface bridge port add bridge=bridgeLocal comment=defconf interface=ether1 add bridge=bridgeLocal comment=defconf interface=ether2 add bridge=bridgeLocal interface=wlan2 add bridge=bridgeLocal interface=wlan1 /interface list member add interface=ether1 list=WAN add interface=ether2 list=LAN add interface=wlan2 list=LAN add interface=wlan1 list=LAN /interface wireless cap # set bridge=bridgeLocal discovery-interfaces=bridgeLocal enabled=yes interfaces=wlan1,wlan2 /ip dhcp-client add comment=defconf disabled=no interface=bridgeLocal /system clock set time-zone-name=Europe/Kiev

      что делаю не так ?
       
×
×
  • Create New...