Jump to content
Local
wowanv

Ubilling- Nas Mikrotik Radius (IP MAC)

Recommended Posts

Доброго вечора. Система Ubilling 1.0.4 rev 7269 Freebsd,  Nas Mikrotik 6.44.6 Radius DHCP. Налаштував все по мануалу. Проблема така після зміни mac клієнта,на старому mac видається іп та швидкість, після видалення користувача з білінгу теж саме! Що не так ????

1.jpg.0c8f1475cdb0dd9704e2f8a0de462ee0.jpg2.jpg.5c858070cd96e3fb4026d9ed5751476b.jpg3.thumb.jpg.2ea8879d71696a3993d2c171ccb5c22d.jpg

Share this post


Link to post
Share on other sites

ну для начала убедится что регенерация аттрибутов происходит с вызовом ubapi

  • Like 1

Share this post


Link to post
Share on other sites

присутнє в кроні.

*/2 * * * *    root /bin/ubapi "multigen"

Після дабавлення в крон

*/5 * * * *    root /bin/ubapi "multigentotal"

  - все запрацювало!

Але я так зрозумів, так немає бути!?

Edited by wowanv

Share this post


Link to post
Share on other sites
13 часов назад, wowanv сказал:

Після дабавлення в крон


*/5 * * * *    root /bin/ubapi "multigentotal"

Настільки дурна ідея, наскільки це можливо.

Такі штуки викликати можна якось хіба що так: 30 2 * * * і не частіше.

 

 

Share this post


Link to post
Share on other sites
13 часов назад, wowanv сказал:

Але я так зрозумів, так немає бути!?

При видаленні користувача - спочатку його деактивація виставленням флагів down/alwaysonline у відповідний стан та примусова регенерація атрибутів.

Що далі з цими відомостями, буде робити конкретно ваш НАС - вже нікого не хвилює.

Share this post


Link to post
Share on other sites
7 часов назад, nightfly сказал:

При видаленні користувача - спочатку його деактивація виставленням флагів down/alwaysonline у відповідний стан та примусова регенерація атрибутів.

Що далі з цими відомостями, буде робити конкретно ваш НАС - вже нікого не хвилює.

Як бути із зміною мак???

Edited by wowanv

Share this post


Link to post
Share on other sites
1 час назад, nightfly сказал:

Слати POD при зміні, нє?

не, это ж дхцп который игнорит PoD/CoA

ему смотреть в сторону POD_ON_MAC_CHANGE который заодно и базу апдейтит

Edited by l1ght

Share this post


Link to post
Share on other sites
2 минуты назад, l1ght сказав:

ему смотреть в сторону POD_ON_MAC_CHANGE который заодно и базу апдейтит

А я о чем? Или там при вызове он экстернал эвентс полного регена не происходит?

Edited by nightfly
причина-хуичина

Share this post


Link to post
Share on other sites
14 минут назад, nightfly сказал:

Или там при вызове он экстернал эвентс полного регена не происходит?

полного нет, замена только конкретных аттрибов для конкретного юзера

Edited by l1ght

Share this post


Link to post
Share on other sites
29 минут назад, l1ght сказав:

полного нет, замена только конкретных аттрибов для конкретного юзера

Если хорошо подумать, то де факто после смены мака, новый - становится новым юзернеймом, а старый себе валяется мертвеньким грузом до следующей multigentotal. В нормальных условиях, это не должно приводить ни к каким последствиям, так как новый юзер уже должен быть авторизован со всеми своими актуальными атрибутами относительно своего нового юзернейма. Если же старый мак уехал к какому-то другому юзеру (ну не знаю, роутер допустим, потащили в соседнюю квартиру) и он будет навешан на соответствующего пользователя из соседней квартиры - тоже ничего страшного не произойдет, все потроха будут регенерированы с этим же юзернеймом по новому через две минуты и все должно быть чики. Когда там вызовется следующая авторизация (по дискавер/ренью же, да? или только по таймауту на микротах?) уже тоже не наша проблема и в целом не важна. Если же старый МАК никуда не утащили... ну повисит он до тотального регена и все, либо просто повисит. Кому какое дело?

 

Итого я окончательно потерялся в попытках найти какую-то драматическую драму в этой всей механике и с чем так героически борется ТС. Мож ему просто лишних 3 рекорда в базе жмут - я хз.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vegas.firestorm
      Добрый день!
      решил поднять на своем Микротике PPTP Всё делал по этой инструкции - https://howitmake.ru/blog/waildhand/176.html
       
      Разве что в правиле на файрволе для порта 1723 указал In. Interface List - WAN
       
      К ВПН-у конектится, но не видит никаких ресурсов внутри сети. Можете подсказать, что нужно ещё сделать, чтобы пользователь, который конектится по ВПН, видел всё внутри сети?
       
       
      Конфиг роутера:
       
      /interface bridge
      add arp=proxy-arp name=bridge1
      /interface pptp-server
      add name=pptp-in1 user=""
      /interface list
      add name=WAN
      add name=LAN
      /interface wireless security-profiles
      set [ find default=yes ] supplicant-identity=MikroTik
      /ip pool
      add name=dhcp ranges=192.168.77.10-192.168.77.154
      add name=vpn ranges=192.168.77.200-192.168.77.250
      /ip dhcp-server
      add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
      /interface bridge port
      add bridge=bridge1 interface=ether2
      add bridge=bridge1 interface=ether3
      add bridge=bridge1 interface=ether4
      add bridge=bridge1 interface=ether5
      add bridge=bridge1 interface=ether6
      add bridge=bridge1 interface=ether7
      add bridge=bridge1 interface=ether8
      add bridge=bridge1 interface=ether9
      add bridge=bridge1 interface=ether10
      add bridge=bridge1 interface=ether11
      add bridge=bridge1 interface=ether12
      /interface l2tp-server server
      set enabled=yes ipsec-secret=(IPSECSecret) use-ipsec=yes
      /interface list member
      add interface=ether1 list=WAN
      add interface=bridge1 list=LAN
      /interface pptp-server server
      set enabled=yes
      /interface sstp-server server
      set default-profile=default-encryption enabled=yes
      /ip address
      add address=111.111.55.102/24 comment=defconf interface=ether1 network=\
          111.111.55.0
      add address=192.168.77.1/24 interface=ether2 network=192.168.77.0
      /ip cloud
      set ddns-enabled=yes ddns-update-interval=1h
      /ip dhcp-client
      add dhcp-options=hostname,clientid interface=ether1
      add dhcp-options=hostname,clientid interface=ether1
      /ip dhcp-server network
      add address=192.168.77.0/24 gateway=192.168.77.1 netmask=24
      /ip dns
      set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4,9.9.9.9,1.1.1.1
      /ip firewall filter
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      /ip firewall nat
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      /ip route
      add distance=1 gateway=111.111.55.254
      add distance=1 gateway=111.111.55.254
      /lcd
      set backlight-timeout=2m
      /lcd pin
      set pin-number=1111
      /ppp secret
      add local-address=192.168.77.1 name=vpn password=vpnvpn profile=\
          default-encryption remote-address=192.168.77.200 service=pptp
      /system clock
      set time-zone-name=Europe/Kiev
    • By andrey-r
      Доброго времени суток, камрады
       
      Нужна помощь админа с опытом настройки роутеров микротик routeros
      Разовые заказы. Появилась потребность - поставил задачи, сделали, заплатил. Раз в 2-3 месяца.
       
      В частности сейчас нужно на один порт (или на сеть) дать гарантированный канал не менее 20мбит
      И на остальные порты (сети) дать не более 80мбит.
      Чтобы вип абонент имел гарантированный канал при 100% нагрузке канала.
       
      Кто поможет?
      Связь тут или Вайбер/телеграм по номеру 0937672229
       
    • By Spiritok42
      Компанія Gazik запрошує до співпраці !
      великий асортимент товару  доступні ціни гарантія 1 рік !!! швидка доставка придбати обладнання з ПДВ! привезти обладнання під замовлення!  
                  ТОП продаж!!!
      MikroTik RB941-2nD                                19,99$
      MikroTik RBD52G-5HacD2HnD-TC         63$  
      MikroTik RB2011UiAS-2HnD-IN              113,85$ 
      MikroTik RBcapGI-5ACD2nD                   61$ 
      Точка доступу UBNT UAP-AC-LITE        85,56$
      Точка доступу UBNT UAP-AC-LR          105,22$   
      Контроллер UBNT UC-CK                      81,85$  
      Точка доступу UBNT LBE-M5-23           47$  
      Точка доступу UBNT PBE-M5-400         86,65$ 
       
      Наш прайс: GAZIK PRICE local.xlsx
       
      За детальною інформаціє звертайтеся:
      - tel. viber: +38 098 886 63 06
      - skype: live:spiritok42

    • By maxkorn
      Вопрос может быть уже задавался на форуме, но ответа я так и не нашел
      Ubilling  установлен на убунту
      /var/www/billing/
      скрипт autoubupdate.sh лежит в каталоге /var/www/
      конфиг:
      #dialog DIALOG="/usr/bin/dialog" #fetch software FETCH="/usr/bin/wget" #pwd command PWD="/bin/pwd" # path to your apache data APACHE_DATA_PATH="/var/www/" # ubilling path UBILLING_PATH="./billing/" #kill default admin account after update? DEFADM_KILL="NO" #use DN online detection? DN_ONLINE_LINKING="YES" #update log file LOG_FILE="/var/log/ubillingupdate.log" При запуске выдает ошибку: Wrong current directory
       
      Может кто-нибудь подсказать, хоть в какую сторону копать
       


    • By golohvostiy
      RB433GL - 800 грн
      RB800 - 2000 грн
      R52Hn - 500 грн (2 шт)
      R52n-M - 600 грн
      NetMetal 5 (RB922UAGS-5HPacD-NM) - 2300 грн
      Под роутерборды есть герметичные корпуса - 400 грн (2 шт)
      SXT Lite5 (RBSXT5nDr2) - отдам даром (питание подаётся, он включается, но сеть не видит)
       
×