Jump to content

Triolan MAC Mikrotik


Recommended Posts

Вітаю шановне товариство! Маю напіввирішену проблему з вищевказаним провайдером і EPON підключенням.

Суть проблеми полягає в тому що періодично і рандомно на Мікротіку відвалюється з'єднання і самостійно відновлюється.

Сетап: 1) ONU Picotel PU-E910, 2) Mikrotik HEX

 

Тріолан наливає інет зі статичною адресою і прив'язкою по МАС. 

На мікроті все стандартно: виділив порт під WAN, насетапив адресу, склонував МАС ноута (спочатку по швидкому тестили інет на ноуті тому його МАС і вбили в білінг), правило НАТу вписав - інет є. 

Потім рандомно почав відвалюватись інет. В логах геть нічого. Порт мікрота не змінював статус. 

Перевірив налаштування - все типово. І ніяких глюків чи помилок не виявлено.

Заміна порта мікрота, прошивка, заміна на інший мікрот (новий з коробки зі скинутим конфігом, налаштований лише з одним правилом НАТу) ніяк не покращили ситуацію. 

Представник саппорта прийшов і замінив ОНУшку. Теж не допомогло. При спілкуванні представника саппорта по телефону з мережевим інженером з'ясувалось що відвал стається саме тоді, коли мікрот перестає передавати свій МАС. Не бачимо маку, нема авторизації, логічно. 

З ноутом на пряму все працює без зауважень. На моє питання: "що може бути?" представник саппорта розвів руками і запропонував роутер "не мікротік")))) Мене такий варік не влаштовує, тому що на моєму роутері побудована і пачка тунелів на роботу і до батьків. 

Почав розбиратись сам, що пробував: 1) ставити чек гетвея пінгами, 2) чек arp запитами, 3) отримувати адресу і по дхцп (так, писав про статику, знаю. Але це рекомендація Тріолану. Взагалі у них працює ДХЦП, але при зникненні світла з ДХЦП є проблеми в них. Тому лишився на статиці), 4) інші мікроти, 5) інші блоки живлення, 6) інші кабелі utp. Все це не мало позитивного результату і не міг відслідкувати що саме спричиняє проблему. 

 

Що допомогло: 1) створив брідж. 2) на брідж прописав майстер-МАС який закріплений в білінгу, 3) відключив на цьому бріджі оновлення МАС, 4) на цей брідж прописав адресу і т.д. 4) вкинув порт, до якого підключена ОНУ, в цей брідж без ніяких налаштувань взагалі, 5) правило срцнат. 

Диво, все працює і аптайм уже більше тижня. При спілкуванні з саппортом все ОК, вони бачать валідний МАС (МАС бріджа).

 

Шановне товариство, допоможіть розібратись: чому схема яка допомогла - працює, а типове налаштування веде до обривів? Дякую за ідеї.

 

 

 

Edited by denisluk
  • Thanks 1
Link to post
Share on other sites

змінить блок живлення на ону. Всі ваши налаштування це місконфіг..

Edited by Sandorik
  • Haha 1
Link to post
Share on other sites
5 minutes ago, Sandorik said:

змінить блок живлення на ону. Всі ваши налаштування це місконфіг..

Дякую, та міняв і БЖ і ОНУ. Результат один і той же. Тому це виключено

Link to post
Share on other sites
17 minutes ago, Sandorik said:

тоді підключить ону через юсб тіка та перезавантажуйте ону. пінайте тріолан

Та пінаю, вони толком нічого сказати не можуть))))) При тому що на цей мікрот заходить і другий провайдер міддю))) і там таких проблем нема. Просто цікаво чому через брідж працює, а через порт без бріджа ні.

Link to post
Share on other sites

А яку роль відіграє мікротік відносно 2-го каналу: як маршрутизатор чи як свіч?

 

Я підозрюю що у вас можливі проблеми з налаштуваннями мікротіка ймовірність 80% . Також не виключаю заводського браку 20%.

 

Але щоб аналізувати потрібно дивитися на ваші "причудливі" налаштування і перевіряти їх конфлікти з сумісністю з іншими налаштуваннями, які ви помістили на ROUTER OS!

 

Підозрюю що їх там не мало. 

Кидайте сюди конфіг і може хтось з форуму допоможе.

 

Можете писати в приват. Думаю можна для початку подивитись , а потім вже обговоримо що не гараз і що заважає

Edited by SavPasha
Link to post
Share on other sites
6 часов назад, carver сказав:

помогла замера медной SFP cisco, которая 300USD стоила,

на что-то фирменное, но дешевое. тиап Finisar там

Я твои посты читаю, каждый раз как в зоопарке побывал.

  • Like 3
  • Haha 4
Link to post
Share on other sites
годину тому, KaYot сказав:

Я твои посты читаю, каждый раз как в зоопарке побывал.

Та я написал уже у человека дыра в голове поэтому и посты такие будто бы сбежал с дурки и постить что то пытается 

  • Like 2
Link to post
Share on other sites

І з приватної переписки і діагностики знайшли проблему в протоколі (R)STP на стороні провайдера. 

 

Подальші діагностика і проблеми будуть вирішуватись на стороні провайдера. 

 

  • Like 2
Link to post
Share on other sites
В 12.06.2024 в 21:25, SavPasha сказал:

І з приватної переписки і діагностики знайшли проблему в протоколі (R)STP на стороні провайдера. 

 

Подальші діагностика і проблеми будуть вирішуватись на стороні провайдера. 

 

Т.е. микрот по умолчанию срет stp( ну дык да, по дефолту и срет) в сторону провайдерского порта. Пров пудак, микротовод кросавец. В прочем ничего нового. И похер шо некоторые бошки умебт все эти стп тупо глобально. Виноват же пров. А не абориген фиг зна чего натыкавший у себя.

Edited by nedoinet
  • Like 1
  • Confused 1
Link to post
Share on other sites
23 часа назад, nedoinet сказав:

Т.е. микрот по умолчанию срет stp( ну дык да, по дефолту и срет) в сторону провайдерского порта. Пров пудак, микротовод кросавец. В прочем ничего нового. И похер шо некоторые бошки умебт все эти стп тупо глобально. Виноват же пров. А не абориген фиг зна чего натыкавший у себя.

Насправді. Якраз із включеним протоколом STP працює без проблем . Якщо вимкнути його, або переналаштувати на фізичний порт починаються проблеми із звязком.

Edited by SavPasha
Link to post
Share on other sites
19 часов назад, SavPasha сказал:

Насправді. Якраз із включеним протоколом STP працює без проблем . Якщо вимкнути його, або переналаштувати на фізичний порт починаються проблеми із звязком.

Ещё раз, пожалуйста. При чем тут стп? Что с ним нужно сделать? Стп если порт не в бридже?

Link to post
Share on other sites
3 часа назад, Kiano сказал:

Ещё раз, пожалуйста. При чем тут стп? Что с ним нужно сделать? Стп если порт не в бридже?

Да походу на порту включен стп, провайдерская железка видит пакет и блочится. 

Link to post
Share on other sites
В 12.06.2024 в 21:25, SavPasha сказал:

І з приватної переписки і діагностики знайшли проблему в протоколі (R)STP на стороні провайдера. 

 

Подальші діагностика і проблеми будуть вирішуватись на стороні провайдера. 

 

Так на мікротіку є різні версії протоколу. І взагалі вимкніть заради експерименту.

Link to post
Share on other sites
16 часов назад, nvr сказав:

Так на мікротіку є різні версії протоколу. І взагалі вимкніть заради експерименту.

Он с выключенным stp продолжает ими срать во все линки. Был такой опыт, пришлось на своей циско выключать stp на этот влан с микротиком, иначе линк в случайные моменты падал пару раз в сутки.

Link to post
Share on other sites

насколько помню, такой прикол был лишь на каких-то прошивках, достаточно давно. Снова "имплементировали"? Не баг, а фича

Link to post
Share on other sites

Может уже починили. Но опять же, им у всех железок разные версии сорта доступны и не все обновляют в принципе.

Года 2 назад делали транспорт омеге и их клиенту, пока не потушили стп - не взлетало.

Инженеры омеги так и сказали, с микротиком на другой стороне это обычная грабля.

Link to post
Share on other sites

А не путаете ли вы стп с луп-детектом? Вот его когда микроты внедрили, то на первых прошивках с ним были проблемы. Потом починили вроде. По умолчанию он дефолт, но насколько помню, при этом он активен. Можно на порту перевести в положение офф. И вот луп детект как раз без бриджа и работает. А стп и его разновидности - только с бриджом. 

  • Sad 1
Link to post
Share on other sites

Спасибо всем неравноодушным к теме! Собрав всю инфу и отсюда и то что нарыл сам в этих ваших Интернетах обратился к провайдеру, но не через саппорт, а через линкера наныл номер сетевого инженера местного, ответственного за данный участок. В беседе изложил суть проблемы, Инженер сказал: "ок, понял, ожидайте". Через 10 минут перенабрал и попросил снести конфиг с бриджем и перевести все настройеи на порт микрота. Сделал, несколько суток аптайма есть без проблем. На вопрос что было - ответ "настройка порта с нашей стороны". Ясен хер что отморозился. Вопрос почему так было - открыт. Ну да и хер с ним))))) Главное - результат. Инет работает стабильно. ЗЫ: я пудаком провайдера не называл и не говорил что микротовод - красавец)))) Я столкнулся с проблемой, которую пытался решить самостоятельно и даже частично решил, хоть и через пень-колоду. Из-за нехватки знаний обратился на профильный форум к скилловым форумчанам. Ибо подобные кейсы для меня - бесценный опыт.

Edited by denisluk
Link to post
Share on other sites
2 minutes ago, Туйон said:

Зачем вообще Вы засунули "WAN-порт" в бридж? 

При типичной настройке, когда в роли WAN выступает порт, ловил отвал инета. Просто рандомно отваливалось соединение. Такая ситуация повторялась на 3х железках (hex, cap ac, 931й), которые были под рукой. И помню что когда - то мне рассказывали про реализацию WAN через бридж. Создается бридж, на него навешиваются все настройки, а в этот бридж уже пихается порт. Решил попробовать. Помогло на всех 3-х железках, которые подкидывал к онушке для теста. Прошивка 7.15 чуть что). Да, при этом на бридже был включен STP. если его вырубить - то опять же проблема возвращалась. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...