Jump to content
Local
Tapac)

Выделение нескольки адресов для NAT (mikrotik)

Recommended Posts

подскажите  как сделать чтоб  локальные клиенты, допустим 192.168.88.0/24, на выходе из микротика в инет подписывались разными белыми адресами?

Share this post


Link to post
Share on other sites

или натить в пул может хотели ?

post-16245-0-94276700-1508757631_thumb.png

Edited by DemonidZe

Share this post


Link to post
Share on other sites

использовать РСС - https://wiki.mikrotik.com/wiki/Manual:PCC

сильно по процу ударит, по собственному опыту утверждаю

 

 

или натить в пул может хотели ?

самый простой и рабочий вариант

но лучше не в пул, а каждое правило под каждый ип

главное в условиях укажите кого куда

Share this post


Link to post
Share on other sites

 

использовать РСС - https://wiki.mikrotik.com/wiki/Manual:PCC

сильно по процу ударит, по собственному опыту утверждаю

 

 

или натить в пул может хотели ?

самый простой и рабочий вариант

но лучше не в пул, а каждое правило под каждый ип

главное в условиях укажите кого куда

 

я так и сделать ))

Share this post


Link to post
Share on other sites
PCC (ну или ECMP) - могут быть спецэффекты (к примеру, каждые 10 минут может меняться белый ип для клиента %) Игроки за такое просто убъют).

 

Исправлюсь.

Спецэффекты при ECMP (там периодически может сбрасываться ECMP cache. Из-за чего не факт, что в следующий раз для того же клиента будет выбран тот же гейт).

А вот в случае PCC этого уже нет - для того же набора src/dst (IP:port) должен выбираться тот же гейт.

В случае NAT походу тот же принцип.

PS: я у себя через маркировку + src-nat раскидываю по разным каналам/адресам, но у меня нагрузка совсем не та, что у провайдеров %). 40 челоевк в офисе это не пару тысяч.

Edited by BlackVS

Share this post


Link to post
Share on other sites

 

 

или натить в пул может хотели ?

самый простой и рабочий вариант

но лучше не в пул, а каждое правило под каждый ип

главное в условиях укажите кого куда

Голосую за этот вариант.

Но при условии, что все белые ип на одном интерфейсе (так как src-nat в postrouting).

Если на разных, то, наверное, проще всего через Route Rules привязать, кто кудой.

PCC (ну или ECMP) - могут быть спецэффекты (к примеру, каждые 10 минут может меняться белый ип для клиента %) Игроки за такое просто убъют).

 

не микротик скорее всего натит с опцией  --persistent мы используем пулы от 5-10 ипишек ни разу небыло проблем, за натом по 1-3к абонов

Share this post


Link to post
Share on other sites

Короче.

На Микротике NAT Pool M серых на N белых делается с помощью action "same" с указанием диапазона типа белых адресов nat to: "х.х.х.х-у.у.у.у" либо сети с маской (например, х.х.х.х/24), если блок белых адресов укладывается в эту подсеть.

Ставится галочка "not by dst"

Желаемый результат гарантирую.

Share this post


Link to post
Share on other sites

Короче.

На Микротике NAT Pool M серых на N белых делается с помощью action "same" с указанием диапазона типа белых адресов nat to: "х.х.х.х-у.у.у.у" либо сети с маской (например, х.х.х.х/24), если блок белых адресов укладывается в эту подсеть.

Ставится галочка "not by dst"

Желаемый результат гарантирую.

посмотрел -- там не "nat to", а "To Addresses:"

Share this post


Link to post
Share on other sites

nat --to-source a.b.c.d/24 --persistent делает то же :-)

Share this post


Link to post
Share on other sites

выше подсказали, но для более понятного ответа

 

chain=srcnat action=src-nat to-addresses=1.1.1.13 src-address=192.168.0.101-192.168.0.110 

Share this post


Link to post
Share on other sites

Я использую РСС прям в правилах НАТ. Работает хорошо.

Share this post


Link to post
Share on other sites

выше подсказали, но для более понятного ответа

 

chain=srcnat action=src-nat to-addresses=1.1.1.13 src-address=192.168.0.101-192.168.0.110 

так не будет то, что нужно

беру свой кусок конфига:

 

/ip firewall address-list
add address=10.0.96.0/19 list=grey_pool
add address=***.***.***.***/28 list=service
add address=***.***.***.***/25 list=service
 
/ip firewall nat
add action=same chain=srcnat comment="NAT Pool ***.***.***.1-***.***.***.254" dst-address-list=!service same-not-by-dst=yes src-address-list=grey_pool to-addresses=***.***.***.1-***.***.***.254

Share this post


Link to post
Share on other sites

А чем плоха классика?

Например

nat 8001 config if vlan1 same_ports deny_in ip 194.0.0.31

nat 8002 config if vlan2 same_ports deny_in ip 194.0.0.32
nat 8003 config if vlan3 same_ports deny_in ip 194.0.0.33
add 10011 nat 8001 ip from 10.180.101.0/24 to not 10.180.101.0/24 out xmit vlan1
add 10012 nat 8001 ip from any to 194.0.0.31 in via vlan1

 add 10021 nat 8002 ip from 10.180.102.0/24 to not 10.180.102.0/24 out xmit vlan2
add 10022 nat 8002 ip from any to 194.0.0.32 in via vlan2

add 10031 nat 8003 ip from 10.180.103.0/24 to not 10.180.103.0/24 out xmit vlan3
add 10032 nat 8003 ip from any to 194.0.0.33 in via vlan3

 

На данном уровне все равно балансировка трафика происходит статически.

Share this post


Link to post
Share on other sites

А чем плоха классика?

Например

nat 8001 config if vlan1 same_ports deny_in ip 194.0.0.31

nat 8002 config if vlan2 same_ports deny_in ip 194.0.0.32

nat 8003 config if vlan3 same_ports deny_in ip 194.0.0.33

add 10011 nat 8001 ip from 10.180.101.0/24 to not 10.180.101.0/24 out xmit vlan1

add 10012 nat 8001 ip from any to 194.0.0.31 in via vlan1

 add 10021 nat 8002 ip from 10.180.102.0/24 to not 10.180.102.0/24 out xmit vlan2

add 10022 nat 8002 ip from any to 194.0.0.32 in via vlan2

add 10031 nat 8003 ip from 10.180.103.0/24 to not 10.180.103.0/24 out xmit vlan3

add 10032 nat 8003 ip from any to 194.0.0.33 in via vlan3

 

На данном уровне все равно балансировка трафика происходит статически.

сорян конечно, но каким боком оно к микротику?))

Share this post


Link to post
Share on other sites

 

выше подсказали, но для более понятного ответа

 

chain=srcnat action=src-nat to-addresses=1.1.1.13 src-address=192.168.0.101-192.168.0.110 

так не будет то, что нужно

беру свой кусок конфига:

 

/ip firewall address-list
add address=10.0.96.0/19 list=grey_pool
add address=***.***.***.***/28 list=service
add address=***.***.***.***/25 list=service
 
/ip firewall nat
add action=same chain=srcnat comment="NAT Pool ***.***.***.1-***.***.***.254" dst-address-list=!service same-not-by-dst=yes src-address-list=grey_pool to-addresses=***.***.***.1-***.***.***.254

 

как раз то что нужно, просто и все работает

post-27896-0-93799500-1509118808_thumb.png

Share this post


Link to post
Share on other sites

можно конечно и PCC но человек не спрашивал о балансировке

Share this post


Link to post
Share on other sites

 

 

выше подсказали, но для более понятного ответа

 

chain=srcnat action=src-nat to-addresses=1.1.1.13 src-address=192.168.0.101-192.168.0.110 

так не будет то, что нужно

беру свой кусок конфига:

 

/ip firewall address-list
add address=10.0.96.0/19 list=grey_pool
add address=***.***.***.***/28 list=service
add address=***.***.***.***/25 list=service
 
/ip firewall nat
add action=same chain=srcnat comment="NAT Pool ***.***.***.1-***.***.***.254" dst-address-list=!service same-not-by-dst=yes src-address-list=grey_pool to-addresses=***.***.***.1-***.***.***.254

 

как раз то что нужно, просто и все работает

 

У каждого свои задачи и свои вкусы, как он это хочет видеть.

Мне больше по душе 1 строка в закладке NAT, чем мелкая дрочь из сотни строк.

Кому-то нравится по-другому.

Мне надо огромное количество серых адресов занатить в /24 и не думать о ручных балансировках, кто через какой адрес ходит -- оно всё делает за меня само.

И не бояться, что у кого-то при посещении одного и того же ресурса вдруг сменится внешний ай-пи и будут глюки -- эта строка сама всё сама учитывает, и у всех геймеров, видеоманов и т.д. всё работает.

Мне не надо контролировать мелкие подсети, чтоб натились в определённый адрес.

Динамических пулов для выдачи на интерфейс абонента нет -- есть привязка серого адреса к абоненту. Если кого-то надо потом найти -- для этого всё собирается через netflow и потом можно посмотреть, кто, куда и когда ходил.

У кого-то другие задачи и вкусы -- делайте по-своему.

ТЧК.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Tornight
      Продам Mikrotik SXT Lite5 (SXT5nDr2), б.у., в рабочем состоянии. Комплект: блок питания, poe инжектор, сама точка и направляющая под трубостойку. В наличии 3 шт. Цена за одну - 600 грн. За все три - 1500 грн.
    • By NET-CREATOR
      Вітаю!
       
      Для невеликою модернізації потрібно таке обладнання
       
      1х Mikrotik hEX S (RB760iGS)
      2x Mikrotik RBcAPGi-5acD2nD
      1x бажано Mikrotik wAP ac BE (RBwAPG-5HacT2HnD-BE) на крайній випадок Mikrotik wAP ac BE (RBwAPG-5HacT2HnD-BE)
      1x TP-Link T2600G-28MPS (TL-SG3424P)
      1x Шафа Rack для монтажу на стіну 12U, глибина 350-400 мм.
      1х Rack група розеток 9 шт. з вимикачем, вилка звичайна
      1х патч-панель 1U 24 порти CAT5E з задньою планкою для кріплення кабелів
      2х організатор 1U закритого типу
       
      Додатково потрібні ціни на різні моделі NVR Dahua.
      Можливо у когось є камери IPC-HDW4433C-A, потрібно буде декілька і адаптери під них PFA-135.
       
      Прошу надсилати свої пропозиції в приватні повідомлення.
       
      Дякую
    • By Netassist
      есть в наличии /20  по 23 доллара за айпи 
      /24 по 5500 евро 
      2/22 по 21 доллар за айпи
    • By benjamin
      Продам маршрутизатор MikroTik RB2011UiAS-RM, роутер б/у но в отличном состоянии (полный комплект), цена 2600 грн, за информацией обращаться по телефону 0505267550 
    • By benjamin
      Продам маршрутизатор MikroTik RB2011UiAS-RM, роутер б/у но в отличном состоянии ( полный комплект), цена 2600 грн.
      за информацией обращаться по телефону 0505267550 
×