Jump to content

Pon Monitor - система мониторинга PON


Recommended Posts

  • Replies 331
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Вот решил выдать, кому интересно, собстветнную систему мониторинга PON сети - Pon Monitor. Сделана по аналогии с Poncontrol, но делалась по потребностям инженеров и монтажников.   Возмо

проект живой. Продвигается медленно, так как нет на него пока времени

Вот Pon Monitor под BDCOM GP3600-16 Берите кому нужно. Переделка не профессиональная, поэтому берите как есть Pon Monitor.rar

Posted Images

Доброго времени суток, друзья прошу помощи, имеем уст-во P3310B, установка Pon Monitor сложностей не вызвала, но при попытке добавить OLT пишет " SNMP не отвечает, проверьте! " Хотя snmp точно отвечает проверял snmpwalk, копаю дальше при нажатии на кнопку сохранить, сюда "http://my_ip/pm/scripts/check_snmp.php" летит запрос с мной вводимыми данными, итого вид " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public&communityrw=private " и тут же я получаю ошибку 500 если привожу строку к виду " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public " тоесть убираю из get " communityrw=private " то скрипт не выдаёт ошибку но соответственно настройки не сохраняются так как кнопка сохранить не была нажата из-за ошибки 500, подскажите куда копать?

Link to post
Share on other sites
8 минут назад, genadich сказал:

Доброго времени суток, друзья прошу помощи, имеем уст-во P3310B, установка Pon Monitor сложностей не вызвала, но при попытке добавить OLT пишет " SNMP не отвечает, проверьте! " Хотя snmp точно отвечает проверял snmpwalk, копаю дальше при нажатии на кнопку сохранить, сюда "http://my_ip/pm/scripts/check_snmp.php" летит запрос с мной вводимыми данными, итого вид " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public&communityrw=private " и тут же я получаю ошибку 500 если привожу строку к виду " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public " тоесть убираю из get " communityrw=private " то скрипт не выдаёт ошибку но соответственно настройки не сохраняются так как кнопка сохранить не была нажата из-за ошибки 500, подскажите куда копать?

лог нужен, смотреть ошибку можен нет модуля в php-snmp или что-то там еще.

  • Like 2
Link to post
Share on other sites
10 минут назад, Інет.укр сказал:

лог нужен, смотреть ошибку можен нет модуля в php-snmp или что-то там еще.

Да Вы правы, не было php-snmp упустил я этот момент, а вот без подсказки почему-то в лог не заглянулось))))))большое спасибо)))))

Link to post
Share on other sites
57 минут назад, genadich сказал:

Да Вы правы, не было php-snmp упустил я этот момент, а вот без подсказки почему-то в лог не заглянулось))))))большое спасибо)))))

спасибо через сердечко под постом.😎

Link to post
Share on other sites
46 минут назад, camchatix сказал:

Підскажіть чому такі крякозябри бачимо ?

міняв locale, пробував інші - 1251, koi8, utf...

 

на сервері є локаль uk_UA.utf8

r.png

кодування бази utf8?

Link to post
Share on other sites
3 часа назад, camchatix сказал:

створював просто - не працювало

удалив базу

створив заново - create database pon CHARACTER SET utf8 COLLATE utf8_general_ci;

і теж саме...

а web server віддає сторінку в правильному кодувані?

Link to post
Share on other sites

 

В 01.09.2019 в 20:21, a_n_h сказал:

"офтопну" - ну почему под ZTE 220 никто ничего не предлагает?!

В 04.09.2019 в 20:59, sape4000 сказал:

А что-то подобного под цдату ни кто не делал?

abills имеет поддержку ZTE/HUAWAI в бесплатной версии. Сейчас допиливают c-data

Edited by vector_zuriel
Link to post
Share on other sites
2 часа назад, Інет.укр сказал:

а web server віддає сторінку в правильному кодувані?

а як це провірити ?

 

странно те що внизу сторінки текст добрий

Українська - Русский IP: 91.22

 

на цьому сервері (freebsd 12) працює uBilling особовий кабінет, і 4 сайта на WordPres

нема ніде таких символів...

Link to post
Share on other sites
10 минут назад, vop сказал:

 

"View Page Info" -> "Text Encoding"

 

Firefox пише - 

 

Кодування - UTF-8

 

файл footer.php - видно техт добре

а інші файли з папки include - вже там НЕ UTF8...

 

загрузив версію 1.5

відкрив у Windows 10 файл - а там уже такі символи

 

echo '<td class="grey">Ethernet РїРѕСЂС‚ ID</td>';
 

Edited by camchatix
Link to post
Share on other sites

Еще хорошей функцией будет быстрый поиск всех неактивных ону по конкретной SFP, дерегистрация всей кучи (возможно выделение птичками) и кнопка сохранения конфига (это вроде есть) 

Link to post
Share on other sites
1 час назад, camchatix сказал:

Firefox пише - 

 

Кодування - UTF-8

 

файл footer.php - видно техт добре

а інші файли з папки include - вже там НЕ UTF8...

 

загрузив версію 1.5

відкрив у Windows 10 файл - а там уже такі символи

 

echo '<td class="grey">Ethernet РїРѕСЂС‚ ID</td>';
 

який редактор?

Link to post
Share on other sites

хм...... у notepad++ всьо добре видно...

перезалив файли на сервер - все одно..

в .htaccess ставлю AddCharset utf-8 .html .css .php .txt .js

ставклю в httpd.conf AddCharset  - тоже нич.... 

всьоравно крякозябри....

 

то не база

то буде апач мабуть

 

як то поправити ??

 

Link to post
Share on other sites
В 19.09.2019 в 23:05, camchatix сказал:

хм...... у notepad++ всьо добре видно...

перезалив файли на сервер - все одно..

в .htaccess ставлю AddCharset utf-8 .html .css .php .txt .js

ставклю в httpd.conf AddCharset  - тоже нич.... 

всьоравно крякозябри....

 

то не база

то буде апач мабуть

 

як то поправити ??

 

коли відкриваєте notepad++ там з низу є кодіровка також пише. 

Як закидуєте файли на сервер? якщо ви їх добуваєте з архіва на windows чи не краще wget https://pm.vm.net.ua/install/pm_v1.5.zip потім unzip pm_v1.5.zip і потім скопіювати куда потрібно і правити їх через nano/vim/ee/тощо?

можу спровбувати допомогти!

Link to post
Share on other sites

Тексти з бази - добре відображається..

А з PHP файлів техт кривий...

пробував і текстовий і двоїчний метод передачі файлів на сервер..

також unzip на стороні сервера.. все однаково

 

тут точно кодіровка зі сторони сервера кліенту криво передається. А як це провірити ?

phpinfo() показує default_charset - UTF-8

 

UPD: поставив на інший сервер - теж саме... %(

Edited by camchatix
Link to post
Share on other sites
18 часов назад, camchatix сказал:

Тексти з бази - добре відображається..

А з PHP файлів техт кривий...

пробував і текстовий і двоїчний метод передачі файлів на сервер..

також unzip на стороні сервера.. все однаково

 

тут точно кодіровка зі сторони сервера кліенту криво передається. А як це провірити ?

phpinfo() показує default_charset - UTF-8

 

UPD: поставив на інший сервер - теж саме... %(

 

Дайте сюда файл с кривым отображение в архиве, любой, главное чтобы он криво отображал текст.

 

В качестве небольшого отступления. Файлы могут быть сохранены не в кодировке UT-8, а к примеру в ANSI тогда текст в UT-8 может отображаться кракозяблами.

 

Вот Вам ссылка на онлайн декодер, где наглядно будет показано, что происходит:

http://www.online-decoder.com/ru

2019-09-21_02-56-12.png.c0ea5d5c916863ada82c91dddc625ae2.png

 

 

Посмотрите, в какой кодировке Вам страницу показывает браузер, измените, пока не увидите правильный текст. Откройте конф файлы апача и укажите верную кодировку в настройках AddDefaultCharset.

 

 

 

Edited by Darth Vader2
Link to post
Share on other sites
В 19.09.2019 в 19:32, camchatix сказал:

Firefox пише - 

 

Кодування - UTF-8

 

файл footer.php - видно техт добре

а інші файли з папки include - вже там НЕ UTF8...

 

 

 

Всё понятно, как я и писал выше, файлы все или некоторые в кодировке ANSI, перепишите их в кодировку UTF-8 и всё взлетит. Дайте мне любой файл, я его пересохраню в UTF-8 и проверите.

 

 

 

Edited by Darth Vader2
Link to post
Share on other sites
16 минут назад, vop сказал:

Ну только не ANSI. И, скорее всего, не ascii.Там нет кириллицы.

 

Это опечатка, суть предложения понятна.

 

В Windows под ANSI codepage обычно понимается «системная» кодировка. 
Она используется для не-юникодных программ. 
Для стандартной американской версии это CP 1252, для русской — CP 1251.

Хотя название и ссылается на стандарт ANSI, реально оно ничего общего со стандартом не имеет.

 

Edited by Darth Vader2
Link to post
Share on other sites

В силу того, что скучно, я нашел файл onu_detail.php, результат в браузере у меня:

 

Ethernet РїРѕСЂС‚ ID

 

Сейчас ради интереса буду искать у себя причину такого отображения.

 

p.s. дело в кодировке, по умолчанию на сервере windows-1251, а должно быть utf-8. Файл настроек апача или добавить в conf.d нужный конфигурационный файл. К примеру такой:

 

Alias /test /usr/share/test

<Directory /usr/share/test/>
AddDefaultCharset UTF-8
   AllowOverride All
   Order deny,allow
   Deny from All
   Allow from "ваш ip без кавычек"
</Directory>

После изменений:

 

Ethernet порт ID

 

Edited by Darth Vader2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Pasivka
      Продам залишки :
      - пігтейли :
      LC/UPS 1.5 м 72шт  - 4 грн/шт
      SC/UPC 1.5м 72шт  - 4грн/шт
      - адаптер SC/UPC 150шт/100грн
      - FOB-04-16    2шт   - 100грн/шт
      - Crosver Fosc-MB-338/24-1-12-9SC 6шт                               - 85грн/шт
      - дільник 1/8  30шт  - 85грн/шт








    • By Pasivka
      Продам залишки :
      - пігтейли :
      LC/UPS 1.5 м 72шт  - 4 грн/шт
      SC/UPC 1.5м 72шт  - 4грн/шт
      - адаптер SC/UPC 150шт/100грн
      - FOB-04-16    2шт   - 100грн/шт
      - Crosver Fosc-MB-338/24-1-12-9SC 6шт                               - 85грн/шт
      - дільник 1/8  30шт  - 85грн/шт








    • By Ilya016
      Проблема в следующем. Была задача от начальства перенести конфиг (Не важно как. Я перебил команды вручную) с p3310c на p3608.
      Уже раньше так делал, ничего вроде сложного (это не писать конфиг с нуля), но произошел конфуз... При замене с 33-ей на 36-ую устройство не поднялось. А именно какой-то косяк с приходом. Не регистрируется, удаленного доступа нет, трафик вроде даже не бегает. В чем может быть косяк? Настройки почти идентичные, лишь некоторые расхождений в синтаксисе (на мой оч. непрофессиональный взгляд). Кто сможет, помогите плз.
       
      конфиг 3310:
      !version 10.1.0E build 46085
      service timestamps log date
      service timestamps debug date
      service password-encryption
      logging buffered 4096
      !
      hostname **************
      port-protected 1
      !
      !
      !
      !
      ip default-gateway ***.***.171.1
      !
      !
      spanning-tree mode rstp
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      aaa authentication login default local
      aaa authentication enable default none
      aaa authorization exec default local
      !
      username admin password 7 ******************
      username user password 7 *****************
      !
      !
      epon oam-version 1 0x30
      epon oam-version 2 0x21
      epon oam-version 3 0x20
      !
      !!slot 0 89
      interface GigaEthernet0/1
       description Uplink_mikrotik
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/2
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/3
       shutdown
       description _
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/4
       description _
       switchport trunk vlan-allowed 176
       switchport mode trunk
      !
      interface GigaEthernet0/5
       description Storojka
       switchport trunk vlan-allowed 176,240
       switchport trunk vlan-untagged 240
       switchport pvid 240
      !
      interface GigaEthernet0/6
       description mikrotik_AC_monitoring
       switchport trunk vlan-allowed 171
       switchport mode trunk
        dhcp snooping trust
      !         
      !!slot end
      !         
      interface VLAN171
       description management
       ip address ***.***.171.10 255.255.255.0
      !         
      interface VLAN236
       no ip address
      !         
      interface VLAN239
       no ip address
      !         
      interface VLAN240
       no ip address
      !         
      !         
      !         
      vlan 1,70,171,173,175-176,232-240
      !         
       loopback-detection
      !         
      !         
      !         
      ip dhcp-relay snooping
      ip dhcp-relay snooping vlan  240
      !         
      !         
      ip http server
      !         
      !         
      !         
      snmp-server community 0 ******* ** 
      snmp-server community 0 ******* **** ******
      snmp-server contact ************
      snmp-server location *************
      !         
      line console 0
       length 256
       width 256
      !         
      line vty 0 1
       exec-timeout 0
       length 256
       width 256
      !         
      line vty 2 31
       exec-timeout 0
      !         
      !
      !
      ip sshd enabled
      !
      time-zone Moscow 3 0
      ntp query-interval 720
      ntp server ***.***.***.***
      !         
      !Pending configurations for absent linecards:
      !         
      !No configurations pending global
       
      Конфиг p3608:
      !version 10.1.0F build 72136
      service timestamps log date
      service timestamps debug date
      service password-encryption
      logging buffered 4096
      !
      hostname ***********
      port-protected 1
      !
      !
      !
      !
      !
      !
      spanning-tree mode rstp
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      aaa authentication login default local
      aaa authentication enable default none
      aaa authorization exec default local
      !
      username admin password 7 ****************************
      username user password 7 *************************
      !
      !
      !
      !
      epon oam-version 1 0x30
      epon oam-version 2 0x21
      epon oam-version 3 0x20
      !
      interface Null0
      !
      interface FastEthernet0/0
       shutdown
       ip address 192.168.0.1 255.255.255.0
       no ip directed-broadcast
      !
      !!slot 0 1 unknow CARD
      interface GigaEthernet0/1
       description Uplink_mikrotik_sfp
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/2
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/3
       shutdown
       description _
       switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
       switchport mode trunk
       switchport pvid 240
      !
      interface GigaEthernet0/4
       description _
       switchport trunk vlan-allowed 176
       switchport mode trunk
      !
      interface GigaEthernet0/5
       description Storojka
       switchport trunk vlan-allowed 176,240
       switchport trunk vlan-untagged 240
       switchport mode dot1q-tunnel-uplink
       switchport pvid 240
      !
      interface GigaEthernet0/6
       description mikrotik_AC_monitoring
       switchport trunk vlan-allowed 171
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/7
       description Uplink_mikrotik
       switchport trunk vlan-allowed 70,171,175-176,232-240
       switchport mode trunk
        dhcp snooping trust
      !
      interface GigaEthernet0/8
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      interface TGigaEthernet0/1
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      interface TGigaEthernet0/2
       shutdown
       switchport mode dot1q-tunnel-uplink
      !
      !
      !!slot end
      !
      interface VLAN171
       description management
       ip address ***.***.171.10 255.255.255.0
       no ip directed-broadcast
      !
      interface VLAN236
       no ip address
       no ip directed-broadcast
      !
      interface VLAN239
       no ip address
       no ip directed-broadcast
      !
      interface VLAN240
       no ip address
       no ip directed-broadcast
      !
      !
      !
      vlan 1,70,171,173,175-176,232-240
      !
       loopback-detection
      !
      !
      !
      !
      ip dhcp-relay snooping
      ip dhcp-relay snooping vlan  240
      !
      !
      !
      !
      !
      !
      ip route default ***.***.171.1
      ip exf
      !
      ipv6 exf
      !
      !
      ip http server
      !
      !
      !
      snmp-server community 0 ******* **
      snmp-server community 0 ***** *** *****
      snmp-server contact ***************
      snmp-server location *************
      !
      line console 0
       length 256
       width 256
      !
      line vty 0 1
       exec-timeout 0
       length 256
       width 256
      !
      line vty 2 31
       exec-timeout 0
      !
      !
      !
      ip sshd enable
      !
      time-zone Moscow 3 0
      ntp query-interval 720
      ntp server ***.***.***.***
      !
      !Pending configurations for absent linecards:
      !
      !No configurations pending global
       
       
      На 33-ей приход в 1 gigaethernet, на 36-ой в 7-ой gigaethernet, т.к. на ней нет медных портов до 5-го
    • By ssergiy
      Надаю послуги по розварюванню (сварці), зварюванню оптоволоконна, магістральних ВОЛЗ. Пошук пошкодження, втрати сигналу, вхідний контроль, контроль після прокладки та монтажу. При потребі виконаю виміри рефлектометром, оптичними тестерами.
      При потребі надам виконавчу документацію згідно КНД41-141-99.
      Досвід роботи по будівництву та монтажу ВОЛЗ, PON мережі.
      Ціна залежить від об'єму робіт.
      Можливий виїзд.
      т. 0959310003
    • By os8143385.com
      Продам OLT-и BDCOM у відмінному стані, у зв'язку з переходом на XPON.
      В наявності:
      BDCOM 3616-2TE - 1шт ( 1350 $ )
      BDCOM 3608-2TE - 1шт ( 650 $ )
      BDCOM 3608        - 1шт ( 500 $ )
      BDCOM 3310        - 3шт ( 300 $ )
      Курс 33 грн.
       



×
×
  • Create New...