Jump to content

Abills 0.55b + Mikrotik + PPPoE. Не заводится более одного pppoe сервера с одного микротика в разных вланах.


Recommended Posts

Здравствуйте. Такая история. Есть abills 0.55b и nas mikrotik. Количество абонентов растёт, и решено поделить сеть на вланы. В микротике добавил vlan'ы, на этих вланах добавил pppoe сервера. Вланы прокинул до абонентов. Маки в вланах вижу, но пппое сессии не поднимаются. Если выключаю работающий pppoe сервер, то начинает работать один из новосозданных. В общем одновременно более 1 pppoe сервера не работает.

Есть такая же связка в другом городе, только там стоит abills 0.54b. Там всё работает. Крутится 11 pppoe сервером и всё без проблем. 

Кто то с таким сталкивался?

 

mikr_ng_pppoe.JPG

mikr_ukr_pppoe.JPG

vlan_ng.JPG

vlan_ukr.JPG

ng_nas.JPG

ukr_nas.JPG

Link to post
Share on other sites

абилс то каким здесь боком ? Создайте локальную учетную запись на микротике и попробуйте работоспосбность.

а че там в логах у микротайка ?

картинки ваши просто ни о чем  не говорят 

  • Like 2
Link to post
Share on other sites

В логах микротика ошибку не пишет. Пишет только когда успешно подключается. Если запустить pppoe подключение, пишет ошибка 718 (удалённый компьютер не ответил во время). Если в настройках подключения указать имя сервиса pppoe сервера - у меня это service2, то подключение проходит сразу. Такое ощущение, что сессия упёрто долбится в первый запущенный pppoe сервер. А не в тот, который вещает в своём влане. Естественно обойти всех абонентов, и указать им конкретный service name не вариант от слова совсем.

Link to post
Share on other sites
38 минут назад, Xiovi сказал:

Если в настройках подключения указать имя сервиса pppoe сервера - у меня это service2, то подключение проходит сразу

Бред какой-то.

Зачем ты указываешь service name если его не используешь? Оно и не будет работать без указания у клиента, в этом смысл опции.

Удали у всех "серверов".

Link to post
Share on other sites
В 19.07.2020 в 12:41 PM, Schultz сказав:

Влани у бріджі?

Это пробовали ?

Таки попробуйте забриджевать вланы и повешать pppoe на бриджы.

Link to post
Share on other sites
12 часов назад, Xiovi сказал:

В логах микротика ошибку не пишет. Пишет только когда успешно подключается. Если запустить pppoe подключение, пишет ошибка 718 (удалённый компьютер не ответил во время). Если в настройках подключения указать имя сервиса pppoe сервера - у меня это service2, то подключение проходит сразу. Такое ощущение, что сессия упёрто долбится в первый запущенный pppoe сервер. А не в тот, который вещает в своём влане. Естественно обойти всех абонентов, и указать им конкретный service name не вариант от слова совсем.

Сам рассказал, сам ответил, вывод просто не сделал правильный. Ну а для более глубоких логов по ппое нужно в микротайке настроить правильно логирование на этапе отладки, ибо если оно вам будет сыпать вагоны в нормальной жизни устанете.

Edited by prototip
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By G_ua
      Доброго дня всім!
      Підскажіть, можливо хтось стикався з проблемою:
      На мікротіку IKEv2, тільки для андроід клієнтів. ip адреси видаються з пула dhcp, тобто пула локальної мережі (192.168.1.0/24). При підключенні все працює, кліенти бачать інші vpn мережі (192.168.10.0/24, 192.168.11.0/24) але не бачать локальної, тобто 192.168.1.0/24, з неї вони отримують dhcp при підключенні. Якщо видати кліенту, на приклад, 11.0.0.0/24, любу мережу відмінну від локальної, ми бачим всі адреси в діапазоні 192.168.1.0/24, але не бачимо vpn (бо з тої сторони vpn нема маршруту в мережу 11.0.0.0/24).
      Чи можливо щоб при підключенні андроід кліенти отримували ip з мережі 192.168.1.0/24 та могли підключитися на ресурси цієї мережі, на ...1.2 до прикладу. Тобто воно не  маршрутизує в мережу з якої ми отримаємо адресу, але бачить по дефолту любу відмінну від ...1.0 мережу.
      Клієнт аднроід StrongSwan.
    • By denisluk
      Вітаю шановне товариство! Маю напіввирішену проблему з вищевказаним провайдером і EPON підключенням.
      Суть проблеми полягає в тому що періодично і рандомно на Мікротіку відвалюється з'єднання і самостійно відновлюється.
      Сетап: 1) ONU Picotel PU-E910, 2) Mikrotik HEX
       
      Тріолан наливає інет зі статичною адресою і прив'язкою по МАС. 
      На мікроті все стандартно: виділив порт під WAN, насетапив адресу, склонував МАС ноута (спочатку по швидкому тестили інет на ноуті тому його МАС і вбили в білінг), правило НАТу вписав - інет є. 
      Потім рандомно почав відвалюватись інет. В логах геть нічого. Порт мікрота не змінював статус. 
      Перевірив налаштування - все типово. І ніяких глюків чи помилок не виявлено.
      Заміна порта мікрота, прошивка, заміна на інший мікрот (новий з коробки зі скинутим конфігом, налаштований лише з одним правилом НАТу) ніяк не покращили ситуацію. 
      Представник саппорта прийшов і замінив ОНУшку. Теж не допомогло. При спілкуванні представника саппорта по телефону з мережевим інженером з'ясувалось що відвал стається саме тоді, коли мікрот перестає передавати свій МАС. Не бачимо маку, нема авторизації, логічно. 
      З ноутом на пряму все працює без зауважень. На моє питання: "що може бути?" представник саппорта розвів руками і запропонував роутер "не мікротік")))) Мене такий варік не влаштовує, тому що на моєму роутері побудована і пачка тунелів на роботу і до батьків. 
      Почав розбиратись сам, що пробував: 1) ставити чек гетвея пінгами, 2) чек arp запитами, 3) отримувати адресу і по дхцп (так, писав про статику, знаю. Але це рекомендація Тріолану. Взагалі у них працює ДХЦП, але при зникненні світла з ДХЦП є проблеми в них. Тому лишився на статиці), 4) інші мікроти, 5) інші блоки живлення, 6) інші кабелі utp. Все це не мало позитивного результату і не міг відслідкувати що саме спричиняє проблему. 
       
      Що допомогло: 1) створив брідж. 2) на брідж прописав майстер-МАС який закріплений в білінгу, 3) відключив на цьому бріджі оновлення МАС, 4) на цей брідж прописав адресу і т.д. 4) вкинув порт, до якого підключена ОНУ, в цей брідж без ніяких налаштувань взагалі, 5) правило срцнат. 
      Диво, все працює і аптайм уже більше тижня. При спілкуванні з саппортом все ОК, вони бачать валідний МАС (МАС бріджа).
       
      Шановне товариство, допоможіть розібратись: чому схема яка допомогла - працює, а типове налаштування веде до обривів? Дякую за ідеї.
       
       
       
    • By olapchuk
      Вечір добрий 
      потрібно підсказка чи це взагалі можливо зробити через snmp в ціско
      як влан створити, видалити і переімінувати розібрався через snmp, якщо комусь цікаво тут написано https://www.cisco.com/c/en/us/support/docs/ip/simple-network-management-protocol-snmp/45080-vlans.html, якщо треба приклади скину 
      але проблема в наступному, в ціско всі знають є таке штука яка interface vlan **id**
      тут потрібно саме це створити через snmp і задати пару параментрів, його взагалі можна створити через snmp!?
      interface Vlan3**
        no shutdown
        ip address 192.168.***.***/27
      подякував якщо хто тикне куди дивитись
    • By GekaPeka
      MikroTik PowerBox Pro (RB960PGS-PB), новый, в упаковке. Цена: 2800 грн.
    • By Игорь_Кривой Рог
      Продам за ненадобностью остатки после модернизации, лежать без дела.
       
      Mikrotik RB850Gx2 - 4шт.
       
      Mikrotik RB260GS - 1шт.
       
      Все в рабочем состоянии, сброшены на заводские настройки, битые порты отсутствуют.
       








×
×
  • Create New...