Jump to content

Проблема после переноса конфига с p3310 на p3608


Ilya016

Recommended Posts

Проблема в следующем. Была задача от начальства перенести конфиг (Не важно как. Я перебил команды вручную) с p3310c на p3608.

Уже раньше так делал, ничего вроде сложного (это не писать конфиг с нуля), но произошел конфуз... При замене с 33-ей на 36-ую устройство не поднялось. А именно какой-то косяк с приходом. Не регистрируется, удаленного доступа нет, трафик вроде даже не бегает. В чем может быть косяк? Настройки почти идентичные, лишь некоторые расхождений в синтаксисе (на мой оч. непрофессиональный взгляд). Кто сможет, помогите плз.

 

конфиг 3310:

!version 10.1.0E build 46085
service timestamps log date
service timestamps debug date
service password-encryption
logging buffered 4096
!
hostname **************
port-protected 1
!
!
!
!
ip default-gateway ***.***.171.1
!
!
spanning-tree mode rstp
!
!
!
!
!
!
!
!
!
!
!
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
!
username admin password 7 ******************
username user password 7 *****************
!
!

epon oam-version 1 0x30
epon oam-version 2 0x21
epon oam-version 3 0x20
!
!!slot 0 89
interface GigaEthernet0/1
 description Uplink_mikrotik
 switchport trunk vlan-allowed 70,171,175-176,232-240
 switchport mode trunk
  dhcp snooping trust
!
interface GigaEthernet0/2
 switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
 switchport mode trunk
 switchport pvid 240
!
interface GigaEthernet0/3
 shutdown
 description _
 switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
 switchport mode trunk
 switchport pvid 240
!
interface GigaEthernet0/4
 description _
 switchport trunk vlan-allowed 176
 switchport mode trunk
!
interface GigaEthernet0/5
 description Storojka
 switchport trunk vlan-allowed 176,240
 switchport trunk vlan-untagged 240
 switchport pvid 240
!
interface GigaEthernet0/6
 description mikrotik_AC_monitoring
 switchport trunk vlan-allowed 171
 switchport mode trunk
  dhcp snooping trust

!         
!!slot end
!         
interface VLAN171
 description management
 ip address ***.***.171.10 255.255.255.0
!         
interface VLAN236
 no ip address
!         
interface VLAN239
 no ip address
!         
interface VLAN240
 no ip address
!         
!         
!         
vlan 1,70,171,173,175-176,232-240
!         
 loopback-detection
!         
!         
!         
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  240
!         
!         
ip http server
!         
!         
!         
snmp-server community 0 ******* ** 
snmp-server community 0 ******* **** ******
snmp-server contact ************
snmp-server location *************
!         

line console 0
 length 256
 width 256
!         
line vty 0 1
 exec-timeout 0
 length 256
 width 256
!         

line vty 2 31
 exec-timeout 0
!         

!

!

ip sshd enabled

!

time-zone Moscow 3 0
ntp query-interval 720
ntp server ***.***.***.***
!         
!Pending configurations for absent linecards:
!         
!No configurations pending global

 

Конфиг p3608:

!version 10.1.0F build 72136
service timestamps log date
service timestamps debug date
service password-encryption
logging buffered 4096
!
hostname ***********
port-protected 1
!
!
!
!
!
!
spanning-tree mode rstp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
!
username admin password 7 ****************************
username user password 7 *************************
!
!
!
!

epon oam-version 1 0x30
epon oam-version 2 0x21
epon oam-version 3 0x20
!
interface Null0
!
interface FastEthernet0/0

 shutdown
 ip address 192.168.0.1 255.255.255.0
 no ip directed-broadcast
!
!!slot 0 1 unknow CARD
interface GigaEthernet0/1
 description Uplink_mikrotik_sfp
 switchport trunk vlan-allowed 70,171,175-176,232-240
 switchport mode trunk
  dhcp snooping trust
!
interface GigaEthernet0/2
 switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
 switchport mode trunk
 switchport pvid 240
!
interface GigaEthernet0/3
 shutdown
 description _
 switchport trunk vlan-allowed 2-69,71-170,172,174,177-231,241-4094
 switchport mode trunk
 switchport pvid 240
!
interface GigaEthernet0/4
 description _
 switchport trunk vlan-allowed 176
 switchport mode trunk
!
interface GigaEthernet0/5
 description Storojka
 switchport trunk vlan-allowed 176,240
 switchport trunk vlan-untagged 240
 switchport mode dot1q-tunnel-uplink
 switchport pvid 240
!
interface GigaEthernet0/6
 description mikrotik_AC_monitoring
 switchport trunk vlan-allowed 171
 switchport mode trunk
  dhcp snooping trust
!
interface GigaEthernet0/7
 description Uplink_mikrotik
 switchport trunk vlan-allowed 70,171,175-176,232-240
 switchport mode trunk
  dhcp snooping trust
!
interface GigaEthernet0/8
 shutdown
 switchport mode dot1q-tunnel-uplink
!
interface TGigaEthernet0/1
 shutdown
 switchport mode dot1q-tunnel-uplink
!
interface TGigaEthernet0/2
 shutdown
 switchport mode dot1q-tunnel-uplink
!
!
!!slot end
!
interface VLAN171
 description management
 ip address ***.***.171.10 255.255.255.0
 no ip directed-broadcast
!
interface VLAN236
 no ip address
 no ip directed-broadcast
!
interface VLAN239
 no ip address
 no ip directed-broadcast
!
interface VLAN240
 no ip address
 no ip directed-broadcast
!
!
!
vlan 1,70,171,173,175-176,232-240
!
 loopback-detection
!
!
!
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  240
!
!
!
!
!
!
ip route default ***.***.171.1
ip exf
!
ipv6 exf
!
!
ip http server
!
!
!
snmp-server community 0 ******* **
snmp-server community 0 ***** *** *****
snmp-server contact ***************
snmp-server location *************
!
line console 0
 length 256
 width 256
!
line vty 0 1
 exec-timeout 0
 length 256
 width 256
!
line vty 2 31
 exec-timeout 0
!
!
!
ip sshd enable
!
time-zone Moscow 3 0
ntp query-interval 720
ntp server ***.***.***.***
!
!Pending configurations for absent linecards:
!
!No configurations pending global

 

 

На 33-ей приход в 1 gigaethernet, на 36-ой в 7-ой gigaethernet, т.к. на ней нет медных портов до 5-го

Link to post
Share on other sites
3 минуты назад, alex71bas сказал:

spanning-tree mode rstp  

попробуй отключить

Сегодня вечером буду пробовать менять их местами снова, тогда на месте попробую. Но чувство, что не поможет...

У меня вместо этого:

1    Static  Default                          
70   Static  VLAN0070                         g0/1
171  Static  VLAN0171                         g0/6, g0/1, epon0/2
173  Static  VLAN0173                         
175  Static  VLAN0175                         g0/1, epon0/1, epon0/2, epon0/3, epon0/4
176  Static  VLAN0176                         g0/4, g0/1
232  Static  VLAN0232                         g0/1, epon0/1
233  Static  VLAN0233                         g0/1, epon0/2
234  Static  VLAN0234                         g0/1, epon0/3
235  Static  VLAN0235                         g0/1, epon0/4
236  Static  VLAN0236                         g0/1
237  Static  VLAN0237                         g0/1
238  Static  VLAN0238                         g0/1
239  Static  VLAN0239                         g0/1
240  Static  VLAN0240                         g0/5, g0/1, epon0/1, epon0/2, epon0/3, epon0/4

 

Вот это (на 36-ом BDCom):

1    Static  Default                          g0/8, tg0/1, tg0/2, epon0/6, epon0/7, epon0/8
70   Static  VLAN0070                         g0/1, g0/7, g0/8, tg0/1, tg0/2
171  Static  VLAN0171                         g0/1, g0/6, g0/7, g0/8, tg0/1, tg0/2, epon0/2
173  Static  VLAN0173                         g0/8, tg0/1, tg0/2
175  Static  VLAN0175                         g0/1, g0/7, g0/8, tg0/1, tg0/2, epon0/5, epon0/1, epon0/2, epon0/3, epon0/4
176  Static  VLAN0176                         g0/1, g0/4, g0/5, g0/7, g0/8, tg0/1, tg0/2
232  Static  VLAN0232                         g0/1, g0/7, g0/8, tg0/1, tg0/2, epon0/1
233  Static  VLAN0233                         g0/1, g0/7, g0/8, tg0/1, tg0/2, epon0/2
234  Static  VLAN0234                         g0/1, g0/7, g0/8, tg0/1, tg0/2, epon0/3
235  Static  VLAN0235                         g0/1, g0/7, g0/8, tg0/1, tg0/2, epon0/5, epon0/4
236  Static  VLAN0236                         g0/1, g0/7, g0/8, tg0/1, tg0/2
237  Static  VLAN0237                         g0/1, g0/7, g0/8, tg0/1, tg0/2
238  Static  VLAN0238                         g0/1, g0/7, g0/8, tg0/1, tg0/2
239  Static  VLAN0239                         g0/1, g0/7, g0/8, tg0/1, tg0/2
240  Static  VLAN0240                         g0/1, g0/5, g0/7, g0/8, tg0/1, tg0/2, epon0/5, epon0/1, epon0/2, epon0/3, epon0/4

 

Знаю, что это можно корректировать (видел, как это делал мой предшественник), но как не знаю (у него уже не спросить).
 

Link to post
Share on other sites

Не вижу команды "ip default-gateway ***.***.171.1" в p3608. и еще бы для уверенности дал бы команду no shutdown на interface VLAN171.

Порт то на другой стороне прихода, имею ввиду на вашей стороне, не на стороне олта, физически поднят ?

Link to post
Share on other sites
7 минут назад, Matou сказал:

Не вижу команды "ip default-gateway ***.***.171.1" в p3608. и еще бы для уверенности дал бы команду no shutdown на interface VLAN171.

Порт то на другой стороне прихода, имею ввиду на вашей стороне, не на стороне олта, физически поднят ?

ip default-gateway на p3608 именуется ip route default и она есть перед ip http server. Shutdown попробую. Порт поднят, т.к. замена оборудования происходит "на горячую". Два устройства в ящике, с рабочего приход отсоединяю и ставлю в соответствующий порт на новом устройстве. Линк видится, имеется соответствующие сообщение о поднятии медного порта в консоли. Однако, трафика нет, удаленки нет, Onu не поднимаются, трафик не бежит....

Edited by Ilya016
Link to post
Share on other sites
1 минуту назад, Matou сказал:

А пробовали на новый олт дать иной ип-адрес, не ip address ***.***.171.10

Боюсь этот вариант отпадает, т.к. на этот адрес завязан весь мониторинг и перенастраивать будет необходимо не только это олт но и связаные устройства + до этого устройства есть участок обслуживаемый не нами... В общем проблема. Вопрос только в том почему раньше по данной схеме олт запускались (в т.ч. и перенастроенные 3608), а в этот раз такая подстава.

Link to post
Share on other sites
48 минут назад, Ilya016 сказал:

Вопрос только в том почему раньше по данной схеме олт запускались (в т.ч. и перенастроенные 3608), а в этот раз такая подстава.

Проблема не в ОЛТе, а в чудо-админе. Как вообще можно ставить новую железку в продакшн даже не проверив пингуется ли она после настройки?

Что мешает проверить конфигурацию на столе?

Link to post
Share on other sites
4 часа назад, Ilya016 сказал:

Сегодня вечером буду пробовать менять их местами снова, тогда на месте попробую. Но чувство, что не поможет...

У нас было что то похожее. В узел где стояло две p3608, установили третью p3608. Так вот третья не хотела работать пока не выключили "spanning-tree mode rstp". При этом прошивка и настройки, кроме IP-адреса были одинаковы и до установки на столе всё работало.

В другой раз: в узле где было уже три P3310C, заменили приход с 1G на 10G (используя MikroTik CRS305), ничего не работало пока не выключили "spanning-tree mode rstp"

Link to post
Share on other sites
21 час назад, alex71bas сказал:

spanning-tree mode rstp  

попробуй отключить

 

 

16 часов назад, HYBI сказал:

У нас было что то похожее. В узел где стояло две p3608, установили третью p3608. Так вот третья не хотела работать пока не выключили "spanning-tree mode rstp". При этом прошивка и настройки, кроме IP-адреса были одинаковы и до установки на столе всё работало.

В другой раз: в узле где было уже три P3310C, заменили приход с 1G на 10G (используя MikroTik CRS305), ничего не работало пока не выключили "spanning-tree mode rstp"

Вы мои спасители. Реально помогло... Завелась сразу же...

Link to post
Share on other sites
22 часа назад, alex71bas сказал:

spanning-tree mode rstp  

попробуй отключить

 

 

17 часов назад, HYBI сказал:

У нас было что то похожее. В узел где стояло две p3608, установили третью p3608. Так вот третья не хотела работать пока не выключили "spanning-tree mode rstp". При этом прошивка и настройки, кроме IP-адреса были одинаковы и до установки на столе всё работало.

В другой раз: в узле где было уже три P3310C, заменили приход с 1G на 10G (используя MikroTik CRS305), ничего не работало пока не выключили "spanning-tree mode rstp"

Вы мои спасители. Реально помогло... Завелась сразу же...

Link to post
Share on other sites
22 часа назад, alex71bas сказал:

spanning-tree mode rstp  

попробуй отключить

 

 

17 часов назад, HYBI сказал:

У нас было что то похожее. В узел где стояло две p3608, установили третью p3608. Так вот третья не хотела работать пока не выключили "spanning-tree mode rstp". При этом прошивка и настройки, кроме IP-адреса были одинаковы и до установки на столе всё работало.

В другой раз: в узле где было уже три P3310C, заменили приход с 1G на 10G (используя MikroTik CRS305), ничего не работало пока не выключили "spanning-tree mode rstp"

Вы мои спасители. Реально помогло... Завелась сразу же...

Link to post
Share on other sites
22 часа назад, alex71bas сказал:

spanning-tree mode rstp  

попробуй отключить

 

 

17 часов назад, HYBI сказал:

У нас было что то похожее. В узел где стояло две p3608, установили третью p3608. Так вот третья не хотела работать пока не выключили "spanning-tree mode rstp". При этом прошивка и настройки, кроме IP-адреса были одинаковы и до установки на столе всё работало.

В другой раз: в узле где было уже три P3310C, заменили приход с 1G на 10G (используя MikroTik CRS305), ничего не работало пока не выключили "spanning-tree mode rstp"

Вы мои спасители. Реально помогло... Завелась сразу же...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By os8143385.com
      Продам OLT-и BDCOM у відмінному стані, у зв'язку з переходом на XPON.
      В наявності:
      BDCOM 3616-2TE - 1шт ( 1350 $ )
      BDCOM 3608-2TE - 1шт ( 650 $ )
      BDCOM 3608        - 1шт ( 500 $ )
      BDCOM 3310        - 3шт ( 300 $ )
      Курс 33 грн.
       


    • By wildcore
      WildcoreDMS - Инструмент для мониторинга, уведомлений и менеджмента устройств.
       
      Основная идея - разгрузить инженеров/админов, дать возможность монтажнику провести диагностику в поле, а оператору сориентироваться в проблеме, этим сократить время реакции..
       
      Инструмент чем то напоминает ламповый swtoolz и pon monitor(посмотреть что там на порту и с онушкой), но с отличием, что уже есть расширенный контроль доступов и логов действий.
      Так же имеет плюшки подобные заббикс и нагиос(графики, алерты, уведомления), но уведомление не на мыло или в группу телеграмм, а конкретно пользователю, который отвечает за работу оборудования на участке.
       
      Ориентирован на маленьких/средних интернет-провайдеров.
       
      Не перегружен
      Простая установка(в несколько команд) и максимально легкая настройка(добавить доступы к оборудованию, добавить оборудование, добавить персонал).
      Здесь нету сложных шаблонов по работе с оборудованием, замороченных настроек и т.п.
      (но если у кого то будет желание доработать инструментарий, добавить свои устройства - обращайтесь, обсудим) 
       
      Поддерживаемые вендоры 
      Dlink (DES/DGS) BDcom (P3310B/C/D, P3608B) C-data (OLTs) Mikrotik (роутеры) ZTE (C320, fw 2.1) Полный список поддерживаемого оборудования - https://github.com/meklis/switcher-core/blob/master/docs/DEVICES.md 
      С устройствами работает по SNMP/telnet/ssh  
       
      Основной функционал
      Отображение реалтайм состояния оборудования по запросу Алерты в телеграмм(лично каждому пользователю) и на почту с возможностью настроить фильтры История событий  Получение обновлений одной командой в консоли  RestAPI  Работа в Docker Хранение метрик в TSDB (Prometheus) Гибкое разделение прав доступа для пользователей (по группам) Разделение прав доступа(отображения) для пользователей по группам устройств(в случае, если пользователь не должен видеть все оборудование) Логирование действий пользователей, вызовов оборудования(только которые завершились ошибкой)   
      Как попробовать
      написать в группу в телеграм или оставить обращение на сайте (кнопка "Request beta")
       
       
      Инструмент бесплатен, но не опенсорс
      Группа в телеграмм: https://t.me/wildcore_dms_channel
      Сайт: https://wildcore.tools
      Дока: http://docs.wildcore.tools
       
    • By prototip
      Продам нові плати EIT1F uplink 10g olt ZTE C220
      Плата дозволяє легко і просто отримати аплінк порти 10g на олт ZTE C220
      Плата встановлюється тільки у слот №2 чи №3 
      Модуль формата QSFP у комплект не входить.
      Ціна модуля 320 уе


    • By Naximov
      Продам Абонентский терминал BDCOMP1501DT,в наявності 20 шт,стан нові,7к.
    • By Noobomaster
      Продам  нов. gpon onu bdcom gp1704-2f-e 2 шт.
      Цена 500грн/шт.
×
×
  • Create New...