Slava Опубліковано: December 21, 2005 at 19:25 Опубліковано: December 21, 2005 at 19:25 Собрался без проблем но не запускается ASP10,0 Kernel 2.6.12, вот лог 2005-12-21 21:15:50 -- Stg v. Stg 2.4 alpha.01 2005-12-21 21:15:50 -- Timer thread started successfully. 2005-12-21 21:15:50 -- Storage plugin: file_store v.1.00. Loading successfull. 2005-12-21 21:15:50 -- Users started successfully. 2005-12-21 21:15:50 -- Traffcounter started successfully. 2005-12-21 21:15:50 -- Plugin: ether_cap v.1.0. Start successfull. 2005-12-21 21:15:50 -- Plugin: Always Online authorizator v.0.9. Start successfull. 2005-12-21 21:15:50 -- Error: AUTH_IA: Bind failed. Как вылечить такое?
stg-34 Опубліковано: December 21, 2005 at 19:29 Автор Опубліковано: December 21, 2005 at 19:29 Собрался без проблем но не запускается вот лог 2005-12-21 21:15:50 -- Stg v. Stg 2.4 alpha.01 2005-12-21 21:15:50 -- Timer thread started successfully. 2005-12-21 21:15:50 -- Storage plugin: file_store v.1.00. Loading successfull. 2005-12-21 21:15:50 -- Users started successfully. 2005-12-21 21:15:50 -- Traffcounter started successfully. 2005-12-21 21:15:50 -- Plugin: ether_cap v.1.0. Start successfull. 2005-12-21 21:15:50 -- Plugin: Always Online authorizator v.0.9. Start successfull. 2005-12-21 21:15:50 -- Error: AUTH_IA: Bind failed. Как вылечить такое? Порт авторизатора занят другим приложением. Поменяй в inetaccess.conf порт
Slava Опубліковано: December 21, 2005 at 20:07 Опубліковано: December 21, 2005 at 20:07 Сенкс переназначил порт получилось запустить!
stg-34 Опубліковано: December 23, 2005 at 23:10 Автор Опубліковано: December 23, 2005 at 23:10 stg-2.4-2005.12.24-01.08.47.tgz Пофикшены все известные ошибки Исправлено: 1. выполняются скрипты OnChange 2. выполняются скрипты OnUserAdd и OnUserDel 3. Работает время жизни кредита 4. Исправлена ошибка записи детальной стаитстики 5. Пофикшена кучка ошибок, связанных со снятием абонплаты. 6. Нормально редактируется трафик из конфигуратора. Т.о. известных ошибок больше не знаю, то доделаю плагин с пингование клиентов и будет бета-версия
REND Опубліковано: December 24, 2005 at 01:22 Опубліковано: December 24, 2005 at 01:22 вылезла ошибка при компиляции последней на данный момент времени версии, заменил каталог /common.lib/ на каталог из предыдущей версии всё заработало ОС: fedora core4
egor2fsys Опубліковано: December 24, 2005 at 08:01 Опубліковано: December 24, 2005 at 08:01 вылезла ошибка при компиляции последней на данный момент времени версии, заменил каталог /common.lib/ на каталог из предыдущей версии всё заработалоОС: fedora core4 а описание ошибки где ? пишите конкретней
Slava Опубліковано: December 24, 2005 at 09:04 Опубліковано: December 24, 2005 at 09:04 ASP10.0 Kernel 2.6.9 и Kernel2.6.12 компилится и запускается без проблем. пока только один пользователь в тестовом режиме.
biz Опубліковано: December 24, 2005 at 11:30 Опубліковано: December 24, 2005 at 11:30 есть уже нормыльный stg 2.4 под free 5.4 ? какие баги наблюдаются?
MaйeR Опубліковано: December 24, 2005 at 15:49 Опубліковано: December 24, 2005 at 15:49 есть уже нормыльный stg 2.4 под free 5.4 ? какие баги наблюдаются? последняя альфа нормально собралась и работает, пока стабильно
biz Опубліковано: December 24, 2005 at 17:51 Опубліковано: December 24, 2005 at 17:51 нусс... ждём багов? есть ли смысл ее внедрять пока, или нет ещё??
MaйeR Опубліковано: December 24, 2005 at 18:03 Опубліковано: December 24, 2005 at 18:03 нусс... ждём багов? есть ли смысл ее внедрять пока, или нет ещё?? до релиза и обкатки 2.5-stable точно нет
stg-34 Опубліковано: December 24, 2005 at 18:16 Автор Опубліковано: December 24, 2005 at 18:16 нусс... ждём багов? есть ли смысл ее внедрять пока, или нет ещё?? до релиза и обкатки 2.5-stable точно нет Ну, я думаю стг-2.4 будет стабильным, причем достаточно быстро. В нем по сравнению с стг-2 не будет хватать отсылки сообщений юзерам, но для всяких проблемных случаев стг-2, когда он глючит, стг-2.4 должен стать стабильной альтернативой.
REND Опубліковано: December 25, 2005 at 01:20 Опубліковано: December 25, 2005 at 01:20 вылезла ошибка при компиляции последней на данный момент времени версии, заменил каталог /common.lib/ на каталог из предыдущей версии всё заработалоОС: fedora core4 а описание ошибки где ? пишите конкретней попытался собрать заново (снеся собранный и ставя из последнего на тот момент дистрибутива (stg-2.4-2005.12.24-01.08.47)), но та ошибка не повторилась, видимо сначала была кривость рук :bue: сорри за неточную информацию PS: есть свободный сервер для тестов, буду тестить, обовсех особонностсях отпишусь...
XoRe Опубліковано: December 25, 2005 at 01:51 Опубліковано: December 25, 2005 at 01:51 Прошу посмотреть, что можно сделать для того, чтоб оставался целым файл stat, и чтоб stg не отключал/подключал юзеров толпами) И ещё прошу сделать режим debug.
REND Опубліковано: December 25, 2005 at 01:53 Опубліковано: December 25, 2005 at 01:53 При сборке: g++ stgconfig.o rsconf.o configproto.o parser.o parser_tariff.o parser_admin.o -g3 -shared -o stgconfig.so /usr/bin/ld: errno: TLS definition in /lib/libc.so.6 section .tbss mismatches non-TLS reference in rsconf.o /lib/libc.so.6: could not read symbols: Bad value collect2: ld returned 1 exit status gmake[1]: *** [stgconfig.so] Ошибка 1 при запуске в логах ссылается на отсутствующей файл stgconfig.so Error: Plugin loading failed. ./plugins/configuration/sgconfig/stgconfig.so: cannot open shared object file: No such file or directory OS: fedora core4
Slava Опубліковано: December 25, 2005 at 07:59 Опубліковано: December 25, 2005 at 07:59 Пробую заводить нового Юзера, ввожу логин, IP-адрес, интерфейс, генерирую пароль, ввожу начальное количество денег в итоге: в поле IP-адрес вместо адреса *, денег 0,00, вместо пароля *_EMPTY_PASSWORD_*, вместо тарифа *_EMPTY_TARIFF_*, захожу в редактирование пользователя прописываю IP-адрес, ввожу количество денег выбираю тарифный план - все работает, пробовал конфигураторами, 1.55.7 и 1.60.7 (1,60,7 еще и ошибку периодически выдает Access violation at addres 0057509C in module 'sgconfig.exe'. Read of address 69726174). p.s. сервер не падает
Richman Опубліковано: December 25, 2005 at 09:36 Опубліковано: December 25, 2005 at 09:36 Немного разгребся с работой, есть тестовый сервер для "боевых испытаний". Сегодня вплотную займусь установкой и "краш-тестами". Обязательно отпишусь.
loki Опубліковано: December 25, 2005 at 11:07 Опубліковано: December 25, 2005 at 11:07 ./stargazer ./stargazer: line 8: /etc/init.d/functions: No such file or directory ./stargazer: line 11: /etc/sysconfig/network: No such file or directory ./stargazer: line 18: [: =: unary operator expected Debian Sarge 3.1
stg-34 Опубліковано: December 25, 2005 at 12:27 Автор Опубліковано: December 25, 2005 at 12:27 При сборке: g++ stgconfig.o rsconf.o configproto.o parser.o parser_tariff.o parser_admin.o -g3 -shared -o stgconfig.so /usr/bin/ld: errno: TLS definition in /lib/libc.so.6 section .tbss mismatches non-TLS reference in rsconf.o /lib/libc.so.6: could not read symbols: Bad value collect2: ld returned 1 exit status gmake[1]: *** [stgconfig.so] Ошибка 1 при запуске в логах ссылается на отсутствующей файл stgconfig.so Error: Plugin loading failed. ./plugins/configuration/sgconfig/stgconfig.so: cannot open shared object file: No such file or directory OS: fedora core4 Ну, второй пункт понятен. Не может загрузить плагин, т.к. он не собрался. В вот почему он не собрался (первый пункт) это непонятно. Пока даже прокомментировать не могу. Надо поковыряться будет.
stg-34 Опубліковано: December 25, 2005 at 12:33 Автор Опубліковано: December 25, 2005 at 12:33 ./stargazer./stargazer: line 8: /etc/init.d/functions: No such file or directory ./stargazer: line 11: /etc/sysconfig/network: No such file or directory ./stargazer: line 18: [: =: unary operator expected Debian Sarge 3.1 Это похоже ты запускаешь стг с помощью /etc/init.d/stargazer. Запускай лучше сам бинарник. Эти скрипты разные для разных осей, и я ими еще не занимался. Так, что может быть всякое
stg-34 Опубліковано: December 25, 2005 at 12:38 Автор Опубліковано: December 25, 2005 at 12:38 Прошу посмотреть, что можно сделать для того, чтоб оставался целым файл stat, и чтоб stg не отключал/подключал юзеров толпами) И ещё прошу сделать режим debug. 1. файл stat не должен пропадать. разве, что kill -KILL stargazer, в таком случае можно попасть на момент записи файла и потерять его. Но при корректной остановке такого не должно быть в принципе. 2. Подключение-отключение толпами. Вопрос. У меян 20 всегда онлайнщиков. Я запускаю сервак, для всех 20 выполняется скрипт OnConnect (подключает-отключает толпами) Что с этим можно сделать? Не подключать? Или с паузой в 1 мин подключать? 3. main.cpp:61 //#define NO_DAEMON расскрментировать и будет куча вывода на экран с полезной инфой
loki Опубліковано: December 25, 2005 at 15:33 Опубліковано: December 25, 2005 at 15:33 ./stargazer./stargazer: line 8: /etc/init.d/functions: No such file or directory ./stargazer: line 11: /etc/sysconfig/network: No such file or directory ./stargazer: line 18: [: =: unary operator expected Debian Sarge 3.1 Это похоже ты запускаешь стг с помощью /etc/init.d/stargazer. Запускай лучше сам бинарник. Эти скрипты разные для разных осей, и я ими еще не занимался. Так, что может быть всякое fbi:/opt/stg-2.4-2005.12.24-01.08.47/projects/stargazer# ./startstg ./startstg: line 3: ./stargazer: No such file or directory Star failed
loki Опубліковано: December 25, 2005 at 15:35 Опубліковано: December 25, 2005 at 15:35 ./stargazer./stargazer: line 8: /etc/init.d/functions: No such file or directory ./stargazer: line 11: /etc/sysconfig/network: No such file or directory ./stargazer: line 18: [: =: unary operator expected Debian Sarge 3.1 Это похоже ты запускаешь стг с помощью /etc/init.d/stargazer. Запускай лучше сам бинарник. Эти скрипты разные для разных осей, и я ими еще не занимался. Так, что может быть всякое fbi:/opt/stg-2.4-2005.12.24-01.08.47/projects/stargazer# ./startstg ./startstg: line 3: ./stargazer: No such file or directory Star failed блин поличите под sarge... сколько это стоить будет ?
stg-34 Опубліковано: December 25, 2005 at 16:58 Автор Опубліковано: December 25, 2005 at 16:58 ./stargazer./stargazer: line 8: /etc/init.d/functions: No such file or directory ./stargazer: line 11: /etc/sysconfig/network: No such file or directory ./stargazer: line 18: [: =: unary operator expected Debian Sarge 3.1 Это похоже ты запускаешь стг с помощью /etc/init.d/stargazer. Запускай лучше сам бинарник. Эти скрипты разные для разных осей, и я ими еще не занимался. Так, что может быть всякое fbi:/opt/stg-2.4-2005.12.24-01.08.47/projects/stargazer# ./startstg ./startstg: line 3: ./stargazer: No such file or directory Star failed блин поличите под sarge... сколько это стоить будет ? зппусти как написано в read.me
Slava Опубліковано: December 25, 2005 at 17:10 Опубліковано: December 25, 2005 at 17:10 Не выполняется скрипт OnDisconnect когда заканчиваются деньги на счету начинает считать деньги в минус, если переподключиться то как и нужно подключается но в инет не пускает (скрипт OnConnect не срабатывает).
Рекомендованные сообщения