Перейти к содержимому
Local
allo

Ошибка при подключении нового MikroTik`a в качестве NAS.

Рекомендованные сообщения

Добрый день.

Ubilling установлен по инструкции, работает не первый месяц, нареканий нет.
Возникла ошибка при подключении нового микротика в качестве НАСа

Notice: Undefined variable: _done in /usr/local/www/apache24/data/billing/api/libs/api.routeros.php on line 192

Общая инфорация о состоянии MikroTik`a
Аптайм     5 д. 20h41m33s
Версия RouterOS     6.20
Время сборки     Oct/01/2014 10:06:12
Свободно опер. памяти     1.54 Gb
Всего опер. памяти     1.91 Gb
Процессор     tilegx
Кол-во процессоров     9
Частота процессора     1200 MHz
Загрузка процессора     24 %
Свободно памяти HDD     61.61 Mb
Всего памяти HDD     128 Mb
Архитектура     tile
Название платы     CCR1009-8G-1S-1S+
Платформа     MikroTik



С другим роутером ошибок не возникало, работает отлично.

Общая инфорация о состоянии MikroTik`a
Аптайм     16m31s
Версия RouterOS     6.20
Время сборки     Oct/01/2014 10:06:12
Свободно опер. памяти     40.34 Mb
Всего опер. памяти     64 Mb
Процессор     MIPS 24Kc V8.5
Кол-во процессоров     1
Частота процессора     400 MHz
Загрузка процессора     4 %
Свободно памяти HDD     109.06 Mb
Всего памяти HDD     128 Mb
Записано секторов     750
Всего записано секторов     3562064
Плохих секторов     0 %
Архитектура     mipsbe
Название платы     CRS226-24G-2S+
Платформа     MikroTik


Может кто сталкивался с такой ошибкой и как-то её решил? Спасибо.

 

post-38961-0-79859500-1490786198_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Покажите что у вас в Серверах доступа

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Обратился к спецу по php, то с его слов ошибка в том, что не объявлена переменная $_done, и из елсе выход не корретный. Но исправить не взялся.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Костыль.

Нашёл схожий API, эксемплы котрого работают без ошибок,
нашёл кусок кода, в котором объявляется схожая переменная
https://github.com/BenMenking/routeros-api/blob/master/routeros_api.class.php#L270L274
которая аналогично работает в таком-же блоке,
https://github.com/BenMenking/routeros-api/blob/master/routeros_api.class.php#L324L335
объявил переменную в нашем API и ошибка исчезла.

post-38961-0-56234700-1490860527_thumb.jpg

Обращаюсь к разработчикам: если данный костыль не противоречит логике работы,
то добавить на гитхаб строку $_done = false; после строки
https://github.com/nightflyza/Ubilling/blob/master/api/libs/api.routeros.php#L149

 Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Костыль не помог. Ошибка ушла а вместе с ней и управление микротиком.

 

Может кто сталкивался с такой ошибкой и как-то всё-таки её решил?

 

Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Костыль не помог. Ошибка ушла а вместе с ней и управление микротиком.

 

Может кто сталкивался с такой ошибкой и как-то всё-таки её решил?

 

Спасибо.

Вот здесь была предпринята попытка перевести RouterOS API на версию 1.6, в которой уже исправлены такие глюки, а также добавлена поддержка API-SSL.

https://github.com/nightflyza/Ubilling/pull/9

 

Остальные патчи для MikroTik (определение активности пользователя по нахождению в dhcp leases, просмотр ARP через API, ping через API) планировалось писать поверх RouterOS API версии 1.6.

Но не взлетело :(

 

По решению проблемы - оказалось гораздо проще поддерживать набор локальных патчей.

 

P.S.

https://local.com.ua/forum/topic/92425-%D0%BE%D1%88%D0%B8%D0%B1%D0%BA%D0%B8-%D0%B2-079/

Изменено пользователем Dmitry2

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Нашёл причину, вызывающую ошибку
Notice: Undefined variable: _done in /usr/local/www/apache24/data/billing/api/libs/api.routeros.php on line 192

для её повторения

(проверено на двух разных девайсах, второй девайс такой:
Общая инфорация о состоянии MikroTik`a
Аптайм     17m18s
Версия RouterOS     6.38.5 (stable)
Время сборки     Mar/09/2017 11:32:49
Свободно опер. памяти     1.68 Gb
Всего опер. памяти     1.89 Gb
Процессор     tilegx
Кол-во процессоров     16
Частота процессора     1200 MHz
Загрузка процессора     0 %
Свободно памяти HDD     67.78 Mb
Всего памяти HDD     128 Mb
Архитектура     tile
Название платы     CCR1016-12S-1S+
Платформа     MikroTik)

необходимо добавить 344 влан следующей последовательностью команд:

[admin@MikroTik] > /interface vlan add interface=Ether2 name=VLAN344 vlan-id=344
[admin@MikroTik] > /interface vlan remove VLAN344                                 
[admin@MikroTik] > /interface vlan add interface=Ether2 name=VLAN344 vlan-id=344

Удаление влана устраняет ошибку. Переименование - иногда устраняет, иногда нет.

Костыль, кстати, таки работает, но в правильности его работы не уверен в свзи с отсутствием специфических знаний и умений.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

Удаление влана устраняет ошибку. Переименование - иногда устраняет, иногда нет.

А у тебя "общение" Микротика с биллингом через 344 vlan идет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

"Общение" Микротика с биллингом идет через другой vlan. Ещё возможной причиной могут быть ошибки в конфигурации бриджей и eoip туннелей, которых в этом влане 37 штук. Поиск продолжаю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может быть. Я, когда использовал модуль "Укправление Mikrotik", никаких проблем не было в плане связки billing-mikrotik. Правда со временем все равно перешел на radius, так как статические списки доступа и arp записи не совмем то, что хотелось

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

"Общение" Микротика с биллингом идет через другой vlan. Ещё возможной причиной могут быть ошибки в конфигурации бриджей и eoip туннелей, которых в этом влане 37 штук. Поиск продолжаю.

Щось знайшли? А то схожа проблема в мене, все перепробував неможу знайти чому

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

-del

Изменено пользователем Optimal

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас


  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

  • Похожие публикации

    • Автор: azimut
      Є базова станція мікротік 433AH + R52Hm + сектор на одну поляризацію.
      На даний час 29 абонентів
      Виникла проблема. Абоненти вечером недоотримують швидкості. 
      Вирішили повністю обновити обладнання, можливо в когось є певні рішення.
      Тарифи 2,4,6 Мб
      Дякую
    • Автор: pavloptrovich
      Продам Mikrotik MT CCR1009-7G-1C-1S+
      В наявності.
      Ціна 448 дол.
    • Автор: Notarius
      Індивідуальний підхід до кожного клієнта! Постійним клієнтам - знижки, гуртовим клієнтам - найкращі ціни!
       
      Контактні дані:
       
      тел. (viber, telegram, whatapp): 0688234523 - Андрій
      skype: dj.toxic_13
      web: www.netdream.com.ua
       
      Розрахунок на картку ПриватБанку, по безнготівкому рахунку, а також відправимо накладеним платижем.
       
      Обладнання нове! Гарантія 1 рік на все обладнання.
       
      Багато товару в наявності, чого немає, до тижня часу привеземо!
       
      Ubiquiti:
       
      airGrid M2 HP 16dBi                                                                                     52
      airGrid M2 HP 20dBi                                                                                     59
      airGrid M5 HP 23dBi                                                                                     52
      airGrid M5 HP 27dBi                                                                                     59
      LiteBeam M5 23dBi                                                                                       44
      LiteBeam 5AC 23dBi                                                                                     56
      LiteBeam 5AC 16dBi (LBE-5AC-16-120)                                                      82                             
      NanoStation Loco M2                                                                                    43
      NanoStation Loco M5                                                                                    58
      NanoStation M2                                                                                             78
      NanoStation M5                                                                                             78
      PowerBeam M2-400                                                                                      70
      PowerBeam M5-300 22dBi                                                                            69       
      PowerBeam M5-400 25dBi                                                                            79        
      PowerBeam M5-620 29dBi                                                                            175        
      PowerBeam 5AC-300                                                                                     92
      PowerBeam 5AC-400                                                                                     106
      PowerBeam 5AC-500                                                                                     147
      PowerBeam 5AC-620                                                                                     197
      UniFi UAP                                                                                                       60
      Ubiquiti UniFi UAP 3-pack                                                                              168     
      UniFi UAP-LR                                                                                                 77
      UniFi UAP-LR 3-pack                                                                                     223
      UniFi UAP-PRO                                                                                              200
      UniFi UAP-PRO 3-pack                                                                                  459  
      UAP-AC LR                                                                                                    96
      UAP-AC PRO                                                                                                 130
      UAP-AC PRO 5-pack                                                                                      615
      UAP-AC LITE                                                                                                  80
      UniFi Cloud Key (UC-CK)                                                                                79    
      rocket M2                                                                                                         77
      rocket M5                                                                                                         77
      rocket 5ac Lite                                                                                                 118
      RocketPRISM 5AC Gen2                                                                                 220   
      airMAX 2x2 Sector (AM-2G15-120)                                                                 120                  
      airMAX 2x2 Sector (AM-2G16-90)                                                                   120                
      airMAX 2x2 Sector (AM-5G16-120)                                                                  73                  
      airMAX 2x2 Sector (AM-5G17-90)                                                                    71                
      airMAX 2x2 Sector (AM-5G19-120)                                                                  120                 
      airMAX 2x2 Sector (AM-5G20-90)                                                                    120                
      airMAX ac 2x2 Sector (AM-5AC21-60)                                                             180                      
      airMAX ac 2x2 Sector (AM-5AC22-45)                                                             175                      
      airPRISM airMAX ac 3x30 Sector (AP-5AC-90-HD)                                         395
      PrismAP 5GHz Asymetrical Sector Antenna (PrismAP-5-60)                           73
      PrismAP 5GHz Asymetrical Sector Antenna (PrismAP-5-90)                           73
      RocketDish (RD-5G30)                                                                                     125
      RocketDish (RD-5G34)                                                                                     299
      TOUGHSwitch PRO PoE 8-port                                                                       169               
       
      Mikrotik:
       
      hAP lite TC                                                                                                       20
      hAP                                                                                                                   37   
      hAP ac lite                                                                                                         46
      hAP ac                                                                                                              113        
      hEX                                                                                                                   53 
      hEX lite                                                                                                              37       
      hEX-PoE                                                                                                            50          
      hEX-PoE lite                                                                                                      70               
      RB951Ui-2HnD                                                                                                  49                                      
      RB951G-2HnD                                                                                                   68                 
      cAP                                                                                                                     42 
      DISC Lite 5                                                                                                          42           
      LHG 2                                                                                                                  50                      
      LHG 5                                                                                                                  50                      
      LHG 5 AC                                                                                                            75          
      LDF 5 ac                                                                                                              56        
      mAP                                                                                                                     37
      mAP Lite                                                                                                              23        
      SXT Lite2                                                                                                             42                           
      SXT Lite5                                                                                                             48          
      SXT Lite5 ac                                                                                                        53               
      SXT HG5                                                                                                             76         
      SXT SA5                                                                                                              76       
      SXT 5 ac                                                                                                              95                          
      SXT HG5 ac                                                                                                         99            
      SXT SA5 ac                                                                                                          99            
      SXTsq Lite5                                                                                                          41             
      SXTsq 5 ac                                                                                                           48           
      SXTsq 5 High power                                                                                             44                         
      wAP                                                                                                                      37
      wAP AC                                                                                                                78    
      mANT15s                                                                                                              47                          
      mANT19s                                                                                                              88        
      mANT30                                                                                                               105                         
      mANT30 PA                                                                                                          115
      mANTBox 15s                                                                                                       123               
      mANTBox 19s                                                                                                       168               
      NetBox 5                                                                                                                94       
      BaseBox 2                                                                                                             76          
      BaseBox 5                                                                                                             76        
      PowerBox Pro                                                                                                        88               
      OmniTIK 5 ac                                                                                                         95                              
      OmniTIK 5 PoE ac                                                                                                 115                    
      CCR1009-7G-1C-1S+                                                                                            420                           
      CCR1009-7G-1C-1S+PC                                                                                       405                               
      CCR1009-7G-1C-PC                                                                                              350                         
      CCR1016-12S-1S+                                                                                                 620                     
      CCR1036-8G-2S+                                                                                                   900  
      CCR1036-8G-2S+EM                                                                                             1080                                         
      CCR1072-1G-8S+                                                                                                   2600                   
      CRS 112-8G-4S-IN                                                                                                  120                     
      CRS125-24G-1S-2HnD-IN                                                                                      187                               
      CRS125-24G-1S-IN                                                                                                 163                    
      RB2011iL-IN                                                                                                             85         
      RB2011iL-RM                                                                                                           85           
      RB2011iLS-IN                                                                                                           91           
      RB2011UiAS-IN                                                                                                        95              
      RB2011UiAS-2HnD-IN                                                                                             112                          
      RB2011UiAS-RM                                                                                                      100                                  
      RB3011UiAS-RM                                                                                                      155                
    • Автор: club777
      Нужна помощь.
      Переехали с D-Link на Mikrotik RB951Ui-2HnD, всё настроилось в полпинка, а вот с IP-камерами возникли проблемы!... %)
      Суть проблемы: есть несколько IP-камер, видео с которых мы черпаем через rtsp. У каждой из камер свой порт, используеиый для rtsp. В локалке всё работает на ура, видео без проблем открывается по ссылкам вида rtsp://192.168.10.102:22554/user=admin&password=ХХХ
      Кроме того, это же видео бекапится на внешний хост, соответственно нужен доступ с интернета,- настраиваю проброс порта для IP-камеры, делаю всё четко по инструкции: https://toster.ru/q/183419 , добавил правило: 
      add action=dst-nat chain=dstnat disabled=no dst-port=22554 protocol=tcp to-addresses=192.168.10.102 to-ports=22554
      - не работает!!!
      Пробовал менять protocol=tcp/udp и action=dst-nat/netmap (как рекомендуют тут: http://www.technotrade.com.ua/Articles/mikrotik-port-forwarding.php), ничего не помогает, камеры по rtsp - недоступны... %)
       
      Может я где-то ступил? Подскажите, пожалуйста, куда копать ??????
       
       
       
      На всякий случай /ip firewall nat export:
      # feb/16/2018 09:49:39 by RouterOS 6.41.2
      # software id = I449-W8D6
      #
      # model = 951Ui-2HnD
      # serial number = XXX 
      /ip firewall nat
      add action=dst-nat chain=dstnat dst-port=22554 in-interface=WAN protocol=tcp to-addresses=192.168.10.102 to-ports=22554
      add action=masquerade chain=srcnat out-interface=WAN src-address=192.168.10.0/24
       
    • Автор: vovam
      Продам залишки обладнання Wifi:
      1. air grid m5hp условно рабочий (вскрывался и был в ремонте) без бп - 400грн
      2. bullet 2 без бп - живой - 200грн
      3. bullet m5 без бп - живой - 600грн
      4. bullet m2 без бп - живой - 600грн
      5. rb-711-2hn - не загружается, мигает всеми лампочками, не пищит - дохлый - 100грн
      6. rb-711-2hn - не загружается, мигает всеми лампочками, не пищит - дохлый - 100грн
      7. rb-711-2hn - не загружается, мигает всеми лампочками, не пищит - дохлый - 100грн
      8. rb-711-5hn - питания нет, дохлый - 100грн
      9. rb-711-5hn - живой - 200грн
      10. rb-711-5hn - нет питания, следы пайки чипа, дохлый - 100грн
      11. rb-711-5nh - питание есть, сети нет, дохлый - 100грн
      12. rb-711-5nh - питание есть, сети нет, дохлый - 100грн
      13. rb-433 - живой - 250грн
      14. rb-433 - живой - 250грн
      15. groove 5hn без бп - живой - 250грн
      16. groove 5hn без бп - живой - 250грн
      17. groove 5hn - поврежден лан порт физически (отломана часть пластмаски фиксирующей язычек джека), условно рабочий без бп - 200грн
      18. nanostation 2 - крышка есть, бп есть, жнур к бп есть, две штуки  - живые - 400грн за штуку либо 700грн за обе
      19. nanostation 5 loco - крышка есть, бп нет - живые - есть три штуки - 200грн за штуку либо 500грн за три.
       
      Торг, опт, пропозиції - все обговорюємо. Відправка накладним платежем Новою поштою, Інтаймом або Делівері.
         

×