Jump to content
Local
bolelshik

Обновление freebsd

Recommended Posts

Добрый день.

Обновил порты на freebsd перезагрузил сервер и после получаю

Warning: mysqli::__construct(): (HY000/2002): No such file or directory in /usr/local/www/apache24/data/billing/api/libs/api.mysql.php on line 29

Connection error (2002) No such file or directory

Что делать?

 

Share this post


Link to post
Share on other sites
16 минут назад, bolelshik сказал:

Что делать?

config/mysql.ini проверить

 

UPD: в my.cnf путь к mysql.sock тоже проверить

Edited by ISK

Share this post


Link to post
Share on other sites
6 минут назад, ISK сказал:

config/mysql.ini проверить

Проверил там все вроде в норме

Share this post


Link to post
Share on other sites
8 минут назад, bolelshik сказал:

Проверил там все вроде в норме

Очевидно же что нет. Версию РНР обновляли? my.cnf проверили?

 

И да, первое правило админа: работает - не трогай!

Edited by ISK
  • Like 1

Share this post


Link to post
Share on other sites
5 минут назад, ISK сказал:

Очевидно же что нет. Версию РНР обновляли? my.cnf проверили?

;database host

server = "localhost"

;database port

port = "3306"

;user login

username = "root"

;user password

password = "my*****"

;database name to use

db = "stg"

character = "UTF8"

prefix = "billing

 

my.cnf не проверял, так а если и правда php обновилось где править?

Share this post


Link to post
Share on other sites
5 минут назад, bolelshik сказал:

my.cnf не проверял, так а если и правда php обновилось где править?

А надо бы проверить и php -v гляньте, что выдаст... Версия Фри какая?

Share this post


Link to post
Share on other sites
13 минут назад, ISK сказал:

Очевидно же что нет. Версию РНР обновляли? my.cnf проверили?

а вот и my.cnf

# For advice on how to change settings please see

# http://dev.mysql.com/doc/refman/5.6/en/server-configuration-defaults.html

 

[mysqld]

 

# Remove leading # and set to the amount of RAM for the most important data

# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.

# innodb_buffer_pool_size = 128M

 

# Remove leading # to turn on a very important data integrity option: logging

# changes to the binary log between backups.

# log_bin

 

# These are commonly set, remove the # and set as required.

# basedir = .....

# datadir = .....

# port = .....

# server_id = .....

# socket = .....

 

# Remove leading # to set options mainly useful for reporting servers.

# The server defaults are faster for transactions and fast SELECTs.

# Adjust sizes as needed, experiment to find the optimal values.

# join_buffer_size = 128M

# sort_buffer_size = 2M

# read_rnd_buffer_size = 2M

 

sql_mode=NO_ENGINE_SUBSTITUTION

Share this post


Link to post
Share on other sites
4 минуты назад, ISK сказал:

А надо бы проверить и php -v гляньте, что выдаст... Версия Фри какая?

версия фри 12

 

php 7.0.31, так и есть обновилось php

команда php -v

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/curl.so' - Shared object "libssl.so.8" not found, required by "libcurl.so .4" in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/curl.so' - Shared object "libssl.so.8" not found, required by "libcurl.so.4" i n Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/ftp.so' - Shared object "libssl.so.8" not found, required by "ftp.so" in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/ftp.so' - Shared object "libssl.so.8" not found, required by "ftp.so" in Unkno wn on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/imap.so' - Shared object "libssl.so.8" not found, required by "imap.so" i n Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/imap.so' - Shared object "libssl.so.8" not found, required by "imap.so" in Unk nown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/openssl.so' - Shared object "libssl.so.8" not found, required by "openssl .so" in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/openssl.so' - Shared object "libssl.so.8" not found, required by "openssl.so" in Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/snmp.so' - Shared object "libssl.so.8" not found, required by "snmp.so" i n Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/snmp.so' - Shared object "libssl.so.8" not found, required by "snmp.so" in Unk nown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/zip.so' - Shared object "libssl.so.8" not found, required by "libzip.so.5 " in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/zip.so' - Shared object "libssl.so.8" not found, required by "libzip.so.5" in Unknown on line 0

PHP 7.0.31 (cli) (built: Jul 28 2018 01:13:58) ( NTS )

Copyright (c) 1997-2017 The PHP Group

 

 

Share this post


Link to post
Share on other sites

Судя по написанному выше Вам это не поможет. Откатывайтесь или делайте дамп БД, ставите с нуля, а потом заливаете обратно предварительно потушив старгейзер. Так будет проще)

Edited by ISK

Share this post


Link to post
Share on other sites
2 минуты назад, bolelshik сказал:

версия фри 12

 

php 7.0.31, так и есть обновилось php

команда php -v

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/curl.so' - Shared object "libssl.so.8" not found, required by "libcurl.so .4" in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/curl.so' - Shared object "libssl.so.8" not found, required by "libcurl.so.4" i n Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/ftp.so' - Shared object "libssl.so.8" not found, required by "ftp.so" in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/ftp.so' - Shared object "libssl.so.8" not found, required by "ftp.so" in Unkno wn on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/imap.so' - Shared object "libssl.so.8" not found, required by "imap.so" i n Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/imap.so' - Shared object "libssl.so.8" not found, required by "imap.so" in Unk nown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/openssl.so' - Shared object "libssl.so.8" not found, required by "openssl .so" in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/openssl.so' - Shared object "libssl.so.8" not found, required by "openssl.so" in Unknown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/snmp.so' - Shared object "libssl.so.8" not found, required by "snmp.so" i n Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/snmp.so' - Shared object "libssl.so.8" not found, required by "snmp.so" in Unk nown on line 0

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20 151012/zip.so' - Shared object "libssl.so.8" not found, required by "libzip.so.5 " in Unknown on line 0

 

Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2015101 2/zip.so' - Shared object "libssl.so.8" not found, required by "libzip.so.5" in Unknown on line 0

PHP 7.0.31 (cli) (built: Jul 28 2018 01:13:58) ( NTS )

Copyright (c) 1997-2017 The PHP Group

 

 

пересобирать пхп модули

и ты не дерево портов обновил а весь сука софт на сервере

  • Haha 2

Share this post


Link to post
Share on other sites
6 минут назад, l1ght сказал:

пересобирать пхп модули

и ты не дерево портов обновил а весь сука софт на сервере

только сейчас выяснил, что после моего обновления портов одно чудо обновило софт, теперь б...ь править все

каким только макаром пересобрать пхп модули?

Edited by bolelshik

Share this post


Link to post
Share on other sites
7 минут назад, bolelshik сказал:

только сейчас выяснил, что после моего обновления портов одно чудо обновило софт, теперь б...ь править все

каким только макаром пересобрать пхп модули?

Давай по новой, Миша, всё хуйня Просто перебей систему да накати дамп БД. Так будет проще и быстрее. Честно...

Edited by ISK

Share this post


Link to post
Share on other sites
1 минуту назад, ISK сказал:

Давай по новой, Миша, всё хуйня Просто перебей систему да накати дамп БД. Так будет проще и быстрее. Честно...

Будь рядом с серваком накатил без проблем. а так либо модули пересобирать либо ждать завтра

Share this post


Link to post
Share on other sites

вот список модулей, они должны быть все установлены для нормальной работы

 

root@billing:/usr/home/l1ght # php -m
[PHP Modules]
bcmath
Core
ctype
curl
date
dom
filter
ftp
gd
hash
iconv
imap
json
libxml
mbstring
memcached
mysqli
mysqlnd
openssl
pcre
PDO
pdo_sqlite
Phar
posix
redis
Reflection
session
SimpleXML
snmp
soap
sockets
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlwriter
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

root@billing:/usr/home/l1ght # php -v
PHP 7.0.31 (cli) (built: Jul 28 2018 01:13:58) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.31, Copyright (c) 1999-2017, by Zend Technologies

 

Share this post


Link to post
Share on other sites

root@12345:~ # php -v
PHP 7.3.11 (cli) (built: Nov 14 2019 01:28:56) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.11, Copyright (c) 1999-2018, by Zend Technologies

теперь такая ошибка:
Fatal error: Uncaught Error: Class 'mysqli' not found in /usr/local/www/apache24/data/billing/api/libs/api.mysql.php:29 Stack trace: #0 /usr/local/www/apache24/data/billing/api/apiloader.php(6): include() #1 /usr/local/www/apache24/data/billing/common.php(112): include('/usr/local/www/...') #2 /usr/local/www/apache24/data/billing/index.php(30): require_once('/usr/local/www/...') #3 {main} thrown in /usr/local/www/apache24/data/billing/api/libs/api.mysql.php on line 29

Share this post


Link to post
Share on other sites

root@12345:~ # php -m


bcmath
Core
ctype
curl
date
dom
filter
gd
hash
iconv
imap
json
libxml
mbstring
memcache
mysqli
mysqlnd
openssl
pcre
PDO
pdo_sqlite
Phar
posix
Reflection
session
SimpleXML
snmp
soap
sockets
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlwriter
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

 

Share this post


Link to post
Share on other sites
1 час назад, bolelshik сказал:

PHP 7.3.11 (cli) (built: Nov 14 2019 01:28:56) ( NTS )

я даже не уверен что кто-то тестил это на 7.3

Share this post


Link to post
Share on other sites
11 минут назад, l1ght сказал:

я даже не уверен что кто-то тестил это на 7.3

Уже понял, поставил 7.1

Share this post


Link to post
Share on other sites
2 часа назад, l1ght сказал:

я даже не уверен что кто-то тестил это на 7.3

На 7.2 работаю сейчас, 7.3 не скоро буду тестить.

Share this post


Link to post
Share on other sites
3 часа назад, bolelshik сказал:

же понял, поставил 7.1

ну и? заработало?

Share this post


Link to post
Share on other sites
10 часов назад, l1ght сказал:

ну и? заработало?

нет

Fatal error: Uncaught Error: Class 'mysqli' not found in /usr/local/www/apache24/data/billing/api/libs/api.mysql.php:29 Stack trace: #0 /usr/local/www/apache24/data/billing/api/apiloader.php(6): include() #1 /usr/local/www/apache24/data/billing/common.php(112): include('/usr/local/www/...') #2 /usr/local/www/apache24/data/billing/index.php(30): require_once('/usr/local/www/...') #3 {main} thrown in /usr/local/www/apache24/data/billing/api/libs/api.mysql.php on line 29

Share this post


Link to post
Share on other sites
1 час назад, bolelshik сказал:

нет

значит неправильно делаешь

Share this post


Link to post
Share on other sites
1 час назад, l1ght сказал:

значит неправильно делаешь

хотелось бы понимать что?

Share this post


Link to post
Share on other sites

С Вашими познаниями freebsd легче накатить новый инстал и залить бекап.

 

Share this post


Link to post
Share on other sites
40 минут назад, skybetik сказал:

С Вашими познаниями freebsd легче накатить новый инстал и залить бекап.

Что ему и было посоветовано выше)

15152961751805339.jpg

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By a_n_h
      Всем доброго дня!
      Подскажите как правильно объединить vlans bridge? Что-то Гугл плохо помогает...
    • By Kto To
      Сегодня вечером словил странный глюк на следующей связке.
      FreeBSD 11.2-RELEASE-p9
      MPD version: 5.8
      Клиенты подключаются по PPPOE.
      Онлайна на машине в районе 1600 абонентов
       
      Стали звонить под вечер клиенты с проблемой на неработающий интернет. Причем некоторые.
      Стали разбираться
      В результате выяснился странный глюк
       
      [] show sessions ip 10.10.0.9 ng1865 10.10.0.9 C-1866 7956732-C-1866 vlan60-1137 1137 7956732-vlan60-1137 vova 54:e6:fc:fe:5d:53 ng2233 10.10.0.9 C-2234 7959914-C-2234 vlan60-2290 2290 7959914-vlan60-2290 vova 54:e6:fc:fe:5d:53 ng2151 10.10.0.9 C-2152 7960268-C-2152 vlan60-2298 2298 7960268-vlan60-2298 vova 54:e6:fc:fe:5d:53 ng2112 10.10.0.9 C-2113 7960073-C-2113 vlan60-2299 2299 7960073-vlan60-2299 vova 54:e6:fc:fe:5d:53 [] show sessions ip 10.10.51.184 ng1710 10.10.51.184 C-1711 7933915-C-1711 vlan63-468 468 7933915-vlan63-468 051184 00:30:67:f9:8b:87 ng608 10.10.51.184 C-609 7879576-C-609 vlan63-727 727 7879576-vlan63-727 051184 00:30:67:f9:8b:87 ng883 10.10.51.184 C-884 7933023-C-884 vlan63-1028 1028 7933023-vlan63-1028 051184 00:30:67:f9:8b:87 ng1071 10.10.51.184 C-1072 7932679-C-1072 vlan63-1177 1177 7932679-vlan63-1177 051184 00:30:67:f9:8b:87 ng1643 10.10.51.184 C-1644 7933515-C-1644 vlan63-1714 1714 7933515-vlan63-1714 051184 00:30:67:f9:8b:87 ng1671 10.10.51.184 C-1672 7928866-C-1672 vlan63-1751 1751 7928866-vlan63-1751 051184 00:30:67:f9:8b:87 ng1701 10.10.51.184 C-1702 7931011-C-1702 vlan63-1769 1769 7931011-vlan63-1769 051184 00:30:67:f9:8b:87 ng1709 10.10.51.184 C-1710 7932364-C-1710 vlan63-1777 1777 7932364-vlan63-1777 051184 00:30:67:f9:8b:87 ng2269 10.10.51.184 C-2270 7961076-C-2270 vlan63-2050 2050 7961076-vlan63-2050 051184 00:30:67:f9:8b:87 ng2229 10.10.51.184 C-2230 7960448-C-2230 vlan63-2273 2273 7960448-vlan63-2273 051184 00:30:67:f9:8b:87 ng1425 10.10.51.184 C-1426 7959795-C-1426 vlan63-2280 2280 7959795-vlan63-2280 051184 00:30:67:f9:8b:87 ng2216 10.10.51.184 C-2217 7960721-C-2217 vlan63-2287 2287 7960721-vlan63-2287 051184 00:30:67:f9:8b:87 ng2252 10.10.51.184 C-2253 7960944-C-2253 vlan63-2301 2301 7960944-vlan63-2301 051184 00:30:67:f9:8b:87 ng2236 10.10.51.184 C-2237 7960217-C-2237 vlan63-2302 2302 7960217-vlan63-2302 051184 00:30:67:f9:8b:87 ng2270 10.10.51.184 C-2271 7961240-C-2271 vlan63-2313 2313 7961240-vlan63-2313 051184 00:30:67:f9:8b:87 ng2248 10.10.51.184 C-2249 7960285-C-2249 vlan63-2318 2318 7960285-vlan63-2318 051184 00:30:67:f9:8b:87 ng1899 10.10.51.184 C-1900 7962171-C-1900 vlan63-2347 2347 7962171-vlan63-2347 051184 00:30:67:f9:8b:87 ng2299 10.10.51.184 C-2300 7962389-C-2300 vlan63-2363 2363 7962389-vlan63-2363 051184 00:30:67:f9:8b:87 ng194 10.10.51.184 C-195 7962428-C-195 vlan63-2373 2373 7962428-vlan63-2373 051184 00:30:67:f9:8b:87 ng2260 10.10.51.184 C-2261 7960890-C-2261 vlan63-2378 2378 7960890-vlan63-2378 051184 00:30:67:f9:8b:87 и так далее Почему-то перестали удаляться старые неактивные сессии клиентов. Руками удаляю все сессии - клиент подключается и работает но я так думаю это до следующего реконнекта.
       
      Вот конфиг мпд (может там что-то довписать надо, хотя конфиг переносится от сервака к серваку уже долгие годы)
      pppoe_server: create bundle template C set bundle disable encryption set bundle disable compression set ccp disable mppc set ipcp dns 8.8.8.8 1.1.1.1 set ipcp range a.b.c.d/32 0.0.0.0/0 set iface enable tcpmssfix create link template oe pppoe set link action bundle C set link disable chap pap eap set link enable pap chap set link enable peer-as-calling load radius create link template vlan2 oe set link max-children 1000 set pppoe iface vlan2 set pppoe service "*" set link enable incoming ...... Почему мпд создает ng интерфейс с тем же ип если уже такой существует? Ну и почему не удаляются старые сессии?
       
      Подскажите может сталкивался кто и как побороть.
    • By Impulsee
      День добрый!
      Есть Связка Ubilling+NAS на freebsd. 
      Настроена на Виртуалке VMware. 
      Без VLAN все работает идеально. Трафик бегает, IP раздается, Денюжка зачисляется и т.д.
      Появилась потребность поднять 3 VLAN на локальном интерфейсе для Абонов. 
      Сделал: /etc/rc.conf
       
      Вывод /etc/firewall.conf 
       
       
      Сети, шаблоны NAS, в биллинге прописал. Абоны IP получают через VLAN. Интернет есть....
       
      НО:
       
      При отрицательном балансе на em1 все отключается мгновенно, и отправляет в кабинет. 
      А на VLAN сетях Интернет есть. 
       
      Кусок /var/stargazer/allconnect.log

       
      кусок /var/log/stargazer.log
       
       
      Подскажите, плиз, в какую сторону копать?
       
    • By Baneff
      Всем привет.
      Давно использую freebsd + ipfw + dummynet + kernel nat + ещё куча всякого разного и всё на одном серваке. Менять платформу не хочу - старый я уже для этого. Так вот. Нагрузка постепенно растёт, пора как-бы железо менять в очередной раз, но есть проблема. Всё в этой схеме прекрасно параллелится на мультиядерной системе. Всё, кроме старичка DUMMYNET. В очередной раз смотрю на процесс kernel{dummynet} и в очередной раз вижу конкретное узкое место во всй системе. Обойти невозможно, работает только в один поток и когда загрузка превышает 80-90% начинаются естественные проблемы. Все остальное работает с большим запасом по нагрузке. Вот и вопрос: как-то эту проблему удаётся решать? Чем шейпить юзеров, если не дамминетом? Или может появилась возможность как-то его параллелить? Или, возможно, какие-то новые методы позволяют как-то снизить нагрузку на дамминет? В документации появились некие новые варианты настроек CoDel, PIE, FQ-CoDel и FQ-PIE в дополнение к старым, может они помогут? Кто-то пробовал?
      Спасибо.
    • By FosterUA
      Сегодня на появилось
      cam status uncorrectable parity/crc error
      Reatrying command
      Write fpdma queued
       
      Подскажите что это ? Спасибо
×