Jump to content
Local
Mahmudich

NetFlow+MikroTik настройка

Recommended Posts

Установил MikroTik в качестве NAS через api, все работает как бы, сейчас пытаюсь сделать статистику по трафику через NetFlow. На микротеке включил сенсор и прописал адрес билинга.

/ip traffic-flow set enable=yes interfaces=all cache-entries=256k active-flow-timeout=30m inactive-flow-timeout=15s
/ip traffic-flow target add address=10.0.0.254:42111 version=5

Как настроить сам билинг на прием статистики от микротика? есть ли какая инструкция? перелистал вики ничего ненашол

Share this post


Link to post
Share on other sites

/etc/rc.conf

#netflow sensor
softflowd_enable="YES"
softflowd_interfaces="vtnet0"
softflowd_vtnet0_collector="127.0.0.1:42111"

Share this post


Link to post
Share on other sites
12 минут назад, Lopfi сказал:

/etc/rc.conf

#netflow sensor
softflowd_enable="YES"
softflowd_interfaces="vtnet0"
softflowd_vtnet0_collector="127.0.0.1:42111"

это вообще здесь при чем?

2 часа назад, Mahmudich сказал:

перелистал вики ничего ненашол

старгейзер сразу должен быть собран с модулем netflow (nf_cap) и слушать 42111 порт, если пользоваться штатным инсталлером то всё работает из каробки

Share this post


Link to post
Share on other sites
Цитата

старгейзер сразу должен быть собран с модулем netflow (nf_cap) и слушать 42111 порт, если пользоваться штатным инсталлером то всё работает из каробки 

Использовал штатный инстайлер, все установлено, в топе есть запущеный softflowd порт 42111.  как проверить его работу?

В насе у меня стоит в Bandwidthd адрес микротика http://192.168.1.4/graphs/queue, откудова билинг берет графики.

Я так понимаю если включеный netflow билинг должен с него статистику брать и графики? или я неправильно понимаю как это должно работать?

Share this post


Link to post
Share on other sites
годину тому, Mahmudich сказав:

Использовал штатный инстайлер, все установлено, в топе есть запущеный softflowd порт 42111.  как проверить его работу?

В насе у меня стоит в Bandwidthd адрес микротика http://192.168.1.4/graphs/queue, откудова билинг берет графики.

Я так понимаю если включеный netflow билинг должен с него статистику брать и графики? или я неправильно понимаю как это должно работать?

 

Офтоп. Мсье, прикройтесь. Уж больно неприлично светите микротом своим.

Share this post


Link to post
Share on other sites
4 часа назад, Mahmudich сказал:

запущеный softflowd порт 42111.

при чем тут софтфлоуд?

адрес биллинга верно указан (10.0.0.254)? может ты шлешь нетфлоу не туда 

Share this post


Link to post
Share on other sites

Указан верно

1010.jpg.2c8caba267fe38f37295140d856ef64a.jpg

На стороне билинга что слушает 42111 порт? какой сервис?

 

Share this post


Link to post
Share on other sites
3 минуты назад, Mahmudich сказал:

Указан верно

1010.jpg.2c8caba267fe38f37295140d856ef64a.jpg

На стороне билинга что слушает 42111 порт? какой сервис?

 

адрес билинга какой? 192.168.1.1 ?

Share this post


Link to post
Share on other sites
10 минут назад, Mahmudich сказал:

Указан верно

1010.jpg.2c8caba267fe38f37295140d856ef64a.jpg

На стороне билинга что слушает 42111 порт? какой сервис?

 

слабо моё сообщение прочитать полностью про 42111 порт что б понять кто слушает?

Share this post


Link to post
Share on other sites
24 минуты назад, a_n_h сказал:

адрес билинга какой? 192.168.1.1 ? 

Да, 192.168.1.1 адрес билинга

 

17 минут назад, l1ght сказал:

слабо моё сообщение прочитать полностью про 42111 порт что б понять кто слушает?

Читал, мне непонятно какой процес(демон) отвечает за прослушку 42111. У меня в билинге в топе висит только softflowd, netflow (nf_cap) нет в процесах. Хочу понять от начала до конца как билинг получает даные трафика от микротика.

Share this post


Link to post
Share on other sites
1 час назад, Mahmudich сказал:

мне непонятно какой процес(демон)

stargazer

смотри в sockstat и всё поймешь

и софтфлоуд не слушает порт 42111 а шлет на него данные, разницу чувствуешь?

Share this post


Link to post
Share on other sites
1 час назад, Mahmudich сказав:

Указан верно

1010.jpg.2c8caba267fe38f37295140d856ef64a.jpg

На стороне билинга что слушает 42111 порт? какой сервис?

 

а адрес NASа какой? просто уточнить, мало ли

Share this post


Link to post
Share on other sites
26 минут назад, device сказал:

а адрес NASа какой? просто уточнить, мало ли

192.168.1.4

Share this post


Link to post
Share on other sites
38 минут назад, l1ght сказал:

stargazer

смотри в sockstat и всё поймешь

и софтфлоуд не слушает порт 42111 а шлет на него данные, разницу чувствуешь?

Понятно, а как билинг со старгейзера стягивает даные по трафику, какой модуль или бибилиотека в билинге отвечает?

Share this post


Link to post
Share on other sites
2 минуты назад, Mahmudich сказав:

Понятно, а как билинг со старгейзера стягивает даные по трафику, какой модуль или бибилиотека в билинге отвечает?

Посмотрите модуль старгазера cap_nf, в логах старгазера есть упоминание о нем при запуске?

Share this post


Link to post
Share on other sites
4 минуты назад, Mahmudich сказал:

Понятно, а как билинг со старгейзера стягивает даные по трафику, какой модуль или бибилиотека в билинге отвечает?

читай код

  • Like 1

Share this post


Link to post
Share on other sites
5 часов назад, Mahmudich сказав:

Понятно, а как билинг со старгейзера стягивает даные по трафику, какой модуль или бибилиотека в билинге отвечает?

Вы в принципе не понимаете, как работают сенсоры или коллекторы netflow. Зачем вам эти сведения?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vegas.firestorm
      Добрый день!
      решил поднять на своем Микротике PPTP Всё делал по этой инструкции - https://howitmake.ru/blog/waildhand/176.html
       
      Разве что в правиле на файрволе для порта 1723 указал In. Interface List - WAN
       
      К ВПН-у конектится, но не видит никаких ресурсов внутри сети. Можете подсказать, что нужно ещё сделать, чтобы пользователь, который конектится по ВПН, видел всё внутри сети?
       
       
      Конфиг роутера:
       
      /interface bridge
      add arp=proxy-arp name=bridge1
      /interface pptp-server
      add name=pptp-in1 user=""
      /interface list
      add name=WAN
      add name=LAN
      /interface wireless security-profiles
      set [ find default=yes ] supplicant-identity=MikroTik
      /ip pool
      add name=dhcp ranges=192.168.77.10-192.168.77.154
      add name=vpn ranges=192.168.77.200-192.168.77.250
      /ip dhcp-server
      add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
      /interface bridge port
      add bridge=bridge1 interface=ether2
      add bridge=bridge1 interface=ether3
      add bridge=bridge1 interface=ether4
      add bridge=bridge1 interface=ether5
      add bridge=bridge1 interface=ether6
      add bridge=bridge1 interface=ether7
      add bridge=bridge1 interface=ether8
      add bridge=bridge1 interface=ether9
      add bridge=bridge1 interface=ether10
      add bridge=bridge1 interface=ether11
      add bridge=bridge1 interface=ether12
      /interface l2tp-server server
      set enabled=yes ipsec-secret=(IPSECSecret) use-ipsec=yes
      /interface list member
      add interface=ether1 list=WAN
      add interface=bridge1 list=LAN
      /interface pptp-server server
      set enabled=yes
      /interface sstp-server server
      set default-profile=default-encryption enabled=yes
      /ip address
      add address=111.111.55.102/24 comment=defconf interface=ether1 network=\
          111.111.55.0
      add address=192.168.77.1/24 interface=ether2 network=192.168.77.0
      /ip cloud
      set ddns-enabled=yes ddns-update-interval=1h
      /ip dhcp-client
      add dhcp-options=hostname,clientid interface=ether1
      add dhcp-options=hostname,clientid interface=ether1
      /ip dhcp-server network
      add address=192.168.77.0/24 gateway=192.168.77.1 netmask=24
      /ip dns
      set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4,9.9.9.9,1.1.1.1
      /ip firewall filter
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      add action=accept chain=input comment=\
          "defconf: accept established,related,untracked" connection-state=\
          established,related,untracked
      add action=accept chain=input comment="allow sstp" dst-port=443 \
          in-interface-list=WAN protocol=tcp
      add action=accept chain=input comment="allow l2tp" dst-port=1701 \
          in-interface-list=WAN protocol=udp
      add action=accept chain=input comment="allow pptp" dst-port=1723 \
          in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
      add action=accept chain=input protocol=gre
      add action=accept chain=forward dst-port=445 protocol=tcp
      add action=accept chain=input dst-port=80 protocol=tcp
      add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
          protocol=udp
      add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
      add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
      add action=accept chain=forward comment="defconf: accept in ipsec policy" \
          ipsec-policy=in,ipsec
      add action=accept chain=forward comment="defconf: accept out ipsec policy" \
          ipsec-policy=out,ipsec
      add action=accept chain=forward comment=\
          "defconf: accept established,related, untracked" connection-state=\
          established,related,untracked
      add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
          connection-state=established,related
      add action=drop chain=forward comment="defconf: drop invalid" \
          connection-state=invalid
      add action=drop chain=input comment="defconf: drop invalid" connection-state=\
          invalid
      add action=drop chain=input comment="defconf: drop all not coming from LAN" \
          in-interface-list=!LAN
      add action=drop chain=forward comment=\
          "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
          connection-state=new in-interface-list=WAN
      /ip firewall nat
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      add action=masquerade chain=srcnat comment="defconf: masquerade" \
          ipsec-policy=out,none out-interface-list=WAN
      add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
          192.168.89.0/24
      /ip route
      add distance=1 gateway=111.111.55.254
      add distance=1 gateway=111.111.55.254
      /lcd
      set backlight-timeout=2m
      /lcd pin
      set pin-number=1111
      /ppp secret
      add local-address=192.168.77.1 name=vpn password=vpnvpn profile=\
          default-encryption remote-address=192.168.77.200 service=pptp
      /system clock
      set time-zone-name=Europe/Kiev
    • By andrey-r
      Доброго времени суток, камрады
       
      Нужна помощь админа с опытом настройки роутеров микротик routeros
      Разовые заказы. Появилась потребность - поставил задачи, сделали, заплатил. Раз в 2-3 месяца.
       
      В частности сейчас нужно на один порт (или на сеть) дать гарантированный канал не менее 20мбит
      И на остальные порты (сети) дать не более 80мбит.
      Чтобы вип абонент имел гарантированный канал при 100% нагрузке канала.
       
      Кто поможет?
      Связь тут или Вайбер/телеграм по номеру 0937672229
       
    • By Spiritok42
      Компанія Gazik запрошує до співпраці !
      великий асортимент товару  доступні ціни гарантія 1 рік !!! швидка доставка придбати обладнання з ПДВ! привезти обладнання під замовлення!  
                  ТОП продаж!!!
      MikroTik RB941-2nD                                19,99$
      MikroTik RBD52G-5HacD2HnD-TC         63$  
      MikroTik RB2011UiAS-2HnD-IN              113,85$ 
      MikroTik RBcapGI-5ACD2nD                   61$ 
      Точка доступу UBNT UAP-AC-LITE        85,56$
      Точка доступу UBNT UAP-AC-LR          105,22$   
      Контроллер UBNT UC-CK                      81,85$  
      Точка доступу UBNT LBE-M5-23           47$  
      Точка доступу UBNT PBE-M5-400         86,65$ 
       
      Наш прайс: GAZIK PRICE local.xlsx
       
      За детальною інформаціє звертайтеся:
      - tel. viber: +38 098 886 63 06
      - skype: live:spiritok42

    • By golohvostiy
      RB433GL - 800 грн
      RB800 - 2000 грн
      R52Hn - 500 грн (2 шт)
      R52n-M - 600 грн
      NetMetal 5 (RB922UAGS-5HPacD-NM) - 2300 грн
      Под роутерборды есть герметичные корпуса - 400 грн (2 шт)
      SXT Lite5 (RBSXT5nDr2) - отдам даром (питание подаётся, он включается, но сеть не видит)
       
    • By valexa
      Подскажите где можно купить или у кого то есть, готов купить регулировочный болт для этой антенны. Болт со всем навесным.

×