Jump to content
Local
Sign in to follow this  
vegas.firestorm

VPN на Микротике - не вижу ничего внутри сети

Recommended Posts

Добрый день!

решил поднять на своем Микротике PPTP Всё делал по этой инструкции - https://howitmake.ru/blog/waildhand/176.html

 

Разве что в правиле на файрволе для порта 1723 указал In. Interface List - WAN

 

К ВПН-у конектится, но не видит никаких ресурсов внутри сети. Можете подсказать, что нужно ещё сделать, чтобы пользователь, который конектится по ВПН, видел всё внутри сети?

 

 

Конфиг роутера:

 

/interface bridge
add arp=proxy-arp name=bridge1
/interface pptp-server
add name=pptp-in1 user=""
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.77.10-192.168.77.154
add name=vpn ranges=192.168.77.200-192.168.77.250
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=ether11
add bridge=bridge1 interface=ether12
/interface l2tp-server server
set enabled=yes ipsec-secret=(IPSECSecret) use-ipsec=yes
/interface list member
add interface=ether1 list=WAN
add interface=bridge1 list=LAN
/interface pptp-server server
set enabled=yes
/interface sstp-server server
set default-profile=default-encryption enabled=yes
/ip address
add address=111.111.55.102/24 comment=defconf interface=ether1 network=\
    111.111.55.0
add address=192.168.77.1/24 interface=ether2 network=192.168.77.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=1h
/ip dhcp-client
add dhcp-options=hostname,clientid interface=ether1
add dhcp-options=hostname,clientid interface=ether1
/ip dhcp-server network
add address=192.168.77.0/24 gateway=192.168.77.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4,9.9.9.9,1.1.1.1
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment="allow sstp" dst-port=443 \
    in-interface-list=WAN protocol=tcp
add action=accept chain=input comment="allow l2tp" dst-port=1701 \
    in-interface-list=WAN protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 \
    in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
add action=accept chain=input protocol=gre
add action=accept chain=forward dst-port=445 protocol=tcp
add action=accept chain=input dst-port=80 protocol=tcp
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
    protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment="allow sstp" dst-port=443 \
    in-interface-list=WAN protocol=tcp
add action=accept chain=input comment="allow l2tp" dst-port=1701 \
    in-interface-list=WAN protocol=udp
add action=accept chain=input comment="allow pptp" dst-port=1723 \
    in-interface-list=WAN log=yes log-prefix=VPN-TEST protocol=tcp
add action=accept chain=input protocol=gre
add action=accept chain=forward dst-port=445 protocol=tcp
add action=accept chain=input dst-port=80 protocol=tcp
add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 \
    protocol=udp
add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
    192.168.89.0/24
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=\
    192.168.89.0/24
/ip route
add distance=1 gateway=111.111.55.254
add distance=1 gateway=111.111.55.254
/lcd
set backlight-timeout=2m
/lcd pin
set pin-number=1111
/ppp secret
add local-address=192.168.77.1 name=vpn password=vpnvpn profile=\
    default-encryption remote-address=192.168.77.200 service=pptp
/system clock
set time-zone-name=Europe/Kiev

Share this post


Link to post
Share on other sites
Цитата

add address=192.168.77.1/24 interface=ether2 network=192.168.77.0

висит на эзер2, а манипуляции с бриджом 

Share this post


Link to post
Share on other sites
1 hour ago, Diter_ua said:

висит на эзер2, а манипуляции с бриджом 

 

Ок, поменял на бридж - http://prntscr.com/r3skzn

Вроди ничего не поменялось, но, проверял с телефона, завтра проверю с компа на работе.

Что меня смущает - айпишник ВПН-а выдается с 32й подсетью, т.е. только один айпи в сети. может ли это быть проблемой?

 

Edited by vegas.firestorm

Share this post


Link to post
Share on other sites

/ip firewall nat
add action=masquerade chain=srcnat src-address=192.168.77.200

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By pavelzed
      Маршрутизатор Mikrotik CCR1016-12S-1S
      12500 грн -торг
    • By Angel&
      Всем доброго здравия коллеги. после обновления прошивки на микротике на 6.46.4 а вчера и на 6.47 стали появляться непонятные соединения в логах: 
      TCP connection established from 89.248.168.112
      TCP connection established from 223.71.167.164


      КАК эти соединения заблочить? Я удалённо захожу на свой микротк по pptp и теперь как быть((( - поставить сложнее пароль?
      на микротике есть openVPN от zaborona.help работает а также удалённый микротик соединяется с основным по l2tp.
      В миротике немного дилетант - поэтому прошу помощи на форуме. кто подскажет толково - тому к карме +
      Всем спасибо.
    • By Angel&
      Всем доброго времени суток.
      На удалёнке стоит микротик с свистком E3772 c прошивкой stik. и вот приходят на сим карту смс, а через микротик видно только одни вопросительные знаки, вопрос: как это можно исправить и возможно ли:

    • By yama
      Доброго здоровья !
       
      Хочу купить платный VPN  и настроить его на роутере Zyxel Keenetic Viva https://keenetic.ua/uk/zyxel-keenetic-viva
        https://wifika.ru/vpn-server-na-routere-zyxel-keenetic.html
      смысл просмотр заблокированных HD каналов онлайн из Европы и прочих стриминговых сервисов 
       
      собственно вопросы
      1) какой платный сервис VPN  порекомендуете интересуют серверы Европы,  мне и одного хватит
      2) потянет ли мой Zyxel Keenetic Viva 
      CPU: MediaTek MT7620N (MIPS24Kc) @600MHz, Flash: 16MB, RAM: 128MB (DDR2)
      WLAN: WiSoC 2T2R/300Mbps (2.4GHz), 2x 3dBi (fixed ext), Switch: Realtek RTL8367RB 5x GbE, USB: 1x 2.0
      MT7620 CPU detected
      The CPU frequency set to 580 MHz
      CPU revision is: 00019650 (MIPS 24Kc)
      Primary instruction cache 64kB, VIPT, no aliases, 4-waylinesize 32 bytes.
      Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
      Calibrating delay loop... 386.04 BogoMIPS (lpj=193024) по данним ixbt.com
      4) если мой зухель не потянет hd и 4к  онлайн на Смарт ТВ ( ютуб) тогда что минимум потянет ?
      5) не существенный впрос о качании торрентов надо забыть  ? готов отключать во время \ для скачки торрентов , особо не качок   качаю пару блю рей дисков в неделю максимум
       
       
    • By Інет.укр
      Продам
      CCR1009-7g-1c-1s+   -  7500грн
      CCR1036-12g-4s (Гарантія до 10/20)     -  14299грн
      CCR1009-8g-1s   -  6500грн
      можливий торг





×