Jump to content
Local
Angel&

Mikrotik поднять VPN через Cloud

Recommended Posts

Всем доброго времени суток.
Прошу откликнутся кого либо из участников форума и помочь поднастроить или донастроить мой девайс. 
Ранее в 2013 году мой mikrotik стоял у провайдера с выделенным IP и я без проблем по VPN я заходил во внутреннюю сеть.
На данный момент другой провайдер (Vega) с динамическим IP. Включил через IP->Cloud DDNS, получил имя, но увы ничего не заходит. Настройки не менялись с прошлой настройки, а вот прошивка последней стабильной версии.
Кто может удалённо через Teamviver зайти посмотреть, буду признателен, пишем в ЛС. Что там с меня - тоже в ЛС)

Edited by Angel&

Share this post


Link to post
Share on other sites

Адрес хоть белый на микроте? 

Share this post


Link to post
Share on other sites
5 часов назад, Angel& сказал:

но увы ничего не заходит. Настройки не менялись с прошлой настройки,

смотри в фаерволе адрес листы или где там твой довереный ИПшник записан...

или бросай сюда file.src(конфиг микрота) - export file=<имя файла>

Share this post


Link to post
Share on other sites
19 часов назад, datakrava сказал:

смотри в фаерволе адрес листы или где там твой довереный ИПшник записан...

или бросай сюда file.src(конфиг микрота) - export file=<имя файла>


# mar/19/2020 18:38:23 by RouterOS 6.46.4
# software id = 76UA-G7K3
#
# model = 951-2n
# serial number = ну тут был номер
/interface bridge
add comment="\CF\EE\EB\FC\E7\EE\E2\E0\F2\E5\EB\FC\F1\EA\E8\E9 \E8\ED\F2\E5\F0\
    \F4\E5\E9\F1" fast-forward=no mtu=1500 name="B - LAN" protocol-mode=none
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC \
    country=no_country_set disabled=no frequency=2432 frequency-mode=\
    superchannel hw-protection-mode=rts-cts mode=ap-bridge name=\
    "6 - Wireless Interface" radio-name="" ssid=SSID wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] comment=\
    "\C2\ED\E5\F8\ED\E8\E9 \E8\ED\F2\E5\F0\F4\E5\E9\F1" mac-address=\
    70:5A:B6:97:2D:E3 name="1 - WAN"
set [ find default-name=ether2 ] name="2 - Ethernet"
set [ find default-name=ether3 ] arp=proxy-arp name="3 - Ethernet"
set [ find default-name=ether4 ] name="4 - Ethernet"
set [ find default-name=ether5 ] name="5 - Ethernet"
/interface pptp-server
add name=pptp-in1 user=Chif
/interface vlan
add comment="VLAN \E4\EB\FF \F3\EF\F0\E0\E2\EB\E5\ED\E8\FF AirGrid" \
    interface="1 - WAN" name="1.2 - AirGrid M2 MGMT" vlan-id=2
/interface list
add exclude=dynamic name=discover
add name=mac-winbox
add name=WAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=\
    tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=vova14041982 \
    wpa2-pre-shared-key=vova14041982
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
/ip pool
add name=dhcp ranges=10.24.0.2-10.24.0.254
add name=vpn ranges=192.168.89.2-192.168.89.255
/ip dhcp-server
add address-pool=dhcp authoritative=after-2sec-delay disabled=no interface=\
    "B - LAN" lease-time=52w1d name=dhcp1
/port
set 0 name=serial0
/ppp profile

Share this post


Link to post
Share on other sites
В 18.03.2020 в 22:48, tkapluk сказал:

Адрес хоть белый на микроте? 

 

Да, у веги вроде бы с этим порядок, подключил свисток с сим лайфа - один фиг

 

Edited by Angel&

Share this post


Link to post
Share on other sites
5 часов назад, Angel& сказал:


# mar/19/2020 18:38:23 by RouterOS 6.46.4
# software id = 76UA-G7K3
#
# model = 951-2n
# serial number = ну тут был номер
/interface bridge
add comment="\CF\EE\EB\FC\E7\EE\E2\E0\F2\E5\EB\FC\F1\EA\E8\E9 \E8\ED\F2\E5\F0\
    \F4\E5\E9\F1" fast-forward=no mtu=1500 name="B - LAN" protocol-mode=none
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC \
    country=no_country_set disabled=no frequency=2432 frequency-mode=\
    superchannel hw-protection-mode=rts-cts mode=ap-bridge name=\
    "6 - Wireless Interface" radio-name="" ssid=SSID wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] comment=\
    "\C2\ED\E5\F8\ED\E8\E9 \E8\ED\F2\E5\F0\F4\E5\E9\F1" mac-address=\
    70:5A:B6:97:2D:E3 name="1 - WAN"
set [ find default-name=ether2 ] name="2 - Ethernet"
set [ find default-name=ether3 ] arp=proxy-arp name="3 - Ethernet"
set [ find default-name=ether4 ] name="4 - Ethernet"
set [ find default-name=ether5 ] name="5 - Ethernet"
/interface pptp-server
add name=pptp-in1 user=Chif
/interface vlan
add comment="VLAN \E4\EB\FF \F3\EF\F0\E0\E2\EB\E5\ED\E8\FF AirGrid" \
    interface="1 - WAN" name="1.2 - AirGrid M2 MGMT" vlan-id=2
/interface list
add exclude=dynamic name=discover
add name=mac-winbox
add name=WAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=\
    tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=vova14041982 \
    wpa2-pre-shared-key=vova14041982
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
/ip pool
add name=dhcp ranges=10.24.0.2-10.24.0.254
add name=vpn ranges=192.168.89.2-192.168.89.255
/ip dhcp-server
add address-pool=dhcp authoritative=after-2sec-delay disabled=no interface=\
    "B - LAN" lease-time=52w1d name=dhcp1
/port
set 0 name=serial0
/ppp profile

а firewall?

Share this post


Link to post
Share on other sites
7 часов назад, deltatelecom сказал:

А обязательно белый айпишник?

Да.

Share this post


Link to post
Share on other sites
1 час назад, masters сказал:

Да.

Тю так смысл тогда в этом cloud.? При наличии белого купи я и так зайду удалённо

Share this post


Link to post
Share on other sites
52 минуты назад, deltatelecom сказал:

Тю так смысл тогда в этом cloud.? При наличии белого купи я и так зайду удалённо

дело в том что от Cloud а - выданного адреса устройство пингуется. а мне надо vpn сервер просто поднять и всё, что бы я мог зайти удалёно в свою сеть. 

10 часов назад, olnet сказал:

а firewall?

Я не сильно силён в микротике, чего и прошу толковых помощи.
 

[admin@Chif_PC] /ip firewall filter> print      
Flags: X - disabled, I - invalid, D - dynamic 
 0    ;;;                         10.24.0.0/24                        :
      chain=forward action=accept src-address=10.24.0.0/24 in-interface=B - LAN 
      out-interface=1 - WAN log-prefix="" 

 1    chain=forward action=accept dst-address=10.24.0.0/24 in-interface=1 - WAN 
      out-interface=B - LAN log-prefix="" 

 2    ;;;                    AirGrid M2 HP                   10.24.0.0/24:
      chain=forward action=accept src-address=10.24.0.0/24 
      dst-address=192.168.0.219 in-interface=B - LAN 
      out-interface=1.2 - AirGrid M2 MGMT log-prefix="" 

 3    chain=forward action=accept src-address=192.168.0.219 
      dst-address=10.24.0.0/24 in-interface=1.2 - AirGrid M2 MGMT 
      out-interface=B - LAN log-prefix="" 

 4 X  ;;;                    AirGrid M2 HP                 :
      chain=forward action=accept protocol=tcp dst-address=192.168.0.219 
      in-interface=1 - WAN out-interface=1.2 - AirGrid M2 MGMT dst-port=80 
      log-prefix="" 

 5 X  chain=forward action=accept protocol=tcp src-address=192.168.0.219 
-- [Q quit|D dump|down]
 

Share this post


Link to post
Share on other sites

Vpn через який протокол планується ? Якщо є білий статичний запис просто зробити будь який піддомен А запис.

Share this post


Link to post
Share on other sites
1 час назад, ntp сказал:

Vpn через який протокол планується ? Якщо є білий статичний запис просто зробити будь який піддомен А запис.

Я же пишу что нет статического. есть динамический только IP белый
Для статики используется функция Cloud

Share this post


Link to post
Share on other sites
2 часа назад, Angel& сказал:

Я же пишу что нет статического. есть динамический только IP белый
Для статики используется функция Cloud

Цьому за запросити статичний білий ?

Share this post


Link to post
Share on other sites

ТС, А IP точно белый? Или за НАТом?

На сам IP, что получен микротом от прова пробовал подключится?

6 часов назад, deltatelecom сказал:

Тю так смысл тогда в этом cloud.?

6 часов назад, deltatelecom сказал:

При наличии белого купи я и так зайду удалённо

А если реконнект и IP новый? Зайдешь?

Edited by Dimkers

Share this post


Link to post
Share on other sites
42 минуты назад, Dimkers сказал:

ТС, А IP точно белый? Или за НАТом?

На сам IP, что получен микротом от прова пробовал подключится?

А если реконнект и IP новый? Зайдешь?

Когда Реал айпи не за нат, то все работает прекрасно, а вот когда за нат да ещё и реал статик айпи хз не пробовал

Share this post


Link to post
Share on other sites

Чё вы привязались к тому адресу? белый ону ВЕГИ, БЕЛЫЙб в отличии от вас и адрес тот что дал CLOUD микротика пингуется извне. Почему не работает ВПН....

Share this post


Link to post
Share on other sites

Mikrotik Cloud = DDNS + NTP over HTTP

белых адресов он магическим образом не добавляет.

Share this post


Link to post
Share on other sites

А gre и порт 1723 ведь не открыли из-вне ?

 

ip firewall filter add chain=input action=accept protocol=gre

ip firewall filter add chain=input action=accept protocol=tcp dst-port=1723

 

Выше всех правил поместить

 

Edited by Matou
upd
  • Like 1

Share this post


Link to post
Share on other sites
1 час назад, Matou сказал:

А gre и порт 1723 ведь не открыли из-вне ?

 

ip firewall filter add chain=input action=accept protocol=gre

ip firewall filter add chain=input action=accept protocol=tcp dst-port=1723

 

Выше всех правил поместить

 

отправил скрин в ЛС

Share this post


Link to post
Share on other sites
5 часов назад, Angel& сказал:

Чё вы привязались к тому адресу? белый ону ВЕГИ, БЕЛЫЙб в отличии от вас и адрес тот что дал CLOUD микротика пингуется извне. Почему не работает ВПН....

Ванг тут нет.

IP озвучь.

Ты уверен что НАТа нет?

Там гдето с какойто пришивки поламали GRE в микротиках. Нужно хелпер указывать в фаере.

Но я еще раз говорю - мало вводных. Ты хоть логи смотрел? Адрес на интерфейсе соответствует? GRE у веги не порезан?

И что значит "в отличае от вас"? У меня работает все прекрасно. Белый ИП на микротике и я из любой точки мира подключаюсь. Не работает у тебя. Так что в отличае от вас - у меня руки не из задницы растут.

 

7 часов назад, deltatelecom сказал:

а вот когда за нат да ещё и реал статик айпи хз не пробовал

За НАТом - обычно серый. Я тебе говорю про динамический белый. Это когда при каждом реконнекте - новый белый адрес. Как ты его узнаешь, находясь на расстоянии? Вот как раз для этого и есть клауд от микротика. Все. Считай что это DDNS.

 

Edited by Dimkers

Share this post


Link to post
Share on other sites
6 часов назад, Dimkers сказал:

Ванг тут нет.

IP озвучь.

Ты уверен что НАТа нет?

Там гдето с какойто пришивки поламали GRE в микротиках. Нужно хелпер указывать в фаере.

Но я еще раз говорю - мало вводных. Ты хоть логи смотрел? Адрес на интерфейсе соответствует? GRE у веги не порезан?

И что значит "в отличае от вас"? У меня работает все прекрасно. Белый ИП на микротике и я из любой точки мира подключаюсь. Не работает у тебя. Так что в отличае от вас - у меня руки не из задницы растут.

 

За НАТом - обычно серый. Я тебе говорю про динамический белый. Это когда при каждом реконнекте - новый белый адрес. Как ты его узнаешь, находясь на расстоянии? Вот как раз для этого и есть клауд от микротика. Все. Считай что это DDNS.

 

Не знаю как у Веги эт организовано.

Может адрес и не белый, вот и не работает) 

Share this post


Link to post
Share on other sites
9 часов назад, Dimkers сказал:

Не работает у тебя. Так что в отличае от вас - у меня руки не из задницы растут.

 

Да, так тут форум на котором в ОТЛИЧАЕ от тебя о чём то спрашивают и делятся. Иди в другой ветке поумничай с своими руками.

Share this post


Link to post
Share on other sites

Для теста отключите все правила в firewall и посмотрите или работает. 

И еще, использовать IP, а не ddns пробовали? Так работает? 

Share this post


Link to post
Share on other sites
15 минут назад, olnet сказал:

Для теста отключите все правила в firewall и посмотрите или работает. 

И еще, использовать IP, а не ddns пробовали? Так работает? 

Да это всё пробовал, где то недонастроил наверное толком.Надо всё заново беребирать.
image.png.4f5d6c9cac7df2d433bc4b81aecea33f.png

Share this post


Link to post
Share on other sites
29 минут назад, Angel& сказав:

Да это всё пробовал, где то недонастроил наверное толком.Надо всё заново беребирать.
image.png.4f5d6c9cac7df2d433bc4b81aecea33f.png

так в тебе проблема не в cloud а в налаштуванні pptp!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By valera040569
      Mikrotik CCR1016-12S-1S+ Маршрутизатор 12xSFP порт, 1xSFP+, 16-ядер CPU новый в коробке. Отдам за 450 $ тел 0509678471
      image (2) (1).webp
    • By Spiritok42
      великий асортимент товару 
      доступні ціни гарантія 1 рік !!! швидка доставка  
      Також можемо привезти для вас обладнання під замовлення .
      ТОП продаж!!!
      MikroTik RB941-2nD - 19,5$
      MikroTik RB951Ui-2HnD - 51.7$
      MikroTik RB952Ui-5ac2nD-TC - 43.1$ 
      MikroTik RBD52G-5HacD2HnD-TC - 68$   
      MikroTik RB2011UiAS-2HnD-IN - 110,90$ 
      MikroTik RBcapGI-5ACD2nD - 59.1$
       
      Онлайн прайс : https://docs.google.com/spreadsheets/d/1COY2YGuJA-ipfcAtgsk-eLWZATnWKTqUe8lCE68rYL4/edit?usp=sharing
       
      За детальною інформаціє звертайтеся:
      - tel. viber: +38 098 886 63 06
      - skype: live:spiritok42
       
       
       



    • By Xiovi
      Здравствуйте. Такая история. Есть abills 0.55b и nas mikrotik. Количество абонентов растёт, и решено поделить сеть на вланы. В микротике добавил vlan'ы, на этих вланах добавил pppoe сервера. Вланы прокинул до абонентов. Маки в вланах вижу, но пппое сессии не поднимаются. Если выключаю работающий pppoe сервер, то начинает работать один из новосозданных. В общем одновременно более 1 pppoe сервера не работает.
      Есть такая же связка в другом городе, только там стоит abills 0.54b. Там всё работает. Крутится 11 pppoe сервером и всё без проблем. 
      Кто то с таким сталкивался?
       






    • By mrCrazy
      Возникла проблема с подключением принимающей точки lite5 к роутеру RB951UI 2HnD
      При подключении старого роутера asus n10e,а за ним 951го все ок,но при подключении напрямую нет интернета(
      Такая же проблема была с 750ым микотиком,решил что с ним что-то не так,взял этот - то же самое(
      Уверен проблема с настройками,ткните носом пожалуйста =)
×