Jump to content

Помилка could not add address list


Recommended Posts

Всім привіт!

Є налаштований ubilling+mikrotik+pppoe. Все працювало коли був один NAS Mikrotik, після того як добавив ще один NAS також Mikrotik з'явилась проблема. Коли користувач переходить з стану активний\неактивний чи навпаки в логах мікротіка бачу помилку "could not add address list: already have such entry" хоча дублювання ір-адреси немає.  В статистиці сесій NAS КупаГен помилка - Port-Error. 

Видалення та створення ідентичного користувача - не дало жодного результату, помилка залишилась.

В таблиці mlg_reply для користувача дублюються  значення: 'attribute' => 'Framed-IP-Address', 'attribute' => 'Acct-Interim-Interval',  'attribute' => 'Mikrotik-Address-List', 'attribute' => 'Idle-Timeout'.

Можливо хтось знає як це вирішити, буду вдячний за допомогу.

 

 

Link to post
Share on other sites

было такое, помогла регенегация атрибутов, хотя она и так вроде каждые 2 минуты срабатывает если работает remoteapi

Link to post
Share on other sites

Регенерацію атрибутів робив, не допомогло. 

Можливо не правильно додав NAS ? Вибрав мережу, тип, вказав ір-адресу, ім'я, клонував конфігурацію з існуючого, перезавантажив сервіс radiusd.

Link to post
Share on other sites

Якшо у вас перший нас генерує атрибути для цьго користувача то просто в другому насі лишіть атрибути пустими тільки додайте сервіс, або заводьте абонентів в іншу мережу для другого насу відмінну від тієї що видає перший нас

Edited by zxtaras
Link to post
Share on other sites
В 23.04.2021 в 09:27, eminema_nema сказав:

Регенерацію атрибутів робив, не допомогло. 

Можливо не правильно додав NAS ? Вибрав мережу, тип, вказав ір-адресу, ім'я, клонував конфігурацію з існуючого, перезавантажив сервіс radiusd.

 

30 2 * * *  /bin/ubapi "multigentotal"

 

Link to post
Share on other sites
  • 2 weeks later...
В 24.04.2021 в 14:55, nightfly сказав:

 


30 2 * * *  /bin/ubapi "multigentotal"

 

Залишив один NAS, додав в cron 30 2 * * * /bin/ubapi "multigentotal". Після того як змінився стан абонента активний/неактивний помилка "could not add address list: already have such entry" повернулась.

В /bin/ubapi url та серійник - вписані вірно.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vit75
      /ip firewall nat
      add action=redirect chain=dstnat dst-address=!192.168.0.0/16 dst-port=80 protocol=tcp \
      src-address-list=balance_negative to-ports=8123
      /ip proxy
      set enabled=yes port=8123
       
      Таки правила работают но почему то с задержкой 1-2 мин у клиента. Браузер у клиента крутит 1-2 мин потом редиректит на страницу заглушку в прокси.
      В чем причина задержки?
      Также не работает с портом 443, когда клиент идет по https. Как решить?
    • By FOP_Osypenko
      Маємо VPS сервер на Debian 10 і модем MikroTik LHG LTE6. Задача наступна: налаштувати інтернет через VPN тунель.
       
      На сервер Debian 10 встановив і налаштував WireGuard скриптом: https://github.com/angristan/wireguard-install
      Цим же скриптом згенерував файл налаштувань для клієнта wg0-client-mikrotik.conf:
      [Interface] PrivateKey = yBen7Arcy/jRqB3zqJiPn88IHPCoHYRmRW3wT97D2F0= Address = 10.66.66.2/32,fd42:42:42::2/128 DNS = 94.140.14.14,94.140.15.15 [Peer] PublicKey = 004DOgL44aNB5tWmyoifjiGmi0qBIHdp3Og21EdjUV0= PresharedKey = P8nLh48thuDSvNMJ7XPqMknWp4hpfxE4RUIuf5UBGqQ= Endpoint = 145.239.95.214:53849 AllowedIPs = 0.0.0.0/0,::/0  
      Прошивку на Mikrotik оновив до версії 7.1beta5. В цій версії вже вбудована підтримка WireGuarg.
      В головному меню WinBox обираю пункт WireGuard і відкривається таке вікно:

       
      Створюю новий інтерфейс wiregoard1 з типовими параметрами. Змін ніяких не вношу.

       
      Далі переходжу на вкладку Peers і там створюю новий тунель. Вписую параметри з клієнтського файлу конфігурації.

       
      Далі відкриваю вікно Address List і додаю адресу. Параметри знову беру з клієнтського файлу конфігурації.

       
      Після цих налаштувань нічого не змінюється й інтернет через VPN тунель не йде. Можливо щось не так налаштовую чи не повністю?
    • By vdemon
      Продам абсолютно новый коммутатор CRS354-48G-4S+2Q+RM
      Находится в Киеве. Цена - 11000грн, можно безнал (без НДС)
      о67-4о8-49-6 девять 
    • By Kori
      продам MikroTik CCR1036-8G-2S+
      590$ штука
      в наличии 2шт
       
      viber 0938683542
       
       



    • By Karfax
      Добрый день!
       
      Помогите пожалуйста разобраться как сделать QinQ на CRS-317.
       
      На рисунке схема сети: есть ряд CRS317 в качестве коммутаторов и CCR1072 в качестве маршрутизатора. Задача - из SFP3 порта свича SW2 vlanid 745 обернуть в vlanid 200 и отправить через чужую сеть.
       
      Читал мануалы на вики микротика про Tag stacking - https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Tag_stacking Но там в примере они берут какой-то входящий порт и на него вешают PVID с включенной галочкой Tag stacking, т.е. они оборачивают все входящие вланы с этого порта в влан PVID. Мне же необходимо как-то обернуть только один влан (в перспективе появятся другие вланы).
      VLAN 777 - используется для управления устройствами, проходит через всю сеть тагом, на CRS он создан в /interface vlan и повешан на бридж, в бридже все порты CRSa
      VLAN 745 - это клиентский влан, он также проходит везде тегом, но на CCR на ем висит IP. Этот влан необходимо засунуть в QinQ.
      VLAN 1000 - это, так сказать, влан общий абоненский влан для предоставления интернета. О также проходит везде тегом и терминируется на CCR. Приведен здесь просто "чтобы был", возможно это важно для настройки QinQ.
       
      В SFP3 свича SW2 подключена сторонняя сеть, в которой нам выделен влан 200, с их стороны он отдается нам тагом.
       

×
×
  • Create New...