Jump to content
Local
ppv

Ubiling + Віддалений mikrotik

Recommended Posts

Може хтось підкаже чи можливо привязати віддалений Microtik до ubiling, можливості прогнати vlan нема щоб DHCP давало з білінгу, тільки зовнішня іп в mikrotik, дана іншим провайдером. Ubiling і NAS зараз на одному сервері.

 

Якщо можна то як зробити редірект в особистий кабінет, і як зробити щоб працювало UHW?

 

Треба привязати 4 мікротіка.

Edited by ppv

Share this post


Link to post
Share on other sites

http://local.com.ua/forum/topic/43565-ubilling-nas-%D0%BD%D0%B0-freebsd-%D0%B1%D0%BE%D1%80%D1%82%D0%B6%D1%83%D1%80%D0%BD%D0%B0%D0%BB-%D0%BF%D0%BE%D1%87%D0%B8%D0%BD%D0%B0%D1%8E%D1%87%D0%BE%D0%B3%D0%BE-%D0%B0%D0%B4%D0%BC%D1%96%D0%BD%D0%B0/

 

Читайте, там багато усього :)

В тому числі і ваше питання.

 

А якщо коротко по ділу - то так, можливо, а як саме то вже ви вирішуйте.

Share this post


Link to post
Share on other sites

какбы вот написано как подружить микротик с билингом http://wiki.ubilling.net.ua/doku.php?id=mikrotikapi

ну а как редиректить уже от вашей фантазии зависит, тут кстати недавно была тема по этому поводу.

Share this post


Link to post
Share on other sites

какбы вот написано как подружить микротик с билингом http://wiki.ubilling.net.ua/doku.php?id=mikrotikapi

ну а как редиректить уже от вашей фантазии зависит, тут кстати недавно была тема по этому поводу.

 

Як подружити я читав, вроді більш меньш зрозуміло, буду пробувати, а от якредіректити нерозумію, треба підказку.

Раніше думав зробити eoip тунель, хз чи правильно. Буду пробувати взавтра на віртуалці.

Share this post


Link to post
Share on other sites

 

а от якредіректити нерозумію, треба підказку.

Підказую - кількома сантиметрами нижче на цьому ж форумі.

 

Дякую почитав буду пробувати, впевнений питання винекнуть в процесі роботи).

Edited by ppv

Share this post


Link to post
Share on other sites

 

 

Дякую почитав буду пробувати, впевнений питання винекнуть в процесі роботи).

Я вам навіть лінійку дам.  Ось, беріть, не соромтесь.

ruler.jpg

Приблизно в радіусі дії цього пристрою в даному розділі, вже неодноразово обговорювалось все, що ви тільки зібрались питати. З імовірністю 98.9%.

Share this post


Link to post
Share on other sites

 

Дякую почитав буду пробувати, впевнений питання винекнуть в процесі роботи).

Я вам навіть лінійку дам.  Ось, беріть, не соромтесь.

ruler.jpg

Приблизно в радіусі дії цього пристрою в даному розділі, вже неодноразово обговорювалось все, що ви тільки зібрались питати. З імовірністю 98.9%.

 

 

Та я читаю форум, але як десь там писали відео не помішало б))).   А може підкажете ще чи тут обговорювалось nat pool в ipfw?  а то щось не замітив)

Share this post


Link to post
Share on other sites

Очень актуальная тема, у меня не получилось, может у вас получится.
Вкратце, как делал я, но впоследствии отказался.

Задача была в повышенной автономности удаленной сети от биллинга.

Т.е. принципиальный вопрос был - возможность безпроблемной работы абонентов в случае отсутствия связи биллинг-микротик.

1. Поэтому все запросы dhcp релеить нельзя. dhcp должен быть локальным, а на микротике dhcp сервер не такой гибкий как isc-dhcp в фре.

Микротиковский dhcp сервер не может раздавать статиком ip адреса известным mac адресам, и динамиком - неизвестным из uhw диапазона.

(как оказалось - может, меня поправили ниже в теме)

Я не понял, можно ли статиком раздать известные, а неизвестные маки отрелеить через туннель (у меня не получилось)

2. Туннель между сервером и микротиком мне советовали EoIP. Но я так понял (может неправильно), его нормальной реализации в фре нет!

Поэтому пробовал openvpn layer 2 шифрованный, с сертификатами. freebsd как клиент обращается к серверу OVPN mikrotik и получает статич ip из локалки этого микротика.

Обязательно нужно запретить множественные туннели, они когда рвутся, freebsd переподключается и, поскольку в ovpn pool только один ip адрес, фря в итоге получает адрес 0.0.0.0.

Авторизация - по паролю, требует перекомпиляции openvpn c соответствующей опцией. этот метод авторизации считается небезопасным.

Такой тип туннеля позволяет передать броадкаст из лок. сети микротик на сервер биллинга, только по большому счету он там уже и не нужен...

Кабинет пользователя доступен. а uhw - не работает :(.

Edited by mac

Share this post


Link to post
Share on other sites

Як подружити я читав, вроді більш меньш зрозуміло, буду пробувати, а от якредіректити нерозумію, треба підказку.

Раніше думав зробити eoip тунель, хз чи правильно. Буду пробувати взавтра на віртуалці.

 

если eoip между микротиками (один удаленный, другой - с биллингом) то должно получится

в этой теме jcomm подробно объяснял

http://local.com.ua/forum/topic/54809-mikrotik-%D0%BA%D0%B0%D0%BA-%D1%83%D0%B4%D0%B0%D0%BB%D0%B5%D0%BD%D0%BD%D1%8B%D0%B9-nas/

Edited by mac

Share this post


Link to post
Share on other sites

 

 

Микротиковский dhcp сервер не может раздавать статиком ip адреса известным mac адресам, и динамиком - неизвестным из uhw диапазона.

Може раздавати 

Share this post


Link to post
Share on other sites

может ! у меня с небольшим костыликом в пол строки все ок работает. выдает статику и выдает динамику неизвестным и неизвестных редиректит на uhw а отключеных на кабинет все как и на обычной фре или линухе

Share this post


Link to post
Share on other sites

может ! у меня с небольшим костыликом в пол строки все ок работает. выдает статику и выдает динамику неизвестным и неизвестных редиректит на uhw а отключеных на кабинет все как и на обычной фре или линухе

Респект. У меня не получилось - роутер отказывался поднять еще один dhcp сервер на бридже

 

PS В статику добавили релей 255.255.255.255 ? Точно, после этого разрешил поднять динамик :)

или uhw pool как next pool в основной добавили?

Edited by mac

Share this post


Link to post
Share on other sites

не треба кілька серверів вам.

пул укажіть той що роздається ухв, а далі в leases пишіть статичні записи!

Share this post


Link to post
Share on other sites

не треба кілька серверів вам.

пул укажіть той що роздається ухв, а далі в leases пишіть статичні записи!

спасибо!

Share this post


Link to post
Share on other sites

настройки DHCP выглядят так

/ip dhcp-server
add address-pool=nomac authoritative=yes disabled=no interface=bridge1 \
    lease-script="/ip dhcp-server lease remove numbers=[find dynamic]" \
    lease-time=12h name=lan
/ip dhcp-server config
set store-leases-disk=immediatel

/ip dhcp-server network
add address=10.10.10.0/24 dns-server=10.10.10.1 gateway=10.10.10.1 netmask=24
add address=192.168.20.0/24 dns-server=8.8.8.8 gateway=\
    192.168.20.254 netmask=24

смысл такой цепляешь пул на дхп сервер с ипишками которые будут у тебя для гостевой сети, также цепляешь на интерфейс еще один ип с ипом гостевой сети все что не прописано статикой будет получать из пула , ну а дальше уже как писали в паре сантиметров выше/ниже есть продолжение

Edited by DemonidZe

Share this post


Link to post
Share on other sites

настройки DHCP выглядят так

спасибо!

но сходу не понял назначение "небольшого костылика", буду разбираться.

и еще - зачем лизы записывать немедленно на диск. это ведь гостевые лизы.

чтобы еще кому-то не назначить такой же адрес после перезагрузки роутера при сбое питания?

Share this post


Link to post
Share on other sites

вот костыль lease-script="/ip dhcp-server lease remove numbers=[find dynamic]" сделан он из-за вот этого lease-time=12h

Share this post


Link to post
Share on other sites

может ! у меня с небольшим костыликом в пол строки все ок работает. выдает статику и выдает динамику неизвестным и неизвестных редиректит на uhw а отключеных на кабинет все как и на обычной фре или линухе

 

Добрався я до мікротіка сьогодні поставив, на віртуалці.

Спробував DHCP static, от цікаво при добавленні абонента воно записує його в arp, в ip-firewall-address-list, але не записує leases, чи я щось неправильно зробив?

 

Якщо вручну створити лізу то дає динаміку але тоді при зміні mac і ip абоненту в leases мак небуде міняти, це потрібно якось допилювати чи воно вже реалізовано? 

Edited by ppv

Share this post


Link to post
Share on other sites

настройки DHCP выглядят так

/ip dhcp-server
add address-pool=nomac authoritative=yes disabled=no interface=bridge1 \
    lease-script="/ip dhcp-server lease remove numbers=[find dynamic]" \
    lease-time=12h name=lan
/ip dhcp-server config
set store-leases-disk=immediatel

/ip dhcp-server network
add address=10.10.10.0/24 dns-server=10.10.10.1 gateway=10.10.10.1 netmask=24
add address=192.168.20.0/24 dns-server=8.8.8.8 gateway=\
    192.168.20.254 netmask=24

смысл такой цепляешь пул на дхп сервер с ипишками которые будут у тебя для гостевой сети, также цепляешь на интерфейс еще один ип с ипом гостевой сети все что не прописано статикой будет получать из пула , ну а дальше уже как писали в паре сантиметров выше/ниже есть продолжение

 

Вроді все працює, але можна поцікавитись як ви зробили щоб ubiling зчитував маки клієнтів на mikrotik?

Edited by ppv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Иван Авилов
      Ремонт точек доступа, роутеров , камер , свитчей  Ubiquiti (UBNT), MikroTik , Dahua , Hikvision и другого сетевого оборудования с гарантией.
      Если ваша точка доступа или роутер:
      - не включается;
      - не видна в сети, не пингуется, на точку доступа невозможно зайти;
      - не раздает интернет по Wi-Fi;
      - постоянно обрывает соединение;
      - на роутере или точке стала низкой скорость,
      то, скорее всего, вам необходима помощь квалифицированного специалиста по ремонту.
      Сервисный центр LanService выполняет следующие виды ремонтов оборудования MikroTik и Ubiquiti:
      - перепрошивку точек доступа, восстановление прошивки;
      - замену мелких деталей;
      - ремонт цепей питания;
      - устранение короткого замыкания;
      - замену процессора, LAN-порта, радиомодуля, флеш-памяти и т. д.
      Ремонтируем также точки доступа и роутеры, переставшие работать после грозы.
      Диагностика бесплатно!
      После диагностики оборудования озвучиваются ориентировочные сроки и стоимость ремонта.
      Работаем по всей Украине через Новую Почту.
      Сроки ремонта оборудования Ubiquiti (UBNT), MikroTik:
      - при наличии запчастей - от 2 до 10 дней;
      - при отсутствии запчастей - от 2 до 4 недель.
      Стоимость от 100 грн.
      После ремонта оборудование обязательно тестируется. На выполненные работы - гарантия 1 мес!
      Звоните:
      066-440-73-23
      096-731-98-45
    • By Kto To
      Сегодня вечером словил странный глюк на следующей связке.
      FreeBSD 11.2-RELEASE-p9
      MPD version: 5.8
      Клиенты подключаются по PPPOE.
      Онлайна на машине в районе 1600 абонентов
       
      Стали звонить под вечер клиенты с проблемой на неработающий интернет. Причем некоторые.
      Стали разбираться
      В результате выяснился странный глюк
       
      [] show sessions ip 10.10.0.9 ng1865 10.10.0.9 C-1866 7956732-C-1866 vlan60-1137 1137 7956732-vlan60-1137 vova 54:e6:fc:fe:5d:53 ng2233 10.10.0.9 C-2234 7959914-C-2234 vlan60-2290 2290 7959914-vlan60-2290 vova 54:e6:fc:fe:5d:53 ng2151 10.10.0.9 C-2152 7960268-C-2152 vlan60-2298 2298 7960268-vlan60-2298 vova 54:e6:fc:fe:5d:53 ng2112 10.10.0.9 C-2113 7960073-C-2113 vlan60-2299 2299 7960073-vlan60-2299 vova 54:e6:fc:fe:5d:53 [] show sessions ip 10.10.51.184 ng1710 10.10.51.184 C-1711 7933915-C-1711 vlan63-468 468 7933915-vlan63-468 051184 00:30:67:f9:8b:87 ng608 10.10.51.184 C-609 7879576-C-609 vlan63-727 727 7879576-vlan63-727 051184 00:30:67:f9:8b:87 ng883 10.10.51.184 C-884 7933023-C-884 vlan63-1028 1028 7933023-vlan63-1028 051184 00:30:67:f9:8b:87 ng1071 10.10.51.184 C-1072 7932679-C-1072 vlan63-1177 1177 7932679-vlan63-1177 051184 00:30:67:f9:8b:87 ng1643 10.10.51.184 C-1644 7933515-C-1644 vlan63-1714 1714 7933515-vlan63-1714 051184 00:30:67:f9:8b:87 ng1671 10.10.51.184 C-1672 7928866-C-1672 vlan63-1751 1751 7928866-vlan63-1751 051184 00:30:67:f9:8b:87 ng1701 10.10.51.184 C-1702 7931011-C-1702 vlan63-1769 1769 7931011-vlan63-1769 051184 00:30:67:f9:8b:87 ng1709 10.10.51.184 C-1710 7932364-C-1710 vlan63-1777 1777 7932364-vlan63-1777 051184 00:30:67:f9:8b:87 ng2269 10.10.51.184 C-2270 7961076-C-2270 vlan63-2050 2050 7961076-vlan63-2050 051184 00:30:67:f9:8b:87 ng2229 10.10.51.184 C-2230 7960448-C-2230 vlan63-2273 2273 7960448-vlan63-2273 051184 00:30:67:f9:8b:87 ng1425 10.10.51.184 C-1426 7959795-C-1426 vlan63-2280 2280 7959795-vlan63-2280 051184 00:30:67:f9:8b:87 ng2216 10.10.51.184 C-2217 7960721-C-2217 vlan63-2287 2287 7960721-vlan63-2287 051184 00:30:67:f9:8b:87 ng2252 10.10.51.184 C-2253 7960944-C-2253 vlan63-2301 2301 7960944-vlan63-2301 051184 00:30:67:f9:8b:87 ng2236 10.10.51.184 C-2237 7960217-C-2237 vlan63-2302 2302 7960217-vlan63-2302 051184 00:30:67:f9:8b:87 ng2270 10.10.51.184 C-2271 7961240-C-2271 vlan63-2313 2313 7961240-vlan63-2313 051184 00:30:67:f9:8b:87 ng2248 10.10.51.184 C-2249 7960285-C-2249 vlan63-2318 2318 7960285-vlan63-2318 051184 00:30:67:f9:8b:87 ng1899 10.10.51.184 C-1900 7962171-C-1900 vlan63-2347 2347 7962171-vlan63-2347 051184 00:30:67:f9:8b:87 ng2299 10.10.51.184 C-2300 7962389-C-2300 vlan63-2363 2363 7962389-vlan63-2363 051184 00:30:67:f9:8b:87 ng194 10.10.51.184 C-195 7962428-C-195 vlan63-2373 2373 7962428-vlan63-2373 051184 00:30:67:f9:8b:87 ng2260 10.10.51.184 C-2261 7960890-C-2261 vlan63-2378 2378 7960890-vlan63-2378 051184 00:30:67:f9:8b:87 и так далее Почему-то перестали удаляться старые неактивные сессии клиентов. Руками удаляю все сессии - клиент подключается и работает но я так думаю это до следующего реконнекта.
       
      Вот конфиг мпд (может там что-то довписать надо, хотя конфиг переносится от сервака к серваку уже долгие годы)
      pppoe_server: create bundle template C set bundle disable encryption set bundle disable compression set ccp disable mppc set ipcp dns 8.8.8.8 1.1.1.1 set ipcp range a.b.c.d/32 0.0.0.0/0 set iface enable tcpmssfix create link template oe pppoe set link action bundle C set link disable chap pap eap set link enable pap chap set link enable peer-as-calling load radius create link template vlan2 oe set link max-children 1000 set pppoe iface vlan2 set pppoe service "*" set link enable incoming ...... Почему мпд создает ng интерфейс с тем же ип если уже такой существует? Ну и почему не удаляются старые сессии?
       
      Подскажите может сталкивался кто и как побороть.
    • By Vingpon
      Продам Mikrotik CCR1036-8G-2S+ новый брался для резерва не использовался цена 20 000 грн.



    • By linki
      Нужна помощь в настройке capsman на routerboard и двух точек. В также нужно настроить два порта на приём двух каналов интернета. Использоваться будет один, другой для подхвата если ляжет основной.
      Цена вопроса 600грн 
       
    • By Olh@
      Продам микротик RB2011UiAS-RM
      В работе практически не был, состояние 9/10 пострадал при переездах. 
      Цена 1500
×