Jump to content
Local
strushke

Ubilling + Mikrotik NAS - ничего не происходит

Recommended Posts

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

Share this post


Link to post
Share on other sites

 

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина.  Понимаю, что виноват я, но что делать?

 

0 .позирте лог tail -F /var/stargazer/allconnect.log і потицяйте ресет юзеру. зазвичай допомагає діагностувати що нетак.

 

1 /etc/stargazer/config.ini що там з логіном і паролем mysql? 

 

2. після додавання нового НАС буває треба перезапустити старгейзер або просто ребут системи. 

 

3. Дока ніколи непідводила, все завжди чітко паше.

 

.

Share this post


Link to post
Share on other sites

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. Понимаю, что виноват я, но что делать?

0 .позирте лог tail -F /var/stargazer/allconnect.log і потицяйте ресет юзеру. зазвичай допомагає діагностувати що нетак.

 

1 /etc/stargazer/config.ini що там з логіном і паролем mysql?

 

2. після додавання нового НАС буває треба перезапустити старгейзер або просто ребут системи.

 

3. Дока ніколи непідводила, все завжди чітко паше.

 

.

Да первое маське второе галочки в настройках насов что именно вы хотите управлять

Share this post


Link to post
Share on other sites

0. Error: Can't run executer, NAS type is needed

1. Логинпасс правильные, mysql -u подключается с этими данными

2. С тех пор уже было несколько ребутов

3. Всё делал по доке

 

Благодарствую!

Share this post


Link to post
Share on other sites

а ссилочку на графички ми маєм дописати?

 

У випадку, коли ви намагаєтесь малювати користувацькі графічки на NAS на базі MikroTik - вам слід вказувати Bandwidthd URL у вигляді: http://ваш_nas/graphs/queue

Edited by mgo

Share this post


Link to post
Share on other sites

Появилась ругань, что не может к БД подключиться. Создал отдельного юзера даже, с известным логин-пассом, все равно то же. В config.ini вместо localhost написал и имя и 127.0.0.1 .

 

В логе та же ерунда..

 

Can't connect to database появляется через раз. Тогда, когда удаляю абона и заново добавляю. 

Основная ошибка - nas type is needed

Edited by strushke

Share this post


Link to post
Share on other sites

 

 

Появилась ругань, что не может к БД подключиться.

поставте логін і пасс той, що в вебморді білінгу модуль Налаштування системи.

 

 

Основная ошибка - nas type is needed

спробуйте локал НАС і гляньте, що буде. 

 

Ви щось злосно осквернили своєю творчістю, хоча то треба ще постаратися, все зроблено проктично для домохазяйок, поставив і з коробки полетіло.

Share this post


Link to post
Share on other sites

Спасибо за похвалу! Старался как мог! 

 

Проблема была в другом месте:

Сервер находится в 10.0.0.0,

А сети я сделал 3: 1.0 , 2.0, и 3.0

 

Пока не разобрался с назначением прикрепления "Услуг" к сетям.

 

При добавлении абонента я ему давал IP из услуги с сетью 2.0. 

-----

 

В данный момент (на старом биллинге, LMS)

У меня в 0.0 подсети находится всё оборудование, сеть 1.1 используется для незарегистрированных MAC, 2.0 и 3.0 имеют доступ в интернет.

 

Думал по аналогии всё это перенести на UBi

Я так понимаю, что нужно добавлять NAS отдельно на каждую подсеть. Большое спасибо вам за помощь! 

Share this post


Link to post
Share on other sites

А всё ли так радужно?

 

У меня то же самое.

Добавляешь денег - ничерта не происходит.

Придётся вручную из консоли перезапускать старгейзер.

Самое интересное, что даже при массовом ресете не ходят старгейзер на микротик , при нажатии кнопки ресет у пользователя -- тоже.

 

В предыдущих версиях всё было чётко.

 

Перехапускаешь старгейзер -- всё проверяется, пересоздаётся, включается.
 

Что делать?

Share this post


Link to post
Share on other sites

А всё ли так радужно?

 

У меня то же самое.

Добавляешь денег - ничерта не происходит.

Придётся вручную из консоли перезапускать старгейзер.

Самое интересное, что даже при массовом ресете не ходят старгейзер на микротик , при нажатии кнопки ресет у пользователя -- тоже.

 

В предыдущих версиях всё было чётко.

 

Перехапускаешь старгейзер -- всё проверяется, пересоздаётся, включается.

 

Что делать?

Я бы помог, но сам только узнал про ubilling. 

У меня проблема была, как оказалось, именно в соединении. 

У вас скорее всего не вызывается некий скрипт из ubilling для обновления состояния stargazer, при этом работа с базой проходит успешно. 

Я бы начал с копания, скажем, что происходит, когда нажимаем кнопку reset - какой скрипт вызывается, какие логи пишутся и тд.

Share this post


Link to post
Share on other sites

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина.  Понимаю, что виноват я, но что делать?

 

0 .позирте лог tail -F /var/stargazer/allconnect.log і потицяйте ресет юзеру. зазвичай допомагає діагностувати що нетак.

 

1 /etc/stargazer/config.ini що там з логіном і паролем mysql? 

 

2. після додавання нового НАС буває треба перезапустити старгейзер або просто ребут системи. 

 

3. Дока ніколи непідводила, все завжди чітко паше.

 

.

 

Тоже похожая проблемма.

При выборе Сервера доступа (NAS) выдает такую ошибку

Notice: Undefined index: 1 in /usr/local/www/apache24/data/billing/api/libs/api.workaround.php on line 1793

Share this post


Link to post
Share on other sites

 

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина.  Понимаю, что виноват я, но что делать?

 

0 .позирте лог tail -F /var/stargazer/allconnect.log і потицяйте ресет юзеру. зазвичай допомагає діагностувати що нетак.

 

1 /etc/stargazer/config.ini що там з логіном і паролем mysql? 

 

2. після додавання нового НАС буває треба перезапустити старгейзер або просто ребут системи. 

 

3. Дока ніколи непідводила, все завжди чітко паше.

 

.

 

Тоже похожая проблемма.

При выборе Сервера доступа (NAS) выдает такую ошибку

Notice: Undefined index: 1 in /usr/local/www/apache24/data/billing/api/libs/api.workaround.php on line 1793

 

 

Где же вы нашли сходство? о_О

А вообще - недостаточно входящей информации.

Share this post


Link to post
Share on other sites

 

 

Notice: Undefined index: 1 in /usr/local/www/apache24/data/billing/api/libs/api.workaround.php on line 1793

 

В Насе все прописано?

Share this post


Link to post
Share on other sites

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

закомментируйте строчки

client-id        = NULL

server           = NULL

rate-limit       = NULL

address-list     = NULL

 

Share this post


Link to post
Share on other sites

 

 

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

Странно, а у меня даже нет этого файла?

Share this post


Link to post
Share on other sites

 

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

Странно, а у меня даже нет этого файла?

# ls -R /etc/stargazer

OnChange        conf-enabled.d        remote_nas.conf

OnConnect        config            rules

OnDisconnect        config.ini        stargazer.conf

OnUserAdd        debtors.php        system

OnUserDel        dn

conf-available.d    fullArp.php

 

/etc/stargazer/conf-available.d:

mod_ao.conf        mod_ping.conf        mod_smux.conf

mod_cap_bpf.conf    mod_radius.conf        store_files.conf

mod_cap_divert.conf    mod_remote_script.conf    store_firebird.conf

mod_cap_nf.conf        mod_rpc.conf        store_mysql.conf

mod_ia.conf        mod_sg.conf        store_postgresql.conf

 

/etc/stargazer/conf-enabled.d:

mod_ao.conf        mod_ia.conf        mod_sg.conf

mod_cap_bpf.conf    mod_ping.conf        store_files.conf

 

/etc/stargazer/dn:

 

/etc/stargazer/system:

database    executer    log        ubilling.cls

 

/etc/stargazer/system/database:

mysql.drv

 

/etc/stargazer/system/executer:

mikrotik.drv    rscriptd.drv    tpls

 

/etc/stargazer/system/executer/tpls:

arp.ini        firewall.ini    queue

dhcp.ini    ppp.ini        queue_tree.ini

 

/etc/stargazer/system/executer/tpls/queue:

ros_v4.ini    ros_v5.ini    ros_v6.ini

 

/etc/stargazer/system/log:

file.drv

 

Share this post


Link to post
Share on other sites

 

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

закомментируйте строчки

client-id        = NULL

server           = NULL

rate-limit       = NULL

address-list     = NULL

 

 

 

Не претендую на звание знатока... Но! Совет странноватый так как у меня всё работает и без закомментированных строк, да и думаю не только у меня... из чего следует, что стоит все таки понять чего там нанастраивал sergepo, если вы хотите помочь

Share this post


Link to post
Share on other sites

 

 

да и думаю не только у меня

Согласен, есть кое-какие ньюансы, но, если быть честным, то не такое проблематичные. Две недели тестирую управление НАСом по radius. Пока работает как надо, но приходилось много дорабатывать, чтобы не ставить тайауте сессии, например сутки, а работало по такому же принципу, как "коробочные" механизмы управление НАСами.

Share this post


Link to post
Share on other sites

 

 

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

закомментируйте строчки

client-id        = NULL

server           = NULL

rate-limit       = NULL

address-list     = NULL

 

 

 

Не претендую на звание знатока... Но! Совет странноватый так как у меня всё работает и без закомментированных строк, да и думаю не только у меня... из чего следует, что стоит все таки понять чего там нанастраивал sergepo, если вы хотите помочь

 

http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server#Read_only_properties

Share this post


Link to post
Share on other sites

 

 

 

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

закомментируйте строчки

client-id        = NULL

server           = NULL

rate-limit       = NULL

address-list     = NULL

 

 

 

Не претендую на звание знатока... Но! Совет странноватый так как у меня всё работает и без закомментированных строк, да и думаю не только у меня... из чего следует, что стоит все таки понять чего там нанастраивал sergepo, если вы хотите помочь

 

http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server#Read_only_properties

 

Разобрался.

Индекс 1 - это local NAS, в настройках его небыло прописано сеть/CIDR.

К управлению удаленным Микротик это никак не относится.

Пока наблюдаю, вроде все работает.

Share this post


Link to post
Share on other sites

 

 

 

 

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

закомментируйте строчки

client-id        = NULL

server           = NULL

rate-limit       = NULL

address-list     = NULL

 

 

 

Не претендую на звание знатока... Но! Совет странноватый так как у меня всё работает и без закомментированных строк, да и думаю не только у меня... из чего следует, что стоит все таки понять чего там нанастраивал sergepo, если вы хотите помочь

 

http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server#Read_only_properties

 

Разобрался.

Индекс 1 - это local NAS, в настройках его небыло прописано сеть/CIDR.

К управлению удаленным Микротик это никак не относится.

Пока наблюдаю, вроде все работает.

 

Вот про что я и говорил, ато "закомментируй это".... ссылочку "полезную"....

Share this post


Link to post
Share on other sites

 

 

 

 

 

Установил ubilling при помощи ubinstall, по инструкции (На виртуалку)

По той же инструкции скопировал скрипты On*

Добавил NAS, при заходе на доп настройку показывает параметры NAS, в логе mikrotik'a вижу вход по API.

 

Основная проблема: при добавлении пользователя, абсолютно ничего не происходит. В логе мтика тишина. 

Понимаю, что виноват я, но что делать?

 

Ubilling находится внутри NAT микротика, но судя по логу при просмотре параметров таки связь есть.

в файлике /etc/stargazer/system/executer/tplcat dhcp.ini

закомментируйте строчки

client-id        = NULL

server           = NULL

rate-limit       = NULL

address-list     = NULL

 

 

 

Не претендую на звание знатока... Но! Совет странноватый так как у меня всё работает и без закомментированных строк, да и думаю не только у меня... из чего следует, что стоит все таки понять чего там нанастраивал sergepo, если вы хотите помочь

 

http://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server#Read_only_properties

 

Разобрался.

Индекс 1 - это local NAS, в настройках его небыло прописано сеть/CIDR.

К управлению удаленным Микротик это никак не относится.

Пока наблюдаю, вроде все работает.

 

Вот про что я и говорил, ато "закомментируй это".... ссылочку "полезную"....

 

По ссылочке была документация микротика, где некоторые описанные аттрибуты были в разделе read-only

На ROS 6.37 при попытке передать их через скрипт, микротик ругался и не создавал leases записи для встроенного dhcp сервера.

Посмотреть об ругательствах микротика можно в файлике /var/stargazer/allconnect.log

В новой версии ubilling будет отдельный файлик /etc/stargazer/system/executer/tpls/custom_dhcp.ini с уже закомментированными строчками

Share this post


Link to post
Share on other sites

 

 

В новой версии ubilling будет отдельный файлик /etc/stargazer/system/executer/tpls/custom_dhcp.ini с уже закомментированными строчками

 

А какие еще изменения будут касательно микротов в новом релизе? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rliskov
      Совершенно случайно выявил несколько абонов, которые по два-три месяца пользуются инетом бесплатно.
      Сеть - Ubilling в связке с удаленными NAS Mikrotik.
      Причина - на микротике в firewall/address-lists айпишка абона активна.
      Следствие - минусовой баланс в биллинге а интернет у абона есть
      Предположение - в момент, когда старгейзер отрабатывал скрипты отсутствовала связь с удаленным NAS Mikrotik.
      Есть ли решение этой проблемы, кроме как в ручную делать ресет абонов, чтоб биллинг внес изменения в NAS ?
×