Jump to content
Local
VitalyMoiseev

Pon Monitor - система мониторинга PON

Recommended Posts

еще немного полезной инфы по ОНУ будет выводить

 

Скрытый текст

image.thumb.png.ed7772ee511a29fc448e25f22cefc153.png

 

  • Like 2

Share this post


Link to post
Share on other sites

Доброго времени суток, друзья прошу помощи, имеем уст-во P3310B, установка Pon Monitor сложностей не вызвала, но при попытке добавить OLT пишет " SNMP не отвечает, проверьте! " Хотя snmp точно отвечает проверял snmpwalk, копаю дальше при нажатии на кнопку сохранить, сюда "http://my_ip/pm/scripts/check_snmp.php" летит запрос с мной вводимыми данными, итого вид " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public&communityrw=private " и тут же я получаю ошибку 500 если привожу строку к виду " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public " тоесть убираю из get " communityrw=private " то скрипт не выдаёт ошибку но соответственно настройки не сохраняются так как кнопка сохранить не была нажата из-за ошибки 500, подскажите куда копать?

Share this post


Link to post
Share on other sites
8 минут назад, genadich сказал:

Доброго времени суток, друзья прошу помощи, имеем уст-во P3310B, установка Pon Monitor сложностей не вызвала, но при попытке добавить OLT пишет " SNMP не отвечает, проверьте! " Хотя snmp точно отвечает проверял snmpwalk, копаю дальше при нажатии на кнопку сохранить, сюда "http://my_ip/pm/scripts/check_snmp.php" летит запрос с мной вводимыми данными, итого вид " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public&communityrw=private " и тут же я получаю ошибку 500 если привожу строку к виду " http://my_ip/pm/scripts/check_snmp.php?host=my_ip&port=161&community=public " тоесть убираю из get " communityrw=private " то скрипт не выдаёт ошибку но соответственно настройки не сохраняются так как кнопка сохранить не была нажата из-за ошибки 500, подскажите куда копать?

лог нужен, смотреть ошибку можен нет модуля в php-snmp или что-то там еще.

  • Like 1

Share this post


Link to post
Share on other sites
10 минут назад, Інет.укр сказал:

лог нужен, смотреть ошибку можен нет модуля в php-snmp или что-то там еще.

Да Вы правы, не было php-snmp упустил я этот момент, а вот без подсказки почему-то в лог не заглянулось))))))большое спасибо)))))

Share this post


Link to post
Share on other sites
57 минут назад, genadich сказал:

Да Вы правы, не было php-snmp упустил я этот момент, а вот без подсказки почему-то в лог не заглянулось))))))большое спасибо)))))

спасибо через сердечко под постом.😎

Share this post


Link to post
Share on other sites

Підскажіть чому такі крякозябри бачимо ?

міняв locale, пробував інші - 1251, koi8, utf...

 

на сервері є локаль uk_UA.utf8

r.png

Share this post


Link to post
Share on other sites
46 минут назад, camchatix сказал:

Підскажіть чому такі крякозябри бачимо ?

міняв locale, пробував інші - 1251, koi8, utf...

 

на сервері є локаль uk_UA.utf8

r.png

кодування бази utf8?

Share this post


Link to post
Share on other sites

створював просто - не працювало

удалив базу

створив заново - create database pon CHARACTER SET utf8 COLLATE utf8_general_ci;

і теж саме...

Share this post


Link to post
Share on other sites
3 часа назад, camchatix сказал:

створював просто - не працювало

удалив базу

створив заново - create database pon CHARACTER SET utf8 COLLATE utf8_general_ci;

і теж саме...

а web server віддає сторінку в правильному кодувані?

Share this post


Link to post
Share on other sites

 

В 01.09.2019 в 20:21, a_n_h сказал:

"офтопну" - ну почему под ZTE 220 никто ничего не предлагает?!

В 04.09.2019 в 20:59, sape4000 сказал:

А что-то подобного под цдату ни кто не делал?

abills имеет поддержку ZTE/HUAWAI в бесплатной версии. Сейчас допиливают c-data

Edited by vector_zuriel

Share this post


Link to post
Share on other sites
2 часа назад, Інет.укр сказал:

а web server віддає сторінку в правильному кодувані?

а як це провірити ?

 

странно те що внизу сторінки текст добрий

Українська - Русский IP: 91.22

 

на цьому сервері (freebsd 12) працює uBilling особовий кабінет, і 4 сайта на WordPres

нема ніде таких символів...

Share this post


Link to post
Share on other sites
5 minutes ago, camchatix said:

а як це провірити ?

 

"View Page Info" -> "Text Encoding"

 

Share this post


Link to post
Share on other sites
10 минут назад, vop сказал:

 

"View Page Info" -> "Text Encoding"

 

Firefox пише - 

 

Кодування - UTF-8

 

файл footer.php - видно техт добре

а інші файли з папки include - вже там НЕ UTF8...

 

загрузив версію 1.5

відкрив у Windows 10 файл - а там уже такі символи

 

echo '<td class="grey">Ethernet РїРѕСЂС‚ ID</td>';
 

Edited by camchatix

Share this post


Link to post
Share on other sites

Еще хорошей функцией будет быстрый поиск всех неактивных ону по конкретной SFP, дерегистрация всей кучи (возможно выделение птичками) и кнопка сохранения конфига (это вроде есть) 

Share this post


Link to post
Share on other sites
1 час назад, camchatix сказал:

Firefox пише - 

 

Кодування - UTF-8

 

файл footer.php - видно техт добре

а інші файли з папки include - вже там НЕ UTF8...

 

загрузив версію 1.5

відкрив у Windows 10 файл - а там уже такі символи

 

echo '<td class="grey">Ethernet РїРѕСЂС‚ ID</td>';
 

який редактор?

Share this post


Link to post
Share on other sites

хм...... у notepad++ всьо добре видно...

перезалив файли на сервер - все одно..

в .htaccess ставлю AddCharset utf-8 .html .css .php .txt .js

ставклю в httpd.conf AddCharset  - тоже нич.... 

всьоравно крякозябри....

 

то не база

то буде апач мабуть

 

як то поправити ??

 

Share this post


Link to post
Share on other sites
В 19.09.2019 в 23:05, camchatix сказал:

хм...... у notepad++ всьо добре видно...

перезалив файли на сервер - все одно..

в .htaccess ставлю AddCharset utf-8 .html .css .php .txt .js

ставклю в httpd.conf AddCharset  - тоже нич.... 

всьоравно крякозябри....

 

то не база

то буде апач мабуть

 

як то поправити ??

 

коли відкриваєте notepad++ там з низу є кодіровка також пише. 

Як закидуєте файли на сервер? якщо ви їх добуваєте з архіва на windows чи не краще wget https://pm.vm.net.ua/install/pm_v1.5.zip потім unzip pm_v1.5.zip і потім скопіювати куда потрібно і правити їх через nano/vim/ee/тощо?

можу спровбувати допомогти!

Share this post


Link to post
Share on other sites

Всі надписи російською та українською - вони не в файлах, а у базі. Перевіряйте, що і в який кодировці туди залили

Share this post


Link to post
Share on other sites

Тексти з бази - добре відображається..

А з PHP файлів техт кривий...

пробував і текстовий і двоїчний метод передачі файлів на сервер..

також unzip на стороні сервера.. все однаково

 

тут точно кодіровка зі сторони сервера кліенту криво передається. А як це провірити ?

phpinfo() показує default_charset - UTF-8

 

UPD: поставив на інший сервер - теж саме... %(

Edited by camchatix

Share this post


Link to post
Share on other sites
18 часов назад, camchatix сказал:

Тексти з бази - добре відображається..

А з PHP файлів техт кривий...

пробував і текстовий і двоїчний метод передачі файлів на сервер..

також unzip на стороні сервера.. все однаково

 

тут точно кодіровка зі сторони сервера кліенту криво передається. А як це провірити ?

phpinfo() показує default_charset - UTF-8

 

UPD: поставив на інший сервер - теж саме... %(

 

Дайте сюда файл с кривым отображение в архиве, любой, главное чтобы он криво отображал текст.

 

В качестве небольшого отступления. Файлы могут быть сохранены не в кодировке UT-8, а к примеру в ANSI тогда текст в UT-8 может отображаться кракозяблами.

 

Вот Вам ссылка на онлайн декодер, где наглядно будет показано, что происходит:

http://www.online-decoder.com/ru

2019-09-21_02-56-12.png.c0ea5d5c916863ada82c91dddc625ae2.png

 

 

Посмотрите, в какой кодировке Вам страницу показывает браузер, измените, пока не увидите правильный текст. Откройте конф файлы апача и укажите верную кодировку в настройках AddDefaultCharset.

 

 

 

Edited by Darth Vader2

Share this post


Link to post
Share on other sites
В 19.09.2019 в 19:32, camchatix сказал:

Firefox пише - 

 

Кодування - UTF-8

 

файл footer.php - видно техт добре

а інші файли з папки include - вже там НЕ UTF8...

 

 

 

Всё понятно, как я и писал выше, файлы все или некоторые в кодировке ANSI, перепишите их в кодировку UTF-8 и всё взлетит. Дайте мне любой файл, я его пересохраню в UTF-8 и проверите.

 

 

 

Edited by Darth Vader2

Share this post


Link to post
Share on other sites

Ну только не ANSI. И, скорее всего, не ascii.Там нет кириллицы.

Share this post


Link to post
Share on other sites
16 минут назад, vop сказал:

Ну только не ANSI. И, скорее всего, не ascii.Там нет кириллицы.

 

Это опечатка, суть предложения понятна.

 

В Windows под ANSI codepage обычно понимается «системная» кодировка. 
Она используется для не-юникодных программ. 
Для стандартной американской версии это CP 1252, для русской — CP 1251.

Хотя название и ссылается на стандарт ANSI, реально оно ничего общего со стандартом не имеет.

 

Edited by Darth Vader2

Share this post


Link to post
Share on other sites

В силу того, что скучно, я нашел файл onu_detail.php, результат в браузере у меня:

 

Ethernet РїРѕСЂС‚ ID

 

Сейчас ради интереса буду искать у себя причину такого отображения.

 

p.s. дело в кодировке, по умолчанию на сервере windows-1251, а должно быть utf-8. Файл настроек апача или добавить в conf.d нужный конфигурационный файл. К примеру такой:

 

Alias /test /usr/share/test

<Directory /usr/share/test/>
AddDefaultCharset UTF-8
   AllowOverride All
   Order deny,allow
   Deny from All
   Allow from "ваш ip без кавычек"
</Directory>

После изменений:

 

Ethernet порт ID

 

Edited by Darth Vader2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By bublgum
      Добрый день всем, есть инфы море но не той что нужно..... Подскажите есть ли возможность автомат реги на ЗТЕ320С? Какая форма опт82? Ни как не могу слепить....
    • By Ondp
      Кто сталкивался с подобным?
      На одном из PON портов ОЛТа (только на одном порте) во время кратковременного отключения электричества на Онушке не разрывается PPPoE соединение, и чтоб ты не делал, отключение ОНУ, Роутера на 5-10мин - сутки, PPPOE соединение висит активным, помогает только принудительный разрыв PPPOE на микротике.
      А также был недавно обрыв оптики на этом порту, все ПППОЕ остались активными.
      Что уже делал и что не помогло:
      1. СФП менял.
      2. Физически с порта патчкорд высовывал - все ПППОЕ дисконнектятся
      3. Физически 1 дерево отключал - все ПППОЕ дисконнектятся
      4. Перезагружал Микротик
      5. Пересоздавал на Микротике Влан и ПППОЕ профиль
      что не делал:
      1.Влан не менял
      2.PON Порт не менял
      3.ОЛТ не перезагружал
       
      Конфиг ОЛТа для всех портов идентичный, только Влан для каждого порта разный
       
      Куда копать?))
    • By CrazyAlex
      Помогите опознать онушку и прошивку найти для нее...
      По маку бьется как СДАТА

    • By nvr
      Інтернет для юридичної особи Черкаська область
       
      Локація:
      Звенигородський район Черкаської області, с.Багачівка
      1,4 км на схід від села Багачівка (поруч Всеукраїнський військово-патріотичний центр - музей “ШАМПАНЬ”)
       
      ТТХ:
      швидкість мінімум 50\50 мбіт
      ip-адреса статична
       
      https://www.google.com/maps/place/49°03'46.7"N+31°07'13.6"E/@49.062967,31.1190082,597m/data=!3m2!1e3!4b1!4m6!3m5!1s0x0:0x0!7e2!8m2!3d49.0629674!4d31.1204545
       
×