Jump to content
Local
Sign in to follow this  
bulgar

BDCOM P3608 прошивка

Recommended Posts

Вме bdcom, пацаны. Подскажите, возымелась такая проблемка после обновления прошивки с 33463 на 66506. Да, знаю, большой разрыв, но до сегодняшнего дня никто не обращал внимание на новые прошивки, и всё (как ни прискорбно) работало исправно. При апгрейде прошивки вылез косяк вот такого рода - стоит ону (cdata, однопортовая, гиговая). За ней свитч Dlink dgs 1100-08 за ним абонент с сервером астериска на виртуалке(с виртуалки мак инкапсулируется, если я правильно понял). Отдаём ему телефонию антегом, на виртуалке - статика. После обновления - полностью пропал трафик на этот сервер. Первым вопрос упал на mtu - мимо. Port-protect не настроен. Конфиг лазера и ону ниже. Буду дико благодарен за любой пинок в сторону солюшна.

 

interface EPON0/4
 epon onu-authen-method mac
 epon bind-onu mac 8066.290a.6f6e 32
 switchport trunk vlan-allowed 9-11,1401-1464,1501,2001-2999
 switchport trunk vlan-untagged 1
 switchport mode trunk
 switchport protected 1
interface EPON0/4:32
  epon onu port 1 ctc vlan mode tag 1432 priority 0
 epon sla upstream pir 1000000 cir 10000
 epon sla downstream pir 1000000 cir 10000

 

Share this post


Link to post
Share on other sites
Цитата

на виртуалке

epon local-mac forward включен?

Share this post


Link to post
Share on other sites
6 часов назад, bulgar сказал:

Вме bdcom, пацаны. Подскажите, возымелась такая проблемка после обновления прошивки с 33463 на 66506. Да, знаю, большой разрыв, но до сегодняшнего дня никто не обращал внимание на новые прошивки, и всё (как ни прискорбно) работало исправно. При апгрейде прошивки вылез косяк вот такого рода - стоит ону (cdata, однопортовая, гиговая). За ней свитч Dlink dgs 1100-08 за ним абонент с сервером астериска на виртуалке(с виртуалки мак инкапсулируется, если я правильно понял). Отдаём ему телефонию антегом, на виртуалке - статика. После обновления - полностью пропал трафик на этот сервер. Первым вопрос упал на mtu - мимо. Port-protect не настроен. Конфиг лазера и ону ниже. Буду дико благодарен за любой пинок в сторону солюшна.

 


interface EPON0/4
 epon onu-authen-method mac
 epon bind-onu mac 8066.290a.6f6e 32
 switchport trunk vlan-allowed 9-11,1401-1464,1501,2001-2999
 switchport trunk vlan-untagged 1
 switchport mode trunk
 switchport protected 1

interface EPON0/4:32
  epon onu port 1 ctc vlan mode tag 1432 priority 0
 epon sla upstream pir 1000000 cir 10000
 epon sla downstream pir 1000000 cir 10000

 

X2:XX:XX:XX:XX:XX  
X6:XX:XX:XX:XX:XX  
XA:XX:XX:XX:XX:XX  
XE:XX:XX:XX:XX:XX

 

MAC попадает под этот шаблон?

Share this post


Link to post
Share on other sites
10 часов назад, Pautiina сказал:

X2:XX:XX:XX:XX:XX  
X6:XX:XX:XX:XX:XX  
XA:XX:XX:XX:XX:XX  
XE:XX:XX:XX:XX:XX

 

MAC попадает под этот шаблон?

нет, оба мака, про этот прикол знаю, проверял сразу

11 часов назад, khatgit сказал:

epon local-mac forward включен?

 

 

нет, опять же, потому что мак не попадает под "тот самый шаблон". или эта опция делает чет ещё??

Edited by bulgar

Share this post


Link to post
Share on other sites
11 часов назад, Pautiina сказал:

X2:XX:XX:XX:XX:XX  
X6:XX:XX:XX:XX:XX  
XA:XX:XX:XX:XX:XX  
XE:XX:XX:XX:XX:XX

 

MAC попадает под этот шаблон?

а можно поподробней что это за шаблоны? или ткните где почитать

Share this post


Link to post
Share on other sites
1 час назад, NaviNavi сказал:

а можно поподробней что это за шаблоны? или ткните где почитать

All mac addresses that fit the mask below will be dropped on OLT PON interface starting from 10.1.0E_36039 software

X2:XX:XX:XX:XX:XX Local Administered

X6:XX:XX:XX:XX:XX Local Administered

XA:XX:XX:XX:XX:XX Local Administered

XE:XX:XX:XX:XX:XX Local Administered

If you need to forward such type of MAC adresses please add: Switch_config#epon local-mac forward

Share this post


Link to post
Share on other sites
4 часа назад, NaviNavi сказал:

а можно поподробней что это за шаблоны? или ткните где почитать

человек уже ответил. Да после прошивки 10.1.0E_36039 - Бдком начинает блочить эти маки и не выпускает их из себя, но если локально на Бдкоме поднять айпи - то всех будет пинать норм.

Под этот шаблон зачастую попадают Тплинки и прочие устройства. 

Share this post


Link to post
Share on other sites

и всё таки? есть ещё варианты в какую сторону копать? а то даже никаких change-логов не могу найти по этим прошивка... долбанные китайцы

Share this post


Link to post
Share on other sites
3 часа назад, bulgar сказал:

и всё таки? есть ещё варианты в какую сторону копать? а то даже никаких change-логов не могу найти по этим прошивка... долбанные китайцы

Я вам сказал куда копать. Киньте маки для начала своих виртуалок

Share this post


Link to post
Share on other sites
12 часов назад, Pautiina сказал:

Я вам сказал куда копать. Киньте маки для начала своих виртуалок

52-54-00-00-3D-15

1C-7E-E5-1F-E1-AF

epon local-mac forward включен

Edited by bulgar

Share this post


Link to post
Share on other sites
12 часов назад, Pautiina сказал:

Я вам сказал куда копать. Киньте маки для начала своих виртуалок

и в добавок, теперь актуален вопрос "как залить прошивку на кирпич?" (стендовый бдком шили и чет пошло не так...)

Edited by bulgar

Share this post


Link to post
Share on other sites
Цитата

и в добавок, теперь актуален вопрос "как залить прошивку на кирпич?" (стендовый бдком шили и чет пошло не так...)

Через загрузчик пробуйте восстановить. "Ctrl+P" через консольный порт при загрузке

Share this post


Link to post
Share on other sites

прошивка 33463 достаточно таки хорошая и стабильная. багов не замечено.

зачем вообще с нее уходили? 

Share this post


Link to post
Share on other sites
В 10.11.2019 в 22:41, Diter_ua сказал:

прошивка 33463 достаточно таки хорошая и стабильная. багов не замечено.

зачем вообще с нее уходили? 

поступила команда от начальства "ОБНОВИТЬ!"... обоснуете чем-то может? а то я никаких ченжлогов от китайцев так и не увидел...

В 10.11.2019 в 21:46, khatgit сказал:

Через загрузчик пробуйте восстановить. "Ctrl+P" через консольный порт при загрузке

да, уже разобрался, спасибо)

Edited by bulgar

Share this post


Link to post
Share on other sites
В 08.11.2019 в 22:44, bulgar сказал:

52-54-00-00-3D-15

1C-7E-E5-1F-E1-AF

epon local-mac forward включен

52 второй мак попадает под шаблон

Share this post


Link to post
Share on other sites
2 минуты назад, Pautiina сказал:

52 второй мак попадает под шаблон

"epon local-mac forward включен"

Share this post


Link to post
Share on other sites
2 минуты назад, bulgar сказал:

"epon local-mac forward включен"

Должно всё арбайтен

"switchport trunk vlan-untagged 1" вот это не нужно

Edited by Pautiina

Share this post


Link to post
Share on other sites
Только что, Pautiina сказал:

Должно всё арбайтен

вот в том то и беда... мак со свича не приходит на онушку, пинги не ходят регистрации нет

Share this post


Link to post
Share on other sites

Какой свич и настройки в студию?

И какая версия прошивки на свиче? Управление свича в антеге?

Share this post


Link to post
Share on other sites
4 часа назад, Pautiina сказал:

Какой свич и настройки в студию?

сейчас тот пон стоит не на 66506, а на 33463, но конфиг идентичен.

 

Версия прошивки:

BDCOM(tm) P3608-2TE Software, Version 10.1.0E Build 66506
Copyright by Shanghai Baud Data Communication CO. LTD.
Compiled: 2019-8-21 11:54:37 by SYS, Image text-base: 0x10000
ROM: System Bootstrap, Version 0.4.5, Serial num:00315002339
System image file is "Switch.bin"
hardware version:V1.0
(RISC) processor with 262144K bytes of memory, 32768K bytes of flash
Base ethernet MAC Address: 84:79:73:df:1b:e8
PCB version:B 
snmp info:
 product_ID:2009   system_ID:1.3.6.1.4.1.3320.1.2009.0

Конфиг онушки (за онушкой стоит свитч dgs 1100-08. на него не грешу, т.к. проблема появляется только после прошивки, но если надо - конфиг скину):

 

interface EPON0/4:32
 description Veselij_74
 switchport port-security dynamic maximum 3
  epon onu description Veselij_74
 epon sla upstream pir 1000000 cir 10240
 epon sla downstream pir 1000000 cir 10240

up-link:

interface GigaEthernet0/5
 switchport trunk vlan-allowed 9-10,519,667,884,1000-4001
 switchport trunk vlan-untagged none
 switchport mode trunk

конфиг лазера:

interface EPON0/4
 epon onu-authen-method mac
 epon bind-onu mac 8014.a840.0ba0 32
 switchport trunk vlan-allowed 9-10,667,1011,1029,1031-1032,1133,1136,1199
 switchport trunk vlan-untagged 1
 switchport mode trunk
 switchport protected 1


опять же, в глобал конфиге epon local-mac forward включен, но вложить не могу, т.к. прошивка другая (в 33463 нет вообще такой опции)

 

управление тегом 9 vlan. а это имеет какое-то значение? а то я не в курсе, если честно)

 

если нужны ещё какие ветки конфига - пиши

 

 

 

Edited by bulgar

Share this post


Link to post
Share on other sites

Вы бы уж лучше весь конфиг выложили(учетные записи и всякие ключи конечно можно выпилить) ибо оно Вам нужно, а не кому-то еще догадываться, что у вас там настроено и почему не работает. Показали бы вывод что с ону приходит и т.д.

Цитата

сейчас тот пон стоит не на 66506, а на 33463, но конфиг идентичен. 

А вот это вообще диковато выглядит.

У вас в шапке поста:

interface EPON0/4:32
 epon onu port 1 ctc vlan mode tag 1432 priority 0
 epon sla upstream pir 1000000 cir 10000
 epon sla downstream pir 1000000 cir 10000

а в предыдущем комментарии:

interface EPON0/4:32
 description Veselij_74
 switchport port-security dynamic maximum 3
 epon onu description Veselij_74
 epon sla upstream pir 1000000 cir 10240
 epon sla downstream pir 1000000 cir 10240

Где же оно идентично - это принципиально разные конфиги, под разные задачи. Причем port-security аж глаз режет.

Цитата

вот в том то и беда... мак со свича не приходит на онушку, пинги не ходят регистрации нет 

а тут вообще не понятно - где и что у вас не регистрируется - onu на olt или что?

Share this post


Link to post
Share on other sites
Цитата

У вас в шапке поста:

извиняюсь, в шапке ошибка. верный конфиг без тегирования на ону. не часто приходится общаться с коллегами, поэтому извиняюсь за тугодумие)

выкладываю полный конфиг и ещё раз обрисую ситуацию, что бы исключить недопонимание:

стоит голова BDCOM(tm) P3608-2TE Software, Version 10.1.0E Build 66506, стоит ону TelStream ONU-201 после неё dlink dgs 1100-08 за свичем абонент с сервером астериска на виртуалке(с виртуалки мак инкапсулируется, если я правильно понял). Отдаём ему телефонию антегом. После обновления - полностью пропал трафик на этот сервер. Сейчас голова стоит с 33463 поэтому конфиг слит с неё и может чем-то отличаться, эксперименты проводить можно, но только по ночам)

 

Building configuration...

Current configuration:
!
!version 10.1.0E build 33463
service timestamps log date
service timestamps debug date
service password-encryption
logging buffered 2097152
logging console alerts
logging monitor alerts
!
port-protected 1
!
!
!
lldp run
lldp holdtime 3600
lldp timer 60
lldp reinit 5
!
!
!
no spanning-tree
!
!
!
!
!
!
!
!
!
!
!
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
!
username admin password 7 passwd
!
enable password 7 passwd level 15
!
!
!

epon oam-version 1 0x21
epon oam-version 2 0x20
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
!
!!slot 0 87
!
interface GigaEthernet0/5
 switchport trunk vlan-allowed 9-10,519,667,884,1000-4001
 switchport trunk vlan-untagged none
 switchport mode trunk
 description Up-link
!         
interface TGigaEthernet0/1
!
interface TGigaEthernet0/2
!
interface EPON0/4
 epon onu-authen-method mac
 epon bind-onu mac 8014.a840.0ba0 32
 switchport trunk vlan-allowed 9-10,667,1011,1029,1031-1032,1133,1136,1199
 switchport trunk vlan-allowed add 1204,1252,1266,1303-1304,1335,1400-1499,1502
 switchport trunk vlan-allowed add 1513,1522,1525,1527-1528,1554,1561-1563,1604
 switchport trunk vlan-allowed add 1613,1615,1632,1804,1827,1838,1855,1901
 switchport trunk vlan-allowed add 1903-1904,1933-1934,1941-1944,1949,1951
 switchport trunk vlan-allowed add 1952,1961-1968,2001-2120,2122-2810,2812
 switchport trunk vlan-allowed add 2813-3707,3709-3999,4001
 switchport trunk vlan-untagged 1
 switchport mode trunk
 switchport protected 1
!
interface EPON0/4:32
 description Veselij_74
 switchport port-security dynamic maximum 3
  epon onu description Veselij_74
 epon sla upstream pir 1000000 cir 10240
 epon sla downstream pir 1000000 cir 10240
!
!!slot end
!
interface VLAN1
 no ip address
 no ip directed-broadcast
!
interface VLAN9
 ip address 192.168.xxx.xxx xxx.xxx.xxx.xxx
 no ip directed-broadcast
!
vlan 1,9-10,519,667,884,1000-4001
!
ip route default 192.168.xxx.xxx
ip exf
!
snmp-server community 0 xxxxxxx RO 
snmp-server community 0 xxxxxxx RW
!
time-zone Donetsk 3 0
ntp server 192.168.xxx.xxx
!
!Pending configurations for absent linecards:
!
!No configurations pending global

 

Edited by bulgar

Share this post


Link to post
Share on other sites

на interface EPON0/4:32 в упор не вижу vlan

 

у меня есть такие клиенты и конфиг выглядит по другому за ону стоит длинк dgs-3100 куча камер несколько региков + роутер для инета.

interface EPON0/1:19
 onu-configuration
 epon sla upstream pir 100000 cir 512
 epon sla downstream pir 100000 cir 512
  epon onu port 1 ctc vlan mode trunk 1 2,836
  epon onu port 1 ctc loopback detect
  epon onu port 1 ctc notify loopback
  epon onu port 1 storm-control mode 2 threshold 256
!!onu-configuration-end
 

Share this post


Link to post
Share on other sites
25 минут назад, vitaha-ua сказал:

на interface EPON0/4:32 в упор не вижу vlan

 

у меня есть такие клиенты и конфиг выглядит по другому за ону стоит длинк dgs-3100 куча камер несколько региков + роутер для инета.

interface EPON0/1:19
 onu-configuration
 epon sla upstream pir 100000 cir 512
 epon sla downstream pir 100000 cir 512
  epon onu port 1 ctc vlan mode trunk 1 2,836
  epon onu port 1 ctc loopback detect
  epon onu port 1 ctc notify loopback
  epon onu port 1 storm-control mode 2 threshold 256
!!onu-configuration-end
 

vlan-а нет т.к. тегом все идёт со свича, а на ону ничего не настраивается, т.к. она по дефолту в Transpared

Share this post


Link to post
Share on other sites

попробуйте явно указать  epon onu port 1 ctc vlan mode trunk 1 может на новой прошивке что то поломали

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By mpolk
      Наблюдаем проблему со скоростью аплоуда у клиентов, подключенных к ОЛТу BDCom GP3600-08. Данный ОЛТ у нас первый из устройств этой модели в хозяйстве, и вообще большого опыта в области GPON-а у нас пока нет. Не исключено, что проблема проявлялась уже давно, но обнаружена она была недавно. Суть проблемы: максимальная скорость аплоуда у клиентов ограничена величиной 25-37 Мбит/с. Не видно зависимости скорости аплоуда от уровня сигнала у конкретного клиента, но просматривается зависимость от порта ОЛТа, к которому подключен клиент. К примеру, на 3-м порту у всех клиентов макс. скорость аплоуда 25-28Мбит/с,на 4-м - 32-34 Мбит/с, на 5-м - 35-37 Мбит/с. Потерь пакетов у клиентов не наблюдается; проблем со скоростью даунлоуда - тоже (у всех около 94 Мбит/с). Какой-либо физический перегруз каналов исключен (трафик небольшой).

      На стенде, с 2-мя ONU эта проблема не наблюдалась. Создается впечатление, что скорость аплоуда зависит от количества ОНУ, зарегистрированных на порту, т.е. ОЛТ выделяет каждой ОНУ фиксированную полосу пропускания, не пытаясь осуществлять DBA. Если проблема именно в этом (в чем я не уверен), то способов включить DBA на ОЛТе я не вижу. Я надеялся, что DBA включен автоматически, но, возможно, я ошибался.
       
      Дополнительно, в процессе проведенных изысканий было обнаружено следующее. Возникло подозрение, что скорость аплоуда в порту определяется ОНУшкой с самым слабым сигналом (такое явление обсуждалось в прошлом на local.com.ua применительно к EPON-овскому оборудованию). Для проверки этой гипотезы я начал временно отключать ОНУ работающих клиентов, подключенных к тому же порту, что и тестовый ноутбук, и при этом перемерять скорость аплоуда. Сначала я отключал ОНУ с самым слабым сигналом. Потом стал отключать, наоборот, самые благополучные ОНУ. Оказалось, что по мере отключения параллельно работающих клиентов скорость аплоуда на тестовом оборудовании действительно растет. Однако уровень сигнала отключаемых ОНУ никак не влияет на результат.  Ускорение тестового аплоуда зависит, по-видимому, только от общего количества отключаемых ОНУ.
       
      В целом, вырисовывается такая картина, что дело не в физике, не в уровнях сигнала и т.п., а в каких-то патологиях в распределении ОЛТом восходящей полосы пропускания между ОНУшками. Возможно, патологии обусловлены ошибками конфигурирования ОЛТа (делалось все, естественно, методом китайского научного тыка, как положено с БДКомом). Или, может быть, дырками в софте ОЛТа, или сочетанием того и другого.
       
      Не сталкивался ли кто с такой проблемой и не знает ли методов лечения?
       
      Данные ОЛТа:
       
      ОНУшки используем родные: BDCom GP1501DR.
      Kaz42-GPON.start
    • By stanislavx
      Побудували та запустили нарешті першу гілку в приватному секторі.
      Підкажіть по рівням сигналів
      на ONU:
      -15.4 -16.7 -17.2 на OLT:
      epon0/1:1 -21.8 epon0/1:2 -19.9 epon0/1:3 -20.4  
       
      Та стосовно шаблонів. Чи обов'язково вказувати параметри швидкості:
      cmd-sequence 00X epon sla downstream pir 1000000 cir 15000 cmd-sequence 00X epon sla upstream pir 1000000 cir 15000 Наразі маємо такий шаблон:
      001 epon onu all-port ctc vlan mode tag 30 002 epon onu all-port ctc loopback detect 003 epon onu all-port storm-control mode 4 threshold 256  
      Дякую.
    • By NaviNavi
      Подскажите какая достоверность вывода олт информации о сигналах. Измеритель мощности показывает совсем другие числа, заббикс показывает почти тоже самое что и измеритель. На измерителе например -15 а на олт -18.5
       interface    Temperature(degree)    Voltage(V)    Current(mA)    TxPower(dBm)
      -----------  ---------------------  ------------  -------------  --------------
      epon0/3      38.3                   3.3           13.9           5.7
       interface    RxPower(dBm)
      -----------  --------------
      epon0/3:1    -21.6
      epon0/3:2    -19.5
      epon0/3:3    -18.6
      epon0/3:5    -18.0
      epon0/3:6    -21.0
      epon0/3:7    -19.6
       
    • By all_we_crazy
      Продам Olt BdCom p3310B Бу. В чодовому стані зі 4 сфп модулями С++. Ціна 10000грн. Без торгу
      0683747888 Андрій


×