Jump to content
Local
XNeo

DHCP-Snooping на BDCOM 36xx

Recommended Posts

Здравствуйте.

 

Имеется следующая конфигурация:

interface GigaEthernet0/5
 switchport trunk vlan-allowed 10,116
 switchport trunk vlan-untagged none
 switchport mode trunk
  dhcp snooping trust
!
interface VLAN10
 ip address 10.10.0.55 255.255.240.0
 no ip directed-broadcast
!
interface VLAN116
 no ip address
 no ip directed-broadcast
 ip helper-address 10.0.0.2
!
vlan 1,10,116
!
ip dhcpd enable
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  116
ip dhcp-relay snooping information option format hn-type
!
ip route default 10.10.0.1

VLan116 - пользовательский.

VLan10 - management.

Проблема заключается в том, что OLT не пересылает запросы DHCP-серверу, если в пользовательском VLan116 не назначен IP адрес.

Что я упустил? :)

 

P.S.: BDCOM(tm) P3616-2TE Software, Version 10.1.0E Build 60793

Share this post


Link to post
Share on other sites
39 минут назад, XNeo сказал:

Проблема заключается в том, что OLT не пересылает запросы DHCP-серверу, если в пользовательском VLan116 не назначен IP адрес.

Это фича. :)

Share this post


Link to post
Share on other sites
15 минут назад, sanyadnepr сказал:

Это фича. :)

 

Как же тогда изолировать IP интерфейс от клиентов без костылей?

И это что получается, если у нас 10 VLan'ов, туда надо прицепить 10 IP ? :)

Edited by XNeo

Share this post


Link to post
Share on other sites

Может кто то решил или решит вопрос без костылей и отпишется в теме. :)

10 IP - Да.

Share this post


Link to post
Share on other sites
!
ip dhcpd snooping arp
ip dhcpd enable
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  500,601-608,620
ip verify source vlan  500,601-608,620
ip dhcp-relay snooping write-time 10
ip dhcp-relay snooping write-immediately
ip dhcp-relay snooping information option format hn-type
ip dhcp-relay snooping log
!
.............................................
!
interface VLAN50
 description MANAGEMENT
 ip address 192.168.200.190 255.255.255.0
 no ip directed-broadcast
!
interface VLAN500
 no ip address
 no ip directed-broadcast
!
interface VLAN601
 no ip address
 no ip directed-broadcast
!
interface VLAN602
 no ip address
 no ip directed-broadcast
!
interface VLAN603
 no ip address
 no ip directed-broadcast
!
interface VLAN604
 no ip address
 no ip directed-broadcast
!
interface VLAN605
 no ip address
 no ip directed-broadcast
!
interface VLAN606
 no ip address
 no ip directed-broadcast
!
interface VLAN607
 no ip address
 no ip directed-broadcast
!
interface VLAN608
 no ip address
 no ip directed-broadcast
!
interface VLAN620
 no ip address
 no ip directed-broadcast
!
!
!
vlan 500
 name pon-real
!
vlan 1,50,500,601-608,620
!
.....................................
interface GigaEthernet0/5
 description UpLink
 switchport trunk vlan-allowed 50,500,601-608,620
 switchport trunk vlan-untagged 1
 switchport mode trunk
  dhcp snooping trust
  arp inspection trust
  ip-source trust

С такими настройками у меня все прекрасно работает. P3608-2TE Software, Version 10.1.0E Build 43480

Share this post


Link to post
Share on other sites
2 минуты назад, sanyadnepr сказал:

Так у Вас Epon.

А где ТС писал что у него GPON ?

Share this post


Link to post
Share on other sites

Точно не помню, c какой то версии прошивки на Епон.

Не обратил внимания, что у ТС Епон.

Share this post


Link to post
Share on other sites
17 часов назад, vovchokig сказав:

!
ip dhcpd snooping arp
ip dhcpd enable
!

 

Какую функцию эти команды у вас выполняют ?

 

И автор говорил о работе через dhcp-relay, у вас в конфиге helper-address нет, значит у вас чисто вставка 82 опции.

 

18 часов назад, XNeo сказав:

Как же тогда изолировать IP интерфейс от клиентов без костылей?

И это что получается, если у нас 10 VLan'ов, туда надо прицепить 10 IP ? :)

 

Скорей всего да, и там прикол еще,что прямые dhcp запросы от клиентов остаются, т.е. на сервер прилетает от релея запрос и обычный запрос от пользователя.

Share this post


Link to post
Share on other sites
1 час назад, fet4 сказал:

ip dhcpd snooping arp

Не нашёл нигде, что делает данная команда?

 

1 час назад, fet4 сказал:

И автор говорил о работе через dhcp-relay, у вас в конфиге helper-address нет, значит у вас чисто вставка 82 опции.

Да, у меня именно dhcp-relay.

 

1 час назад, fet4 сказал:

Скорей всего да, и там прикол еще,что прямые dhcp запросы от клиентов остаются, т.е. на сервер прилетает от релея запрос и обычный запрос от пользователя.

Тоже когда-то замечал этот момент. Думал мой косяк где-то :))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Andrey1980
      КУПЛЮ БУ BDCOM 3310c
    • By dnserg
      Б.У. В работе было 2 года. Цена - 32400 грн. В цену модуля не входят. минимальный торг.
       

    • By Romari0
      Продам
       
      Quanta LB6M 10GbE 24-Port SFP 4x 1GbE, прошита под брокейд, жрет как 10ж так и 1ж модули - 400 баксов
       
      MikroTik CCR1036-12G-4S - 500 баксов
       
      OLT BDCOM P3310B есть три штуки, по 300 баксов за штуку или 850 за три сразу
       
      Все добро находится в г. Бровары, могу подвезти в Киев, или отправлю новой почтой
    • By XNeo
      Всем привет
       
      Такая вот конфигурация клиента:
      interface EPON0/6:1 epon onu port 1 ctc vlan mode tag 222 priority 0 epon onu port 1 loopback detect epon onu port 1 storm-control mode 4 threshold 256 epon onu port 1 ip access-group access_list_6:23 От клиента валит флуд следующего типа:
      74:ea:3a:ad:xx:xx (oui Unknown) > Broadcast, ethertype ARP (0x0806), length 60: Request who-has 192.168.1.1 tell 192.168.1.1, length 46 Около 2500 пакетов в секунду. ONU никак не реагирует. Что я упустил/сделал не так?
       
      BDCOM(tm) P3608-2TE Software, Version 10.1.0E Build 60793
      ONU Model 151C, 10.0.17A 1007.
×