Jump to content
Local
Sign in to follow this  
andrey19

Проблема с сетями на X96 mini после перепрошивки

Recommended Posts

Здравствуйте. Начну с вероятной причины проблемы. Прошиваю тв боксы не в первый раз, но в этот затупил: после прошивки перед 1-м включением воткнул ethernet (зачем-то). И когда началась первая длинная загрузка, спохватился и вытащил кабель. В результате все вроде бы работает, кроме подключения к интернету. Wi-fi бесконечно ищет и не находит ни одной сети (добавить тоже не получается), на включенный lan-кабель никакой реакции. Сбрасывал на заводские, сбрасывал настройки сети, ставил разные стоки и кастомы, сетей нет. Прописал вместо dhcp статический из диапазона роутера. Пишет подключено (по кабелю), но без доступа в интернет. В роутере виден в arp таблице. Буду рад любой подсказке.

Share this post


Link to post
Share on other sites
23 минуты назад, andrey19 сказал:

Прописал вместо dhcp статический из диапазона роутера.

DNS указал?

Share this post


Link to post
Share on other sites
4 минуты назад, a_n_h сказал:

DNS указал? 

Оставил те, что были по умолчанию 8.8.8.8 и 8.8.4.4.

 

Share this post


Link to post
Share on other sites

адрес:192.168.1.27

шлюз: 192.168.1.1

длина префикса сети: 24

dns1: 8.8.8.8

dns2: 8.8.4.4

Share this post


Link to post
Share on other sites
1 минуту назад, skybetik сказал:

Шей https://www.atvxperience.com/ и забудь о проблемах с этим куском говна.

Чего только не прошивал (ATV9, порт ATV, сток 7, сток9, minix2,...)  - понял что прошивка никак не решает проблему сети. На всех одно и то же.

Share this post


Link to post
Share on other sites
38 минут назад, skybetik сказал:

Шей https://www.atvxperience.com/ и забудь о проблемах с этим куском говна.

Та там либо оно крякнуло по такому совпадению. Либо же корявенько прошили и затернули нужные разделы типа vendor, persist. Или nv-ram покалечили

Share this post


Link to post
Share on other sites
5 минут назад, nedoinet сказал:

Та там либо оно крякнуло по такому совпадению. Либо же корявенько прошили и затернули нужные разделы типа vendor, persist. Или nv-ram покалечили

что сделать для более точного диагноза?

Share this post


Link to post
Share on other sites
1 час назад, nedoinet сказал:

...затернули нужные разделы типа vendor, persist. Или nv-ram покалечили 

Можно ли восстановить с бекапа другой новой x96 mini?(с такой же платой и памятью).

Edited by andrey19
убрал лишнее

Share this post


Link to post
Share on other sites

"Как определить, что проблема именно в NVRAM

Признаки, по которым можно судить о потере файла:

Если включить на смартфоне Wi-Fi, появляется сеть с названием «NVRAM warning err=0x10»"(с)

 

У меня сетей вообще не находит.

 

Vendor есть в корне, и в System...

Share this post


Link to post
Share on other sites

поставить какойнить busybox и поглядеть что там в кишках творится

  • Like 1

Share this post


Link to post
Share on other sites
24 минуты назад, Dimkers сказал:

поставить какойнить busybox и поглядеть что там в кишках творится

 

P00508-181712.jpg

Share this post


Link to post
Share on other sites
5 минут назад, Dimkers сказал:

Смущает rx = 0.

А может быть такое: соединено через ipv6, поэтому и нет доступа к интернету? Отправляет, но не получает.

Share this post


Link to post
Share on other sites

А кто вам сказал что у вас соединено через ipv6?

Share this post


Link to post
Share on other sites
1 минуту назад, Dimkers сказал:

А кто вам сказал что у вас соединено через ipv6?

Никто. Недостаток знаний делает меня суеверным.))

Share this post


Link to post
Share on other sites

Патч точно рабочий? Порт на роутере рабочий? Может патч - крос?

Ping c роутера на ip приставки и с приставки на ip роутера делали?

Edited by Dimkers

Share this post


Link to post
Share on other sites

Патч заводской проверенный (пробовал несколько проверенных), порты проверял. С приставки через терминал делать пинг? также как в виндовс с командной

ping 192.168.1.1 -t ?

Share this post


Link to post
Share on other sites

Да, только без -t

Если патч вытащить с приставки и воткнуть в ПК\Ноут - работает?

Если приставку патчем воткнуть к ПК, поднять IP из той же сети и запустить снифер?

Edited by Dimkers

Share this post


Link to post
Share on other sites

Это что? Я говорю с роутера на приставку и с приставки на роутер

Share this post


Link to post
Share on other sites
12 минут назад, Dimkers сказал:

Если патч вытащить с приставки и воткнуть в ПК\Ноут - работает? 

Работает.

 

13 минут назад, Dimkers сказал:

Если приставку патчем воткнуть к ПК, поднять IP из той же сети и запустить снифер?

тут нужно сначала покурить теорию.

да, напомню, роутер видит ip и мак приставки. В "Списке клиентов" " ARP таблица".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ECOLAN
      Продам X96 MINI 2/16
      Цена 24$





    • By Evgenij
      Срочно нужно 2 онушки с вай-фай 4порта. 
      Желательно НДС, но как уже есть
    • By i-gor
      Продається розумний свіч.
      Ціна 1,5к грн (міні-торг).
       
      Фото додаю, детальні характеристики в неті.
       
      !!!Б/В!!



    • By Petro Skip
      Привет народ, да я знаю что можно взять любой бюджетник и на белом ip запустить либо pptp либо mikrotik  и стартануть l2tp server
       
      вопрос в другом, можноли сделать так чтоб я получил доступ черех hamchi  к одному конкретному ip внутри сети  другого компютера который тоже законекчен через хамачи
      и через hamachi два компютера друг друга видят
       
       
      обрисую,
      =LAN 1
      ---PC 1       --192.168.43.200   192.168.43.1     --hanachi 5.20.x.x
       
      =LAN 2
      ---PC 2       --192.168.1.60      192.168.1.1         --hamachi 5.23.x.x
      --Device 1  --192.168.1.62      192.168.1.1  
       
      нужно с PC 1 получить доступ к Device1
       
      что сделано, 
      1)с двух сторон хамача и локалка компы друг другу рады, тут понятно
      2)в хамачи настроил форвардинг по статье (ТИЦ)
      в хамачи (System > Preferences > Settings > Advanced Settings ) кляпаем по строке Service configuration ->  кнопка open
      ищем в открывшейся папке файл h2-engine.cfg  строку вида:
      Vpn.Domain Hamachi, 0 [1 0 0 0] [1 0.0.0.0 0.0.0.0] [0 0 0] [] [1]
      мением два бита что было так
      Vpn.Domain Hamachi, 0 [1 0 0 0] [1 0.0.0.0 0.0.0.0] [1 1 0] [] [1]
      остановил в диспетчере задач что сам хамачи что сервис хамачи сохранил перезапустил,
       
      в реестре сделал так
      HKEY_Local_Machine\System\CurrentControlSet\Services\Tcpip\Parameters\
      IPEnableRouter сменил на  1
       
      на машынах прописал роутинг
      на PC1 
      route -p add 192.168.1.0   mask  255.255.255.255   25.x.x.x /p ----25.x.x.x ип хамачи на PC 2
       
      на PC2
      route -p add 192.168.43.0   mask  255.255.255.255   25.x.x.x /p ----25.x.x.x ип хамачи на PC 1
       
       
      но доступа к Device 1 попрежнему нету,
      задача малой кровью и малым костылем получить доступ к Device 1
       
      критике рад,
      также рад советам которые помогут 
       
      P.S.   да я знаю что ip может поменятса и всем маршутам капец,  но то потом, давейте поднимем мост
       
       
       
    • By PraS
      Ubiquiti AirGrid M2 HP 16dbi с блоками питания, все проверено.
      Есть количество. Цена 1000 грн за 1 шт.
      По всей информации звоните +38097-381-24-31 Сергей.


×