Jump to content

Recommended Posts

В 03.05.2023 в 14:18, ikuferu сказал:

Доброго дня. Потрібно обладнання для офісу до 20 машин.

 

1) Є два провайдера в 1 та 2 з статичними PPPoE підключеннями.

2) Потрібно обладнання щоб автоматично переключався з одного провайдера  на іншого у випадку відключення.

3) Маємо два внутрішні влани, 1 влан для виходу в інтернет, 2 влан для обладнання без виходу в інет. ( Але є декілька машин з 1 влана які будуть ходить до 2 влану )

4) Також між основним маршрутизатором та віддаленим офісом побудований IP sec. 

Потрібно основний маршрутизатор та свічі для розв'язки внутрішньої мережі та роутери для WI-FI.

 

 

Строим с нового чужое или строим для себя?

1, 2, 4 - на 2x100 мбит вполне хватит hap ac^2 (чуть быстрее чем упомянутый выше hex s, а стоит заметно дешевле). Если  нужно больше, если уж брать - так уже 5009-й (по цене не сильно ушел от 4011, но он уже закроет все офисные кейсы, как роутер).

На ppp вешаются скрипты, которые будут дописывать/убирать правила роутинга и фаерволла, передергивать тоннели. Дальше основной скрипт по планировщику заданий будет проверять доступность и  переключать маршруты с одного интерфейса на другой.

На коммутацию надо взять нужное количество свитчиков, управляемых L2, но лучше сразу гигабитные. Так как одних хостов два десятка, то одного 24-х портового будет маловато, а на больше портов уже с кулерами, т.е. шумят. Требований к ним немного - щелкать вланы в основном. Под wifi - если нужно чисто мобилки посадить, то берем домашние роутеры в качестве ап (из серии дешево и сердито), если нужно именно поработать (ноуты и прочее) - то радиоразведка и какие нибудь рукусы со вторички.

  • Like 2
Link to post
Share on other sites
41 минуту назад, nvr сказал:

Якось печально з подібним функціоналом в мікротіка.

Тоді вже тазік з трьома мережевими, debian і load balancing.

І не треба ліпии скріпти для переключення.

В смысле печально? Точно такой же дуалван, тот же iptables (только в обвертке), тот же роутинг. Только коробочка махонькая, жрет мало, живет на 12v/7.2Ah много часов.

  • Like 1
Link to post
Share on other sites
6 часов назад, Alver сказал:

Сейчас как раз у меня стоит задача сделать ДВА 1Г канала внешних в Интернет ( две разных IP сети и соответственно gateway-  далее NAT в серые адреса) в режиме дублирования ( горячего резерва )- то есть работает основной , если он упал то автоматом поднимается второй. Гуглить я могу и вникать в вопрос тоже.  Но может быть у кого есть готовый конфиг , решающий эту задачу для  RB4011 или  RB2011. Поделитесь пожалуйста.

Дефолт резервного каналу має бути більше 1. Якщо це статика то вказуєте при додаванні. Якщо отримуєте по dhcp, то в клієнті вказуєте в параметрі Default routing distance
На основний канал списуєте маршрут до, наприклад, 8.8.4.4 (можна і до адреси провайдера, але якщо впаде у нього аплінк то ваш канал фактично робити не буде)

/ip route add dst-address=8.8.4.4 gateway=<main_isp_gw>

Додаєте рекурсивний маршрут через 8.8.4.4

/ip route add check-gateway=ping gateway=8.8.4.4
check-gateway=ping - активує механізм полінгу шлюза, кожні 10 сек виконується пінг і після двох невдалих перевірок (20сек) маршрут деактивується. Але перевірки виконуються далі і при вдалій перевірці маршрут стає активним.
І в файерволі треба заборонити вихід пакетів на 8.8.4.4 через резервний канал.

/ip firewall filter add chain=output dst-address=8.8.4.4 out-interface=<interface_reserv> action=drop

Більш складну логіку або інші інтервали перевірки можна реалізувати скриптами в netwatch або scheduler

  • Like 1
Link to post
Share on other sites

Я тут гит принес, оставлю как пример https://github.com/vikilpet/mikrotik-interface-check - на семерку возможно надо переделать, но там где дуалван у меня стоит - там шестерка, поэтому не заморачивался.

Суть - скрипт проверяет доступность хостов пингом и что-то там делает по результату. Ну, т.е. маршрут переключить, конекшн трекер сбросить и все в таком духе.

 

PS: в смысле переделать скрипт: не синтаксис, а логику - может где изменили что. Хотя внешне должно работать, скрипт прост как валенок. Есть более продвинутый вариант, там критерий на переключение - процент потерь. Да и вообще, можно гонять ping speed как контроль за каналом, но как показывает опыт - обычно провайдер либо работает, либо нет, усложнение логики не всегда оправдано.

Edited by linkar
  • Like 1
Link to post
Share on other sites
  • 5 weeks later...

Juniper SRX240H2POE (є моделі і без рое)
Juniper SRX550
Тобі файрвол, роутер, іпсек молотилка (срх240 пережує десь 250мбіт іпсека на sha-384+dh group20, срх550 десь під 1гбіт) і рое коммутатор в одному девайсі. Або більш кучеряву модель SRX550. На ебеях коштує копійки (навіть дешевше нового мікрота), а по функціоналу дрючить всіх і вся.

Link to post
Share on other sites

о, раз Juniper вспомнили, кто-то в курсе, как mx5 в mx80 переделать. ну там за 300USD ?
видел тут пару спаммеров, на какрой-то A10 и пон, постоянно апают топики.

но продаванов Juniper - что-то не нагуглил.

Link to post
Share on other sites
  • 9 months later...
  • 3 weeks later...
В 05.04.2024 в 14:09, netstriker сказал:

дуже швидко відповідають))))))))))))))))

за всіма не услідиш)) не так часто тут буваю, тому краще в лічку пишіть якщо є потреба в обладнанні)

Link to post
Share on other sites
В 03.05.2023 в 21:21, Туйон сказал:

Что? UBNT? Давно они стали энтерпрайзом?

По теме - берите Микротик.

а є ще альтернативи мікротіку під таку заадчу?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tarantul13
      Продається маршрутизатор Juniper MX80 зі всіма ліцензіями. Працював в датацентрі. Замінився на інше обладнання. Все робоче - перевірено.
      Додаткові питання - пишіть. Можливо по перерахунку.
    • By BALTAR
      Продам Mikrotik RB3011UiAS-RM, новий, купувався під проєкт, але не зрослось. 
      Ціеа 5500 грн
    • By Htos
      Добрый день.
      Подскажите, пожалуйста, подойдёт ли неуправляемый коммутатор для раздачи интернета на два-три устройства (один компьютер и ноутбуки, всё с помощью кабеля, без wi-fi). И если подойдёт, то какой лучше выбрать.

      Интернет подключён через оборудование провайдера - абонентский PON-терминал Extralink 1GE ONU. Там один порт для кабеля RJ-45, которым он и соединён с компьютером. 
       
      Провайдер говорит, что неуправляемый коммутатор решит проблему. На мой вопрос, есть ли в абонентском терминале («онушке») DHCP, не будет ли проблемы с выделением адресов, мне дали такой ответ: «Свитч, подключённый к ONU, выполняет роль простого множителя. Каждый порт повторяет настройки портов "онушки". Позволяет одновременно работать на всех портах свитча. Но! Общая скорость будет равномерно делиться на количество работающих портов. Один адрес будет на всех».

      То есть, если я правильно понимаю, будет работать (именно одновременно), но с потерей скорости. Или я ещё чего-то важного не уловил в ответе провайдера?
       
       
    • By SXM.U
      L3 48SFP+ 6QSFP мегакрутий комбайн з широкими можливостями в прекрасному стані.
      BGP/OSPF/MPLS, і тд., все, що душа забажає. Реальне споживання ВСЬОГО до 200Вт. За рахунок 2U корпусу не такий шумний, як його колеги N3/5/6/7K, і набагато ширші функції, може прийняти кілька українських Х-ів(128к маршрутів)
      Характеристики - www.stack-systems.com.ua/kommutator-cisco-nexus-n9k-c9396px
      Є версія на 6 QSFP - 800$, та 12QSFP - 850$.
       
      L3 Cisco Nexus 3064PX - 48*SFP+, 4*QSFP - 750$







    • By azimut
      Продам Б/У Мікротік CCR1036-12g- 4S EM
      Працював без проблем, замінили на більш кращий. Стоїть в стійці без потреби. Кому цікаво пропонуйте ціну

×
×
  • Create New...