Jump to content

mikrotik bgp


Recommended Posts

hi all

2 пира bgp. Есть задача искуственно удлинить маршрут к одному из отдаваемых префиксов, все остальные префиксы анонсировать прозрачно без удлинения. По аналогии с цыской set as-path prepend 65000 65000 65000. Как на микротике подобное сделать?

Спасибо

Link to post
Share on other sites
/routing filter

add action=accept chain=in-mir-blabla-888888 comment=TEST disabled=no invert-match=no \

    prefix=0.0.0.0/0 set-bgp-prepend=5 set-bgp-prepend-path=""

 

Увеличиваем на 5

Edited by max_m
Link to post
Share on other sites

 

13   chain=AS11111-bgp-out prefix=x.x.x.0/24 invert-match=no action=accept 

     set-bgp-local-pref=300 set-bgp-prepend-path=65000,65000,65000

 

/routing filter
add action=accept chain=in-mir-blabla-888888 comment=TEST disabled=no invert-match=no \
    prefix=0.0.0.0/0 set-bgp-prepend=5 set-bgp-prepend-path=""
 
Увеличиваем на 5

 

а-я-я-й

 

Link to post
Share on other sites
  • 5 years later...
В 12.02.2015 в 23:26, max_m сказал:
/routing filter
 
add action=accept chain=in-mir-blabla-888888 comment=TEST disabled=no invert-match=no \
 
    prefix=0.0.0.0/0 set-bgp-prepend=5 set-bgp-prepend-path=""
 
 
 
Увеличиваем на 5

не люблю быть некропостером, но придется)

Это правило у меня не удленило маршрут(( что делаю не так?

Цель: Некоторые префиксы зафильтровать с помощью удлинения маршрута чтоб ходили через определенного оператора

Интересует только Входящий трафик

таким образом хочу разбалансировать нагрузку между БГП сэсиями

Link to post
Share on other sites

Если сеть /23, то разделить по /24  В одну сторону анонсить только /23 В другую /24+/24+/23 или /24+/23 Правда, это может быть сильно радикально по входу.

Link to post
Share on other sites
1 час назад, Ondp сказал:

не люблю быть некропостером, но придется)

Это правило у меня не удленило маршрут(( что делаю не так?

Цель: Некоторые префиксы зафильтровать с помощью удлинения маршрута чтоб ходили через определенного оператора

Интересует только Входящий трафик

таким образом хочу разбалансировать нагрузку между БГП сэсиями

 

судя по названию фильтра и префикса, вы какого-то хера удлиняете вход.

удлиннять нужно анонсы, а не то, что принимаете

Link to post
Share on other sites
1 час назад, bit сказал:

Если сеть /23, то разделить по /24  В одну сторону анонсить только /23 В другую /24+/24+/23 или /24+/23 Правда, это может быть сильно радикально по входу.

имею только /24

Link to post
Share on other sites
27 минут назад, LV10 сказал:

 

судя по названию фильтра и префикса, вы какого-то хера удлиняете вход.

удлиннять нужно анонсы, а не то, что принимаете

chain=data-bgp-out prefix=(мои IP)*.*.*.0/24 invert-match=no action=accept 
     set-bgp-prepend=2 set-bgp-prepend-path=""

Вот это правило работает коректно, маршруты удлиняются, а мне нужно удлинить не весь трафик, а определенный префикс)

Ссори если не правильно выражаюсь)

Link to post
Share on other sites

Определенный префикс-это какой конкретно?

Женя, ты в мир анонсируешь аплинкам свою /24 сеть, трафик к тебе приходит по кратчайшему маршруту, можешь удлинить маршрут с помощью prepend, но опять-таки ты удлиняешь всей /24 подсети. Имея хотя бы /23 сеть ты мог бы ее разбить на две /24 и с разным препендом отправлять их разным аплинкам и таким образом хоть как-то разруливать входящий трафик 

  • Thanks 1
Link to post
Share on other sites

У даты богатое комьюнити. Полистайте на досуге их whois. С их помощью можно неплохо балансить трафик.

А так, то могут даже фильтррвать.

Edited by Dimkers
  • Thanks 1
Link to post
Share on other sites
1 час назад, lemosh сказал:

Определенный префикс-это какой конкретно?

Женя, ты в мир анонсируешь аплинкам свою /24 сеть, трафик к тебе приходит по кратчайшему маршруту, можешь удлинить маршрут с помощью prepend, но опять-таки ты удлиняешь всей /24 подсети. Имея хотя бы /23 сеть ты мог бы ее разбить на две /24 и с разным препендом отправлять их разным аплинкам и таким образом хоть как-то разруливать входящий трафик 

Ооо спасибо)

Та думал мегого и другие ресурсы направить через определенного оператора, тем самым разбалансировать трафик, так как заметил что основная нагрузка в час пик это ТВ

Link to post
Share on other sites
5 минут назад, Ondp сказал:

Ооо спасибо)

Та думал мегого и другие ресурсы направить через определенного оператора, тем самым разбалансировать трафик, так как заметил что основная нагрузка в час пик это ТВ

Это через комьюнити делается. 

  • Thanks 1
Link to post
Share on other sites
  • 7 months later...

Дабы не плодить темы, задам вопрос здесь:

 

Mikrotik поднимает BGP соединение (принимает по дефолту) и анонсит сеть в мир. Хоп (пир) пока настроен один. Из нюансов, без галки multihop сессия не поднимается, а так вроде всё остальное настроено по дефолту.

Сам микрот получает интернет нормально, а вот все остальные хосты которым он роутит интернет, получают маршруты не полностью, криво, а точнее - допустим googl сервисы, украинские хосты резолвятся, а вот 1.1.1.1 и speedtest.net уже недоступен и роут на них обрывается где-то в миру. Голову уже сломал, клава и монитор пока целые😄 

Может кто стыкался ?

Edited by virtus
Link to post
Share on other sites
12 минут назад, virtus сказал:

украинские хосты резолвятся, а вот 1.1.1.1 и speedtest.net уже недоступен

Значит в ua-ix ваша сеть анонится, а в мир нет. Надо не бордер лечить, а смотреть свои префиксы на точках обмена и в мире через лукингглассы.

  • Like 1
Link to post
Share on other sites
21 минуту назад, KaYot сказал:

Значит в ua-ix ваша сеть анонится, а в мир нет. Надо не бордер лечить, а смотреть свои префиксы на точках обмена и в мире через лукингглассы.

так бордер видит весь мир нормально

Edited by virtus
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...