Jump to content
Local
set_default

mikrotik bgp

Recommended Posts

hi all

2 пира bgp. Есть задача искуственно удлинить маршрут к одному из отдаваемых префиксов, все остальные префиксы анонсировать прозрачно без удлинения. По аналогии с цыской set as-path prepend 65000 65000 65000. Как на микротике подобное сделать?

Спасибо

Share this post


Link to post
Share on other sites
/routing filter

add action=accept chain=in-mir-blabla-888888 comment=TEST disabled=no invert-match=no \

    prefix=0.0.0.0/0 set-bgp-prepend=5 set-bgp-prepend-path=""

 

Увеличиваем на 5

Edited by max_m

Share this post


Link to post
Share on other sites

 

13   chain=AS11111-bgp-out prefix=x.x.x.0/24 invert-match=no action=accept 

     set-bgp-local-pref=300 set-bgp-prepend-path=65000,65000,65000

 

/routing filter
add action=accept chain=in-mir-blabla-888888 comment=TEST disabled=no invert-match=no \
    prefix=0.0.0.0/0 set-bgp-prepend=5 set-bgp-prepend-path=""
 
Увеличиваем на 5

 

а-я-я-й

 

Share this post


Link to post
Share on other sites

Не успел дописать мой пример для входящего фильтра , а тебе по аналогии для исходящего

.

Share this post


Link to post
Share on other sites
В 12.02.2015 в 23:26, max_m сказал:
/routing filter
 
add action=accept chain=in-mir-blabla-888888 comment=TEST disabled=no invert-match=no \
 
    prefix=0.0.0.0/0 set-bgp-prepend=5 set-bgp-prepend-path=""
 
 
 
Увеличиваем на 5

не люблю быть некропостером, но придется)

Это правило у меня не удленило маршрут(( что делаю не так?

Цель: Некоторые префиксы зафильтровать с помощью удлинения маршрута чтоб ходили через определенного оператора

Интересует только Входящий трафик

таким образом хочу разбалансировать нагрузку между БГП сэсиями

Share this post


Link to post
Share on other sites

Если сеть /23, то разделить по /24  В одну сторону анонсить только /23 В другую /24+/24+/23 или /24+/23 Правда, это может быть сильно радикально по входу.

Share this post


Link to post
Share on other sites
1 час назад, Ondp сказал:

не люблю быть некропостером, но придется)

Это правило у меня не удленило маршрут(( что делаю не так?

Цель: Некоторые префиксы зафильтровать с помощью удлинения маршрута чтоб ходили через определенного оператора

Интересует только Входящий трафик

таким образом хочу разбалансировать нагрузку между БГП сэсиями

 

судя по названию фильтра и префикса, вы какого-то хера удлиняете вход.

удлиннять нужно анонсы, а не то, что принимаете

Share this post


Link to post
Share on other sites
1 час назад, bit сказал:

Если сеть /23, то разделить по /24  В одну сторону анонсить только /23 В другую /24+/24+/23 или /24+/23 Правда, это может быть сильно радикально по входу.

имею только /24

Share this post


Link to post
Share on other sites
27 минут назад, LV10 сказал:

 

судя по названию фильтра и префикса, вы какого-то хера удлиняете вход.

удлиннять нужно анонсы, а не то, что принимаете

chain=data-bgp-out prefix=(мои IP)*.*.*.0/24 invert-match=no action=accept 
     set-bgp-prepend=2 set-bgp-prepend-path=""

Вот это правило работает коректно, маршруты удлиняются, а мне нужно удлинить не весь трафик, а определенный префикс)

Ссори если не правильно выражаюсь)

Share this post


Link to post
Share on other sites

Определенный префикс-это какой конкретно?

Женя, ты в мир анонсируешь аплинкам свою /24 сеть, трафик к тебе приходит по кратчайшему маршруту, можешь удлинить маршрут с помощью prepend, но опять-таки ты удлиняешь всей /24 подсети. Имея хотя бы /23 сеть ты мог бы ее разбить на две /24 и с разным препендом отправлять их разным аплинкам и таким образом хоть как-то разруливать входящий трафик 

  • Thanks 1

Share this post


Link to post
Share on other sites

У даты богатое комьюнити. Полистайте на досуге их whois. С их помощью можно неплохо балансить трафик.

А так, то могут даже фильтррвать.

Edited by Dimkers
  • Thanks 1

Share this post


Link to post
Share on other sites
1 час назад, lemosh сказал:

Определенный префикс-это какой конкретно?

Женя, ты в мир анонсируешь аплинкам свою /24 сеть, трафик к тебе приходит по кратчайшему маршруту, можешь удлинить маршрут с помощью prepend, но опять-таки ты удлиняешь всей /24 подсети. Имея хотя бы /23 сеть ты мог бы ее разбить на две /24 и с разным препендом отправлять их разным аплинкам и таким образом хоть как-то разруливать входящий трафик 

Ооо спасибо)

Та думал мегого и другие ресурсы направить через определенного оператора, тем самым разбалансировать трафик, так как заметил что основная нагрузка в час пик это ТВ

Share this post


Link to post
Share on other sites
5 минут назад, Ondp сказал:

Ооо спасибо)

Та думал мегого и другие ресурсы направить через определенного оператора, тем самым разбалансировать трафик, так как заметил что основная нагрузка в час пик это ТВ

Это через комьюнити делается. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×