Перейти к содержимому
Local
KPA666

Может ли NAT повлиять на пинг?

Рекомендованные сообщения

Собственно такой вот вопрос.

 

Влияет ил как-то пинг на на UDP подключения к игровым серверам?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сам то понял че спросил ?  Это что вроде вопроса изменится ли удой коров , если зоотехник Вася выпьет водки . 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Конечно влияет. А вообще-то если хочешь получить правильный ответ-задай правильно вопрос.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Интересно и  какая же зависимость влияния ната на величину задержки пакета ?  Накладные расходы у маршрутизатора на NAT  обычно  не превышают 10% от обычной маршрутизации пакетов , поэтому посмею заявить , что задержки на маршрутизаторе с натом и без будут практически одинаковы . 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

поэтому посмею заявить , что задержки на маршрутизаторе с натом и без будут практически одинаковы . 
 

 

++++

Сам проверял это, разницы никакой воооообще.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну да не влияет NAT)) особенно если на тазике, и процы загружены под 90% и памяти мало и сетевуха-нонейм...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ще є багато різних способів реалізувати нат 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пф, встречал как-то пациента, который сказал что если от провайдера приходит в квартиру витуха, а в квартире 2 компа то можно к проводу просто примотать 2 сетевых шнурка и всё будет работать (по типу электроудлинителя). А Вы тут про NAT и QoS...

Я сразу было подумал что мир перевернулся... Вот же она - золотая жила.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

del

Изменено пользователем logic

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пф, встречал как-то пациента, который сказал что если от провайдера приходит в квартиру витуха, а в квартире 2 компа то можно к проводу просто примотать 2 сетевых шнурка и всё будет работать (по типу электроудлинителя). А Вы тут про NAT и QoS...

Я сразу было подумал что мир перевернулся... Вот же она - золотая жила.

А ведь пациент не так уж и неправ. Во многих случаях такой "разветвитель" действительно будет работать, проверяли как-то в офисе - работало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Зачем свичи по 200 баксов покупать, смотрел все в кучу параллельно и хорош.

Изменено пользователем antilenin

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

Зачем свичи по 200 баксов покупать, смотрел все в кучу параллельно и хорош.
 

Ну, не обязательно паралельно, можно и последовательно - тогда 100 мегабит одного клиента перейдут на другого и у всех будет соточка :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Зачем свичи по 200 баксов покупать, смотрел все в кучу параллельно и хорош.
 

Ну, не обязательно паралельно, можно и последовательно - тогда 100 мегабит одного клиента перейдут на другого и у всех будет соточка :)

 

Последовательно то уже 200 мбит будет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 13.01.2017 at 1:33 PM, KaYot said:
On 13.01.2017 at 10:33 AM, H_U_L_K said:

Пф, встречал как-то пациента, который сказал что если от провайдера приходит в квартиру витуха, а в квартире 2 компа то можно к проводу просто примотать 2 сетевых шнурка и всё будет работать (по типу электроудлинителя). А Вы тут про NAT и QoS...

Я сразу было подумал что мир перевернулся... Вот же она - золотая жила.

А ведь пациент не так уж и неправ. Во многих случаях такой "разветвитель" действительно будет работать, проверяли как-то в офисе - работало.

Теоретически, если сетевухи старые, и помнят времена CSMA/CD, заработает.

Запустится в полудуплексе и эта шина будет одним доменом коллизии, которые будут гаситься этим самым CSMA/CD.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 13.01.2017 at 3:01 PM, antilenin said:

Зачем свичи по 200 баксов покупать, смотрел все в кучу параллельно и хорош.

Очень интересует вопрос:

А можно так опту слепить в одно целое и избавиться от херов*й тучи 10 Г модулей?

И что будет если убрать промежуточные коммутаторы за хрен*ву тучу денег, которые выполняют функцию рипитеров, а просто в этот стык слепленных волокон подсветить 50 w led прожектором? (Или от led прожекторов дисперсия большая будет?) :):):)

Изменено пользователем melvin

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
17 hours ago, melvin said:

Очень интересует вопрос:

А можно так опту слепить в одно целое и избавиться от херов*й тучи 10 Г модулей?

И что будет если убрать промежуточные коммутаторы за хрен*ву тучу денег, которые выполняют функцию рипитеров, а просто в этот стык слепленных волокон подсветить 50 w led прожектором? (Или от led прожекторов дисперсия большая будет?) :):):)

Можно, Pon называется :)

  • Like 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 16.01.2018 в 08:23, masters сказал:

Можно, Pon называется :)

Пробывал светить прожектором - результат ноль.

Принял решение - наверное прожектор не добивает до конечной точки. :)

Бугага

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 18.10.2016 в 17:32, KPA666 сказал:

Собственно такой вот вопрос.

 

Влияет ил как-то пинг на на UDP подключения к игровым серверам?

 

Да! Брейнфак называться!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу.

  • Похожие публикации

    • Автор: Туйон
      Добрый вечер, коллеги!
      Столкнулся с такой ситуацией.
      Вышестоящий провайдер выдаёт интернет посредством gre-tunnel.
      К серверу (микротику) подключается 5 отдельных локальных подсетей.
      Раньше на этом туннеле был один ай-пи, допустим 111.111.111.111
      В ip - firewall было создано одно правило НАТ, применен scr-nat, в настройках было указано to-address 111.111.111.111
      Всё работало.
      Было принято решение чуть разгрузить это всё и добавлен ещё один внешний ай-пи, отличающийся на 1 цифру допустим 111.111.111.112.
      К слову, оба этих ай-пи прописаны прямо на интерфейс туннеля (в ip - addresses).
      Для того, чтобы две из пяти локальных сети выходили в мир по 111.111.111.111, а три другие по 111.111.111.112, я принял решение создать отдельно 5 правил scr-nat.
      Вот кусок конфига:
       
      /ip firewall nat
      add action=src-nat chain=srcnat dst-address=!192.168.0.0/16 out-interface=gw-a src-address=192.168.0.0/24 src-address-list=Clients to-addresses=111.111.111.111
      add action=src-nat chain=srcnat dst-address=!192.168.0.0/16 out-interface=gw-a src-address=192.168.1.0/24 src-address-list=Clients to-addresses=111.111.111.111
      add action=src-nat chain=srcnat dst-address=!192.168.0.0/16 out-interface=gw-a src-address=192.168.2.0/24 src-address-list=Clients to-addresses=111.111.111.112
      add action=src-nat chain=srcnat dst-address=!192.168.0.0/16 out-interface=gw-a src-address=192.168.3.0/24 src-address-list=Clients to-addresses=111.111.111.112
      add action=src-nat chain=srcnat dst-address=!192.168.0.0/16 out-interface=gw-a src-address=192.168.4.0/24 src-address-list=Clients to-addresses=111.111.111.112
       
      Вроде всё работает, но то ли мне кажется, то ли сайты иногда подвисают.
       
      Посему вопросы:
      1. Правильно ли я разрулил 2 внешних ай-пи на 5 локальных сетей?
      2. Что это такое !192.168.0.0/16. Я понимаю, что это исключение адресного пространства локалки из НАТа, но с какой целью? Надо ли так делать?
      3. Если на туннеле прописаны оба внешника 111.111.111.111 и 111.111.111.112, то если я буду пинговать некий сайт прямо с микротика, с какого из этих двух адресов будут идти запросы на сайт?
    • Автор: Myr4ik
      Здравствуйте, ребята!
      Есть желание пробросить unicast IPTV из сети одного оператора в сеть другого поверх интернета без туннелей.
      Обычно делаю следующую настройку в NAT устройства (mikrotik), которое подключено к оператору, что вещает IPTV:
       
      chain=dstnat action=dst-nat to-addresses="IP UDP-to-HTTP сервера провайдера" to-ports=4022 protocol=tcp in-interface=ether1 dst-port=4321 ether1 - линк с оператором, в который приходит IPTV и интернет, и откуда, разумеется, IPTV уходит во вне с порта 4321.
      UDP-to-HTTP сервер оператора вещает с "IP UDP-to-HTTP сервера провайдера" и порта 4022.
       
       
      После вышеописанного, модифицирую соответствующий плэйлист с каналами на принимающей стороне и вуяля - все работает.
      Но недавно столкнулся с оператором, с которым этот финт не прокатил...
       
      Суть проблемы, как мне кажется, в следующем:
      Оператор, с которым, как я поначалу подумал не заработало правило NAT (а оно заработало вполне корректно), использует для вещания IPTV ПО Astra, которому не нравится в запросе от, например VLC, в поле Host, указание IP-адреса, а не FQDN.
      Изображение недуачной попытки посмотреть ТВ:
       

       
       
      А вот успешный запрос с FQDN, после которого сразу начинается передача-прием потока:
       

       
      Вопрос - есть ли способ модифицировать правило(а) на mikrotik (без создания DNS-записей на принимающей стороне), чтобы стало возможным просматривать IPTV вне сети оператора с Astr`ой? Правильно ли я локализовал "проблему"?
       
      Спасибо.
    • Автор: bot
      Сервис Latency.at, осуществляющий распределённый мониторинг доступности и отзывчивости серверов, объявил об открытии всех лежащих в его основе разработок. В том числе доступен код бэкенда на языке Go c реализацией API, балансировщиком нагрузки и шиной обмена сообщениями, система для выполнения проверок параметров работы сервисов (надстройка над Prometheus Blackbox Exporter) и фрондэнд с реализацией web-интерфейса.
       

       
      Код открыт под лицензией Apache 2.0 и позволяет развернуть на своих мощностях функциональность, аналогичную Latency.at. Связанные с выполнением проверок дополнения переданы открытому проекту Prometheus. В ближайшее время планируется опубликовать образы контейнеров для Docker и Kubernetes с преднастроенной системой мониторинга. Из особенностей системы можно отметить учёт времени обработки различных стадий выполнения запросов HTTP и HTTPS (резолвинг в DNS, установка соединения, согласование TLS, передача данных). Также поддерживаются проверки DNS и произвольных TCP-сервисов. Результаты проверки отображаются в виде наглядных графиков.

      https://blog.latency.at/2018-03-28-we-open-source-everything

      https://gitlab.com/latency.at/latencyAt
       

       
      Источник: opennet
    • Автор: Futura
      Имеется тазик на Debian c двумя сетевухами:
      Internet-eth0<NAT<eth1-PPPoE
      Если установить еще одну карточку (пусть будет eth2) c резервным каналом
      как организовать автоматическое переключение при падении основного и корректную работу NAT?
    • Автор: tfron
      Всем привет. В разделе мониторниг в абилсе можно пропинговать абонента, но отсылает только 5 пакетов. Не всегда получается отследить проблему. Можно сделать хотябы 15 запросов, может кто знает?(версия 0.55b)
×